[Unstable Update] 2023-05-03 - Python 3.11, GCC 13

Hello community,

Another unstable branch update with some usual package updates for you.

Notable Package Updates:

Additional Info

:information_source: You will need to rebuild any AUR Python packages that install files to site-packages or link to libpython3.10.so. :information_source:

Print a list of of packages that have files in /usr/lib/python3.10/ :

pacman -Qoq /usr/lib/python3.10/

Rebuild them all at once:*

pamac build $(pacman -Qoq /usr/lib/python3.10)

* Note that if any fail to build, you’ll have to rebuild what’s remaining one or a few at a time.

Use rebuild-detector to see if anything else needs to be rebuilt:


Get our latest daily developer images now from Github: Plasma, Gnome, XFCE. You get the latest stable releases of Manjaro from CDN77.

Info about AUR packages

:warning: AUR (Arch User Repository) packages are neither supported by Arch nor Manjaro. Posts about them in Announcement topics are off-topic and will be flagged, moved or removed without warning.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Unstable Updates Announcements RSS feed

Please RTFT (Read This Fine Thread) first before reporting the same issues over and over again!

:arrow_right: 2023-05-03

Help with upgrading Python packages that were installed from AUR or PyPI

[HowTo] After a Python interpreter upgrade, reinstall non-working Python packages



GRUB: some backwards hardware compatibility has been restored

A modification has been reverted in order to restore support to old motherboards: [Unstable Update] 2023-02-17 - Plasma 5.27 LTS, GNOME, Python - #51 by philm

GRUB, LUKS and full disk encryption: 'no such cryptodisk found'

Following grub’s update, new configuration may be needed to be manually applied:

  • Check for modifications to /etc/default/grub
    Most notably, if you use LUKS with full disk encryption, you may need to:
    • check that GRUB_ENABLE_CRYPTODISK=y is not commented out
  • Don’t use tools like grub-customizer as it may create issues with the grub.cfg file.
  • Check if the UUID of your encrypted drive matches in your config files.
  • Based on the manual, unlike filesystem UUIDs, UUIDs for encrypted devices must be specified without dash separators. So check /boot/grub/grub.cfg for entries like cryptomount -u 3722dfb2-3b32-414b-bd59-4329fa92b6a9 and try to remove the dash separators.
  • If you modified the above configuration, you then need to update the grub menu with sudo update-grub.
  • A message “no such cryptodisk found” may appear on the following reboot, but should not prevent you from continuing by typing any key.

You may still want to have a liveUSB ready, in the rare case your bootloader does break, in which case you will need to reinstall grub.

For more details:

Info about recent NVIDIA packaging changes

[Testing Update] 2023-03-25 - Kernels, Firefox, Deepin, GNOME, NVIDIA, Wine - #42 by philm

Possible kernel fs block code regression in 6.2.3 umounting usb drives

With kernel 6.2.3 when you simply plug in a usb external drive, mount it and umount it, then the journal has a kernel Oops. A bug report, that includes the journal output was submitted at. https://bugzilla.kernel.org/show_bug.cgi?id=217174 Discussion can be found here: Re: Possible kernel fs block code regression in 6.2.3 umounting usb drives — Linux Stable Kernel Updates

kernel 5.15.99+ Black/empty screen during boot with i915 Intel gfx. No ways to do anything

Seems there is a regression introduced with 5.15.99 kernel update: [i915]drm:add_taint_for_CI [i915]] CI tainted:0x9 by intel_gt_init+0xae/0x2d0 [i915] (#8284) · Issues · drm / intel · GitLab. My thoughts here: [Testing Update] 2023-03-11 - Kernels, Mesa 22.3.7, Phosh, LibreOffice 7.4.6 - #31 by philm

NVIDIA 530.41.03-1 high refresh rate problems

FS#77975 - [nvidia] 530.41.03-1 high refresh rate problems


Switch to the base-devel meta package requires manual intervention

2023-02-12 - Robin Candau

On February 2nd, the base-devel package group has been replaced by a meta package of the same name.
If you installed the base-devel package group prior to this date, explicitly re-install it to get the new base-devel package installed on the system:

pacman -Syu base-devel

Arch Linux - News: Switch to the base-devel meta package requires manual intervention


vlc player crashes while playing videos

A solution, regarding to rob215x, is:
VLC would crash immediately when trying to play any video. I opened VLC directly, and changed Preferences > Video > Output from “Automatic” to “VDPAU” and it works now. I found that solution on another thread but I still don’t understand the problem and why VDPAU works.


PHP 8.2 update and introduction of legacy branch

2023-01-13 - Pierre Schmitz

The php packages have been updated to the latest version 8.2. In addition to this, a new set of php-legacy packages have been introduced. These will follow the oldest but still actively supported PHP branch. This enables users to install the latest version but also introduces the option to use third party applications that might rely on an older version. Both branches will be kept up to date following our rolling release model. php and php-legacy can be installed at the same time as the latter uses a -legacy suffix for its binaries and configuration files.

In addition to this, the php7 packages have been removed as they reached end of life. The imap extension will no longer be provided as it relies on the c-client library which has been abandoned for many years.

Arch Linux - News: PHP 8.2 update and introduction of legacy branch


pacman-mirrors was temporarily renamed to manjaro-mirrors (changed has been reverted)

This was done to avoid confusion with an AUR / WSL package with the same name and avoid possible breakage. It should be a seamless transition.

Rename project (#183) · Issues · Applications / pacman-mirrors · GitLab

dbus-x11 demoted to AUR

dbus-x11 was installed out of the box on some flavors of Manjaro as of a year ago, but is no longer needed. If you have it installed, please replace it with dbus using the following:

sudo pacman -Syu dbus
XFCE becomes unusable if libxfce4ui-nocsd is still installed

So far XFCE Classic project hasn’t updated yet to 4.18 series. We pushed 4.17.0 version of the package, but don’t know if that helps in that situation. It is recommended to install the regular libxfce4ui package to avoid issues and comment on this issue: libxfce4ui 4.18.0 released · Issue #15 · Xfce-Classic/libxfce4ui-nocsd · GitHub


Bootsplash… ==> Kernel 6.3.1-2

zgrep CONFIG_BOOTSPLASH /proc/config.gz 


journalctl warning:
archlinux kernel: memfd_create() without MFD_EXEC nor MFD_NOEXEC_SEAL, pid=1 'systemd'

Not really THE solution??
I have NOT bootsplash installed…

1 Like

I can not reproduce this issue with mkinitcpio and dracut including native systemd.

Edit:// It is just warning, but not error.

Try to change udev hook to systemd hook in /etc/mkinitcpio.conf, then run $ sudo mkintcpio -P

1 Like

After updating Python 3.11 I lost some useful python tools on my local (not system), for example: TxtStyle


  1. Remove old python 3.10 libs in my local, not system.
$ rm -rf $HOME/.local/lib/python[OLD_VERSION]
  1. Reinstall TxtStyle again:
$ pip install TxtStyle 

has been in for a long time: /etc/mkinitcpio.conf,
HOOKS=(base systemd autodetect modconf block keyboard keymap filesystems)
EDIT: latest update (incl. linux6.3.1-3) no change…
(its only a warning)

1 Like

The only failure occurred on python-fasttext with a compile error. Fortunately this was an optional dependency of python-dateparser, so removing the broken package did not hurt me.

Are there any plans to replace mkinitcpio with dracut in Manjaro?

I have this warning in journald too.

When I use kernel linux63 I have this warnings:

kernel zswap: compressor lz4 not available, using default zstd
kernel zswap: loaded using pool zstd/z3fold

But, when using kernel linux62:

kernel zswap: loaded using pool lz4/z3fold

I have set in /etc/grub to use “zswap.compressor=lz4” and “zswap.zpool=z3fold”. As is in the Arch zswap wiki. Manjaro uses zstd as default, I will change this to use zstd, by removing this parametres. But when I remove them:

kernel zswap: loaded using pool zstd/zsmalloc

Then, this is the defaults for Manjaro.
I read somewhere that lz4 and z3fold is better for zswap compression.

FYI, yay has been dropped from the repos. It is no longer a viable AUR helper if it can’t rebuild packages because the same version is cached. pamac and paru can.

octopi will also be dropped as we no longer have any of the AUR helpers it supports in the repos.

Reminder: Neither Arch nor Manjaro officially support the AUR let alone AUR helpers. However, both still still have dedicated sections of the forum for assistance.

EDIT: I’ve reverted the changes. yay and octopi are back in the repos.


Damn, that was a fast drop from repo. The bug was just reported.

I’ve been using yay for a few years. Hopefully they fix that.


There are many “firmware” things in the AUR - needed to get a working System…

Like what?
Seems it would be a rather rare case.

…but…it still doesnt change anything about AUR’s status as unofficial,third-party,unsupported.

Feel like elaborating on the first part about yay, cause I just replaced pikaur cause I didn’t feel like building it by hand?

As for Octopi you don’t have pikaur in the Manjaro repos? I switched switched to it when I thought yay was end of life and refused and still refuse to use paru.

That said Seeing Octopi dropped won’t hurt my feelings. Never been a fan of it. Years back when I first tried out Manjaro it came with Octopi and because if it and something else which I don’t remember I dropped Manjaro like a hot potato. Since then I learned I could simply install any number of software managers. Any Arch distro I install gets pamac with aur, snap, and flatpak support even though I update through the terminal and us pacseek for finding software.

Bug in yay causes it to even ignore explicit flags such as

--rebuild --answerclean All

(a workaround is to manually clean the cache … then yay will have to clean build)


Nonsense! if you remove the applications with a bug, manjaro will be empty!
Why not also remove pamac at the first bug? yay’s engine was rewritten a few weeks ago, so it’s normal to have bugs right now and they are fixed very fast. If manjaro doesn’t trust the developers anymore, they better stop the distribution right away.

If manjaro doesn’t trust the developers anymore, they better stop the distribution right away.

Why we have branches? I thought it was for this case ???
Why block testing when plasma or gnome is a problem when it is easier to remove them. :rofl:


yay -S "package_name" --answerclean All not work ? it’s your solution last year for python 3.9 to 3.10 and, i can’t found issue in forum eos and arch for this python update with yay …


This depends on which hardware components are used on your System.

and not what is the weather like -Microsoft Answer, fully coorect but not helpful.


Folks, you’re free to use any AUR helper you like. There are binary releases of Yay and Paru if you don’t want to build them from source.

1 Like

This implies that if yay fixes the current issue, that it will be re-added to the repos. Is this the case? (If so, I agree that’s a weird reason to remove a long-time staple package from all Manjaro branches).

If that’s not the case, maybe be more straight-forward with the reasoning? i.e. Manjaro devs offer and support pamac, which is probably seen as having feature-parity with yay for most general use-cases, so maintaining yay in the repos is no longer easy to justify.


I don’t really have much skin in this - I mainly use pikaur, which can also be used for rebuilds as follows:

pikaur -Sa --rebuild $(pacman -Qqo /usr/lib/python3.10)

or all AUR packages (not just python) that need a rebuild (depends on rebuild-detector):

pikaur -Sa --rebuild $(checkrebuild|grep -oP '^foreign\s+\K(?!.*-bin$)([\w\.@\+\-]*)$')