[Unstable Update] 2023-04-14 - Kernels, Deepin, Qt5/6, KDE Frameworks 5.105.0,

Hello community,

Another unstable branch update with some usual package updates for you.


get a whopping 82% off + 2 months free on your subscription with Surfshark VPN

Recent News:

  • Manjaro, like many other open-source projects, relies on the generosity of its community through donations and corporate sponsorships to support its growth and development. These donations are essential in covering the various expenses incurred in the operations of the project such as server costs, software development tools, infrastructure expenses, training, flying people to events or conferences and the salaries of key developers. With the help of these donations, Manjaro is able to secure the necessary financial stability that allows the project to continuously improve and remain active. If you love Manjaro, consider to donate!
  • As you might have seen some of our team were able to attend FOSDEM 2023 and the conference proved to be incredibly productive for us. See our blog post for more.
Previous News
Finding information easier about Manjaro

Finding information easier about Manjaro always has been a topic that needed to be solved. With our new search we have put all Manjaro data accessible in one place and divided by sections so it makes it easier to digest: New Manjaro search engine is available | Blog


Notable Package Updates:

  • Some of our Kernels got updated
  • Deepin got some updates
  • Qt 5.15.9 Opensource
    Qt 6.5 LTS
  • KDE Frameworks are now at 5.105.0
  • Usual KDE-git, Python and Haskell updates
  • Arch did their Spring-Cleaning. Hence some packages moved to the AUR
  • We also started to do some Spring-Cleaning

Additional Info

Info about AUR packages

:warning: AUR (Arch User Repository) packages are neither supported by Arch nor Manjaro. Posts about them in Announcement topics are off-topic and will be flagged, moved or removed without warning.

Info about GNOME 43

GNOME 43 is here! :partying_face:

New in Manjaro GNOME:

Lonely leftover orphan packages that have been removed from the Arch / Manjaro repositories:

  • adwaita-maia
  • dynamic-wallpaper-editor
  • firefox-gnome-theme-maia
  • gtkhash-nautilus
    (Not compatible with Nautilus 43)
  • manjaro-dynamic-wallpaper
  • manjaro-gdm-tweak
  • nautilus-terminal
    (Not compatible with Nautilus 43 & EOL)

Get our latest daily developer images now from Github: Plasma, GNOME, XFCE. You can get the latest stable releases of Manjaro from CDN77.

Our current supported kernels

  • linux419 4.19.280
  • linux54 5.4.240
  • linux510 5.10.177
  • linux515 5.15.107
  • linux61 6.1.24
  • linux62 6.2.11
  • linux63 6.3-rc6
  • linux515-rt 5.15.94_rt59
  • linux60-rt 6.0.5_rt14

Package Changes (Fri Apr 14 03:49:07 CEST 2023)

A detailed list of all package changes can be found here

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Known issues and solutions

This is a wiki post; please edit as necessary.
Please, consider subscribing to the Unstable Updates Announcements RSS feed

Please RTFT (Read This Fine Thread) first before reporting the same issues over and over again!

:arrow_right: 2023-04-14



GRUB: some backwards hardware compatibility has been restored

A modification has been reverted in order to restore support to old motherboards: [Unstable Update] 2023-02-17 - Plasma 5.27 LTS, GNOME, Python - #51 by philm

GRUB, LUKS and full disk encryption: 'no such cryptodisk found'

Following grub’s update, new configuration may be needed to be manually applied:

  • Check for modifications to /etc/default/grub
    Most notably, if you use LUKS with full disk encryption, you may need to:
    • check that GRUB_ENABLE_CRYPTODISK=y is not commented out
  • Don’t use tools like grub-customizer as it may create issues with the grub.cfg file.
  • Check if the UUID of your encrypted drive matches in your config files.
  • Based on the manual, unlike filesystem UUIDs, UUIDs for encrypted devices must be specified without dash separators. So check /boot/grub/grub.cfg for entries like cryptomount -u 3722dfb2-3b32-414b-bd59-4329fa92b6a9 and try to remove the dash separators.
  • If you modified the above configuration, you then need to update the grub menu with sudo update-grub.
  • A message “no such cryptodisk found” may appear on the following reboot, but should not prevent you from continuing by typing any key.

You may still want to have a liveUSB ready, in the rare case your bootloader does break, in which case you will need to reinstall grub.

For more details:

Info about recent NVIDIA packaging changes

[Testing Update] 2023-03-25 - Kernels, Firefox, Deepin, GNOME, NVIDIA, Wine - #42 by philm

Possible kernel fs block code regression in 6.2.3 umounting usb drives

With kernel 6.2.3 when you simply plug in a usb external drive, mount it and umount it, then the journal has a kernel Oops. A bug report, that includes the journal output was submitted at. https://bugzilla.kernel.org/show_bug.cgi?id=217174 Discussion can be found here: Re: Possible kernel fs block code regression in 6.2.3 umounting usb drives — Linux Stable Kernel Updates

kernel 5.15.99+ Black/empty screen during boot with i915 Intel gfx. No ways to do anything

Seems there is a regression introduced with 5.15.99 kernel update: [i915]drm:add_taint_for_CI [i915]] CI tainted:0x9 by intel_gt_init+0xae/0x2d0 [i915] (#8284) · Issues · drm / intel · GitLab. My thoughts here: [Testing Update] 2023-03-11 - Kernels, Mesa 22.3.7, Phosh, LibreOffice 7.4.6 - #31 by philm

NVIDIA 530.41.03-1 high refresh rate problems

FS#77975 - [nvidia] 530.41.03-1 high refresh rate problems


Switch to the base-devel meta package requires manual intervention

2023-02-12 - Robin Candau

On February 2nd, the base-devel package group has been replaced by a meta package of the same name.
If you installed the base-devel package group prior to this date, explicitly re-install it to get the new base-devel package installed on the system:

pacman -Syu base-devel

Arch Linux - News: Switch to the base-devel meta package requires manual intervention


vlc player crashes while playing videos

A solution, regarding to rob215x, is:
VLC would crash immediately when trying to play any video. I opened VLC directly, and changed Preferences > Video > Output from “Automatic” to “VDPAU” and it works now. I found that solution on another thread but I still don’t understand the problem and why VDPAU works.


PHP 8.2 update and introduction of legacy branch

2023-01-13 - Pierre Schmitz

The php packages have been updated to the latest version 8.2. In addition to this, a new set of php-legacy packages have been introduced. These will follow the oldest but still actively supported PHP branch. This enables users to install the latest version but also introduces the option to use third party applications that might rely on an older version. Both branches will be kept up to date following our rolling release model. php and php-legacy can be installed at the same time as the latter uses a -legacy suffix for its binaries and configuration files.

In addition to this, the php7 packages have been removed as they reached end of life. The imap extension will no longer be provided as it relies on the c-client library which has been abandoned for many years.

Arch Linux - News: PHP 8.2 update and introduction of legacy branch


pacman-mirrors was temporarily renamed to manjaro-mirrors (changed has been reverted)

This was done to avoid confusion with an AUR / WSL package with the same name and avoid possible breakage. It should be a seamless transition.

Rename project (#183) · Issues · Applications / pacman-mirrors · GitLab

dbus-x11 demoted to AUR

dbus-x11 was installed out of the box on some flavors of Manjaro as of a year ago, but is no longer needed. If you have it installed, please replace it with dbus using the following:

sudo pacman -Syu dbus
XFCE becomes unusable if libxfce4ui-nocsd is still installed

So far XFCE Classic project hasn’t updated yet to 4.18 series. We pushed 4.17.0 version of the package, but don’t know if that helps in that situation. It is recommended to install the regular libxfce4ui package to avoid issues and comment on this issue: libxfce4ui 4.18.0 released · Issue #15 · Xfce-Classic/libxfce4ui-nocsd · GitHub

A post was split to a new topic: Trouble on choice keyboard language on boot iso

@Yochanan @philm FYI, there is new update upstream to grub 2:2.06.r499.ge67a551a4-1

only for this

umm, i dont think its just switch removal. r456 is of a commit done on 02/02/23. r499 is of a commit done 13/04/23. i didnt dig into many commits inbetween (not that it i understand any) but there are many. anyway just thought of informing

A post was merged into an existing topic: Behind the scene - Manjaro Community - mesa nonfree codecs

Got the
Warning: Could not load "/usr/lib/graphviz/libgvplugin_gdk.so.6" - It was found, so perhaps one of its dependents was not. Try ldd.
issue during recent update.

Full fragment excerpt
Package (7)                Old Version  New Version  Net Change  Download Size

extra/graphviz             8.0.2-1      8.0.3-1        0.01 MiB       3.95 MiB
:: Processing package changes...
(1/7) upgrading graphviz                                                                                                       [############################################################################] 100%
Warning: Could not load "/usr/lib/graphviz/libgvplugin_gdk.so.6" - It was found, so perhaps one of its dependents was not.  Try ldd.
Warning: Could not load "/usr/lib/graphviz/libgvplugin_gtk.so.6" - It was found, so perhaps one of its dependents was not.  Try ldd.
Warning: Could not load "/usr/lib/graphviz/libgvplugin_gdk.so.6" - It was found, so perhaps one of its dependents was not.  Try ldd.
Warning: Could not load "/usr/lib/graphviz/libgvplugin_gtk.so.6" - It was found, so perhaps one of its dependents was not.  Try ldd.
(2/7) upgrading imagemagick                                                                                                    [############################################################################] 100%

To install the gtk2 package (origin: [SOLVED] graphviz dependency on gtk2 / Pacman & Package Upgrade Issues / Arch Linux Forums )


Hi. When trying to update unstable just now, I got this error:

error: failed to commit transaction (conflicting files)
konsole: /etc/xdg/konsolerc exists in filesystem (owned by manjaro-kde-settings)
Errors occurred, no packages were upgraded.

What is the suggested path forward in this case?

I’m taking a look now. Look for manjaro-kde-settings 20230421-1 soon.

In the meantime, manually remove the file, then update.

sudo rm /etc/xdg/konsolerc

Yeah, I got the same thing here. I just moved konsolerc to a backup version and then deleted it. The update then went ahead.

Various messages of this kind in the recent kernel update to 6.3.0-1 in “$ dmesg”:

failed to validate module [vboxdrv] BTF: -22
BPF: 1 type_id=117613 bits_offset=0
BPF: Invalid name

If you check the build log you might see that virtualbox and other modules are not part of the build: Release 6.3.0-1 · manjaro-kernels/linux63 · GitHub

1 Like


Nothing about Lxqt 1.3.0 ?
But present on the unstable branch, thanks :slight_smile:

It was released after this post was created. Are you new here? :stuck_out_tongue_winking_eye:


@phil just rebuilt them. linux63-virtualbox-host-modules 7.0.8-1 are now available.

1 Like

It’s ok now, with the rebuild.

No bootsplash?

Do you mean Linux 6.3 initramfs does not show plymouth boot screen?

No, I use the Bootsplash provided by Manjaro: