[Unstable Update] 2022-10-13 - Kernels, Plasma 5.26, KDE Frameworks 5.99, Nvidia 520.56.06

Hello community,

Another unstable branch update with some usual package updates for you.

  • Plasma is now at 5.26 which brings Plasma to the TV and more new features
  • KDE Frameworks got updated to 5.99
  • KDE Gear got update to 22.08.2
  • Nvidia 520.56.06 fixes some regressions on laptops and adds new features to their driver
  • Some KDE-git, Haskell and Python updates as usual

Additional Info

Info about AUR packages

:warning: AUR (Arch User Repository) packages are neither supported by Arch nor Manjaro. Posts about them in Announcement topics are off-topic and will be flagged, moved or removed without warning.

:information_source: You may need to rebuild any AUR packages that install files to site-packages …

Get our latest daily developer images now from Github: Plasma, GNOME, XFCE. You can get the latest stable releases of Manjaro from CDN77.

Our current supported kernels

  • linux419 4.19.261
  • linux54 5.4.217
  • linux510 5.10.147
  • linux515 5.15.73
  • linux519 5.19.15
  • linux60 6.0.1
  • linux515-rt 5.15.71_rt51
  • linux519-rt 5.19.0_rt10

Package changes (Thu Oct 13 09:22:42 CEST 2022)

A list of all package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


#kde #discover Could the “software update” module in “system administration” be omitted or adapted to call pamac?

#xorg It seems that we still don’t have KDE 5.26 new feature option for animated image ( here is a video from that link) as wallpaper.

I had to deal with tracker3 core dumps at start-up, as I’m using KDE, but also have installed some GNOME apps which have it as dependency. My workaround was to mask it and then restart.

systemctl --user mask tracker-extract-3.service tracker-miner-fs-3.service tracker-miner-rss-3.service tracker-writeback-3.service tracker-xdg-portal-3.service tracker-miner-fs-control-3.service

That’s all I could find so far. Solid update, nonetheless.

Just tested the animated wallpaper and it’s fine. I used a gif. I had to logout and back in but once back on the desktop it was working perfectly.

Please do not forget to vote accordingly in the poll.

1 Like

Yup, gif worked for me too, no restart was necessary (although I did reboot after I applied this update) but I did notice an immediate and sustained increase in cpu usage for plasmashell once I selected the gif, so despite the coolness of an animated wallpaper I think I’ll stick with a plain old image for now.

I had at the time voted for “no issues” because I only found out about tracker3 nagging issue after a little while (check the amount of edits in my post). Also, to be fair, technically misplaced GNOME dependencies aren’t a KDE issue IMHO.

I assume you added a plugin for that Animated Image option in the drop down selection, because I don’t seem to have that option?

You can without installing any plugin just right-click on a gif file and select set as wallpaper

Anyway I first did it the hard way, I first placed a gif into my user’s wallpaper folder (/home/ydar/.local/share/wallpapers/) and then proceeded to select it from Configure Desktop and Wallpaper.

Yes, there isn’t such an option like in some KDE add-ons. I didn’t add a plugin, just ducked-go a picture for it to illustrate what I was unwittingly misconceiting.

Maybe Manjaro can cook a few animated wallpapers for when these updates reach “stable”.

1 Like

Almost surely a plasma 5.26 issue. Virtualbox 6.40 windows 7 guest windows jump around rather than moving smoothly across the desktop via mouse drag. This happens only in win7 guests, win11 and Linux guests work fine. It may be fixed in VB 7, but the kernel modules aren’t yet available. The visual errors did not occur before, including with kwin 5.25.90 beta, which I installed to fix a 5.25 bug. Reverting to 5.25.90 beta doesn’t effect the jumping win7 windows, which occurs in all display modes: seamless, full screen, and normal .

Managed to install kernel modules for VB7, problem is solved.

I expected xdg-desktop-portal-kde issue would be fixed with new Plasma version, but it still fails to start on boot.
5.26 seems to be quite normal update: I can’t name any new regression, but many issues I had before the update still present. For instance, switching to Wayland session with KDE systemd startup makes keyboard layout settings get reset – just as before the update. Screens still jump weirdly on logon. Night Color in X11 session still fails to apply on logon.
Stability ftw! :upside_down_face:

Dolphin windows not remember their respective location on their virtual desktop after a reboot or login after the 5.26 update.

3 posts were split to a new topic: Why is GNOME 43 not yet available in the unstable branch?

I installed latest updates today which brought kernel 5.19.15-1 then rebooted and kernel mod did not load went to black screen.I rebooted into kernel 5.15.73-1 and everything was ok.I went ahead and installed kernel 6.0.1-1 and rebooted and everything works.I’m not really worried about 5.19 as it will be EOL soon so all is well with latest kernel and updates.

5.15.74 | 5.19.16 | 6.0.2 are released and will land to unstable soon…
On stable as well because this have some security fixes


A post was split to a new topic: Trouble building ROCm

GNOME Users: Please test gnome-layout-switcher 0.8.28 and see if I missed anything while cleaning up old code.

  • Known issue: Traditional preview only shows correct image when selected; otherwise shows Manjaro preview image

9 posts were split to a new topic: Can anyone else confirm if modules from already uninstalled kernels are leftover?

This issue is not Manjaro related, as it also happens on Arch, but in Plasma 5.26, I no longer have highlights in my application menu.
What I mean is, that in 5.25, there would be a highlight of objects the mouse is over, with the accent color.
This is no longer the case with 5.26. It happens on at least 2 of my machines, My x64 laptop and my Pinebook Pro, so it’s not architecture or driver related either.

So it’s either caused by Plasma 5.26 or KDE Frameworks 5.99.

Did we test frameworks 5.99 against 5.25 when Plasma wasn’t updated yet? currently it is just guessing …

You’re right I just checked and no high-liting on mouseover, but not really necessary.