[Unstable Update] 2021-01-17 - Kernels, Powerline-Go, Mutter, Python

Try a different theme for the DE - see if the icon appears again.

I tried a couple, I’m using Breeze by default but I tried with Breath2 and Oxygen; and also Default for GTK apps, but it doesn’t change.
I noticed that in the section “notifications” in telegram there isn’t anymore the option “use native notifications”

I downgraded to the older version, since it works correctly. This is the output of telegram-desktop-2.5.5.r1 (the latest working version) when I launch from terminal

telegram-desktop                                                                                              

(process:6883): Telegram-WARNING **: 16:45:32.764: Unfortunately, GTK integration conflicts with qgtk2 platformtheme
and style. Therefore, QT_QPA_PLATFORMTHEME and QT_STYLE_OVERRIDE will be unset.
Telegram-Message: 16:45:32.765: This can be ignored by setting TDESKTOP_I_KNOW_ABOUT_GTK_INCOMPATIBILITY environment
variable to any value, however, if qgtk2 theme or style is used, this will lead to a crash.
Telegram-Message: 16:45:32.765: GTK integration can be disabled by setting TDESKTOP_DISABLE_GTK_INTEGRATION to any v
alue. Keep in mind that this will lead to clipboard issues and tdesktop will be unable to get settings from GTK (suc
h as decoration layout, dark mode & more).

(process:6883): Telegram-WARNING **: 16:45:32.765: Application was built without embedded fonts, this may lead to fo
nt issues.
[ALSOFT] (EE) Failed to set real-time priority for thread: Operation not permitted (1)
1 Like

I updated PulseEffects to 5.0 but it didn’t work with the meta package manjaro-pulse, so I installed PulseEffects legacy 4.8.4 from AUR.

Arch totally botched the pulseeffects 5.0 update. 5.0 will only work with Pipewire.

1 Like

5 posts were split to a new topic: Looking for recent ISO

PHP 8.0 and PHP 7 legacy packages are available

2021-01-28 - Pierre Schmitz

The php package has been updated to version 8.0. Please refer to the upstream migration guide. As some applications are not compatible with PHP 8 yet we provide a php7 package which can be installed alongside version 8. Packages that depend on PHP reflect this update and will require php7 if needed. You might need to update your configuration accordingly. PHP 7 binaries and configuration have the “7” suffix:

  • /usr/bin/php → /usr/bin/php7
  • /etc/php → /etc/php7
  • /usr/bin/php-fpm → /usr/bin/php-fpm7
  • /usr/lib/systemd/system/php-fpm.service → /usr/lib/systemd/system/php-fpm7.service
  • /run/php-fpm → /run/php-fpm7

We also provide third party modules compiled for PHP 7:

Note that support for php7 will be limited and likely be dropped in about a year depending on how soon the majority of applications will be compatible with version 8.

https://archlinux.org/news/php-80-and-php-7-legacy-packages-are-available/

2 Likes

@schinfo

At shutdown “many” terminal messages running all over the screen

NOT (!) at reboot.
Regards:
Kernel 510 (5.10.11-1)
Kernel 511 (5.11.rc5.d0124.g6ee1d74-1)
Gnome / also with extensions disabled / no reason found in bootlog

Not affected: Kernel 59 (5.9.16-1) - here everything normal…

Start a thread in the Support section with the output of journalctl --no-hostname --no-pager -b -1 -p3 (on a boot next to that when you see those lines). Without that, it is hard to tell anything.
I for one, see no issues (except for infamous and long-standing sd-umoun trashlines due to Nvidia driver, but I am used to that) on any of recent kernels, including git’s 5.11-rc6. Most likely you have some hardware-specific “shenanigans”.

Old swedish… Digital Spuk. But which Witch?
I played too much with the System.
Finally I decided to install it new.
No error as described above.


Did one know, that changing the hostname in Gnome resets
/home/[user]/.config/dconf/user
to default???

linux510.12-2
The same BTF Issue as usual…
.EDIT:
Solved in linux510.12.3

Confirmed same BTF issue on boot as earlier builds of 5.10.

Today updates…

:: Starting full system upgrade…
resolving dependencies…
looking for conflicting packages…
error: unresolvable package conflicts detected
error: failed to prepare transaction (conflicting dependencies)
:: opencolorio1 and opencolorio are in conflict

3 Likes

opencolorio1 1.1.1-2 fixes the issue.

1 Like

journalcrl:
could not read from ‘/sys/module/amd64_edac_mod/initstate’: No such device

Linux510.12-3
Solution: Reboot once with “fallback initramfs” entry in GRUB-menu.

Chromium losing Sync support in early March

2021-02-03 - Evangelos Foutras

Google has announced that they are going to block everything but Chrome from accessing certain Google features (like Chrome sync) starting on March 15. This decision by Google is going to affect Arch’s chromium package a bit earlier, on March 2, when Chromium 89 gets released.

We know for sure that data syncing will stop working (passwords, bookmarks, etc.). Other features such as geolocation or enhanced spell check might continue to function for a bit longer. Extensions integrating with Google Drive might misbehave and LibreOffice will lose access to documents stored there.

Other distros such as openSUSE and Fedora have already removed the soon-to-be-limited API keys from their Chromium 88 packages. Fedora’s advisory provides a great deal of perspective on this and I also found this Hackaday post to be quite informative.

https://archlinux.org/news/chromium-losing-sync-support-in-early-march/

2 Likes

i guess this means those who rely on google sync will have to resort to GChrome from AUR afterwards

which don’t have video acceleration at all, what a pity

1 Like

Are you sure? :wink:

2 Likes

Thank you works perfect !