[Unstable Update] 2019-10-24 - Pacman 5.2, Pamac, Octopi, Auracle, Yay

Hello community,

I am happy to announce another Unstable Update. Mostly we have updates for Pacman 5.2 release.

Update news

This update holds the following changes:

Give us the usual feedback and let us know what you think about this update.


Current supported Kernels

  • linux316 3.16.75
  • linux44 4.4.197 (no legacy nvidia-340 module!)
  • linux49 4.9.197
  • linux414 4.14.150
  • linux419 4.19.80
  • linux52 5.2.21 [EOL] (no catalyst module!)
  • linux53 5.3.7 (no catalyst module!)
  • linux54 5.4.0-rc4 (not all modules build yet!)
  • linux419-rt 4.19.72_rt26
  • linux52-rt 5.2.21_rt13

Package Changes (Thu Oct 24 15:19:15 CEST 2019)

:: Different overlay package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-10-23           2019-10-24
-------------------------------------------------------------------------------
                   alpm-octopi-utils              1.0.0-3              1.0.1-3
      gnome-shell-extension-arc-menu34.1+dev+5+gb8bd28f-136.0+dev+2+gd687897-1
               manjaro-arm-installer              1.2.5-1              1.2.6-1
  manjaro-xfce-gtk3-minimal-settings           20190729-1           20191024-1
          manjaro-xfce-gtk3-settings           20190729-1           20191024-1
                       mattercontrol1.7.5+r5200.1670834-1    2.19.10.10370-1.1
                              mntray              0.1.3-2              0.1.4-1
                              octopi             0.9.0-16             0.9.0-17
          octopi-notifier-frameworks             0.9.0-16             0.9.0-17
                 octopi-notifier-qt5             0.9.0-16             0.9.0-17
                                 yay            9.3.3-1.0              9.4.2-1
                             auracle                    -       r290.d59f80b-1
                              pacaur                    -              4.8.6-1


:: Different sync package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-10-23           2019-10-24
-------------------------------------------------------------------------------
                             ansible              2.8.5-1              2.8.6-1
                                atom             1.40.1-1             1.41.0-1
                           bleachbit                2.2-2                3.0-1
                           borgmatic             1.3.26-1              1.4.0-1
                       cabal-install          2.4.0.0-149          2.4.0.0-150
                             caprine             2.39.0-1             2.40.0-1
                           ctemplate                2.3-5                2.3-6
                               darcs           2.14.2-120           2.14.2-121
                            electron             6.0.12-1              6.1.1-1
                           electron4             4.2.11-1             4.2.12-1
               firefox-ublock-origin             1.22.4-1             1.23.0-1
                            geda-gaf              1.8.2-4             1.10.0-1
                           git-annex         7.20191017-8         7.20191017-9
                              gitlab             12.3.5-1             12.4.0-1
                       gitlab-runner             12.3.0-2             12.4.0-1
                        gtkimageview              1.6.4-5              1.6.4-6
                    haskell-aeson-qq            0.8.2-138            0.8.2-139
                haskell-authenticate            1.3.4-356            1.3.4-357
                         haskell-aws           0.21.1-110           0.21.1-111
               haskell-clash-prelude            0.99.3-70            0.99.3-71
                   haskell-criterion           1.5.5.0-74           1.5.5.0-75
                     haskell-githash           0.1.3.2-14           0.1.3.2-15
                      haskell-hakyll         4.12.5.2-113         4.12.5.2-114
                        haskell-here            1.2.13-86            1.2.13-87
                       haskell-hpack             0.33.0-4             0.33.0-5
              haskell-hspec-wai-json             0.9.2-82             0.9.2-83
                        haskell-http         4000.3.14-44         4000.3.14-45
                haskell-http-conduit            2.3.7.3-3            2.3.7.3-4
               haskell-http-download           0.1.0.0-37           0.1.0.0-38
                 haskell-interpolate             0.2.0-98             0.2.0-99
    haskell-interpolatedstring-perl6              1.0.2-1              1.0.2-2
                   haskell-js-jquery            3.3.1-288            3.3.1-289
             haskell-optparse-simple           0.1.1.2-67           0.1.1.2-68
                      haskell-pantry           0.1.1.1-50           0.1.1.1-52
               haskell-persistent-qq             2.9.1-74             2.9.1-75
              haskell-servant-server            0.16.2-29            0.16.2-30
                       haskell-shake            0.18.3-41            0.18.3-42
             haskell-simple-sendfile            0.2.28-58             0.2.29-1
                  haskell-singletons             2.5.1-32             2.5.1-33
                    haskell-src-meta             0.8.2-31             0.8.2-32
                       haskell-store           0.5.1.2-20           0.5.1.2-21
                  haskell-th-desugar               1.9-35               1.9-36
                  haskell-th-orphans            0.13.7-24             0.13.9-1
                haskell-th-utilities            0.2.3.1-1            0.2.3.1-2
              haskell-wai-app-static          3.1.6.3-110          3.1.6.3-111
          haskell-wai-handler-launch          3.0.2.4-223          3.0.2.4-224
                        haskell-warp              3.3.3-2              3.3.3-3
                    haskell-warp-tls             3.2.8-15             3.2.8-16
                       haskell-yesod            1.6.0-358            1.6.0-359
                  haskell-yesod-auth             1.6.8-30             1.6.8-31
                  haskell-yesod-core          1.6.16.1-19          1.6.16.1-20
               haskell-yesod-default            1.2.0-601            1.2.0-602
                  haskell-yesod-form             1.6.7-19             1.6.7-20
            haskell-yesod-persistent          1.6.0.2-106          1.6.0.2-107
                haskell-yesod-static          1.6.0.1-212          1.6.0.1-213
                  haskell-yesod-test              1.6.7-3              1.6.7-4
                         hledger-web              1.15-27              1.15-28
                              hoogle         5.0.17.11-17         5.0.17.11-18
                             klayout             0.25.9-1               0.26-1
                             labplot                2.6-4              2.7.0-1
                             libdnet              1.12-10              1.12-11
                   npm-check-updates             3.1.24-1             3.1.25-1
                              pandoc             2.7.3-63             2.7.3-64
                     pandoc-citeproc           0.16.2-130           0.16.2-131
                     pandoc-crossref          0.3.4.1-112          0.3.4.1-113
                           postgrest             6.0.0-41             6.0.0-43
                     python-cfn-lint             0.24.4-1             0.24.5-1
                          python-irc               16.4-1               17.1-1
               python-keystoneclient             3.21.0-1             3.22.0-1
                   python-novaclient             15.1.0-1             16.0.0-1
           python-sqlalchemy-migrate             0.12.0-1             0.13.0-1
          python2-sqlalchemy-migrate             0.12.0-1             0.13.0-1
               react-native-debugger             0.10.1-1             0.10.2-1
                          shellcheck             0.7.0-47             0.7.0-48
                               stack             2.1.3-57             2.1.3-59
                      tamarin-prover            1.4.1-174            1.4.1-175
         v2ray-domain-list-community         20191017.1-1         20191024.1-1
                           wordpress              5.2.3-1              5.2.4-1
                       xcursor-comix              0.9.0-2              0.9.0-3
                              xmobar              0.31-10              0.31-11
          haskell-ordered-containers                    -              0.2.2-1
                              texlab                    -              1.6.0-2


:: Different overlay package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-10-23           2019-10-24
-------------------------------------------------------------------------------
                              pacman              5.1.3-1              5.2.0-1


:: Different overlay package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-10-23           2019-10-24
-------------------------------------------------------------------------------
                             auracle       r261.342de84-1                    -
                          fontconfig 2:2.13.1+12+g5f5ec56-1                  -
                   manjaro-arm-tools              2.6.4-1              2.7.0-1
                              pacaur              4.8.6-1                    -
                           pamac-cli              9.0.1-3              9.0.1-4
                        pamac-common              9.0.1-3            9.0.1-4.1
                           pamac-gtk              9.0.1-3              9.0.1-4
                   pamac-snap-plugin              9.0.1-3              9.0.1-4
             pamac-tray-appindicator              9.0.1-3              9.0.1-4
                              pyalpm              0.8.5-2                    -


:: Different sync package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-10-23           2019-10-24
-------------------------------------------------------------------------------
                        arch-signoff              0.2.1-1                0.3-1
                                 ell               0.24-1               0.25-1
                         foomatic-db         3:20190905-1         3:20191024-1
                 foomatic-db-nonfree         3:20190905-1         3:20191024-1
            foomatic-db-nonfree-ppds         3:20190905-1         3:20191024-1
                    foomatic-db-ppds         3:20190905-1         3:20191024-1
                               gpart                0.3-2                0.3-3
                     grml-zsh-config             0.16.0-1             0.16.1-1
               gtk-update-icon-cache    1:3.24.12-1 1:3.24.12+32+g39e28ab933-1
                                gtk3    1:3.24.12-1 1:3.24.12+32+g39e28ab933-1
                        libqalculate              3.4.0-1              3.5.0-2
                             librsvg           2:2.46.2-1           2:2.46.3-1
                               libuv             1.33.0-1             1.33.1-1
                                 php             7.3.10-1             7.3.11-1
                          php-apache             7.3.10-1             7.3.11-1
                             php-cgi             7.3.10-1             7.3.11-1
                           php-dblib             7.3.10-1             7.3.11-1
                           php-embed             7.3.10-1             7.3.11-1
                         php-enchant             7.3.10-1             7.3.11-1
                             php-fpm             7.3.10-1             7.3.11-1
                              php-gd             7.3.10-1             7.3.11-1
                            php-imap             7.3.10-1             7.3.11-1
                            php-intl             7.3.10-1             7.3.11-1
                            php-odbc             7.3.10-1             7.3.11-1
                           php-pgsql             7.3.10-1             7.3.11-1
                          php-phpdbg             7.3.10-1             7.3.11-1
                          php-pspell             7.3.10-1             7.3.11-1
                            php-snmp             7.3.10-1             7.3.11-1
                          php-sodium             7.3.10-1             7.3.11-1
                          php-sqlite             7.3.10-1             7.3.11-1
                            php-tidy             7.3.10-1             7.3.11-1
                             php-xsl             7.3.10-1             7.3.11-1
                             python2             2.7.16-1             2.7.17-1
                       qalculate-gtk              3.4.0-1              3.5.0-1
                    xkeyboard-config               2.27-1               2.28-1
                            qt5-mqtt                    -             5.13.1-1


:: Different overlay package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-10-23           2019-10-24
-------------------------------------------------------------------------------
                    lib32-fontconfig2:2.13.1+12+g5f5ec56-1                    -


:: Different sync package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-10-23           2019-10-24
-------------------------------------------------------------------------------
                       lib32-librsvg             2.46.2-1             2.46.3-1

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

3 Likes

Blöde Frage: wo seid ihr den gerade vor Ort ? :smiley:

I am getting this when trying to prepare transaction, then fails:

*could not satisfy dependencies:
*unable to satisfy dependency 'pacman<5.2' required by pamac-common
*unable to satisfy dependency 'pacman<5.2' required by pamac-common

pacman is at 5.2.0-1 right now. Can't update due to this.

Me too, same error.

1 Like
So was von OT

Stimmt :smiley: :wink:

"Altes" Foto :wink: , irgendwo in Ă–sterreich.

Yeah, I also get the same dependency error.

Yes, same error.

same error.

I updated testing, then switched back to unstable, ran pacman-mirrors -f 5, and unstable updates worked fine.

For me just the pacman-mirrors -f 5 fixed the updating issue.

Was it that our mirrors were not fully up-to-date?

Wow, I switched to testing, updated database, there was nothing to do, switched back to unstable and found new packages, update went fine now. I assume, the unstable package was fixed plus some additional came in and the whole unstable->testing->unstable trip is not necessary.

No need for pacman-mirrors -f 5 either.

Nah, the repo got updated after we saw the error, I always rank my mirrors before an update.
repo.manjaro.org:

[ ]	pamac-common-9.0.1-6-x86_64.pkg.tar.xz	24-Oct-2019 18:59 	370K
2 Likes
sgs@mx Linux 5.3.7-2-MANJARO x86_64 18.1.1 Juhraya
~ >>> pacman -Q pamac                                                                                             
pamac-gtk 9.0.1-6

I'm about to reboot the VM, but so far it all looked to go well.

Summary
[kdemeoz@Manjaro18KDEbetaVM ~]$ sudo pacman-mirrors -f5 && sudo pacman -Syyu
[sudo] password for kdemeoz: 
::INFO Downloading mirrors from repo.manjaro.org
::INFO Using default mirror file
::INFO Querying mirrors - This may take some time
  2.132 Germany        : https://mirror.alpix.eu/manjaro/
  3.223 Germany        : https://mirror.netzspielplatz.de/manjaro/packages/
  ..... Germany        : https://manjaro.moson.eu/
  ..... Germany        : https://mirror.philpot.de/manjaro/
  ..... Bulgaria       : https://manjaro.ipacct.com/manjaro/
::INFO Writing mirror list
::Germany         : https://mirror.alpix.eu/manjaro/unstable
::Germany         : https://mirror.netzspielplatz.de/manjaro/packages/unstable
::Germany         : https://mirror.philpot.de/manjaro/unstable
::Bulgaria        : https://manjaro.ipacct.com/manjaro/unstable
::Germany         : https://manjaro.moson.eu/unstable
::INFO Mirror list generated and saved to: /etc/pacman.d/mirrorlist
:: Synchronizing package databases...
 core                                               149.0 KiB   119K/s 00:01 [############################################] 100%
 extra                                             1769.7 KiB   276K/s 00:06 [############################################] 100%
 community                                            5.3 MiB   208K/s 00:26 [############################################] 100%
 multilib                                           184.1 KiB   128K/s 00:01 [############################################] 100%
 herecura                                            61.8 KiB  99.2K/s 00:01 [############################################] 100%
:: Starting full system upgrade...
warning: fontconfig: local (2:2.13.91+24+g75eadca-1) is newer than extra (2:2.13.1+12+g5f5ec56-1)
warning: lib32-fontconfig: local (2:2.13.91+24+g75eadca-1) is newer than multilib (2:2.13.1+12+g5f5ec56-1)
resolving dependencies...
looking for conflicting packages...

Package (20)                          Old Version   New Version                 Net Change  Download Size

community/alpm-octopi-utils           1.0.0-3       1.0.1-3                      -0.02 MiB       0.02 MiB
extra/gtk-update-icon-cache           1:3.24.12-1   1:3.24.12+32+g39e28ab933-1    0.00 MiB       0.01 MiB
extra/gtk3                            1:3.24.12-1   1:3.24.12+32+g39e28ab933-1   -0.05 MiB      10.71 MiB
multilib/lib32-libva-mesa-driver      19.2.1-2      19.2.2-1                     17.90 MiB       2.35 MiB
multilib/lib32-mesa                   19.2.1-2      19.2.2-1                    211.71 MiB      16.62 MiB
extra/libqalculate                    3.4.0-1       3.5.0-2                       0.05 MiB       1.59 MiB
extra/librsvg                         2:2.46.2-1    2:2.46.3-1                    0.02 MiB       1.16 MiB
extra/libuv                           1.33.0-1      1.33.1-1                      0.00 MiB       0.20 MiB
extra/libva-mesa-driver               19.2.1-2      19.2.2-1                     17.16 MiB       2.21 MiB
extra/mesa                            19.2.1-2      19.2.2-1                    201.22 MiB      19.73 MiB
community/octopi                      0.9.0-16      0.9.0-17                     -0.08 MiB       0.86 MiB
community/octopi-notifier-frameworks  0.9.0-16      0.9.0-17                     -0.04 MiB       0.50 MiB
core/pacman                           5.1.3-1       5.2.0-1                      -0.67 MiB       0.76 MiB
extra/pamac-cli                       9.0.1-3       9.0.1-6                      -0.01 MiB       0.04 MiB
extra/pamac-common                    9.0.1-3       9.0.1-6                      -0.76 MiB       0.36 MiB
extra/pamac-gtk                       9.0.1-3       9.0.1-6                      -0.07 MiB       0.11 MiB
extra/pamac-tray-appindicator         9.0.1-3       9.0.1-6                      -0.02 MiB       0.01 MiB
extra/python2                         2.7.16-1      2.7.17-1                     -0.05 MiB      11.77 MiB
herecura/vivaldi-snapshot             2.9.1699.4-1  2.9.1705.4-1                 -0.40 MiB      63.65 MiB
extra/xkeyboard-config                2.27-1        2.28-1                       -0.34 MiB       0.62 MiB

Total Download Size:    133.29 MiB
Total Installed Size:  1018.06 MiB
Net Upgrade Size:       445.55 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
 pacman-5.2.0-1-x86_64                              774.1 KiB   137K/s 00:06 [############################################]   0%
 librsvg-2:2.46.3-1-x86_64                         1966.1 KiB   152K/s 00:13 [############################################]   1%
 gtk-update-icon-cache-1:3.24.12+32+g39e28ab93...  1980.2 KiB   150K/s 00:13 [############################################]   1%
 mesa-19.2.2-1-x86_64                                21.7 MiB   320K/s 01:09 [############################################]  16%
 xkeyboard-config-2.28-1-any                         22.3 MiB   323K/s 01:11 [############################################]  16%
 gtk3-1:3.24.12+32+g39e28ab933-1-x86_64              33.0 MiB   353K/s 01:36 [############################################]  24%
 libqalculate-3.5.0-2-x86_64                         34.6 MiB   360K/s 01:38 [############################################]  25%
 libuv-1.33.1-1-x86_64                               34.8 MiB   359K/s 01:39 [############################################]  26%
 libva-mesa-driver-19.2.2-1-x86_64                   37.0 MiB   363K/s 01:44 [############################################]  27%
 pamac-common-9.0.1-6-x86_64                         37.4 MiB   362K/s 01:46 [############################################]  28%
 pamac-cli-9.0.1-6-x86_64                            37.4 MiB   357K/s 01:47 [############################################]  28%
 pamac-gtk-9.0.1-6-x86_64                            37.5 MiB   356K/s 01:48 [############################################]  28%
 pamac-tray-appindicator-9.0.1-6-x86_64              37.5 MiB   355K/s 01:48 [############################################]  28%
 python2-2.7.17-1-x86_64                             49.3 MiB   403K/s 02:05 [############################################]  36%
 alpm-octopi-utils-1.0.1-3-x86_64                    49.3 MiB   402K/s 02:05 [############################################]  36%
 octopi-0.9.0-17-x86_64                              50.2 MiB   405K/s 02:07 [############################################]  37%
 octopi-notifier-frameworks-0.9.0-17-x86_64          50.7 MiB   406K/s 02:08 [############################################]  38%
 lib32-libva-mesa-driver-19.2.2-1-x86_64             53.0 MiB   409K/s 02:13 [############################################]  39%
 lib32-mesa-19.2.2-1-x86_64                          69.6 MiB   443K/s 02:41 [############################################]  52%
 vivaldi-snapshot-2.9.1705.4-1-x86_64               133.3 MiB   683K/s 03:20 [############################################] 100%
(20/20) checking keys in keyring                                             [############################################] 100%
(20/20) checking package integrity                                           [############################################] 100%
(20/20) loading package files                                                [############################################] 100%
(20/20) checking for file conflicts                                          [############################################] 100%
(20/20) checking available disk space                                        [############################################] 100%
:: Processing package changes...
( 1/20) upgrading pacman                                                     [############################################] 100%
warning: /etc/pacman.conf installed as /etc/pacman.conf.pacnew
( 2/20) upgrading alpm-octopi-utils                                          [############################################] 100%
( 3/20) upgrading librsvg                                                    [############################################] 100%
( 4/20) upgrading gtk-update-icon-cache                                      [############################################] 100%
( 5/20) upgrading mesa                                                       [############################################] 100%
( 6/20) upgrading xkeyboard-config                                           [############################################] 100%
( 7/20) upgrading gtk3                                                       [############################################] 100%
( 8/20) upgrading lib32-libva-mesa-driver                                    [############################################] 100%
( 9/20) upgrading lib32-mesa                                                 [############################################] 100%
(10/20) upgrading libqalculate                                               [############################################] 100%
(11/20) upgrading libuv                                                      [############################################] 100%
(12/20) upgrading libva-mesa-driver                                          [############################################] 100%
(13/20) upgrading octopi                                                     [############################################] 100%
(14/20) upgrading octopi-notifier-frameworks                                 [############################################] 100%
(15/20) upgrading pamac-common                                               [############################################] 100%
warning: /etc/pamac.conf installed as /etc/pamac.conf.pacnew
(16/20) upgrading pamac-cli                                                  [############################################] 100%
(17/20) upgrading pamac-gtk                                                  [############################################] 100%
(18/20) upgrading pamac-tray-appindicator                                    [############################################] 100%
(19/20) upgrading python2                                                    [############################################] 100%
(20/20) upgrading vivaldi-snapshot                                           [############################################] 100%
:: Running post-transaction hooks...
(1/9) Reloading system bus configuration...
(2/9) Probing GDK-Pixbuf loader modules...
(3/9) Compiling GSettings XML schema files...
(4/9) Probing GTK3 input method modules...
(5/9) Updating icon theme caches...
(6/9) Reloading system manager configuration...
(7/9) Arming ConditionNeedsUpdate...
(8/9) Updating the desktop file MIME type cache...
(9/9) Updating the MIME type database...
[kdemeoz@Manjaro18KDEbetaVM ~]$ sudo pacman -Syyuu
[sudo] password for kdemeoz: 
:: Synchronizing package databases...
 core                                            149.0 KiB   202 KiB/s 00:01 [############################################] 100%
 extra                                          1769.7 KiB   721 KiB/s 00:02 [############################################] 100%
 community                                         5.3 MiB   686 KiB/s 00:08 [############################################] 100%
 multilib                                        184.1 KiB   361 KiB/s 00:01 [############################################] 100%
 herecura                                         61.8 KiB  56.5 KiB/s 00:01 [############################################] 100%
:: Starting full system upgrade...
warning: fontconfig: downgrading from version 2:2.13.91+24+g75eadca-1 to version 2:2.13.1+12+g5f5ec56-1
warning: lib32-fontconfig: downgrading from version 2:2.13.91+24+g75eadca-1 to version 2:2.13.1+12+g5f5ec56-1
resolving dependencies...
looking for conflicting packages...

Package (2)                Old Version              New Version             Net Change  Download Size

extra/fontconfig           2:2.13.91+24+g75eadca-1  2:2.13.1+12+g5f5ec56-1   -0.06 MiB       0.85 MiB
multilib/lib32-fontconfig  2:2.13.91+24+g75eadca-1  2:2.13.1+12+g5f5ec56-1    0.00 MiB       0.12 MiB

Total Download Size:    0.97 MiB
Total Installed Size:   2.36 MiB
Net Upgrade Size:      -0.06 MiB

:: Proceed with installation? [Y/n] 
:: Retrieving packages...
 fontconfig-2:2.13.1+12+g5f5ec56-1-x86_64        874.2 KiB   321 KiB/s 00:03 [############################################]  87%
 lib32-fontconfig-2:2.13.1+12+g5f5ec56-1-x86_64  995.6 KiB   284 KiB/s 00:04 [############################################] 100%
(2/2) checking keys in keyring                                               [############################################] 100%
(2/2) checking package integrity                                             [############################################] 100%
(2/2) loading package files                                                  [############################################] 100%
(2/2) checking for file conflicts                                            [############################################] 100%
(2/2) checking available disk space                                          [############################################] 100%
:: Processing package changes...
(1/2) downgrading fontconfig                                                 [############################################] 100%
Rebuilding fontconfig cache... done.
(2/2) downgrading lib32-fontconfig                                           [############################################] 100%
Rebuilding 32-bit fontconfig cache... done.
:: Running post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...
[kdemeoz@Manjaro18KDEbetaVM ~]$ 


It rebooted fine. Before the reboot, but after the update, Pamac told me that there were 3 AUR updates, but Octopi did not. For the moment i ignored them.

Post-reboot, Octopi continued to believe there were no more updates, whereas Pamac again notified me of them. I did these 3 AUR updates successfully in Pamac.

erreur : la préparation de la transaction a échoué (la satisfaction des dépendances a échoué)
:: l’installation de pacman (5.2.0-1) casse la dépendance « pacman<5.2 » requise par pkgbrowser

pkgbrowser needs to be updated for the update to be able to proceed.

Edit: the updated package is in the AUR repository.

@oberon package-query is v1.10 in aur - compatible libalpm 12

Smplayer 19.5.0-1 is currently broken because of mpv 0.30.
https://bugs.archlinux.org/task/64268?project=5&string=smplayer
Upstream fixed it with the latest version, but Arch didn't update yet.
I build it yesterday and can confirm that it's working again as expected with Version 19.10.

3 Likes

@philm, @oberon after the last updates to some qt packages on my gnome (unstable) desktop the qt applications (qt5-settings, manjaro-settings-manager and virtualbox) doesn't launch anymore, with the same issue

qt5ct: using qt5ct plugin
Cannot mix incompatible Qt library (version 0x50d02) with this library (version 0x50d01)
[1]    17504 abort (core dumped)  qt5ct settings
1 Like

yes we know. We have to see why we have qt5ct in our overlay. Also other applications might not work due to this.

1 Like

Forum kindly sponsored by