[Unstable Update] 2019-05-03 - Kernels, Backintime, Palemoon

I had same problem as @mparillo in the morning , but after some hours, tried again and all is good now... I can also cinfirm that 5.1.3-2 is working...

Theodore

The installation of this update has destroyed the ability of Linux5.0 as well as Linux 5.2RC from booting with:

[Failed] Failed to start Load Kernel Modules.

Seems like something in Linux5.1 update/build process is going awry. I'm using the broadcom-wl wifi driver in non dkms mode if this means anything.

Reinstalling linux5.2 causes this error output & more that is not allowed to be copied:

Warning: could not get file information for usr/lib/modules/5.2.0-1-MANJARO/
Warning: could not get file information for usr/lib/modules/5.2.0-1-MANJARO/build/
Warning: could not get file information for usr/lib/modules/5.2.0-1-MANJARO/build/vmlinux
Warning: could not get file information for usr/lib/modules/5.2.0-1-MANJARO/extramodules
Warning: could not get file information for usr/lib/modules/5.2.0-1-MANJARO/kernel/
Warning: could not get file information for usr/lib/modules/5.2.0-1-MANJARO/kernel/arch/
Warning: could not get file information for usr/lib/modules/5.2.0-1-MANJARO/kernel/arch/x86/
Warning: could not get file information for usr/lib/modules/5.2.0-1-MANJARO/kernel/arch/x86/crypto/
Warning: could not get file information for usr/lib/modules/5.2.0-1-MANJARO/kernel/arch/x86/crypto/aegis128-aesni.ko.xz
Warning: could not get file information for usr/lib/modules/5.2.0-1-MANJARO/kernel/arch/x86/crypto/aegis128l-aesni.ko.xz
Warning: could not get file information for usr/lib/modules/5.2.0-1-MANJARO/kernel/arch/x86/crypto/aegis256-aesni.ko.xz
Warning: could not get file information for usr/lib/modules/5.2.0-1-MANJARO/kernel/arch/x86/crypto/aes-x86_64.ko.xz
Warning: could not get file information for usr/lib/modules/5.2.0-1-MANJARO/kernel/arch/x86/crypto/aesni-intel.ko.xz
Warning: could not get file information for usr/lib/modules/5.2.0-1-MANJARO/kernel/arch/x86/crypto/blowfish-x86_64.ko.xz
Warning: could not get file information for usr/lib/modules/5.2.0-1-MANJARO/kernel/arch/x86/crypto/camellia-aesni-avx-x86_64.ko.xz
Warning: could not get file information for usr/lib/modules/5.2.0-1-MANJARO/kernel/arch/x86/crypto/camellia-aesni-avx2.ko.xz
Warning: could not get file information for usr/lib/modules/5.2.0-1-MANJARO/kernel/arch/x86/crypto/camellia-x86_64.ko.xz
Warning: could not get file information for usr/lib/modules/5.2.0-1-MANJARO/kernel/arch/x86/crypto/cast5-avx-x86_64.ko.xz
Warning: could not get file information for usr/lib/modules/5.2.0-1-MANJARO/kernel/arch/x86/crypto/cast6-avx-x86_64.ko.xz
Warning: could not get file information for usr/lib/modules/5.2.0-1-MANJARO/kernel/arch/x86/crypto/chacha-x86_64.ko.xz
Warning: could not get file information for usr/lib/modules/5.2.0-1-MANJARO/kernel/arch/x86/crypto/crc32-pclmul.ko.xz
Warning: could not get file information for usr/lib/modules/5.2.0-1-MANJARO/kernel/arch/x86/crypto/crc32c-intel.ko.xz
Warning: could not get file information for usr/lib/modules/5.2.0-1-MANJARO/kernel/arch/x86/crypto/crct10dif-pclmul.ko.xz
Warning: could not get file information for usr/lib/modules/5.2.0-1-MANJARO/kernel/arch/x86/crypto/des3_ede-x86_64.ko.xz
Warning: could not get file information for usr/lib/modules/5.2.0-1-MANJARO/kernel/arch/x86/crypto/ghash-clmulni-intel.ko.xz
Warning: could not get file information for usr/lib/modules/5.2.0-1-MANJARO/kernel/arch/x86/crypto/glue_helper.ko.xz
Warning: could not get file information for usr/lib/modules/5.2.0-1-MANJARO/kernel/arch/x86/crypto/morus1280-avx2.ko.xz
Warning: could not get file information for usr/lib/modules/5.2.0-1-MANJARO/kernel/arch/x86/crypto/morus1280-sse2.ko.xz
Warning: could not get file information for usr/lib/modules/5.2.0-1-MANJARO/kernel/arch/x86/crypto/morus1280_glue.ko.xz
Warning: could not get file information for usr/lib/modules/5.2.0-1-MANJARO/kernel/arch/x86/crypto/morus640-sse2.ko.xz
Warning: could not get file information for usr/lib/modules/5.2.0-1-MANJARO/kernel/arch/x86/crypto/morus640_glue.ko.xz
Warning: could not get file information for usr/lib/modules/5.2.0-1-MANJARO/kernel/arch/x86/crypto/nhpoly1305-avx2.ko.xz
Warning: could not get file information for usr/lib/modules/5.2.0-1-MANJARO/kernel/arch/x86/crypto/nhpoly1305-sse2.ko.xz
Warning: could not get file information for usr/lib/modules/5.2.0-1-MANJARO/kernel/arch/x86/crypto/poly1305-x86_64.ko.xz
Warning: could not get file information for usr/lib/modules/5.2.0-1-MANJARO/kernel/arch/x86/crypto/serpent-avx-x86_64.ko.xz
Warning: could not get file information for usr/lib/modules/5.2.0-1-MANJARO/kernel/arch/x86/crypto/serpent-avx2.ko.xz
Warning: could not get file information for usr/lib/modules/5.2.0-1-MANJARO/kernel/arch/x86/crypto/serpent-sse2-x86_64.ko.xz
Warning: could not get file information for usr/lib/modules/5.2.0-1-MANJARO/kernel/arch/x86/crypto/sha1-ssse3.ko.xz

Same for linux50

Checking available disk space...
Warning: could not get file information for usr/lib/modules/5.0.16-1-MANJARO/
Warning: could not get file information for usr/lib/modules/5.0.16-1-MANJARO/build/
Warning: could not get file information for usr/lib/modules/5.0.16-1-MANJARO/build/vmlinux
Warning: could not get file information for usr/lib/modules/5.0.16-1-MANJARO/extramodules
Warning: could not get file information for usr/lib/modules/5.0.16-1-MANJARO/kernel/
Warning: could not get file information for usr/lib/modules/5.0.16-1-MANJARO/kernel/arch/
Warning: could not get file information for usr/lib/modules/5.0.16-1-MANJARO/kernel/arch/x86/
Warning: could not get file information for usr/lib/modules/5.0.16-1-MANJARO/kernel/arch/x86/crypto/
Warning: could not get file information for usr/lib/modules/5.0.16-1-MANJARO/kernel/arch/x86/crypto/aegis128-aesni.ko.xz
Warning: could not get file information for usr/lib/modules/5.0.16-1-MANJARO/kernel/arch/x86/crypto/aegis128l-aesni.ko.xz
Warning: could not get file information for usr/lib/modules/5.0.16-1-MANJARO/kernel...............................

UPDATE:
So now reinstalling linux50 takes out linux51 & linux52 as described previously?

Update2:
Removing linux51-broadcom-wl (6.30.223.271-4)...
Removing linux51 (5.1.3-2)...
Removing linux52-broadcom-wl (6.30.223.271-0.1)...
Configuring linux52-broadcom-wl...
depmod: ERROR: could not open directory /lib/modules/5.2.0-1-MANJARO: No such file or directory
depmod: FATAL: could not search modules: No such file or directory
Error: command failed to execute correctly

I was hoping the latest xfwm4 update to 4.13.2 would solve ongoing cpu issues, but they're still elevated for me. 25% additional for gaming and streaming video, 10% additional for regular videos. (First time seeing this issue was on v4.13.1-8 on 7-May.)

Disabling the xfce compositor is still a workaround.

2 Likes

Good news: the new xfwm4 version bump to 4.13.2-3 in unstable solved the cpu issues for me. There was mention of buggy 4k video playback in a bug report, but I'm wondering if that person was maybe trying to play an unsupported codec on libvdpau like vp8/9 or hevc 10-bit. This will probably have to go through more testing. Although the commits directly mention issues with the nvidia non-free driver, there may be improvements with the open-source drivers. You can read about them here and here.

@acutbal @pappl @themew

edit: I've tested h.264 and standard hevc 8-bit 4k videos in vlc using default hw-acceleration without issues. Configuration of vdpau should be set by default, but it's probably worth a check to make sure you're using the correct drivers in your /etc/environment file. Here's mine:

LIBVA_DRIVER_NAME=vdpau
VDPAU_DRIVER=nvidia

:slightly_smiling_face:

2 Likes

Thank you very much for the notice!! :grinning::+1:

The latest Chromium package has a bad window drawing bug. Try to reproduce:

Open chromium, make sure full hardware acceleration is on (incl. flags), maximize the window, then ctrl+shift+n for a new incognito window, continue opening new incognito windows and diagonal scanlines should be visible when they are redrawn. You can briefly see the square outlines of where the window is initially drawn before rastered.

chrome://gpu log should list them all.

update:

alsa doesn't restore on boot

Process '/usr/bin/alsactl restore 1' failed with exit code 99.

then works normally. Solved as shown https://community.chakralinux.org/t/how-to-solve-usr-sbin-alsactl-restore-0-failed-with-exit-code-99/7047

No offense meant, but, with the new version of "Unstable 19.05.21, ISO" out, I think it is time for a new topic.

[bob@Manjaro-Unstable ~]$ inxi -Fxzc0
System:
  Host: Manjaro-Unstable Kernel: 5.1.5-1-MANJARO x86_64 bits: 64 
  compiler: gcc v: 8.3.0 Desktop: Xfce 4.13.4git-be04da 
  Distro: Manjaro Linux 
Machine:
  Type: Desktop System: LENOVO product: 10181 v: Lenovo K450e 
  serial: <filter> 
  Mobo: LENOVO model: N/A v: 31900058 STD serial: <filter> BIOS: LENOVO 
  v: I1KT38AUS date: 06/10/2014 
Battery:
  Device-1: hidpp_battery_0 model: Logitech M570 charge: 85% 
  status: Discharging 
CPU:
  Topology: Quad Core model: Intel Core i5-4460 bits: 64 type: MCP 
  arch: Haswell rev: 3 L2 cache: 6144 KiB 
  flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx 
  bogomips: 25554 
  Speed: 1278 MHz min/max: 800/3400 MHz Core speeds (MHz): 1: 1194 2: 1187 
  3: 1168 4: 1102 
Graphics:
  Device-1: NVIDIA GK208 [GeForce GT 720] vendor: Micro-Star MSI 
  driver: nvidia v: 430.14 bus ID: 01:00.0 
  Display: x11 server: X.Org 1.20.4 driver: nvidia tty: N/A 
  OpenGL: renderer: GeForce GT 720/PCIe/SSE2 v: 4.6.0 NVIDIA 430.14 
  direct render: Yes 
Audio:
  Device-1: Intel 8 Series/C220 Series High Definition Audio vendor: Lenovo 
  driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  Device-2: NVIDIA GK208 HDMI/DP Audio vendor: Micro-Star MSI 
  driver: snd_hda_intel v: kernel bus ID: 01:00.1 
  Sound Server: ALSA v: k5.1.5-1-MANJARO 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Lenovo driver: r8168 v: 8.047.01-NAPI port: d000 bus ID: 03:00.0 
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  Device-2: Realtek RTL8821AE 802.11ac PCIe Wireless Network Adapter 
  vendor: Lenovo driver: rtl8821ae v: kernel port: c000 bus ID: 04:00.0 
  IF: wlp4s0 state: down mac: <filter> 
Drives:
  Local Storage: total: 1.82 TiB used: 54.27 GiB (2.9%) 
  ID-1: /dev/sda vendor: Western Digital model: WD10EZEX-08M2NA0 
  size: 931.51 GiB 
  ID-2: /dev/sdb type: USB vendor: Western Digital model: WD Elements 25A2 
  size: 931.48 GiB 
Partition:
  ID-1: / size: 453.55 GiB used: 18.80 GiB (4.1%) fs: ext4 dev: /dev/sda2 
  ID-2: swap-1 size: 7.95 GiB used: 5.8 MiB (0.1%) fs: swap dev: /dev/sda3 
Sensors:
  System Temperatures: cpu: 42.0 C mobo: N/A gpu: nvidia temp: 56 C 
  Fan Speeds (RPM): N/A gpu: nvidia fan: 29% 
Info:
  Processes: 198 Uptime: 3h 09m Memory: 7.72 GiB used: 1.16 GiB (15.0%) 
  Init: systemd Compilers: gcc: 8.3.0 Shell: bash v: 5.0.7 inxi: 3.0.34 

anyone having a problem with todays upgrade of xorg-server and xorg-server-common to 1.20.5-0? My old core 2 duo required a downgrade back to 1.20.4

What was the issue? It broke your system?

hi Phil, did not break just lots of screen tearing

all good here now with the last batch of updates..:slight_smile:

OK, will try to announce more often in unstable too.

Today's update for my KDE+GNOME VM was fine.

Seems I reported a fix too soon. My issue is back, happens after suspending the system.
After a complete shutdown everything is fine. Will do more investigating.

Appears to be a minor warning, because, after a re-boot, everything seemed normal.

$ sudo pacman -Syyu
[sudo] password for mparillo: 
:: Synchronizing package databases...
 core                                                                152.5 KiB  1694K/s 00:00 [#######################################################] 100%
 extra                                                              1836.3 KiB  2.23M/s 00:01 [#######################################################] 100%
 community                                                             5.2 MiB  2.05M/s 00:03 [#######################################################] 100%
 multilib                                                            184.0 KiB  2.25M/s 00:00 [#######################################################] 100%
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...

Packages (1) linux419-4.19.48-1

...

/dev/mapper/control: open failed: No such device
Failure to communicate with kernel device-mapper driver.
Check that device-mapper is available in the kernel.
Incompatible libdevmapper 1.02.156 (2019-03-22) and kernel driver (unknown version).
2 Likes

@philm, I've got a couple items from the latest unstable:

Are you still building linux51-nvidia 1:430.14-6? linux419 has it but not 51 yet...

After updating the perl packages I got this:

WARNING: '/usr/lib/perl5/5.28' contains data from at least 1 packages which will NOT be used by the installed perl interpreter.
-> Run the following command to get a list of affected packages: pacman -Qqo '/usr/lib/perl5/5.28'

doing pacman -Qqo '/usr/lib/perl5/5.28':

xfconf-gtk3

I cannot apply the latest Unstable updates, due to:

Summary
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing perl (5.30.0-2) breaks dependency 'perl<5.29' required by perl-gtk2-unique
[kdemeoz@Manjaro18KDEbetaVM ~]$

In turn i cannot simply uninstall perl-gtk2-unique because it is needed by one of my most indispensible applications, Shutter:

Summary
[kdemeoz@Manjaro18KDEbetaVM ~]$ pacman -Qi perl-gtk2-unique
Name            : perl-gtk2-unique
Version         : 0.05-23
Description     : Perl bindings for the C library libunique
Architecture    : x86_64
URL             : https://metacpan.org/release/Gtk2-Unique
Licenses        : LGPL  PerlArtistic
Groups          : None
Provides        : None
Depends On      : perl  gtk2-perl  libunique  perl>=5.28  perl<5.29
Optional Deps   : None
Required By     : shutter
Optional For    : None
Conflicts With  : None
Replaces        : None
Installed Size  : 129.00 KiB
Packager        : Unknown Packager
Build Date      : Wed Mar 27 18:48:27 2019
Install Date    : Wed Mar 27 18:48:38 2019
Install Reason  : Explicitly installed
Install Script  : No
Validated By    : None

[kdemeoz@Manjaro18KDEbetaVM ~]$ 

Can anyone suggest a solution here pls?

AUR package, AUR page:
https://aur.archlinux.org/packages/shutter/

1 Like

Forum kindly sponsored by Bytemark