[Unstable Update] 2019-04-20 - gcc, kde, deepin

unstable
update
#1

gcc 8.3.0 has arrived and I will start re-building all our kernels with their latest updates and extramodules now...
Also new Kde and Deepin package versions are here.


Current supported Kernels

  • linux316 3.16.65
  • linux318 3.18.138 [EOL]
  • linux44 4.4.168 (nvidia-340xx module no longer available!)
  • linux49 4.9.169 > 4.9.170
  • linux414 4.14.112 > 4.14.113
  • linux419 4.19.35 > 4.19.36
  • linux420 4.20.17
  • linux50 5.0.8 > 5.0.9
  • linux51rc 5.1rc1.d0317.g9e98c67 (experimental, currently no extramodules)
  • linux419-rt 4.19.31_rt18
  • linux50-rt 5.0.7_rt5

The full list of updated packages to be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

4 Likes
#2

Almost everything went smoothly. The only issue was a rhythmic clicking through wireless headphones that would come through when no sound was playing.

Solved by disabling power saving in TLP as per this thread Audio *click* when sound is about to play and when sound finishes playing

1 Like
#3

Everything seems to be OK at this point. Had to reinstall my kernel 5.0.9 just to keep it above updated 4.19 in rEFInd menu - but it has nothing to do with the very update.

#4

Am fully updated and see no problems, as usual.

#5

@oberon , i see a new version glibc,
does it means all will be again compiled ?

#6

?????

#7

Not sure.

#8

@jonathon can you please have a look at this overlay pkg? Thanks.

newer overwritten sync packages:

   [OVERWRITTEN SYNC PACKAGE]  ->  [LOCAL PACKAGE]
   openssh-8.0p1-1-x86_64.pkg.tar.xz  ->  openssh-7.9p1-1.1-x86_64.pkg.tar.xz
#9

It depends. When extramodules are updated they sometimes complain when compiler version of the kernel is different, not sure about dkms ... we shall find out, soon :wink:
However, we have a lot of new versions of kernels anyway and I just built them with their modules.
We now have:

5.0.9
4.19.36
4.14.113
and
4.9.170

2 Likes
#10

But still 5.1-rc1... :thinking:

#11

Looks like the VirtualBox issues have been solved in Arch and they have uploaded a new build.

2 Likes
#12

That has now been removed. The overlay package was a security update which shouldn't be needed now.

Edit: It looks like boxit has broken on the server - I don't know if you have access to be able to clear it?

-------------------------------------------------------------------------------
Errors of branch unstable
-------------------------------------------------------------------------------
uncomplete desc file '/var/tmp/boxit/sessions/sync_session/.db/metasploit-5.0.9-1/desc'!
1 Like
#13

Yes. I am trying to fix it - am in contact with Phil also ... We shall see.

#14

And apparently packages are dropped to AUR and require "update"

image

Rebuilding of pacman-mirrors is failing
#15

???

$ pacman -Si spectre-meltdown-checker xcursor-breeze xfce-theme-greybird
Repository      : community
Name            : spectre-meltdown-checker
Version         : 0.37-1
Description     : Spectre & Meltdown vulnerability/mitigation checker
                  (CVE-2017-5753, CVE-2017-5715, CVE-2017-5754)
Architecture    : any
URL             : https://github.com/speed47/spectre-meltdown-checker
Licenses        : GPL
Groups          : None
Provides        : None
Depends On      : bash
Optional Deps   : None
Conflicts With  : None
Replaces        : None
Download Size   : 44.41 KiB
Installed Size  : 161.00 KiB
Packager        : Philip Mueller <philm@manjaro.org>
Build Date      : So 29 Apr 2018 12:32:10 CEST
Validated By    : MD5 Sum  SHA-256 Sum  Signature

Repository      : community
Name            : xcursor-breeze
Version         : 5.11.5-1
Description     : KDE5 cursor theme
Architecture    : any
URL             : http://kde-look.org/content/show.php/Breeze?content=165371
Licenses        : GPL
Groups          : None
Provides        : breeze-snow-cursor-theme
Depends On      : libxcursor
Optional Deps   : None
Conflicts With  : breeze-snow-cursor-theme
Replaces        : breeze-snow-cursor-theme
Download Size   : 271.07 KiB
Installed Size  : 5346.00 KiB
Packager        : Bernhard Landauer <oberon@manjaro.org>
Build Date      : Fr 19 Jän 2018 20:33:43 CET
Validated By    : MD5 Sum  SHA-256 Sum  Signature

Repository      : community
Name            : xfce-theme-greybird
Version         : 3.22.9+1-1
Description     : A grey and blue Xfce theme.
Architecture    : any
URL             : https://github.com/shimmerproject/Greybird
Licenses        : CCPL:by-sa-3.0  GPL
Groups          : None
Provides        : None
Depends On      : gtk-engine-murrine
Optional Deps   : elementary-xfce-icons: Matching icon set; use the dark icon
                  theme
                  shimmer-wallpapers: Contains the Greybird wallpaper, among
                  others
                  lightdm-gtk-greeter: Required for the LightDM GTK theme
                  lightdm-unity-greeter: Required for the LightDM Unity theme
                  lib32-gtk-engine-murrine: Required for 32-bit apps in 64-bit
                  environments
Conflicts With  : None
Replaces        : None
Download Size   : 200.68 KiB
Installed Size  : 1188.00 KiB
Packager        : Philip Mueller <philm@manjaro.org>
Build Date      : So 21 Okt 2018 10:20:23 CEST
Validated By    : MD5 Sum  SHA-256 Sum  Signature

1 Like
#16

Everything back to normal now. Thanks!
Now i get the update for
image

:+1:

#17

While trying to apply the patch for Elan touchpads to mainline kernel I've encountered an error. It turned out that 5.1-rc6 had already received a bunch of relevant commits. So for 5.1 both Elan and tpm2 patches are not needed @philm @oberon

#18
$ pacman -Qi virtualbox
Name                     : virtualbox
Version                  : 6.0.6-2

fixed the problem with the ACPI tables and Windows 7 VM boots normal.

:+1: to all guys working on this

1 Like
#19

@oberon

After the last upgrade on gnome (23/04/19) doesn't launch any qt5 app (virtualbox, kdenlive, e.t.c). The error is:

Cannot mix incompatible Qt library (version 0x50c03) with this library (version 0x50c02))
1 Like
Incompatible Qt library after upgrade (5.12.3)
#20

In addition to @kouros17 - on KDE Plasma kwin crashes like a champ and in fact not even SDDM is able to be consistent :slight_smile:

This is from a VBox install but is the same on a bare metal install

image

None of the options work. The system is unusable.

1 Like