[Unstable Update] 2019-04-10/11 nvidia, systemd, grub, gnome, deepin ...

Hi community,

while Philip is on his little trip to Asia we have quite a bunch of package updates...

  • systemd upgrades to v242
  • most of the kernels got renewed
  • latest firefox and thunderbird
  • grub 2.03.5
  • some more gnome-apps, deepin, and python updates
  • also, I just built nvidia 418.56
  • mesa 19.0.2
  • brave browser we have removed from our repos for now. It can now be updated from the AUR

Please test thoroughly and report any issue you encounter


Current supported Kernels

  • linux316 3.16.65
  • linux318 3.18.138 [EOL]
  • linux44 4.4.167 [FZN]
  • linux49 4.9.168
  • linux414 4.14.111
  • linux419 4.19.34
  • linux420 4.20.17
  • linux50 5.0.7
  • linux51rc 5.1rc1.d0317.g9e98c67
  • linux419-rt 4.19.31_rt18
  • linux50-rt 5.0.5_rt3

Package Updates (Sun Feb 24 12:13:32 CET 2019)

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

4 Likes

no regular linux50 and linux51rc? :wink:

1 Like

Good point :stuck_out_tongue_winking_eye: thank you.
fixed.

5 Likes

The lib32-nvidia-utils 418.56-1 package was missed in this update, so steam wont run. I used the package from Arch and it now works. Otherwise everything works fine.

2 Likes

Thanks! In the repo now.

[New Packages]
lib32-nvidia-utils-1:418.56-1-x86_64.pkg.tar.xz
lib32-opencl-nvidia-1:418.56-1-x86_64.pkg.tar.xz
2 Likes

No prob. It happens.

I actually ran into this problem once before, so I knew what to check for.

Not my intention to rush things up (it isn't even in Arch testing yet), but is publishing a "-0" package for Mesa 19.0.2 in Unstable something considered?

https://www.mesa3d.org/relnotes/19.0.2.html

1 Like

Today's 15 package update & reboot was smooth & good. It was a welcome contrast to yesterday's, ahem, excitement... Ooh, i broke my Unstable VM.

2 Likes

it is now in Arch stable :wink:

edit: Unfortunately, lib32-mesa is not yet updated in arch

1 Like

Synced from upstream just now:


unstable_extra_x86_64

[New Packages]
libva-mesa-driver-19.0.2-1-x86_64.pkg.tar.xz
mesa-19.0.2-1-x86_64.pkg.tar.xz
mesa-vdpau-19.0.2-1-x86_64.pkg.tar.xz
opencl-mesa-19.0.2-1-x86_64.pkg.tar.xz
vulkan-intel-19.0.2-1-x86_64.pkg.tar.xz
vulkan-radeon-19.0.2-1-x86_64.pkg.tar.xz


unstable_community_x86_64

[New Packages]
apm-2.1.7-1-x86_64.pkg.tar.xz
atom-1.36.0-1-x86_64.pkg.tar.xz
caprine-2.30.2-1-any.pkg.tar.xz
code-1.33.0-1-x86_64.pkg.tar.xz
electron-4.1.1-2-x86_64.pkg.tar.xz
geogebra-6.0.529.0-1-x86_64.pkg.tar.xz
go-ethereum-1.8.26-1-x86_64.pkg.tar.xz
min-1.9.2-1-any.pkg.tar.xz
mkinitcpio-netconf-0.0.5-1-any.pkg.tar.xz
parity-ethereum-2.4.5-1-x86_64.pkg.tar.xz
subsurface-4.8.6-1-x86_64.pkg.tar.xz
subsurface-libdc-4.8.6-1-x86_64.pkg.tar.xz
wire-desktop-3.8.2894-2-x86_64.pkg.tar.xz
1 Like

Well, that was fast.

Just need to wait for lib32-mesa then.

Looks good so far. - Switched temporarly for unstable since the latest gnome-terminal-transperancy update won't install. Dependency on stable und testing for vte is too old.

VP9 HW video decode in Chromium finally fixed with this new mesa. Yay!

1 Like

@philm

I noticed that: GRUB 2.03.5-1 is only in english
whereas GRUB 2.03.4-1 is in german
means localization is broken?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.