[Unstable Update] 2019-01-13 - Kernels, Cinnamon, Systemd, Readline, KDE Frameworks, Python

unstable
update

#1

Hi community,

Welcome to our fourth unstable update of 2019. So what do we have with this one?

  • most Kernels got updated. Note that linux44 is currently frozen, as some proprietary drivers don’t build with 4.4.168+.
  • some updates to Cinnamon
  • more git-commits to Systemd
  • rebuilds against new readline
  • KDE Framework is now at 5.54.0
  • the regular python updates

We hope with all these changes Manjaro to be more efficient for you all.


FOSDEM19

Some of our core developers will join PINE64 Inc. at FOSDEM19 in Brussels. We will establish an even more closer relationship with this ARM based company. Also we are looking forward to see your reactions on the big announcement PINE64 Inc. will do at FOSDEM19. Stay tuned for any upcoming news.

Partnership with FCS Linux Aarhus

We are happy to announce a new partnership with FCS Linux Aarhus owned by @fhdk. This enables us to offer you Laptops with Manjaro pre-installed and Manjaro Stickers you can use on your own hardware or gift them to a friend. For each sale FCS will donate a percentage to the Manjaro project.

Manjaro v18.0.2 released!

To end the year with a high note we updated our flagship ISOs of Manjaro Illyria with the latest packages. It comes with refreshed packages and updated tools. You may want to download our XFCE Edition with the latest 4.13 packages, aswell as our most recent styling efforts. Our KDE fans may try our KDE Edition with the latest KDE v5.14 instead. And our GNOME fans may try our Gnome Edition with the latest GNOME v3.30.


Current supported Kernels

  • linux316 3.16.62
  • linux318 3.18.132 [EOL]
  • linux44 4.4.167 [FZN]
  • linux49 4.9.150
  • linux414 4.14.93
  • linux417 4.17.19 [EOL]
  • linux418 4.18.20 [EOL]
  • linux419 4.19.15
  • linux420 4.20.2
  • linux414-rt 4.14.87_rt50
  • linux416-rt 4.16.18_rt11
  • linux418-rt 4.18.16_rt9

Package Updates (Sun Jan 13 20:32:31 CET 2019)

:: Different overlay package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-01-12           2019-01-13
-------------------------------------------------------------------------------
                            cinnamon            4.0.8-1.1            4.0.9-1.1
                         linux414-rt       4.14.87_rt49-1       4.14.87_rt50-1
               linux414-rt-acpi_call             1.1.0-22             1.1.0-23
                linux414-rt-bbswitch               0.8-22               0.8-23
             linux414-rt-broadcom-wl      6.30.223.271-22      6.30.223.271-23
                linux414-rt-catalyst     1:15.201.1151-22     1:15.201.1151-23
                 linux414-rt-headers       4.14.87_rt49-1       4.14.87_rt50-1
                  linux414-rt-nvidia           1:415.25-2           1:415.25-3
            linux414-rt-nvidia-390xx             390.87-5             390.87-6
                linux414-rt-nvidiabl              0.88-22              0.88-23
                   linux414-rt-r8168          8.045.08-22          8.045.08-23
               linux414-rt-rt3562sta        2.4.1.1_r4-22        2.4.1.1_r4-23
                linux414-rt-tp_smapi              0.41-22              0.41-23
             linux414-rt-vhba-module          20161009-22          20161009-23
linux414-rt-virtualbox-guest-modules              6.0.0-1              6.0.0-2
 linux414-rt-virtualbox-host-modules              6.0.0-1              6.0.0-2
                          pcaudiolib        r34.af7edad-1                    -
                      budgie-desktop                    - 10.4+226+g6d814d56-1


:: Different sync package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-01-12           2019-01-13
-------------------------------------------------------------------------------
               aarch64-linux-gnu-gdb              8.2.1-1              8.2.1-2
                      acpi_call-dkms            1.1.0-183            1.1.0-184
                              aeolus              0.9.7-1              0.9.7-2
                            afpfs-ng             0.8.1-12             0.8.1-13
                            algol68g              2.8.5-1              2.8.5-2
                        algol68g-doc              2.8.5-1              2.8.5-2
                               amule              11004-2              11004-3
               android-file-transfer                3.7-1                3.7-2
                  appmenu-gtk-module             0.6.94-1              0.7.1-1
                              ardour               5.12-9              5.12-10
                   arm-none-eabi-gdb              8.2.1-1              8.2.1-2
                               atftp              0.7.1-5              0.7.1-6
                                atom             1.33.1-3             1.34.0-1
                              augeas             1.11.0-1             1.11.0-2
                             avr-gdb              8.2.1-1              8.2.1-2
                             avrdude              1:6.3-3              1:6.3-4
                         bluez-tools              0.2.0-3              0.2.0-4
                               bochs              2.6.9-2              2.6.9-3
                                 bpf               4.20-1               4.20-2
                             cadaver            0.23.3-10            0.23.3-11
                                calc           2.12.6.8-1           2.12.7.1-1
                                cgdb              0.7.0-2              0.7.0-3
               cgroup_event_listener               4.20-1               4.20-2
                                 cjs              4.0.0-1              4.0.0-2
                             connman               1.36-1               1.36-2
                            cpupower               4.20-1               4.20-2
                               crash              7.2.4-1              7.2.5-1
                                cvc4                1.6-1                1.6-2
                            ecasound             2.9.1-12             2.9.1-13
                            edbrowse              3.7.3-1              3.7.3-2
                                eric              18.11-1              19.01-1
                         eric-common              18.11-1              19.01-1
                        eric-i18n-de              18.11-1              19.01-1
                        eric-i18n-en              18.11-1              19.01-1
                        eric-i18n-es              18.11-1              19.01-1
                        eric-i18n-ru              18.11-1              19.01-1
                               fcron              3.2.1-3              3.2.1-4
              firefox-tree-style-tab             2.7.14-1             2.7.16-1
                          fluidsynth             1.1.11-2             1.1.11-3
                             freeciv              2.6.0-2              2.6.0-3
                          freeradius             3.0.17-7             3.0.17-8
                               fwupd              1.2.3-1              1.2.3-2
                       gameconqueror               0.17-1               0.17-2
                                 gap             4.10.0-4             4.10.0-5
                             gap-doc             4.10.0-4             4.10.0-5
                        gap-packages             4.10.0-4             4.10.0-5
                            geogebra          6.0.507.0-1          6.0.518.0-1
                                gftp             2.0.19-9            2.0.19-10
                               ginac              1.7.4-1              1.7.4-2
                           glusterfs              1:5.2-1              1:5.2-2
                              gnokii            0.6.31-16            0.6.31-17
                               gnubg           1.06.002-1           1.06.002-2
                            gnuchess              6.2.5-1              6.2.5-2
                               gpsim             0.30.0-1             0.30.0-2
                              hatari              2.1.0-1              2.1.0-2
                            hsetroot              1.0.2-6              1.0.2-7
                              hyperv               4.20-1               4.20-2
                                  io         2017.06.08-2         2017.06.08-3
                            ipmitool             1.8.18-4             1.8.18-5
                         ipsec-tools              0.8.2-8              0.8.2-9
                            iverilog               10.2-1               10.2-2
                                 iwd               0.13-1               0.13-2
                               jack2             1.9.12-6             1.9.12-8
                          jack2-dbus             1.9.12-6             1.9.12-8
                               js185              1.0.0-7              1.0.0-8
                              julius            4.4.2.1-3            4.4.2.1-4
                                kid3              3.7.0-1              3.7.0-2
                             kid3-qt              3.7.0-1              3.7.0-2
                        languagetool                4.3-1                4.4-1
                             libgiac           1.5.0.35-1           1.5.0.35-2
                              libldm              0.2.4-2              0.2.4-3
                            libmatio             1.5.12-4             1.5.13-1
              libperconaserverclient           8.0.13_3-1           8.0.13_3-2
                          libscanmem               0.17-1               0.17-2
                              libsmf                1.3-8                1.3-9
                       libtraceevent               4.20-1               4.20-2
                             libvirt              4.9.0-1              4.9.0-2
                    linux-tools-meta               4.20-1               4.20-2
                               lldpd              1.0.3-1              1.0.3-2
                           mailutils                3.5-2                3.5-3
                        man-pages-de                2.9-1               2.10-1
                          mathomatic             16.0.5-5             16.0.5-6
                             ncmpcpp              0.8.2-5              0.8.2-6
                               netcf              0.2.8-6              0.2.8-7
                             ngspice                 30-1                 30-2
                              nickle               2.82-1               2.82-2
                              octave              4.4.1-3              4.4.1-4
                             opendbx              1.4.6-6              1.4.6-7
                             opendht            1:1.7.4-3            1:1.7.4-4
                            openipmi             2.0.26-1             2.0.26-2
                              opensc             0.19.0-1             0.19.0-2
                                pari             2.11.1-1             2.11.1-2
                      percona-server           8.0.13_3-1           8.0.13_3-2
              percona-server-clients           8.0.13_3-1           8.0.13_3-2
                                perf               4.20-1               4.20-2
              perl-term-readline-gnu               1.35-5               1.35-6
                               pinfo             0.6.10-7             0.6.10-8
                           profanity            1:0.5.1-2            1:0.5.1-3
                       profanity-gtk            1:0.5.1-2            1:0.5.1-3
                     python-autobahn            18.12.1-1             19.1.1-1
                    python-biopython               1.72-1               1.73-1
                       python-bleach              3.0.2-3              3.1.0-1
                    python-fonttools             3.34.2-1             3.35.1-1
         python-sphinxcontrib-bibtex              0.4.1-1              0.4.2-1
                  python-zc.lockfile                1.4-1                1.4-2
                    python2-autobahn            18.12.1-1             19.1.1-1
                   python2-biopython               1.72-1               1.73-1
                      python2-bleach              3.0.2-3              3.1.0-1
                        python2-eric              18.11-1              19.01-1
                   python2-fonttools             3.34.2-1             3.35.1-1
        python2-sphinxcontrib-bibtex              0.4.1-1              0.4.2-1
                 python2-zc.lockfile                1.4-1                1.4-2
                python2-zope.testing              4.6.2-1                    -
                              remake       4.2.1+dbg1.4-1       4.2.1+dbg1.4-2
                         renameutils             0.12.0-5             0.12.0-6
               riscv64-linux-gnu-gdb              8.2.1-1              8.2.1-2
                              rlwrap               0.43-2               0.43-3
                            ruby-atk              3.3.0-2              3.3.1-1
                  ruby-cairo-gobject              3.3.0-2              3.3.1-1
                    ruby-gdk_pixbuf2              3.3.0-2              3.3.1-1
                           ruby-gio2              3.3.0-2              3.3.1-1
                          ruby-glib2              3.3.0-2              3.3.1-1
          ruby-gobject-introspection              3.3.0-2              3.3.1-1
                           ruby-gtk2              3.3.0-2              3.3.1-1
                       ruby-mustache              1.0.5-2              1.1.0-1
                          ruby-pango              3.3.0-2              3.3.1-1
                             ruby2.5              2.5.3-1              2.5.3-3
                            sagemath                8.5-2                8.5-3
                    sagemath-jupyter                8.5-2                8.5-3
                               scala             2.12.7-1             2.12.8-1
                          scala-docs             2.12.7-1             2.12.8-1
                       scala-sources             2.12.7-1             2.12.8-1
                             scanmem               0.17-1               0.17-2
                               scdoc              1.6.0-2              1.6.0-3
                                sdcc              3.8.0-1              3.8.0-2
                                sdcv              0.5.2-1              0.5.2-2
                            singular           4.1.1.p4-2           4.1.1.p4-3
                           smalltalk             3.2.91-6             3.2.91-7
                           sqlcipher              4.0.1-1              4.0.1-2
                       supercollider             3.10.0-1             3.10.0-2
                          swi-prolog              7.6.4-1              7.6.4-2
                           tarantool         2.0.4.r497-3         2.0.4.r497-4
                                 tig              2.4.1-1              2.4.1-2
                                tmon               4.20-1               4.20-2
                           turbostat               4.20-1               4.20-2
                            udftools                2.1-1                2.1-2
                               units               2.18-1               2.18-2
                               usbip               4.20-1               4.20-2
                                vice                3.3-1                3.3-2
                             wesnoth             1.14.5-2             1.14.5-3
                           wvstreams             4.6.1-15             4.6.1-16
              x86_energy_perf_policy               4.20-1               4.20-2
                                xcas           1.5.0.35-1           1.5.0.35-2
                            xmlrpc-c          1:1.43.08-1          1:1.43.08-2
                     xmms2 0.8DrO_o.949.gca15e830-13 0.8DrO_o.949.gca15e830-14
                                 yaz             5.27.1-1             5.27.1-2
                             yoshimi             1.5.10-1             1.5.10-2
                     zsh-completions             0.29.0-1             0.30.0-1
                                zssh              1.5c-10              1.5c-11
                            geonkick                    -                1.0-1
                         ibm-sw-tpm2                    -               1332-1
                          tpm2-abrmd                    -              2.0.3-1
                          tpm2-tools                    -              3.1.3-2
                            tpm2-tss                    -              2.1.0-1
                             urlscan                    -              0.9.1-3


:: Different overlay package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-01-12           2019-01-13
-------------------------------------------------------------------------------
                                bash            4.4.023-2              5.0.0-1
                      bashrc-manjaro            4.4.023-2              5.0.0-1
                          libsystemd              239.6-2            240.191-1
                            linux318           3.18.131-1           3.18.132-1
                    linux318-headers           3.18.131-1           3.18.132-1
                            linux414            4.14.92-1            4.14.93-1
                    linux414-headers            4.14.92-1            4.14.93-1
                            linux420             4.20.1-1             4.20.2-1
                    linux420-headers             4.20.1-1             4.20.2-1
                             linux49            4.9.149-1            4.9.150-1
                     linux49-headers            4.9.149-1            4.9.150-1
                             systemd              239.6-2            240.191-1
                  systemd-resolvconf              239.6-2            240.191-1
                  systemd-sysvcompat              239.6-2            240.191-1


:: Different sync package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-01-12           2019-01-13
-------------------------------------------------------------------------------
                                bash            4.4.023-1              5.0.0-1
                       device-mapper           2.02.183-1           2.02.183-2
                                gawk              4.2.1-1              4.2.1-2
                                gdbm             1.18.1-1             1.18.1-2
                               gnupg             2.2.12-1             2.2.12-2
                              gnutls              3.6.5-1              3.6.5-2
                           inetutils              1.9.4-6              1.9.4-7
                             libedit       20180525_3.1-1       20181209_3.1-1
                       libutil-linux             2.33.1-1             2.33.1-2
                                lvm2           2.02.183-1           2.02.183-2
                             ncurses                6.1-4                6.1-6
                                pcre               8.42-1               8.42-2
                               pcre2              10.32-1              10.32-2
                            readline            7.0.005-1              8.0.0-1
                              sqlite             3.26.0-1             3.26.0-2
                     sqlite-analyzer             3.26.0-1             3.26.0-2
                          sqlite-doc             3.26.0-1             3.26.0-2
                          sqlite-tcl             3.26.0-1             3.26.0-2
                            syslinux         6.03-11 6.04.pre1.r41.g5e426532-1
                          util-linux             2.33.1-1             2.33.1-2
                      wpa_supplicant              2:2.6-1              2:2.6-2
                            xfsprogs             4.19.0-1             4.19.0-2


:: Different overlay package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-01-12           2019-01-13
-------------------------------------------------------------------------------
                               boxit              2.1.2-6              2.1.2-7
                            boxit-32              2.1.2-5              2.1.2-6
                     boxit-32-server              2.1.2-5              2.1.2-6
                        boxit-server              2.1.2-6              2.1.2-7
                  linux414-acpi_call             1.1.0-74             1.1.0-75
                   linux414-bbswitch               0.8-74               0.8-75
                linux414-broadcom-wl      6.30.223.271-74      6.30.223.271-75
                   linux414-catalyst     1:15.201.1151-74     1:15.201.1151-75
                linux414-ndiswrapper              1.61-74              1.61-75
                     linux414-nvidia           1:415.25-4           1:415.25-5
               linux414-nvidia-340xx           340.107-33           340.107-34
               linux414-nvidia-390xx            390.87-19            390.87-20
                   linux414-nvidiabl              0.88-74              0.88-75
                      linux414-r8168          8.045.08-62          8.045.08-63
                  linux414-rt3562sta        2.4.1.1_r4-74        2.4.1.1_r4-75
                        linux414-spl             0.7.12-3             0.7.12-4
                   linux414-tp_smapi              0.41-74              0.41-75
                linux414-vhba-module          20161009-74          20161009-75
   linux414-virtualbox-guest-modules              6.0.0-3              6.0.0-4
    linux414-virtualbox-host-modules              6.0.0-3              6.0.0-4
                        linux414-zfs             0.7.12-3             0.7.12-4
                  linux419-acpi_call             1.1.0-11             1.1.0-12
                   linux419-bbswitch               0.8-11               0.8-12
                linux419-broadcom-wl      6.30.223.271-11      6.30.223.271-12
                   linux419-catalyst     1:15.201.1151-11     1:15.201.1151-12
                linux419-ndiswrapper              1.61-11              1.61-12
                     linux419-nvidia           1:415.25-3           1:415.25-4
               linux419-nvidia-340xx           340.107-11           340.107-12
               linux419-nvidia-390xx            390.87-12            390.87-13
                   linux419-nvidiabl              0.88-11              0.88-12
                      linux419-r8168          8.045.08-11          8.045.08-12
                        linux419-spl             0.7.12-3             0.7.12-4
                   linux419-tp_smapi              0.41-11              0.41-12
                linux419-vhba-module          20161009-11          20161009-12
   linux419-virtualbox-guest-modules              6.0.0-3              6.0.0-4
    linux419-virtualbox-host-modules              6.0.0-3              6.0.0-4
                        linux419-zfs             0.7.12-3             0.7.12-4
                  linux420-acpi_call              1.1.0-1              1.1.0-2
                   linux420-bbswitch                0.8-1                0.8-2
                linux420-broadcom-wl       6.30.223.271-1       6.30.223.271-2
                   linux420-catalyst      1:15.201.1151-1      1:15.201.1151-2
                linux420-ndiswrapper               1.61-1               1.61-2
                     linux420-nvidia           1:415.25-1           1:415.25-2
               linux420-nvidia-340xx            340.107-1            340.107-2
               linux420-nvidia-390xx             390.87-1             390.87-2
                   linux420-nvidiabl               0.88-1               0.88-2
                      linux420-r8168           8.045.08-1           8.045.08-2
                  linux420-rtl8723bu    4.3.9.3.13200-0.1    4.3.9.3.13200-1.1
                        linux420-spl           0.7.12-1.1             0.7.12-2
                   linux420-tp_smapi               0.41-1               0.41-2
                linux420-vhba-module           20161009-1           20161009-2
   linux420-virtualbox-guest-modules              6.0.0-1              6.0.0-2
    linux420-virtualbox-host-modules              6.0.0-1              6.0.0-2
                        linux420-zfs           0.7.12-1.1             0.7.12-2
                   linux49-acpi_call            1.1.0-108            1.1.0-109
                    linux49-bbswitch              0.8-108              0.8-109
                 linux49-broadcom-wl     6.30.223.271-108     6.30.223.271-109
                    linux49-catalyst    1:15.201.1151-108    1:15.201.1151-109
                 linux49-ndiswrapper             1.61-106             1.61-107
                      linux49-nvidia           1:415.25-2           1:415.25-3
                linux49-nvidia-340xx           340.107-27           340.107-28
                linux49-nvidia-390xx            390.87-16            390.87-17
                    linux49-nvidiabl             0.88-108             0.88-109
                       linux49-r8168          8.045.08-48          8.045.08-49
                   linux49-rt3562sta       2.4.1.1_r4-106       2.4.1.1_r4-107
                         linux49-spl             0.7.12-1             0.7.12-2
                    linux49-tp_smapi             0.41-108             0.41-109
                 linux49-vhba-module         20161009-106         20161009-107
    linux49-virtualbox-guest-modules              6.0.0-1              6.0.0-2
     linux49-virtualbox-host-modules              6.0.0-1              6.0.0-2
                         linux49-zfs             0.7.12-1             0.7.12-2


:: Different sync package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-01-12           2019-01-13
-------------------------------------------------------------------------------
                             abiword              3.0.2-8              3.0.2-9
                               abook              0.6.1-3              0.6.1-4
                            alsa-lib              1.1.7-2              1.1.8-1
                            alsa-oss              1.1.6-1              1.1.8-1
                        alsa-plugins              1.1.7-3              1.1.8-1
                          alsa-utils              1.1.7-1              1.1.8-1
                           asymptote  2.47+14+g38a59370-1  2.47+14+g38a59370-2
                              attica             5.53.0-1             5.54.0-1
                               baloo             5.53.0-1             5.54.0-1
                                  bc             1.07.1-2             1.07.1-3
                                bind             9.13.5-2             9.13.5-3
                          bind-tools             9.13.5-2             9.13.5-3
                                bird              2.0.2-1              2.0.2-2
                               bluez               5.50-3               5.50-4
                          bluez-cups               5.50-3               5.50-4
                       bluez-hid2hci               5.50-3               5.50-4
                          bluez-libs               5.50-3               5.50-4
                       bluez-plugins               5.50-3               5.50-4
                            bluez-qt             5.53.0-1             5.54.0-1
                         bluez-utils               5.50-3               5.50-4
                        breeze-icons             5.53.0-1             5.54.0-1
                               clisp            2.49.93-1            2.49.93-2
                 extra-cmake-modules             5.53.0-1             5.54.0-1
                               folks0.11.4+42+g5520ed9a-10.11.4+42+g5520ed9a-2
                           fontforge           20170731-2           20170731-3
         foomatic-db-gutenprint-ppds              5.3.1-1              5.3.1-2
                frameworkintegration             5.53.0-1             5.54.0-1
                             freetds            1.00.96-1            1.00.96-2
                                fvwm              2.6.8-3              2.6.8-4
                                 gdb              8.2.1-1              8.2.1-3
                          gdb-common              8.2.1-1              8.2.1-3
                              genius             1.0.24-1             1.0.24-2
                                 gjs           2:1.54.3-1           2:1.54.3-2
                       gnome-builder             3.30.2-2             3.30.3-1
                             gnuplot              5.2.6-1              5.2.6-2
                             gphoto2             2.5.20-1             2.5.20-2
                               gsasl              1.8.0-8              1.8.0-9
                               guile              2.2.4-1              2.2.4-2
                            guile1.8              1.8.8-6              1.8.8-7
                            guile2.0             2.0.14-2             2.0.14-3
                          gutenprint              5.3.1-1              5.3.1-2
                            hunspell              1.7.0-1              1.7.0-2
                                jack            0.125.0-5            0.125.0-7
                                js52             52.9.0-1             52.9.0-2
                                js60             60.4.0-1             60.4.0-2
                         kactivities             5.53.0-1             5.54.0-1
                   kactivities-stats             5.53.0-1             5.54.0-1
                            kalgebra            18.12.1-1            18.12.1-2
                             kapidox             5.53.0-1             5.54.0-1
                            karchive             5.53.0-1             5.54.0-1
                               kauth             5.53.0-1             5.54.0-1
                          kbookmarks             5.53.0-1             5.54.0-1
                            kcmutils             5.53.0-1             5.54.0-1
                             kcodecs             5.53.0-1             5.54.0-1
                         kcompletion             5.53.0-1             5.54.0-1
                             kconfig             5.53.0-1             5.54.0-1
                      kconfigwidgets             5.53.0-1             5.54.0-1
                         kcoreaddons             5.53.0-1             5.54.0-1
                              kcrash             5.53.0-1             5.54.0-1
                         kdbusaddons             5.53.0-1             5.54.0-1
                        kdeclarative             5.53.0-1             5.54.0-1
                                kded             5.53.0-1             5.54.0-1
                     kdelibs4support             5.53.0-1             5.54.0-1
                     kdesignerplugin             5.53.0-1             5.54.0-1
                               kdesu             5.53.0-1             5.54.0-1
                           kdewebkit             5.53.0-1             5.54.0-1
                              kdnssd             5.53.0-1             5.54.0-1
                           kdoctools             5.53.0-1             5.54.0-1
                          kemoticons             5.53.0-1             5.54.0-1
                       kfilemetadata             5.53.0-1             5.54.0-1
                        kglobalaccel             5.53.0-1             5.54.0-1
                          kguiaddons             5.53.0-1             5.54.0-1
                           kholidays           1:5.53.0-1           1:5.54.0-1
                               khtml             5.53.0-1             5.54.0-1
                               ki18n             5.53.0-1             5.54.0-1
                         kiconthemes             5.53.0-1             5.54.0-1
                           kidletime             5.53.0-1             5.54.0-1
                       kimageformats             5.53.0-1             5.54.0-1
                               kinit             5.53.0-2             5.54.0-1
                                 kio             5.53.0-1             5.54.0-1
                           kirigami2             5.53.0-1             5.54.0-1
                         kitemmodels             5.53.0-1             5.54.0-1
                          kitemviews             5.53.0-1             5.54.0-1
                         kjobwidgets             5.53.0-1             5.54.0-1
                                 kjs             5.53.0-1             5.54.0-1
                            kjsembed             5.53.0-1             5.54.0-1
                        kmediaplayer             5.53.0-1             5.54.0-1
                           knewstuff             5.53.0-1             5.54.0-1
                      knotifications             5.53.0-1             5.54.0-1
                       knotifyconfig             5.53.0-1             5.54.0-1
                            kpackage             5.53.0-1             5.54.0-1
                              kparts             5.53.0-1             5.54.0-1
                             kpeople             5.53.0-1             5.54.0-1
                           kplotting             5.53.0-1             5.54.0-1
                                kpty             5.53.0-1             5.54.0-1
                               kross             5.53.0-1             5.54.0-1
                             krunner             5.53.0-1             5.54.0-1
                            kservice             5.53.0-1             5.54.0-1
                         ktexteditor             5.53.0-1             5.54.0-1
                        ktextwidgets             5.53.0-1             5.54.0-1
                     kunitconversion             5.53.0-1             5.54.0-1
                             kwallet             5.53.0-1             5.54.0-1
                            kwayland             5.53.0-1             5.54.0-1
                      kwidgetsaddons             5.53.0-1             5.54.0-1
                       kwindowsystem             5.53.0-1             5.54.0-1
                             kxmlgui             5.53.0-1             5.54.0-1
                       kxmlrpcclient             5.53.0-1             5.54.0-1
                                lftp              4.8.4-2              4.8.4-3
                           libfprint             0.99.0-1  0.99.0+1+ga1e46de-1
                              libgda5.2.4+39+g3f70d4fce-2 5.2.8+7+ga5355eb42-1
                     libgda-firebird5.2.4+39+g3f70d4fce-2 5.2.8+7+ga5355eb42-1
                         libgda-jdbc5.2.4+39+g3f70d4fce-2 5.2.8+7+ga5355eb42-1
                        libgda-mysql5.2.4+39+g3f70d4fce-2 5.2.8+7+ga5355eb42-1
                     libgda-postgres5.2.4+39+g3f70d4fce-2 5.2.8+7+ga5355eb42-1
                          libgphoto2             2.5.21-1             2.5.22-1
                          libisoburn              1.5.0-1              1.5.0-2
                     libnm 1.14.5dev+17+gba83251bb-1 1.14.5dev+17+gba83251bb-2
                libnm-glib 1.14.5dev+17+gba83251bb-1 1.14.5dev+17+gba83251bb-2
                        libqalculate              2.8.2-1              2.8.2-2
                          libsynctex         2018.48691-3         2018.48691-4
                         libwbclient              4.9.4-1              4.9.4-2
                             libxml2              2.9.8-6              2.9.8-8
                                 lua              5.3.5-1              5.3.5-2
                               lua51              5.1.5-7              5.1.5-8
                               lua52              5.2.4-3              5.2.4-4
                     modemmanager-qt             5.53.0-1             5.54.0-1
            networkmanager 1.14.5dev+17+gba83251bb-1 1.14.5dev+17+gba83251bb-2
                   networkmanager-qt             5.53.0-1             5.54.0-1
                            nftables            1:0.9.0-2            1:0.9.0-3
                        oxygen-icons           1:5.53.0-1           1:5.54.0-1
                    oxygen-icons-svg           1:5.53.0-1           1:5.54.0-1
                              parted                3.2-7                3.2-8
                                 php              7.3.1-1              7.3.1-2
                          php-apache              7.3.1-1              7.3.1-2
                             php-cgi              7.3.1-1              7.3.1-2
                           php-dblib              7.3.1-1              7.3.1-2
                           php-embed              7.3.1-1              7.3.1-2
                         php-enchant              7.3.1-1              7.3.1-2
                             php-fpm              7.3.1-1              7.3.1-2
                              php-gd              7.3.1-1              7.3.1-2
                            php-imap              7.3.1-1              7.3.1-2
                            php-intl              7.3.1-1              7.3.1-2
                            php-odbc              7.3.1-1              7.3.1-2
                           php-pgsql              7.3.1-1              7.3.1-2
                          php-phpdbg              7.3.1-1              7.3.1-2
                          php-pspell              7.3.1-1              7.3.1-2
                            php-snmp              7.3.1-1              7.3.1-2
                          php-sodium              7.3.1-1              7.3.1-2
                          php-sqlite              7.3.1-1              7.3.1-2
                            php-tidy              7.3.1-1              7.3.1-2
                             php-xsl              7.3.1-1              7.3.1-2
                    plasma-framework             5.53.0-1             5.54.0-1
                          postgresql               11.1-2               11.1-3
                     postgresql-docs               11.1-2               11.1-3
                     postgresql-libs               11.1-2               11.1-3
                              prison             5.53.0-1             5.54.0-1
                             purpose             5.53.0-1             5.54.0-1
                              python              3.7.2-1              3.7.2-3
                             python2             2.7.15-2             2.7.15-4
                  qqc2-desktop-style             5.53.0-1             5.54.0-1
                              quagga              1.2.4-2              1.2.4-3
                                   r              3.5.2-1              3.5.2-2
                                ruby              2.6.0-4              2.6.0-5
                           ruby-docs              2.6.0-4              2.6.0-5
                               samba              4.9.4-1              4.9.4-2
                                sddm             0.18.0-1             0.18.0-2
                                slim              1.3.6-7              1.3.6-8
                           smbclient              4.9.4-1              4.9.4-2
                               socat            1.7.3.2-3            1.7.3.2-4
                               solid             5.53.0-1             5.54.0-1
                              sonnet             5.53.0-1             5.54.0-1
                         syndication             5.53.0-1             5.54.0-1
                 syntax-highlighting             5.53.0-1             5.54.0-1
                         texlive-bin         2018.48691-3         2018.48691-4
                            tftp-hpa                5.2-7                5.2-8
                        threadweaver             5.53.0-1             5.54.0-1
                            unixodbc              2.3.7-1              2.3.7-2
                xfce4-battery-plugin              1.1.1-1              1.1.2-1
                             xine-ui            0.99.10-1            0.99.10-2


:: Different overlay package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-01-12           2019-01-13
-------------------------------------------------------------------------------
                       lib32-systemd              239.6-2            240.191-1


:: Different sync package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-01-12           2019-01-13
-------------------------------------------------------------------------------
                      lib32-alsa-lib              1.1.7-1              1.1.8-1
                  lib32-alsa-plugins              1.1.7-1              1.1.8-1
                    lib32-fluidsynth             1.1.11-1              2.0.0-2
                       lib32-ncurses                6.1-3                6.1-4
                      lib32-readline            7.0.005-1              8.0.0-1
  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


#2

Looks like bash 5.0 is out there right now as well.


#3

Watch out for this one - there are a number of critical packages which will break with the wrong version of readline installed, so make sure your mirrors are fully up-to-date before running the update.

In fact, I’d make sure to have a copy of libreadline.so.7 somewhere which you can link back under /usr/lib just in case.


#4

In my case bash was not synced yet and I got the missing library error. If your mirrors are synced everything is fine


#5

When I did the update earlier today, I got readline errors. Then of course I could no longer login. I didn’t search too much for a fix, and decided just to re-install. Then I had no problem with this update.

Obviously the mirror wasn’t quite up to date. I wonder if it’s possible to automate a way to prevent this sort of accident?


#6

No; we’re running the unstable branch, we’re on the bleeding edge. It’s our “job” to find issues and fix them.


#7

Change branch to stable or testing, but even then this sort of issue is possible if you don’t check your mirror is fully synced before updating.

There is a link within all announcement threads for this very purpose.


#8

Look, I understand the risks of using unstable, and you misunderstood what I was suggesting. The same sort of thing can happen to anyone using stable and testing too if the mirror isn’t completely up to date. I was just wondering if there is a way for pacman/octopi to auto-check that the mirror is fully updated.


#9

Refreshing the mirror database is a time consuming task (more than a minute to test around 80 Manjaro mirrors currently). So I think this is why most (every?) all-in-one update apps do not try to sync mirrors before an update check. If programs automatically tries to speed up the process by testing a smaller subset of synced mirrors (pacman-mirrors -f3), the mirror the user gets might be on the other side of the world.

So it’s probably better to leave it up to the user to optimize pacman-mirrors with a custom mirrorlist and run pacman-mirrors (“Refresh Mirrors List” in pamac) manually before critical updates.


#10


I m getting this error msg
Don’t know how to resolve
I m a new user please help


#11

#12

In such cases you could set a minimal version ( >= ) in the dependency list of a package. This would make it impossible to install the update if the required version is not yet synced.


#13

That’s understandable, and I normally do wait a bit before doing large updates and make sure the mirror I use is up to date.


#14

actually it’s not a problem… as you should have a 404 error or a corrupt package if not complete.
the only way to have a “partial update” if mirror is not yet full synched is if all repositories database (core, community and extra) are not “in synch” during the check.

after if the mirror is not up-to-date because the problem has been solved just after the mirror synched (happen more often on unstable) it’s an other problem.


#15

Sure. I don’t say it’s a problem. It just could be one if a dependency is not in sync but the app is build against the new dependency and can’t run without. That shouldnt happen in stable


#16

A bit late now, but you probably shouldn’t be on the unstable branch.

Read this:

You may need to boot from a live installer so you can chroot into the installation and fix it.


#17

Hi,
i’m newbie User and using unstable branch,
any advise to be safe here ?


#18

Use the stable branch? Take backups?


#19

always keep live bootable usb and backup


#20

you mean keep current official version of manjaro in usb for login fails?
i don’t need backup my files because i use separated home partition , but is there any way to backup apps and their configuration?