[Unstable Update] 2019-01-04 - Deepin, Certbot, Systemd, Haskell, Python

unstable
update

#1

Hi community,

Welcome to our second unstable update of 2019. :roller_coaster:

So what do we have with this one?

  • we updated some deepin packages
  • certbot got updated to 0.30.0
  • more git commits added to systemd
  • all the regular haskell and python updates

We hope with all these changes Manjaro to be more efficient for you all.


Partnership with FCS Linux Aarhus

We are happy to announce a new partnership with FCS Linux Aarhus owned by @fhdk. This enables us to offer you Laptops with Manjaro pre-installed and Manjaro Stickers you can use on your own hardware or gift them to a friend. For each sale FCS will donate a percentage to the Manjaro project.



Manjaro v18.0.2 released!

To end the year with a high note we updated our flagship ISOs of Manjaro Illyria with the latest packages. It comes with refreshed packages and updated tools. You may want to download our XFCE Edition with the latest 4.13 packages, aswell as our most recent styling efforts. Our KDE fans may try our KDE Edition with the latest KDE v5.14 instead. And our GNOME fans may try our Gnome Edition with the latest GNOME v3.30.


Current supported Kernels

  • linux316 3.16.62
  • linux318 3.18.131 [EOL]
  • linux44 4.4.167
  • linux49 4.9.148
  • linux414 4.14.91
  • linux417 4.17.19 [EOL]
  • linux418 4.18.20 [EOL]
  • linux419 4.19.13
  • linux420 4.20.0
  • linux414-rt 4.14.87_rt49
  • linux416-rt 4.16.18_rt11
  • linux418-rt 4.18.16_rt9

Package Updates (Fri Jan 4 09:08:15 CET 2019)

  • unstable extra x86_64: 15 new and 13 removed package(s)
  • unstable community x86_64: 89 new and 89 removed package(s)
:: Different overlay package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-01-02           2019-01-04
-------------------------------------------------------------------------------
      deepin-desktop-schemas-manjaro              3.9.1-1             3.10.0-1
                   deepin-session-ui            4.8.0-1.3            4.8.2-1.1
                              ipscan              3.5.3-1              3.5.5-1
                             obsuite              0.1.2-1                0.2-1
                      budgie-desktop                    - 10.4+218+ga412b3c0-1


:: Different sync package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-01-02           2019-01-04
-------------------------------------------------------------------------------
                               acorn            1:6.0.4-1            1:6.0.5-1
                             certbot             0.29.1-1             0.30.0-1
                      certbot-apache             0.29.1-1             0.30.0-1
              certbot-dns-cloudflare             0.29.1-1             0.30.0-1
                certbot-dns-cloudxns             0.29.1-1             0.30.0-1
            certbot-dns-digitalocean             0.29.1-1             0.30.0-1
                certbot-dns-dnsimple             0.29.1-1             0.30.0-1
             certbot-dns-dnsmadeeasy             0.29.1-1             0.30.0-1
                  certbot-dns-gehirn             0.29.1-1             0.30.0-1
                  certbot-dns-google             0.29.1-1             0.30.0-1
                  certbot-dns-linode             0.29.1-1             0.30.0-1
                  certbot-dns-luadns             0.29.1-1             0.30.0-1
                   certbot-dns-nsone             0.29.1-1             0.30.0-1
                     certbot-dns-ovh             0.29.1-1             0.30.0-1
                 certbot-dns-rfc2136             0.29.1-1             0.30.0-1
                 certbot-dns-route53             0.29.1-1             0.30.0-1
             certbot-dns-sakuracloud             0.29.1-1             0.30.0-1
                       certbot-nginx             0.29.1-1             0.30.0-1
                        cozy-desktop             3.11.1-1             3.11.2-1
                         debootstrap            1.0.111-1            1.0.112-1
                          deepin-api             3.14.0-1             3.15.0-1
                       deepin-daemon             3.16.0-1             3.17.0-1
                 deepin-desktop-base       2:2018.10.29-1       2:2019.01.15-1
              deepin-desktop-schemas              3.9.1-1             3.10.0-1
                       deepin-editor                1.1-1              1.2.6-1
                 deepin-file-manager         1:4.7.1.12-1            1:4.7.3-1
                deepin-gir-generator              1.1.0-2              1.2.0-1
                       deepin-go-lib              1.7.0-1              1.8.0-1
                 deepin-image-viewer              1.3.6-1              1.3.7-1
                        deepin-movie           1:3.2.17-1           1:3.2.18-1
               deepin-qt5dxcb-plugin             1.1.21-1             1.1.22-1
                   deepin-session-ui              4.8.0-1              4.8.2-1
                     deepin-terminal                3.1-1                3.2-1
                       deepin-topbar              0.6.0-1              0.6.2-1
                             dtkcore         1:2.0.9.13-1         1:2.0.9.14-1
                           dtkwidget           2.0.9.13-1           2.0.9.14-1
              firefox-tree-style-tab              2.7.7-1              2.7.8-1
                       haskell-brick               0.46-3               0.46-4
          haskell-cassava-megaparsec              2.0.0-3              2.0.0-4
                  haskell-config-ini            0.2.4.0-4            0.2.4.0-5
                      haskell-hakyll         4.12.4.0-101         4.12.4.0-102
                 haskell-hledger-lib               1.12-5               1.12-6
            haskell-hspec-megaparsec              2.0.0-2              2.0.0-3
                      haskell-hsyaml            0.1.1.2-5            0.1.1.3-1
                  haskell-megaparsec              7.0.4-2              7.0.4-3
                 haskell-megaparsec6              6.5.0-2              6.5.0-3
          haskell-neat-interpolation            0.3.2.4-2            0.3.2.4-3
          haskell-parser-combinators              1.0.0-5              1.0.1-1
                             hledger             1.12.1-6             1.12.1-7
                         hledger-api              1.12-23              1.12-24
                          hledger-ui             1.12.1-6             1.12.1-7
                         hledger-web              1.12-26              1.12-27
                               idris             1.3.1-23             1.3.1-24
                              kcptun           20181230-1           20190103-1
                             mongodb              4.0.4-1              4.0.5-1
                                nmon                16g-2                16h-1
                                 nnn                2.1-1                2.2-1
                              pandoc               2.5-16               2.5-17
                     pandoc-citeproc          0.15.0.1-17          0.15.0.1-18
                     pandoc-crossref           0.3.4.0-19           0.3.4.0-20
                         python-acme             0.29.1-1             0.30.0-1
                           python-fs              2.1.3-1              2.2.0-1
                       python-hunter              2.0.2-2              2.1.0-1
                   python-hypothesis             3.85.2-1             3.86.0-1
                    python-netifaces             0.10.7-2             0.10.9-1
                        python-pydot              1.3.0-1              1.4.1-1
                     python-pynamodb              3.3.1-1              3.3.2-1
                  python-ruamel-yaml            0.15.82-1            0.15.83-1
                      python-zconfig              3.3.0-1              3.4.0-1
                python-zope-security              4.3.0-1              4.3.1-1
                        python2-acme             0.29.1-1             0.30.0-1
                          python2-fs              2.1.3-1              2.2.0-1
                      python2-hunter              2.0.2-2              2.1.0-1
                  python2-hypothesis             3.85.2-1             3.86.0-1
                   python2-netifaces             0.10.7-2             0.10.9-1
                       python2-pydot              1.3.0-1              1.4.1-1
                     python2-zconfig              3.3.0-1              3.4.0-1
               python2-zope-security              4.3.0-1              4.3.1-1
                           ruby-sass              3.6.0-1              3.7.2-1
                          shellcheck             0.6.0-16             0.6.0-17
                             snapper              0.8.0-1              0.8.1-1
                               stack             1.9.3-26             1.9.3-27
                            startdde              3.8.0-3              3.8.0-4
                              stubby              0.2.3-1              0.2.4-1
                           uriparser              0.9.0-1              0.9.1-1
                            uwsgitop               0.10-2               0.11-1
                          wiredtiger     3.1.0.20181030-1     3.1.0.20181203-1


:: Different overlay package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-01-02           2019-01-04
-------------------------------------------------------------------------------
                          libsystemd              239.6-2             240.58-1
                             systemd              239.6-2             240.58-1
                  systemd-resolvconf              239.6-2             240.58-1
                  systemd-sysvcompat              239.6-2             240.58-1


:: Different overlay package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-01-02           2019-01-04
-------------------------------------------------------------------------------
                  manjaro-tools-yaml             0.15.9-3             0.15.9-4


:: Different sync package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-01-02           2019-01-04
-------------------------------------------------------------------------------
                                asio             1.12.1-1             1.12.2-1
                               cmake             3.13.1-1             3.13.2-1
                 ibus-typing-booster              2.3.1-1              2.4.1-1
                      perl-dbd-mysql              4.048-1              4.049-1
                              python              3.7.1-1              3.7.2-1
                         python-lxml              4.2.5-1              4.2.6-1
                    python-lxml-docs              4.2.5-1              4.2.6-1
                     python-requests             2.20.1-1             2.21.0-1
                        python2-lxml              4.2.5-1              4.2.6-1
                    python2-requests             2.20.1-1             2.21.0-1
                            rp-pppoe               3.12-3               3.13-1
                          sdl2_mixer              2.0.4-1              2.0.4-2
                       smartmontools                6.6-2                7.0-1
                          prometheus                    -              2.6.0-2
            prometheus-node-exporter                    -             0.17.0-1


:: Different overlay package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2019-01-02           2019-01-04
-------------------------------------------------------------------------------
                       lib32-systemd              239.6-2             240.58-1
  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


#2

The same issues (with systemd-udevd and long boot time) still persists on my gnome desktop with gdm after the new update of systemd 240.58-1:


#3

On bare metal, it seems, the CPU temperature sensor widgets do not reload the information automatically and i always have to reload them manually as they appear OFF. Not sure when this came about … not sure where too look for and for what :slight_smile:


Plasma5- applet thermal monitor not showing CPU temperature
#4

That is also happening in Stable, for the past few days [ie, since the last Update; but ironically only in Lappy, not also my poltergeisty Tower]. I’ve not yet solved it. Thought it might have been the dbus change, so tried dbus-x11, but made no difference.

EDIT [2 days later]: Nope, also happens in Tower.


#5

Was this already reported upstream?


#6

I synced more packages. Included are updates to Vulkan and further Deepin plus Python packages.


#7

I didn’t find any solution either … Still looking into it. I don’t mind to reload the Temp Sources, but what is interesting: the package is version 1.2.9-1 and was last updated in 17/05/2018, but the plasmoid version reports 1.2.8
Either way, the HDD and GPU temperatures load but not the isa + CPU that are shown trough lmsensors
Not sure if is related with the KDE Framework + Qt that changed versions since 17/05/2018.


#8

Update appeared smooth, but on re-boot it seemed as if my WiFi adapter was completely disabled. I re-booted again (and again, for confirmation), and everything seems normal


#9

anything on that?


#10

What happens if you uncheck Anonymously report errors and usage statitics in options?

@Ste74 builds etcher … it was last built on Dec-18 … there is a thread on Manjaro packages that needs a rebuild, somewhere.

Is this the only way to flag Manjaro built packages out of date?


#11

that message shows after the flashing is finished. so i don’t want to re-flash the sd-card again.

in repo the version is 1.4.8 and the latest is 1.4.9 .Change Log

i could not understand what are you talking about the thread or flag an out-dated package. sorry.


#12

There is a thread for raising awareness of Manjaro maintained packages (like etcher) that are out of date.


#13

I opened an issue and finally solved in systemd 240.156-1. :slight_smile:


closed #14