[Unstable Update] 2018-12-14 - Cinnamon, Deepin, QT5, Systemd, KDE-Apps, KDE-Framework, Mesa

unstable
update

#22

Broken !
I get a GUI popup : “impossible de contacter le serveur de configuration”
No cursor, thus cannot clic, doesn’t react to keys
Tried fallback 4.19 : idem

Tried tty, had to go to tty4
Tried rm -rf ~/.cache/sessions/no effect
Now changing for stable

[Edit] My details (back to stable) tell me if logs needed

~]$ inxi
CPU: Dual Core Intel Core i3-2370M (-MT MCP-) 
speed/min/max: 2166/800/2400 MHz Kernel: 4.19.12-1-MANJARO x86_64 Up: 2m 
Mem: 1798.6/5855.9 MiB (30.7%) Storage: 698.64 GiB (61.3% used) Procs: 222 
Shell: bash 4.4.23 inxi: 3.0.28 
[asatysco2@manjaro ~]$ inxi -Fxz
System:
  Host: manjaro Kernel: 4.19.12-1-MANJARO x86_64 bits: 64 compiler: gcc 
  v: 8.2.1 Desktop: Xfce 4.13.2git-UNKNOWN Distro: Manjaro Linux 
Machine:
  Type: Laptop System: Hewlett-Packard product: HP ENVY m6 Notebook PC 
  v: 0882110000305B10000620100 serial: <filter> 
  Mobo: Hewlett-Packard model: 18A5 v: 73.50 serial: <filter> UEFI: Insyde 
  v: F.26 date: 05/14/2014 
Battery:
  ID-1: BAT1 charge: 40.3 Wh condition: 40.3/40.3 Wh (100%) 
  model: 13-24 MO06062 status: Full 
CPU:
  Topology: Dual Core model: Intel Core i3-2370M bits: 64 type: MT MCP 
  arch: Sandy Bridge rev: 7 L2 cache: 3072 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 19164 
  Speed: 1539 MHz min/max: 800/2400 MHz Core speeds (MHz): 1: 1381 2: 1866 
  3: 1219 4: 1494 
Graphics:
  Device-1: Intel 2nd Generation Core Processor Family Integrated Graphics 
  vendor: Hewlett-Packard driver: i915 v: kernel bus ID: 00:02.0 
  Device-2: AMD Thames [Radeon HD 7500M/7600M Series] 
  vendor: Hewlett-Packard driver: radeon v: kernel bus ID: 01:00.0 
  Display: x11 server: X.Org 1.20.3 driver: intel resolution: 1366x768~60Hz 
  OpenGL: renderer: Mesa DRI Intel Sandybridge Mobile v: 3.3 Mesa 18.2.6 
  direct render: Yes 
Audio:
  Device-1: Intel 7 Series/C216 Family High Definition Audio 
  vendor: Hewlett-Packard driver: snd_hda_intel v: kernel bus ID: 00:1b.0 
  Sound Server: ALSA v: k4.19.12-1-MANJARO 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Hewlett-Packard driver: N/A port: 2000 bus ID: 07:00.2 
  Device-2: Intel Wireless 7260 driver: iwlwifi v: kernel port: 2000 
  bus ID: 08:00.0 
  IF: wlp8s0 state: up mac: <filter> 
Drives:
  Local Storage: total: 698.64 GiB used: 427.99 GiB (61.3%) 
  ID-1: /dev/sda vendor: Western Digital model: WD7500BPKX-22HPJT0 
  size: 698.64 GiB 
RAID:
  Hardware-1: Intel 82801 Mobile SATA Controller [RAID mode] driver: ahci 
  v: 3.0 bus ID: 00:1f.2 
Partition:
  ID-1: / size: 53.48 GiB used: 41.23 GiB (77.1%) fs: ext4 dev: /dev/sda2 
  ID-2: /home size: 633.70 GiB used: 386.76 GiB (61.0%) fs: ext4 
  dev: /dev/sda3 
Sensors:
  System Temperatures: cpu: 56.0 C mobo: N/A gpu: radeon temp: 27 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 221 Uptime: 3m Memory: 5.72 GiB used: 1.78 GiB (31.1%) 
  Init: systemd Compilers: gcc: 8.2.1 clang: 7.0.0 Shell: bash v: 4.4.23 
  inxi: 3.0.28 

Systemd 240 update breaks graphical login
#23

It might be this:


#24

I have the same problem.
LVM in LUKS, I use the systemd ... sd-encrypt sd-lvm2 ... hooks. I did not try the older hooks. The problem is the new systemd, the newer Kernels work with the old systemd.


#25

Thank you, I’ll rerevert back to unstable as I see that 240.1 is out


#26

As far as I can remember I’m using the older hooks and still can’t boot.


#27

Can’t either


#28

@philm I get the following warning in the journal after the last updates of systemd on unstable (240.1-2):

systemd-udevd[413]: Failed to wait spawned command '/usr/bin/alsactl restore 1': Input/output error
systemd-udevd[424]: Failed to wait spawned command '/usr/bin/alsactl restore 0': Input/output error

I managed to resolve it by following the instructions from here although I’m not sure if it’s the right way or if the error is something important.


#29

Hola muchachos, después de actualizar mi notebook hoy (22/12/18), no puedo acceder ni siquiera a la terminal TTY. Creo que esta relacionado a systemd y la partición primaria encriptada (luks).
Les dejo una imagen del proceso de arranque.

Si alguien puede ayudarme…
¡Felices Fiestas Comunidad!
Edgar.


#30

Replaced dbus with dbus-x11 on a Xfce VM Unstable using another TTY and no more problem with login.


#31

It is a problem with udev and lvm. It seems that udev doesn’t activate the lvm volumes. It can be done manually.

In Emergency Mode, you can use the lvm command and then in lvm interactive vgchange -ay. After that you can boot with systemctl default . But because of the problems with udev, there are not devices below /dev/mapper .

There is a systemd bug report on github.


edit

A workaround is to remove quite and rd.udev.log-priority=3 from the Kernel command line. But this doesn’t look that nice with smooth bootup. But the system is working and all lvm volumes are found.


#32

Seems there are also other regressions reported for systemd. So we have to find out on how we address these issues somehow and still get working packages to our testing branch.


#33

Well, what’s new about this?

UPD So, I managed to fix it a bit. The screenshot tells about it even without translation.


#34

Latest unstable hangs on SDDM login, maybe related to systemd. Reverting to testing branch.


#35

What is the rush?

If there are upstream regressions then rollback 240 and wait until it has been properly patched.

Neddlessly plowing ahead and causing the same issues (ie non booting systems) on testing branch is pointless and dangerous.

Manjaro is not in a position to be a bleeding edge systemd adopter currently, Manjaro was running 240 before any other distro, which is simply asking for trouble.

Arch has a bigger team and much bigger community, let them be the test dummies for major upgrades like this one.

Great, now sddm is broken, I’m moving all my unstable bare metal systems to testing for the foreseeable future.


#36

I must be one of the lucky ones, running KDE unstable with no issues (at least none that I’m aware of). But I am running older (but not ancient) stable hardware:
Pentium E6700
AMD Redwood XT [Radeon HD 5670/5690/5730]
ASUSTeK P5G41T-M LX PLUS motherboard


#37

Maybe not, I am running sddm-git 0.18.0.0.gc8867e0-1 so perhaps the version in repositories isn’t affected.


#38

I have no rush what so ever. Currently the known working systemd packages is with version 239.6. After that we had 239.300, which crashed, tested with 239.303 and got 239.370 in that given series. Any of these packages were at least tested in testing, but never reached stable. unstable is our testbed. There we change and test packages as needed. Most of the issues are already patched on our end. Currently I still don’t know on how to move from 239.6 to a newer version. Also 239.6 has some security issues, which need to be patched. Therefore we are working so hard to find a solution.


#39
(17/19) Updating the appstream cache...
The AppStream system cache was updated, but some errors were detected, which might lead to missing metadata. Refer to the verbose log for more information.
error: command failed to execute correctly

[2018-12-24 09:40] [ALPM-SCRIPTLET] The AppStream system cache was updated, but some errors were detected, which might lead to missing metadata. Refer to the verbose log for more information.
  • If someone would tell me where is this verbose log to further check this out. Maybe provide the name of the log in the message?
  • After the upgrade the system was waiting for a job to finish, but who has the time to wait?
    Forcefull restart did not work (ctrl+alt+delete), so I had to hit the reset button.
  • SDDM is working and do not have problems with the system.
System:    Host: zoki-pc Kernel: 4.19.12-2-MANJARO x86_64 bits: 64 Console: tty 1 Distro: Manjaro Linux 
Machine:   Type: Desktop Mobo: ASUSTeK model: H170M-PLUS UEFI: American Megatrends v: 3805 
           date: 05/16/2018 
CPU:       Topology: Quad Core model: Intel Core i5-6600K bits: 64 type: MCP L2 cache: 6144 KiB 
           Speed: 3665 MHz min/max: 800/3900 MHz Core speeds (MHz): 1: 3740 2: 3698 3: 3778 4: 3728 
Graphics:  Device-1: Intel HD Graphics 530 driver: i915 v: kernel 
           Display: server: X.Org 1.20.3 driver: intel unloaded: modesetting resolution: 1920x1080~60Hz 
           OpenGL: renderer: Mesa DRI Intel HD Graphics 530 (Skylake GT2) v: 4.5 Mesa 18.3.1 
Audio:     Device-1: Intel 100 Series/C230 Series Family HD Audio driver: snd_hda_intel 
           Sound Server: ALSA v: k4.19.12-2-MANJARO 
Network:   Device-1: Intel Ethernet I219-V driver: e1000e 
           IF: eth0 state: up speed: 1000 Mbps duplex: full
Drives:    Local Storage: total: 232.89 GiB used: 162.56 GiB (69.8%) 
           ID-1: /dev/sda vendor: Samsung model: SSD 850 EVO 250GB @ size: 232.89 GiB 
Partition: ID-1: / size: 227.94 GiB used: 162.56 GiB (71.3%) fs: ext4 dev: /dev/sda2 
Sensors:   System Temperatures: cpu: 29.8 C mobo: 27.8 C 
Info:      Processes: 229 Uptime: 11m Memory: 7.65 GiB used: 3.73 GiB (48.8%) Shell: bash inxi: 3.0.28

#40

Thank you for the insight.
Thanks to your post, my system is bootable involving much less work than I had anticipated.

Interestingly, while lvm was available and able to activate the logical volumes in the emergency shell, systemctl was not found. Consequently, a manual boot did not work that way.

A revert to systemd 239 solved it for now.


#41

Desktop widgets stop working, panels still work