[Unstable Update] 2018-12-14 - Cinnamon, Deepin, QT5, Systemd, KDE-Apps, KDE-Framework, Mesa

unstable
update

#1

Hi community,

Welcome to another unstable update.
So what do we have with this one?

  • Deepin and Cinnamon updates
  • We updated QT5 to 5.12 LTS; please tell us if some is still broken
  • Systemd is still at 239.303, which broke some systems - still
  • KDE Frameworks are at 5.53.0
  • KDE Apps are at 18.12.0
  • Mesa got updated to 18.3.1
  • all the regular haskell, php and python updates

We hope with all these changes Manjaro to be more efficient for you all.


#ManjaroBook - shipping worldwide since this Winter!

manjarobook

We are happy to announce our partnership with LINUX-SERVICE.BE BVBA from Belgium. With them we established a wider range of laptops and PCs optimized for Manjaro - starting from 390 €- available to be shipped worldwide. All models are customizable as you may need them. Check out our new line-up in the shop.


Manjaro v18.0.1 RC1 released!

If you are curious about the latest Manjaro-Illyria 18.0.1 release, you now have the opportunity to download XFCE Edition with the latest 4.13 packages, aswell as our most recent styling efforts. Our KDE fans may try our KDE Edition with the latest KDE v5.14 instead. And our GNOME fans may try our Gnome Edition with the latest GNOME v3.30.


Current supported Kernels

  • linux316 3.16.61
  • linux318 3.18.128 [EOL]
  • linux44 4.4.166
  • linux49 4.9.144
  • linux414 4.14.87
  • linux417 4.17.19 [EOL]
  • linux418 4.18.20 [EOL]
  • linux419 4.19.8
  • linux414-rt 4.14.78_rt47
  • linux416-rt 4.16.18_rt11
  • linux418-rt 4.18.16_rt9

Sync Package Updates (Fri Dec 14 19:56:14 CET 2018)

A detailed list of all package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


#2

Sorry, wrong category, post deleted, user51


#3

Still unable to boot into kernel 4.9.144-1, sddm is crashing.

Saw an Arch forum thread with this same issue, it was resolved by updating their system to 4.14.


#4

We have to figure that issue out, before we move QT5 to our testing branch. What does the Internet say about it?


#5

Not much, but how many distros currently offering Qt 5.12 and 4.9 kernel?

This is an older issue that sounds similar, where Qt 5.10 was using a system call not supported in older kernels.

https://bbs.archlinux.org/viewtopic.php?id=232682

Maybe same thing happening here?


#6

Kmozillahelper (presumably formerly required by firefox-kde-opensuse) is now orphaned?

$ pacman -Qdt
kmozillahelper 5.0.2-1

[Security Update] 2018-12-11 - Firefox 64.0
#7

@AJSlye builds that … he would be the best person to answer this.

EDIT :

Nevermind, answered in the Firefox 64 update thread.


#8

I already answered this exact same question here:

@mparillo,
Bernhard (@oberon) is the one who packages Kmozillahelper for Manjaro.
As far as I know, he still does. You might want to ask him.

PS. Can we please, try not to double post the same question in more than one thread.


#9

My fault. I thought it was only occurring in unstable, so I first posted here. Then I realized I normally check for new orphans after a big update, but I may have neglected to do so with the small FF security update in testing, so I went back to testing and I saw the orphan there too, so it was more applicable to the FF security thread than the unstable thread.


#10

Still, I’m not sure where you are getting orphaned from. This was never officially packaged in Arch, and the AUR entry has a maintainer. @oberon is the one that has been packaging kmozillahelper for Manjaro.


#11

On my secondary laptop I am running manjaro cinnamon, unstable branch.
Update fails to connect with the mirrors.
I originally tried to run from a F4 tty, then pamac, then terminal emulator.
I’m getting error messages that appear to be related to python instructions.(??)
pacman -Q python returns python 3.7.1-1.

Confirmation of branch and initial attempt to update:

[charlie@dell-studio-xps-pc ~]$ sudo pacman-mirrors -G
unstable

[charlie@dell-studio-xps-pc ~]$ sudo pacman -Syu
[sudo] password for charlie: 
:: Synchronizing package databases...
error: failed to update core (no servers configured for repository)
error: failed to update extra (no servers configured for repository)
error: failed to update community (no servers configured for repository)
error: failed to update multilib (no servers configured for repository)
error: failed to synchronize all databases

Attempt to regenerate pacman-mirrors:

[charlie@dell-studio-xps-pc ~]$ sudo pacman-mirrors -aB unstable
::INFO Branch in config is changed
::INFO Downloading mirrors from repo.manjaro.org
Traceback (most recent call last):
  File "/usr/bin/pacman-mirrors", line 28, in <module>
    pm.run()
  File "/usr/lib/python3.7/site-packages/pacman_mirrors/pacman_mirrors.py", line 108, in run
    defaultFn.load_config_mirror_pool(self)
  File "/usr/lib/python3.7/site-packages/pacman_mirrors/functions/defaultFn.py", line 33, in load_config_mirror_pool
    customFn.load_custom_mirror_pool(self)
  File "/usr/lib/python3.7/site-packages/pacman_mirrors/functions/customFn.py", line 79, in load_custom_mirror_pool
    config=self.config, custom_pool=self.mirrors.mirror_pool)
  File "/usr/lib/python3.7/site-packages/pacman_mirrors/functions/customFn.py", line 35, in apply_status_to_custom_mirror_pool
    status_list = tuple(jsonFn.read_json_file(filename=config["status_file"], dictionary=False))
  File "/usr/lib/python3.7/site-packages/pacman_mirrors/functions/jsonFn.py", line 42, in read_json_file
    result = json.load(infile)
  File "/usr/lib/python3.7/json/__init__.py", line 296, in load
    parse_constant=parse_constant, object_pairs_hook=object_pairs_hook, **kw)
  File "/usr/lib/python3.7/json/__init__.py", line 348, in loads
    return _default_decoder.decode(s)
  File "/usr/lib/python3.7/json/decoder.py", line 337, in decode
    obj, end = self.raw_decode(s, idx=_w(s, 0).end())
  File "/usr/lib/python3.7/json/decoder.py", line 355, in raw_decode
    raise JSONDecodeError("Expecting value", s, err.value) from None
json.decoder.JSONDecodeError: Expecting value: line 1 column 1 (char 0)

I’ve also tried pacman-mirrors -i and -id and tried switching to stable branch with similar results every time.

Here’s my inxi on this laptop:

[charlie@dell-studio-xps-pc ~]$ inxi -Fxz
System:
  Host: dell-studio-xps-pc Kernel: 4.19.7-2-MANJARO x86_64 bits: 64 
  compiler: gcc v: 8.2.1 Desktop: Cinnamon 4.0.5 Distro: Manjaro Linux 
Machine:
  Type: Portable System: Dell product: Studio XPS 1640 v: A123 
  serial: <filter> 
  Mobo: Dell model: 0U785D v: A12 serial: <filter> BIOS: Dell v: A12 
  date: 11/19/2009 
Battery:
  ID-1: BAT0 charge: 5.1 Wh condition: 5.1/6.6 Wh (77%) 
  model: PANASONIC Dell status: Full 
CPU:
  Topology: Dual Core model: Intel Core2 Duo P8700 bits: 64 type: MCP 
  arch: Penryn rev: A L2 cache: 3072 KiB 
  flags: lm nx pae sse sse2 sse3 sse4_1 ssse3 vmx bogomips: 10110 
  Speed: 798 MHz min/max: 800/2534 MHz Core speeds (MHz): 1: 1094 2: 1115 
Graphics:
  Device-1: AMD RV635/M86 [Mobility Radeon HD 3670] vendor: Dell 
  driver: radeon v: kernel bus ID: 01:00.0 
  Display: x11 server: X.Org 1.20.3 driver: ati,radeon unloaded: modesetting 
  tty: N/A 
  OpenGL: renderer: AMD RV635 (DRM 2.50.0 / 4.19.7-2-MANJARO LLVM 7.0.0) 
  v: 3.3 Mesa 18.3.0 direct render: Yes 
Audio:
  Device-1: Intel 82801I HD Audio vendor: Dell driver: snd_hda_intel 
  v: kernel bus ID: 00:1b.0 
  Device-2: AMD RV635 HDMI Audio [Radeon HD 3650/3730/3750] vendor: Dell 
  driver: snd_hda_intel v: kernel bus ID: 01:00.1 
  Sound Server: ALSA v: k4.19.7-2-MANJARO 
Network:
  Device-1: Broadcom and subsidiaries BCM43224 802.11a/b/g/n 
  vendor: Dell Wireless 1520 Half-size Mini PCIe Card driver: wl v: kernel 
  port: 2000 bus ID: 04:00.0 
  IF: wlp4s0 state: up mac: <filter> 
  Device-2: Broadcom and subsidiaries NetLink BCM5784M Gigabit Ethernet PCIe 
  vendor: Dell driver: tg3 v: 3.137 port: 2000 bus ID: 08:00.0 
  IF: enp8s0 state: down mac: <filter> 
Drives:
  Local Storage: total: 465.76 GiB used: 7.81 GiB (1.7%) 
  ID-1: /dev/sda vendor: Samsung model: SSD 850 EVO 500GB size: 465.76 GiB 
Partition:
  ID-1: / size: 449.18 GiB used: 7.75 GiB (1.7%) fs: ext4 dev: /dev/sda1 
  ID-2: swap-1 size: 8.40 GiB used: 61.7 MiB (0.7%) fs: swap dev: /dev/sda2 
Sensors:
  System Temperatures: cpu: 68.0 C mobo: 52.0 C 
  Fan Speeds (RPM): cpu: 3836 fan-2: 3587 fan-3: 4085 
Info:
  Processes: 172 Uptime: 8d 4h 18m Memory: 3.82 GiB used: 1.35 GiB (35.4%) 
  Init: systemd Compilers: gcc: 8.2.1 Shell: bash v: 4.4.23 inxi: 3.0.28 

Any ideas how to fix short of reinstalling?
It’s bedtime now. I will work on this tomorrow during the day New York time.

EDIT: just tried one more thing that will probably be related to the root cause:

[charlie@dell-studio-xps-pc ~]$ inxi -r
Repos:
  No active pacman repos in: /etc/pacman.d/mirrorlist 

Wonder if I could copy the mirrorlist from my main manjaro laptop??? Let me try that.

Nope – tried that.
Tried following these instructions:

# NOTE: You must run `pacman-key --init` before first using pacman; the local
# keyring can then be populated with the keys of all official Manjaro Linux
# packagers with `pacman-key --populate archlinux manjaro`.

Still no luck. :disappointed:


#13

Plasma loads with a very unstable desktop after upgrading on my laptop. Desktop image has fragmentation and black dialog boxes. Work is not possible. x11. Intel Mobile GM965/GL960 Integrated Graphics Controller.


#14

I’m also experiencing these issues, but I thought it was (once again) a problem related to Nvidia + Nouveau driver (see this post in the Arch forum).

In my case, turning on and off the compositor several times (Alt + Shift + F12), usually stabilizes the desktop (!). Or switching to Xrender…


#15

This is not an option.:confused:


#16

4.19.10 and 4.19.11-rc1 broke my amdgpu - no display at all (stays powered off). CTRL-ALT-F2 + CTRL-ALT-DEL works to reboot.

4.14.89 gives me a display but Bluetooth is broken, adapter shows up in lsusb/rfkill but Blueman segfaults when I enable BT and when restarted won’t show any BT adapter.

What did they do to these kernels? Why so much breakage? :weary:


#17

Nothing. Did you update to the latest linux-firmware? See here.


#18

Ah, that will be it. As far as I know I’m always up-to-date but I’ll check versions.


OK - those reverts are for vega (which I don’t have).

The odd behaviour remains with 4.19.11-1 and linux-firmware 20181218.0f22c85-0.

Laptop internal display is blank on boot (backlight active). External HDMI display is active. Log in, disable internal display in Display Settings, revert, internal display becomes active. Reboot - internal display blank.


#19

When will be in Testing?


#20

All amdgpu firmwares got updated, however only vega10 reverted. Which APU do you have? You may try linux-firmware-20181214.8aa9e3e-1 from our testing branch and let me know if that works on your end.


#21

I have not found a newer unstable post, so here:

After the newest round of updates, my encrypted setup does not boot.
I have an unencrypted boot, rest encrypted (lvm in LUKS), using grub. The logical volume is not found.

I suspect systemd 240.

I’ll write when I know more.