[Unstable Update] 2018-09-18 - Gnome 3.30, Firefox-Dev, Python, Haskell

unstable
update

#1

Hi community,

Wow, what is this? Welcome to another unstable update. Yeah, I found some time to announce some here. Feel free to report issues!

  • Gnome 3.30 got added to our repos.
  • latest firefox-dev
  • The usual upstream updates, incl. python and haskell

We hope with all these changes Manjaro to be more efficient for you all.


The Iconic Spitfire: Now Quad-Core!

jpg%3Alarge

Visit StationX now!


#beta-release - 18.0 will be available in late October!

If you are curious about the latest state of development for the upcoming Manjaro-Illyria 18.0 release, you now have the opportunity to download a beta-build of Manjaro-Xfce 18.0 including the latest xfce-gtk3 packages aswell as our most recent styling efforts. Our KDE fans may try our beta-build with the latest KDE v5.13 instead. And our GNOME fans may try our beta-build with the latest GNOME v3.28.


Current supported Kernels

  • linux316 3.16.57
  • linux318 3.18.122 [EOL]
  • linux44 4.4.156
  • linux49 4.9.127
  • linux414 4.14.70
  • linux417 4.17.19 [EOL]
  • linux418 4.18.8
  • linux419 4.19-rc3
  • linux414-rt 4.14.63_rt40
  • linux416-rt 4.16.18_rt11

Package Updates (Tue Sep 18 07:06:59 CEST 2018)

  • unstable core x86_64: 3 new and 3 removed package(s)
  • unstable multilib x86_64: 3 new and 3 removed package(s)
  • unstable extra x86_64: 124 new and 123 removed package(s)
  • unstable community x86_64: 181 new and 176 removed package(s)

A detailed list of all package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Ready for Testing ?!?

  • We are ready to move this to our testing branch
  • I still see some issues (post about them)

0 voters


#2

One thing i noticed for those that use Dash to Panel extension. It doesn’t install the 16 version automatically and 15.1 version needs to be removed, reboot and then be able to install it again from extensions.gnome.org trough Chromium browser.

Edit: September 17, 2018 (Europe: Paris), September 17, 2018 (America: Los Angeles)
Whatever Gnome developers did with 3.30 version, they broken entirely the Tablet and Pen support, and whatever fix we had in the past, is no longer working, regardless Gnome-shell (original or branded), as it seems the pad-osd.css file has no longer any effect. Recompiling gnome-shell-theme.gresources with the correct values (as is used to be) doesn’t change anything.
The Tablet buttons can’t be mapped anymore and when the Stylus/Pen is detected, gnome-shell restarts and brings me back to login screen asking for user and password.


#3

No issue here. Gnome 3.30. Nautilus still in 3.28.


#4

The Budgie Desktop will likely have issues with this update due to Gnome 3.30, so Budgie should be updated to the git version instead of the current release of 10.4


#5

I have noticed just one issue as of today.
control-centre crashes if I click on the “share” tab. The ugly thing is when restarting CC it remembers the panel last used and crashes again.
Remedy: run e.g. “gnome-control-center background” in a terminal.

I have to add that I run stable and only installed the GNOME packages from unstable.

By the way, looking for a way to install debugging symbols…

$ gdb /usr/bin/gnome-control-center

Thread 1 “gnome-control-c” received signal SIGSEGV, Segmentation fault.
0x00005555555a0f8b in ?? ()
(gdb) bt full
#0 0x00005555555a0f8b in ()
#1 0x000055555562cf40 in ()
#2 0x00007ffff7cd70f4 in () at /usr/lib/libgio-2.0.so.0
#3 0x00007ffff7cd9ad7 in () at /usr/lib/libgio-2.0.so.0
#4 0x00007ffff7c86aa2 in () at /usr/lib/libgio-2.0.so.0
#5 0x00007ffff7cd70f4 in () at /usr/lib/libgio-2.0.so.0
#6 0x00007ffff7cd7129 in () at /usr/lib/libgio-2.0.so.0
#7 0x00007ffff7b0d271 in g_main_context_dispatch () at /usr/lib/libglib-2.0.so.0
#8 0x00007ffff7b0ef89 in () at /usr/lib/libglib-2.0.so.0
#9 0x00007ffff7b0efce in g_main_context_iteration () at /usr/lib/libglib-2.0.so.0
#10 0x00007ffff7cb38ce in g_application_run () at /usr/lib/libgio-2.0.so.0
#11 0x00005555555a0359 in main ()


#6

No issues, gnome 3.30 kernel 4.19


#7

Never do that. Switch either to a branch or simply wait. All packages in unstable may be compiled against different depending libraries. Please switch to unstable to fix your issue.


#8

[Testing Review] 2018-09-21 - Gnome 3.30, Deepin, LibreOffice, NetworkManager, PHP, QT

… current packages in queue …

Ready for testing?

    • ready to be moved to testing
    • wait, still see some issues

0 voters


Plasma is Great!
#9

Had this issue today:

:: Synchronizing package databases...
 core                                          148.6 KiB   743K/s 00:00 [----------------------------------------] 100%
 extra                                        1763.7 KiB  1084K/s 00:02 [----------------------------------------] 100%
 community                                       4.9 MiB  1410K/s 00:04 [----------------------------------------] 100%
 multilib                                      182.1 KiB  1937K/s 00:00 [----------------------------------------] 100%
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing iptables (1:1.6.2-3) breaks dependency 'ebtables' required by firewalld
Error installing repo packages

Solved with

pacman -Syu firewalld

ref: https://bbs.archlinux.org/viewtopic.php?pid=1809335#p1809335


[Testing Update] 2018-09-25 - Gnome, Grub, Kernel 4.19-rc5, Plasma-Workspace
#10

After going entirely to testing (which has the packages by now), the issue mentioned by me is gone. So indeed it was due to the mix of stable and unstable packages.


closed #11

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.