[Unstable Update] 2018-08-06 - Kernels, Python 3.7, Perl 5.28, LibreOffice

unstable
update

#1

Hi community,

Wow, what is this? Welcome to another unstable update. Yeah, I found some time to announce some here. Feel free to report issues!

  • we updated again some of our kernels
  • also we pushed our rebuilds for python 3.7 and perl 5.28. There might be still packages needed to be rebuilt. Please report any issues with this.
  • LibreOffice got updated to 6.0.6

We hope with all these changes Manjaro to be more efficient for you all.


Currently we are working on a new Manjaro-Hardware project, the Bladebook Fall 2018. It will be powered by Manjaro KDE v18.0 and the latest Intel Apollo Lake Quad-Core HD APU. Having a fanless metal material (cassis either silver or gold-rose) and eMMC as storage (additional M2-SSD possible), it will have a long battery life. Find out more on our hardware page.

If you are curious about the latest state of development for the upcoming Manjaro-Illyria 18.0 release, you now have the opportunity to download a beta-build of Manjaro-Xfce 18.0 including the latest xfce-gtk3 packages aswell as our most recent styling efforts. Our KDE fans may try our beta-build with the latest KDE v5.13 instead. And our GNOME fans may try our beta-build with the latest GNOME v3.28.


Latest information about the intel-cpu-bug risk and our efforts can be found here.


Current supported Kernels

  • linux316 3.16.57
  • linux318 3.18.117 [EOL]
  • linux41 4.1.52 [EOL]
  • linux44 4.4.146
  • linux49 4.9.118
  • linux414 4.14.61
  • linux415 4.15.18 [EOL]
  • linux416 4.16.18 [EOL]
  • linux417 4.17.13
  • linux418 4.18-rc7
  • linux414-rt 4.14.52_rt34
  • linux416-rt 4.16.18_rt11

Package Updates (Mon Aug 6 16:54:34 CEST 2018)

A detailed list may be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


Ready for Testing ?!?

  • We are ready to move this to our testing branch
  • I still see some issues (post about them)

0 voters


#3

Known issues and solutions

Something using Perl/Python/glibc broke

Rebuilds needed! If it’s an AUR package, rebuild it. If it’s a repo package, check back regularly for rebuilds.


#4

Xfce all together 144 update files :slight_smile: , smooth, thx :slight_smile:
4.18.0-1-MANJARO

LibreOffice still 5.4.7-3
LibreOffice fresh 6.0.6-1 ok :slight_smile:


[Unstable Update] 2018-08-06 - Kernels, Python 3.7, Perl 5.28, LibreOffice
#5

On KDE I had around 262 packages!

The only problem I had was with caffeine-ng from AUR and as far as I remember to solve this problem I had to reinstall python-ewmh from AUR and it worked.


#6

The glibc update to 2.28 causes skypeforlinux to segfault (skypeforlinux-preview also). It’s already been reported in the Skype forum: https://answers.microsoft.com/en-us/skype/forum/skype_linux-skype_startms-skype_installms/segfault-after-system-upgrade/12b4e250-68a5-40c4-aaad-c986023b7699

I suppose there’s no fixing it until MS rebuilds skypeforlinux…

EDIT: The PKGBUILD for skypeforlinux in AUR has been edited to include its own glibc 2.27 (until the problem is fixed), so it just needs to be rebuilt. Nice!


#7

Well, the web-application is included in our ms-office-online package. Give it a try.


#8

Compiz Settings gone.
Compiz Config doesn’t open anymore. (XFCE)


#9
This?


#10

Yes

Compiz GTK decorator theme is opening.
CompizConfig Setting does not.


#11

Working on it :wink:


#12

That was quick. Everythings working again. Thanks!


#13

Thanks for the tip. But it looks like maybe something needs a rebuild, due to the python update?

$ ms-skype
Ops something went wrong: No module named 'j'
./ms-skype-online:10: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded.
  from gi.repository import Gtk, WebKit2, GLib
./ms-skype-online:10: PyGIWarning: WebKit2 was imported without specifying a version first. Use gi.require_version('WebKit2', '4.0') before import to ensure that the right version gets loaded.
  from gi.repository import Gtk, WebKit2, GLib
Traceback (most recent call last):
  File "./ms-skype-online", line 18, in <module>
    class OfficeWindow(AppWindow):
NameError: name 'AppWindow' is not defined

#14

@philm sound works on the new 418 series kernel (after I remembered to remove it from IgnorePkg :blush: ).


#15

So far so good. Update went smoothly, system boots, bumblebee works, on a quick glance all works well. Will post here if I discover any issue.


#16

I had to uninstall pkgbrowser due to dependency python<3.7. Otherwise all appears ok. Not a big deal, since I rarely use it.


Manjaro-specific packages which need an update
#17

Theres been problem with perl-gtk2-unique conflicting with newest version of perl - removing perl-gtk2-unique, updating and installing unique then solved the case.


#18

Sorry, this is an AUR package.


#19

Everything running smooth on my gnome desktop!


#20

I had the same issue as Soulforged above. Also same solution (but needed nodeps to remove).

Thanks for posting that.

viking

PS. Sadly the dependency of perl-gtk2-unique (shutter) now no longer works, I will have to give it some time I guess.


#21

Thunderbird 60 ?
btw how much RAm has the Bladebook?
Intel Atom x7 E3950 or x5 E3940