[Unstable Update] 2018-05-07 - GCC8, Cinnamon, Gnome, Haskell, Python

unstable
update
gcc8

#1

Hi community,

welcome to another update update of Manjaro. I love to break stuff. Especially in our unstable branch. This time I drive DKMS nuts due to the fact of GCC update. Read about it here. A rebuild of all kernels is needed to get DKMS working again. Since we provide binary extramodules, I don’t see a rush with this.

Also we had some Cinnamon and Gnome package updates plus the regular upstream updates/rebuilds, such as python and haskell.

Since I’m about to go for a business trip in CW20, to visit Timișoara, expect not many updates from my side in the coming weeks. However, the rest of the team might do the necessary steps to step in.

Our effort and all the needed information about the new security risk can be found here.

So please report back and give us feedback for given changes made to our repositories. Users of our 32-bit Distro should read this.


Current supported Kernels

  • linux316 3.16.56
  • linux318 3.18.108 [EOL]
  • linux41 4.1.51
  • linux44 4.4.131
  • linux49 4.9.98
  • linux414 4.14.39
  • linux415 4.15.18 [EOL]
  • linux416 4.16.7
  • linux417 4.17-rc3
  • linux414-rt 4.14.39_rt29
  • linux416-rt 4.16.7_rt1

Package Updates (Mon May 7 19:44:13 CEST 2018)

  • unstable core x86_64: 11 new and 11 removed package(s)
  • unstable extra x86_64: 25 new and 25 removed package(s)
  • unstable community x86_64: 51 new and 51 removed package(s)
:: Different overlay package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-05-06           2018-05-07
-------------------------------------------------------------------------------
              manjaro-openbox-common              1.3.0-1            1.3.0.2-1
                manjaro-openbox-core            1.3.0.1-1            1.3.0.2-1
               manjaro-openbox-extra              1.3.0-1            1.3.0.2-1
          manjaro-openbox-extra-skel              1.3.0-1            1.3.0.2-1
          manjaro-openbox-grub-theme                1.0-4                1.3-1
             manjaro-openbox-minimal              1.3.0-1            1.3.0.2-1
        manjaro-openbox-minimal-skel              1.3.0-1            1.3.0.2-1


:: Different sync package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-05-06           2018-05-07
-------------------------------------------------------------------------------
                      acpi_call-dkms            1.1.0-126            1.1.0-127
                          addinclude                1.0-1                1.0-2
                              arpack              3.5.0-3              3.5.0-4
                         broadcom-wl      6.30.223.271-13      6.30.223.271-14
                                ccid             1.4.29-2             1.4.29-3
                               cgrep            6.6.23-22             6.6.25-1
                    cinnamon-desktop              3.8.0-1              3.8.1-1
                      cinnamon-menus              3.8.0-1              3.8.1-1
                cinnamon-screensaver              3.8.0-1              3.8.1-1
            cinnamon-settings-daemon              3.8.0-1              3.8.1-1
                             compton       0.1_beta2.5-10       0.1_beta2.5-11
                             freemat                4.2-8                4.2-9
                             gendesk                0.7-1                0.7-2
                               glide             0.13.1-1             0.13.1-2
                         gnome-boxes             3.28.2-1             3.28.3-1
                      haskell-hakyll          4.11.0.0-71          4.11.0.0-72
         haskell-tamarin-prover-term              1.2.3-8              1.4.0-1
       haskell-tamarin-prover-theory             1.2.3-11              1.4.0-1
        haskell-tamarin-prover-utils              1.2.3-3              1.4.0-1
                     haskell-texmath          0.10.1.1-16           0.10.1.2-1
                                hdf5             1.10.1-2             1.10.1-3
                        hdf5-openmpi             1.10.1-3             1.10.1-4
                               julia            2:0.6.2-7            2:0.6.2-8
                          julia-docs            2:0.6.2-7            2:0.6.2-8
                             libgiac           1.4.9.59-2           1.4.9.59-3
                             liteide               33.3-1               33.3-2
                               lxcfs              3.0.0-1              3.0.0-3
                              muffin              3.8.0-1              3.8.1-1
                                mypy              0.600-2              0.600-3
                                nemo              3.8.1-1              3.8.2-1
                      netcdf-fortran              4.4.4-4              4.4.4-5
                              octave              4.2.2-1              4.4.0-1
                              pandoc             2.1.3-21             2.1.3-22
                     pandoc-citeproc          0.13.0.1-63          0.13.0.1-64
                     pandoc-crossref            0.3.1.0-2            0.3.1.0-3
                            pcsclite             1.8.23-2             1.8.23-3
                          perl-mouse              2.5.2-1              2.5.4-1
                            polymake             3.2.r2-3             3.2.r3-1
                        python-munch              2.3.1-1              2.3.2-1
                        python-scipy              1.0.1-1              1.0.1-2
                    python-tarantool              0.6.1-2              0.6.2-1
                       python2-munch              2.3.1-1              2.3.2-1
                       python2-scipy              1.0.1-1              1.0.1-2
                   python2-tarantool              0.6.1-2              0.6.2-1
                            qrupdate              1.1.2-2              1.1.2-3
                              qtpass              1.2.1-2              1.2.2-1
                      tamarin-prover             1.2.3-42              1.4.0-1
                              trojan              1.1.0-1              1.2.0-1
                               xapps              1.2.0-1              1.2.1-1
                                xcas           1.4.9.59-2           1.4.9.59-3
                             xreader              1.6.2-2              1.8.0-2


:: Different sync package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-05-06           2018-05-07
-------------------------------------------------------------------------------
                            binutils               2.30-3               2.30-4
                                 gcc     7.3.1+20180406-1              8.1.0-1
                             gcc-ada     7.3.1+20180406-1              8.1.0-1
                         gcc-fortran     7.3.1+20180406-1              8.1.0-1
                              gcc-go     7.3.1+20180406-1              8.1.0-1
                            gcc-libs     7.3.1+20180406-1              8.1.0-1
                            gcc-objc     7.3.1+20180406-1              8.1.0-1
                               glibc               2.27-2               2.27-3
                      lib32-gcc-libs     7.3.1+20180406-1              8.1.0-1
                         lib32-glibc               2.27-2               2.27-3
                             libtool 2.4.6+40+g6ca5e224-5 2.4.6+40+g6ca5e224-6


:: Different sync package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-05-06           2018-05-07
-------------------------------------------------------------------------------
                                blas              3.8.0-1              3.8.0-2
                               cblas              3.8.0-1              3.8.0-2
                           evolution             3.28.1-1             3.28.2-1
                evolution-bogofilter             3.28.1-1             3.28.2-1
               evolution-data-server             3.28.1-1             3.28.2-1
                       evolution-ews             3.28.1-1             3.28.2-1
              evolution-spamassassin             3.28.1-1             3.28.2-1
                    gnome-characters             3.28.0-1             3.28.2-1
                       gnome-keyring         1:3.28.0.2-1           1:3.28.2-1
                          gnome-logs  3.28.0+1+gea3e78c-1             3.28.2-1
                         gnome-music           1:3.28.1-1           1:3.28.2-1
                                gvfs             1.36.1-1             1.36.2-1
                            gvfs-afc             1.36.1-1             1.36.2-1
                            gvfs-goa             1.36.1-1             1.36.2-1
                         gvfs-google             1.36.1-1             1.36.2-1
                        gvfs-gphoto2             1.36.1-1             1.36.2-1
                            gvfs-mtp             1.36.1-1             1.36.2-1
                            gvfs-nfs             1.36.1-1             1.36.2-1
                            gvfs-smb             1.36.1-1             1.36.2-1
                               krita              4.0.1-2              4.0.2-1
                              lapack              3.8.0-1              3.8.0-2
                          lapack-doc              3.8.0-1              3.8.0-2
                             lapacke              3.8.0-1              3.8.0-2
                             libsoup             2.62.1-1             2.62.2-1
                             openmpi              3.0.1-1              3.0.1-2

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


GCC 8.1.0 in Manjaro Unstable
#2

No issue here on two installs (VBox) - but i’ll update tomorrow on the experimental machine and see. Have a great time in Timișoara, and if happens to travel more north, i still have some 30 years old “pălincă” to share :wink:


#3

That GCC update hit like a truck, luckily, there is a warning message when starting to compile stuff which says pretty clearly that one can try to set the environment variable to ignore the version differences, but it should be used carefully as it will not work for every case and definitely should not be set as a permanent variable:
export IGNORE_CC_MISMATCH=1

I guess the times are changing, code is evolving and the versions keep on rolling - just like Manjaro. Good luck with the rebuilds and your efforts are highly appreciated! :hugs:


#4

I don’t know when exactly this issue was introduced, but sometime over the last couple of weeks (possibly with the most recent update) the Manjaro-System update script version 2018507-1 now shows up as an orphan scheduled for removal when I try to clean my system with:

pacman -Rns $(pacman -Qtdq)

When I investigate with Pamac under “Details,” the package is listed as being “installed as a dependency for another package,” however, when I look under “Dependencies” only the packages that it depends on are listed. The original package that depends upon Manjaro-System is no longer listed.

I’m extremely leery of allowing the manjaro-system package to be removed, out of fear that it might cause something else to break during an update. Should I allow it to be removed or is this just a bug caused by an omission in the latest ebuild(s)?

Clarification would be greatly appreciated.


#5

Where is my unstable Plasma 5.13? :wink:
I dont know if we will get it or not since is still on beta…but lots of people saying that the new version is really amazing and I wanted to try it out… :star_struck:

Other than that I have tried today to install two NEW VM’s using Oracle virtualbox with no success.
One VM was windows 10 and other was windows 7. The installation started but after rebooting for first time it was a mess , something went wrong and Windows VM was always restarting. However my existing VM’s are running more than fine.


#6

Not in Manjaro, but I think the Arch users can access 5.13 beta through the KDE-Unstable repo, if you absolutely cannot wait to try it out.

Not due for official stable release until June 12, so a couple of weeks away yet.

Ca sometimes take up to a week for major Plasma releases to progress from Arch Testing through to Manjaro Testing.

New major version of Qt just released also, 5.11, so there will be a lot to test.

No idea why you posted that in this thread though … :confused: