[Unstable Update] 2018-05-04 - Nvidia-390xx, MHWD, Firefox v61-b1

unstable
update

#1

Hi community,

welcome to another unstable update of Manjaro. Mostly we worked the past days on our toolchain. This includes the following changes:

The new version of glibc removes support for NIS and NIS+. The default /etc/nsswitch.conf file provided by filesystem package already reflects this change. Please make sure to merge pacnew file if it exists prior to upgrade.

NIS functionality can still be enabled by installing libnss_nis package. There is no replacement for NIS+ in the official repositories.

Additionally we updated pam. pam 1.3.0-2 no longer ships pam_unix2 module and pam_unix_*.so compatibility symlinks. Before upgrading, review PAM configuration files in the /etc/pam.d directory and replace removed modules with pam_unix.so. Users of pam_unix2 should also reset their passwords after such change. Defaults provided by pambase package do not need any modifications.

Check grep -rn 'pam_unix[2_]' /etc/pam.d, if no output, you need to do nothing.

Other changes are:

  • added Nvidia 390xx legacy drivers
  • added needed changes for nvidia-390xx to mhwd
  • latest Firefox Development Edition is now at v61-beta1
  • usual upstream updates

Our effort and all the needed information about the new security risk can be found here.

So please report back and give us feedback for given changes made to our repositories. Users of our 32-bit Distro should read this.


Current supported Kernels

  • linux316 3.16.56
  • linux318 3.18.108 [EOL]
  • linux41 4.1.51
  • linux44 4.4.131
  • linux49 4.9.98
  • linux414 4.14.39
  • linux415 4.15.18 [EOL]
  • linux416 4.16.7
  • linux417 4.17-rc3
  • linux-rt 4.14.34_rt27

Package Updates (Fri May 4 09:17:11 CEST 2018)

:: Different overlay package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-05-03           2018-05-04
-------------------------------------------------------------------------------
              manjaro-openbox-common           20180502-2              1.2.3-1
                             spotify         1.0.77.338-1         1.0.79.223-1
                        slack-online                    -                  1-1


:: Different sync package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-05-03           2018-05-04
-------------------------------------------------------------------------------
                    adapta-gtk-theme           3.93.1.1-1           3.93.1.7-1
                               bazel             0.12.0-1             0.13.0-1
                             busybox             1.28.2-1             1.28.3-1
                             calibre             3.22.1-1             3.23.0-1
                             certbot             0.23.0-1             0.24.0-1
                      certbot-apache             0.23.0-1             0.24.0-1
              certbot-dns-cloudflare             0.23.0-1             0.24.0-1
                certbot-dns-cloudxns             0.23.0-1             0.24.0-1
            certbot-dns-digitalocean             0.23.0-1             0.24.0-1
                certbot-dns-dnsimple             0.23.0-1             0.24.0-1
             certbot-dns-dnsmadeeasy             0.23.0-1             0.24.0-1
                  certbot-dns-google             0.23.0-1             0.24.0-1
                  certbot-dns-luadns             0.23.0-1             0.24.0-1
                   certbot-dns-nsone             0.23.0-1             0.24.0-1
                 certbot-dns-rfc2136             0.23.0-1             0.24.0-1
                 certbot-dns-route53             0.23.0-1             0.24.0-1
                       certbot-nginx             0.23.0-1             0.24.0-1
                                 coq              8.8.0-1              8.8.0-2
                             coq-doc              8.8.0-1              8.8.0-2
                              coqide              8.8.0-1              8.8.0-2
                               dillo              3.0.5-5              3.0.5-6
                      docker-compose             1.21.1-1             1.21.2-1
           firefox-developer-edition            60.0b15-1             61.0b1-1
  firefox-developer-edition-i18n-ach            60.0b15-1             61.0b1-1
   firefox-developer-edition-i18n-af            60.0b15-1             61.0b1-1
   firefox-developer-edition-i18n-an            60.0b15-1             61.0b1-1
   firefox-developer-edition-i18n-ar            60.0b15-1             61.0b1-1
   firefox-developer-edition-i18n-as            60.0b15-1             61.0b1-1
  firefox-developer-edition-i18n-ast            60.0b15-1             61.0b1-1
   firefox-developer-edition-i18n-az            60.0b15-1             61.0b1-1
   firefox-developer-edition-i18n-be            60.0b15-1             61.0b1-1
   firefox-developer-edition-i18n-bg            60.0b15-1             61.0b1-1
firefox-developer-edition-i18n-bn-bd            60.0b15-1             61.0b1-1
firefox-developer-edition-i18n-bn-in            60.0b15-1             61.0b1-1
   firefox-developer-edition-i18n-br            60.0b15-1             61.0b1-1
   firefox-developer-edition-i18n-bs            60.0b15-1             61.0b1-1
   firefox-developer-edition-i18n-ca            60.0b15-1             61.0b1-1
  firefox-developer-edition-i18n-cak            60.0b15-1             61.0b1-1
   firefox-developer-edition-i18n-cs            60.0b15-1             61.0b1-1
   firefox-developer-edition-i18n-cy            60.0b15-1             61.0b1-1
   firefox-developer-edition-i18n-da            60.0b15-1             61.0b1-1
   firefox-developer-edition-i18n-de            60.0b15-1             61.0b1-1
  firefox-developer-edition-i18n-dsb            60.0b15-1             61.0b1-1
   firefox-developer-edition-i18n-el            60.0b15-1             61.0b1-1
firefox-developer-edition-i18n-en-gb            60.0b15-1             61.0b1-1
firefox-developer-edition-i18n-en-us            60.0b15-1             61.0b1-1
firefox-developer-edition-i18n-en-za            60.0b15-1             61.0b1-1
   firefox-developer-edition-i18n-eo            60.0b15-1             61.0b1-1
firefox-developer-edition-i18n-es-ar            60.0b15-1             61.0b1-1
firefox-developer-edition-i18n-es-cl            60.0b15-1             61.0b1-1
firefox-developer-edition-i18n-es-es            60.0b15-1             61.0b1-1
firefox-developer-edition-i18n-es-mx            60.0b15-1             61.0b1-1
   firefox-developer-edition-i18n-et            60.0b15-1             61.0b1-1
   firefox-developer-edition-i18n-eu            60.0b15-1             61.0b1-1
   firefox-developer-edition-i18n-fa            60.0b15-1             61.0b1-1
   firefox-developer-edition-i18n-ff            60.0b15-1             61.0b1-1
   firefox-developer-edition-i18n-fi            60.0b15-1             61.0b1-1
   firefox-developer-edition-i18n-fr            60.0b15-1             61.0b1-1
firefox-developer-edition-i18n-fy-nl            60.0b15-1             61.0b1-1
firefox-developer-edition-i18n-ga-ie            60.0b15-1             61.0b1-1
   firefox-developer-edition-i18n-gd            60.0b15-1             61.0b1-1
   firefox-developer-edition-i18n-gl            60.0b15-1             61.0b1-1
   firefox-developer-edition-i18n-gn            60.0b15-1             61.0b1-1
firefox-developer-edition-i18n-gu-in            60.0b15-1             61.0b1-1
   firefox-developer-edition-i18n-he            60.0b15-1             61.0b1-1
firefox-developer-edition-i18n-hi-in            60.0b15-1             61.0b1-1
   firefox-developer-edition-i18n-hr            60.0b15-1             61.0b1-1
  firefox-developer-edition-i18n-hsb            60.0b15-1             61.0b1-1
   firefox-developer-edition-i18n-hu            60.0b15-1             61.0b1-1
firefox-developer-edition-i18n-hy-am            60.0b15-1             61.0b1-1
   firefox-developer-edition-i18n-ia            60.0b15-1             61.0b1-1
   firefox-developer-edition-i18n-id            60.0b15-1             61.0b1-1
   firefox-developer-edition-i18n-is            60.0b15-1             61.0b1-1
   firefox-developer-edition-i18n-it            60.0b15-1             61.0b1-1
   firefox-developer-edition-i18n-ja            60.0b15-1             61.0b1-1
   firefox-developer-edition-i18n-ka            60.0b15-1             61.0b1-1
  firefox-developer-edition-i18n-kab            60.0b15-1             61.0b1-1
   firefox-developer-edition-i18n-kk            60.0b15-1             61.0b1-1
   firefox-developer-edition-i18n-km            60.0b15-1             61.0b1-1
   firefox-developer-edition-i18n-kn            60.0b15-1             61.0b1-1
   firefox-developer-edition-i18n-ko            60.0b15-1             61.0b1-1
  firefox-developer-edition-i18n-lij            60.0b15-1             61.0b1-1
   firefox-developer-edition-i18n-lt            60.0b15-1             61.0b1-1
   firefox-developer-edition-i18n-lv            60.0b15-1             61.0b1-1
  firefox-developer-edition-i18n-mai            60.0b15-1             61.0b1-1
   firefox-developer-edition-i18n-mk            60.0b15-1             61.0b1-1
   firefox-developer-edition-i18n-ml            60.0b15-1             61.0b1-1
   firefox-developer-edition-i18n-mr            60.0b15-1             61.0b1-1
   firefox-developer-edition-i18n-ms            60.0b15-1             61.0b1-1
   firefox-developer-edition-i18n-my            60.0b15-1             61.0b1-1
firefox-developer-edition-i18n-nb-no            60.0b15-1             61.0b1-1
firefox-developer-edition-i18n-ne-np            60.0b15-1             61.0b1-1
   firefox-developer-edition-i18n-nl            60.0b15-1             61.0b1-1
firefox-developer-edition-i18n-nn-no            60.0b15-1             61.0b1-1
   firefox-developer-edition-i18n-or            60.0b15-1             61.0b1-1
firefox-developer-edition-i18n-pa-in            60.0b15-1             61.0b1-1
   firefox-developer-edition-i18n-pl            60.0b15-1             61.0b1-1
firefox-developer-edition-i18n-pt-br            60.0b15-1             61.0b1-1
firefox-developer-edition-i18n-pt-pt            60.0b15-1             61.0b1-1
   firefox-developer-edition-i18n-rm            60.0b15-1             61.0b1-1
   firefox-developer-edition-i18n-ro            60.0b15-1             61.0b1-1
   firefox-developer-edition-i18n-ru            60.0b15-1             61.0b1-1
   firefox-developer-edition-i18n-si            60.0b15-1             61.0b1-1
   firefox-developer-edition-i18n-sk            60.0b15-1             61.0b1-1
   firefox-developer-edition-i18n-sl            60.0b15-1             61.0b1-1
  firefox-developer-edition-i18n-son            60.0b15-1             61.0b1-1
   firefox-developer-edition-i18n-sq            60.0b15-1             61.0b1-1
   firefox-developer-edition-i18n-sr            60.0b15-1             61.0b1-1
firefox-developer-edition-i18n-sv-se            60.0b15-1             61.0b1-1
   firefox-developer-edition-i18n-ta            60.0b15-1             61.0b1-1
   firefox-developer-edition-i18n-te            60.0b15-1             61.0b1-1
   firefox-developer-edition-i18n-th            60.0b15-1             61.0b1-1
   firefox-developer-edition-i18n-tr            60.0b15-1             61.0b1-1
   firefox-developer-edition-i18n-uk            60.0b15-1             61.0b1-1
   firefox-developer-edition-i18n-ur            60.0b15-1             61.0b1-1
   firefox-developer-edition-i18n-uz            60.0b15-1             61.0b1-1
   firefox-developer-edition-i18n-vi            60.0b15-1             61.0b1-1
   firefox-developer-edition-i18n-xh            60.0b15-1             61.0b1-1
firefox-developer-edition-i18n-zh-cn            60.0b15-1             61.0b1-1
firefox-developer-edition-i18n-zh-tw            60.0b15-1             61.0b1-1
     firefox-extension-privacybadger          2018.4.10-2          2018.4.23-2
                       gitlab-gitaly             0.97.0-2             0.98.0-1
                                gtop              0.1.4-1              0.1.5-1
                   libringclient 2:20180425.2.4d29110-1 2:20180501.1.3b176a6-1
                            lollypop            0.9.507-1            0.9.507-2
                                 lxc            1:3.0.0-1            1:3.0.0-2
                             psensor              1.2.0-3              1.2.0-4
                         python-acme             0.23.0-1             0.24.0-1
                        python-flask              1.0.1-1              1.0.2-1
                    python-monotonic                1.4-1                1.5-1
             python-ovirt-engine-sdk              4.2.5-1              4.2.6-1
                        python-prctl              1.6.1-1                1.7-1
               python-pytest-twisted              1.7.1-1                1.8-1
                       python-qrcode                5.3-3                6.0-1
                        python2-acme             0.23.0-1             0.24.0-1
                       python2-flask              1.0.1-1              1.0.2-1
                   python2-monotonic                1.4-1                1.5-1
            python2-ovirt-engine-sdk              4.2.5-1              4.2.6-1
                       python2-prctl              1.6.1-1                1.7-1
              python2-pytest-twisted              1.7.1-1                1.8-1
                      python2-qrcode                5.3-3                6.0-1
                              recoll             1.23.7-1             1.23.8-1
                     ring-daemon 2:20180425.2.4d29110-1 2:20180501.1.3b176a6-1
                      ring-gnome 3:20180425.2.4d29110-1 3:20180501.1.3b176a6-1
                        rxvt-unicode               9.22-5               9.22-6
               rxvt-unicode-terminfo               9.22-5               9.22-6
                             unbound              1.7.0-1              1.7.1-1
                             zathura              0.3.9-1              0.3.9-2
                     deepin-anything                    -              0.0.1-1
                                llpp                    -                 27-1
                        ocaml-lablgl                    -               1.05-6


:: Different overlay package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-05-03           2018-05-04
-------------------------------------------------------------------------------
                                mhwd              0.6.2-5              0.6.3-1
                             mhwd-db              0.6.2-4              0.6.3-1
                   mhwd-nvidia-390xx                    -           390.48-1.1


:: Different sync package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-05-03           2018-05-04
-------------------------------------------------------------------------------
                                crda               3.18-1               4.14-1
                              dhcpcd              7.0.1-1              7.0.4-1
                                file               5.32-1               5.33-1
                              libaio            0.3.110-1            0.3.111-1
                              libidn               1.33-2               1.34-2


:: Different overlay package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-05-03           2018-05-04
-------------------------------------------------------------------------------
                   manjaro-tools-iso             0.15.7-3             0.15.7-4
               linux316-nvidia-390xx                    -             390.48-1
               linux318-nvidia-390xx                    -             390.48-1
                linux41-nvidia-390xx                    -             390.48-1
               linux414-nvidia-390xx                    -             390.48-1
               linux415-nvidia-390xx                    -             390.48-1
               linux416-nvidia-390xx                    -             390.48-1
               linux417-nvidia-390xx                    -           390.48-0.1
                linux44-nvidia-390xx                    -             390.48-1
                linux49-nvidia-390xx                    -             390.48-1
                  nvidia-390xx-utils                    -             390.48-1
                 opencl-nvidia-390xx                    -             390.48-1


:: Different sync package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-05-03           2018-05-04
-------------------------------------------------------------------------------
                             flatpak             0.11.6-1             0.11.7-1
                      graphicsmagick             1.3.28-2             1.3.29-1
                         kwallet-pam             5.12.5-1             5.12.5-2
                              libraw             0.18.9-1            0.18.10-1
                         libwbclient              4.8.0-2              4.8.1-1
            perl-file-copy-recursive               0.40-1               0.44-1
                       python-django            1.11.11-1            1.11.13-1
                        python-numpy             1.14.2-1             1.14.3-1
                      python2-django            1.11.11-1            1.11.13-1
                       python2-numpy             1.14.2-1             1.14.3-1
                           qtcreator              4.6.0-1              4.6.1-1
                               samba              4.8.0-2              4.8.1-1
                           smbclient              4.8.0-2              4.8.1-1
                         terminology              1.1.1-1              1.2.0-1


:: Different overlay package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-05-03           2018-05-04
-------------------------------------------------------------------------------
            lib32-nvidia-390xx-utils                    -             390.48-1
           lib32-opencl-nvidia-390xx                    -             390.48-1


  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


#2

This is a wiki post; please edit as necessary.


Nvidia drivers and Fermi support

With the current Nvidia driver release v396.24 support for the old Fermi cards got dropped. Please switch either over to Nouveau driver or downgrade to v390xx driver series.

Bumblebee users follow:

sudo mhwd -r pci video-hybrid-intel-nvidia-bumblebee
sudo mhwd -i pci video-hybrid-intel-nvidia-390xx-bumblebee

#3

video-hybrid-intel-nvidia-390xx-bumblebee works fine for me, after this change:

  • Added blacklist nvidia-drm to /etc/modprobe.d/mhwd-nvidia
  • Created bbswitch.conf in /etc/modules-load.d/, containing bbswitch* -> not needed when using bumblebeed

I also run mkinitcpio for my kernels.
*I know bumblebeed is supposed to handle this, but if i didn’t have that file there, I got dmesg that ‘GPU fallen of the bus’ or something along those lines. I don’t know, maybe
it was nvidia-drm causing it

Works fine now, thanks team! I suggest nvidia-drm is added to the mhwd generated blacklist


#4

Full list

blacklist nouveau
blacklist nvidia
blacklist nvidia-drm
blacklist nvidia-modeset
blacklist nvidia-uvm
blacklist nvidiafb
blacklist rivafb
blacklist ttm

bbswitch is called automatically. You need only blacklist modules listed above.

In dmesg should be clean like this:

[    4.437032] bbswitch: version 0.8
[    4.437061] bbswitch: Found integrated VGA device 0000:00:02.0: \_SB_.PCI0.GFX0
[    4.437067] bbswitch: Found discrete VGA device 0000:01:00.0: \_SB_.PCI0.PEG0.PEGP
[    4.437078] ACPI Warning: \_SB.PCI0.PEG0.PEGP._DSM: Argument #4 type mismatch - Found [Buffer], ACPI requires [Package] (20180313/nsarguments-66)
[    4.437557] bbswitch: detected an Optimus _DSM function
[    4.437569] pci 0000:01:00.0: enabling device (0000 -> 0003)
[    4.437720] bbswitch: disabling discrete graphics
[    4.546871] bbswitch: Succesfully loaded. Discrete card 0000:01:00.0 is off

#5

The 390xx nvidia driver is working normally in my system, but I haven’t a fancy configuration :roll_eyes: thanks team!


#6

I have not been able to update since this error came yesterday evening:


#7

#8

Thanks for the tip…so I could solve that partial update yesterday and I 've done a new partial update some mins ago…but the only package update missing is FFox v61-b1… I am still using FFox 59 and my local mirror is correctly updated since yesterday. I guess I will have to keep waiting a couple of days and see if this missing update comes or the second choice could be : remove my actual FFox and the folder with my settings and re install FFox from unstable repos again.
Just adding, I removed FF 59 completely and then installed FF 61 developer edition + FFox dev-edition-pack es_es and language package did not work for my language ?


#9

Firefox 59 is the current stable version. Firefox 60 is supposed to be coming out on the 9th. Firefox 61 is the beta developer’s version (which is what is announced in this update).