[Unstable Update] 2018-04-25 - Kernels, PAM, GLIBC, GCC, PHP, Firefox, Gnome-Settings

unstable
update

#1

Hi community,

welcome to another unstable update of Manjaro. Mostly we worked on our toolchain. This includes the following changes:

The new version of glibc removes support for NIS and NIS+. The default /etc/nsswitch.conf file provided by filesystem package already reflects this change. Please make sure to merge pacnew file if it exists prior to upgrade.

NIS functionality can still be enabled by installing libnss_nis package. There is no replacement for NIS+ in the official repositories.

Additionally we updated pam. pam 1.3.0-2 no longer ships pam_unix2 module and pam_unix_*.so compatibility symlinks. Before upgrading, review PAM configuration files in the /etc/pam.d directory and replace removed modules with pam_unix.so. Users of pam_unix2 should also reset their passwords after such change. Defaults provided by pambase package do not need any modifications.

Other changes are:

  • updated kernels
  • latest firefox development edition
  • latest php
  • adjustments to our gnome-settings
  • usual rebuilds

Our effort and all the needed information about the new security risk can be found here.

So please report back and give us feedback for given changes made to our repositories. Users of our 32-bit Distro should read this.


Current supported Kernels

  • linux316 3.16.56
  • linux318 3.18.106 [EOL]
  • linux41 4.1.51
  • linux44 4.4.129
  • linux49 4.9.96
  • linux414 4.14.36
  • linux415 4.15.18 [EOL]
  • linux416 4.16.4
  • linux417 4.17-rc2
  • linux-rt 4.14.34_rt27

Package Updates (Wed Apr 25 08:05:38 CEST 2018)

:: Different overlay package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-04-24           2018-04-25
-------------------------------------------------------------------------------
           adapta-black-breath-theme         3.93.0.268-1         3.93.0.280-1
             adapta-black-maia-theme         3.93.0.268-1         3.93.0.280-1
                 adapta-breath-theme         3.93.0.268-1         3.93.0.280-1
                   adapta-maia-theme         3.93.0.268-1         3.93.0.280-1
                            cinnamon            3.8.0-1.2            3.8.0-1.4
                                 cjs              3.8.0-0                    -
                  linux414-rt-nvidia           1:390.48-2           1:396.18-2
                    vertex-maia-gtk3           20180424-2           20180424-3
                  vertex-maia-themes           20180424-3           20180424-4
                       vertex-themes           20180424-2           20180424-3
                manjaro-gnome-assets                    -           20180424-1
manjaro-gnome-extension-settings-17.0                   -           20180424-1
         manjaro-gnome-settings-17.0                    -           20180424-1


:: Different sync package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-04-24           2018-04-25
-------------------------------------------------------------------------------
                                 apm             1.19.0-2             1.19.0-4
                             autossh               1.4e-1               1.4e-2
                           bettercap                2.4-1                2.5-1
                               boinc              7.8.4-1              7.8.4-3
                           boinc-nox              7.8.4-1              7.8.4-3
                             cadence              0.9.0-1              0.9.0-2
                            cinnamon              3.6.7-3              3.8.0-1
                                 cjs              3.6.1-1              3.8.0-1
                            collectd              5.8.0-4              5.8.0-5
                          containerd              1.0.3-1              1.1.0-1
                           darktable            2:2.4.2-1            2:2.4.3-1
                       deepin-daemon           3.2.13.3-1           3.2.13.4-1
                               eolie             0.9.28-1             0.9.29-1
                                exim             4.90.1-1             4.90.1-2
                        feedreader 2.0.2+548+g08dfb5db-1 2.0.2+559+g78d7ced8-1
           firefox-developer-edition            60.0b14-1            60.0b15-1
  firefox-developer-edition-i18n-ach            60.0b14-1            60.0b15-1
   firefox-developer-edition-i18n-af            60.0b14-1            60.0b15-1
   firefox-developer-edition-i18n-an            60.0b14-1            60.0b15-1
   firefox-developer-edition-i18n-ar            60.0b14-1            60.0b15-1
   firefox-developer-edition-i18n-as            60.0b14-1            60.0b15-1
  firefox-developer-edition-i18n-ast            60.0b14-1            60.0b15-1
   firefox-developer-edition-i18n-az            60.0b14-1            60.0b15-1
   firefox-developer-edition-i18n-be            60.0b14-1            60.0b15-1
   firefox-developer-edition-i18n-bg            60.0b14-1            60.0b15-1
firefox-developer-edition-i18n-bn-bd            60.0b14-1            60.0b15-1
firefox-developer-edition-i18n-bn-in            60.0b14-1            60.0b15-1
   firefox-developer-edition-i18n-br            60.0b14-1            60.0b15-1
   firefox-developer-edition-i18n-bs            60.0b14-1            60.0b15-1
   firefox-developer-edition-i18n-ca            60.0b14-1            60.0b15-1
  firefox-developer-edition-i18n-cak            60.0b14-1            60.0b15-1
   firefox-developer-edition-i18n-cs            60.0b14-1            60.0b15-1
   firefox-developer-edition-i18n-cy            60.0b14-1            60.0b15-1
   firefox-developer-edition-i18n-da            60.0b14-1            60.0b15-1
   firefox-developer-edition-i18n-de            60.0b14-1            60.0b15-1
  firefox-developer-edition-i18n-dsb            60.0b14-1            60.0b15-1
   firefox-developer-edition-i18n-el            60.0b14-1            60.0b15-1
firefox-developer-edition-i18n-en-gb            60.0b14-1            60.0b15-1
firefox-developer-edition-i18n-en-us            60.0b14-1            60.0b15-1
firefox-developer-edition-i18n-en-za            60.0b14-1            60.0b15-1
   firefox-developer-edition-i18n-eo            60.0b14-1            60.0b15-1
firefox-developer-edition-i18n-es-ar            60.0b14-1            60.0b15-1
firefox-developer-edition-i18n-es-cl            60.0b14-1            60.0b15-1
firefox-developer-edition-i18n-es-es            60.0b14-1            60.0b15-1
firefox-developer-edition-i18n-es-mx            60.0b14-1            60.0b15-1
   firefox-developer-edition-i18n-et            60.0b14-1            60.0b15-1
   firefox-developer-edition-i18n-eu            60.0b14-1            60.0b15-1
   firefox-developer-edition-i18n-fa            60.0b14-1            60.0b15-1
   firefox-developer-edition-i18n-ff            60.0b14-1            60.0b15-1
   firefox-developer-edition-i18n-fi            60.0b14-1            60.0b15-1
   firefox-developer-edition-i18n-fr            60.0b14-1            60.0b15-1
firefox-developer-edition-i18n-fy-nl            60.0b14-1            60.0b15-1
firefox-developer-edition-i18n-ga-ie            60.0b14-1            60.0b15-1
   firefox-developer-edition-i18n-gd            60.0b14-1            60.0b15-1
   firefox-developer-edition-i18n-gl            60.0b14-1            60.0b15-1
   firefox-developer-edition-i18n-gn            60.0b14-1            60.0b15-1
firefox-developer-edition-i18n-gu-in            60.0b14-1            60.0b15-1
   firefox-developer-edition-i18n-he            60.0b14-1            60.0b15-1
firefox-developer-edition-i18n-hi-in            60.0b14-1            60.0b15-1
   firefox-developer-edition-i18n-hr            60.0b14-1            60.0b15-1
  firefox-developer-edition-i18n-hsb            60.0b14-1            60.0b15-1
   firefox-developer-edition-i18n-hu            60.0b14-1            60.0b15-1
firefox-developer-edition-i18n-hy-am            60.0b14-1            60.0b15-1
   firefox-developer-edition-i18n-ia            60.0b14-1            60.0b15-1
   firefox-developer-edition-i18n-id            60.0b14-1            60.0b15-1
   firefox-developer-edition-i18n-is            60.0b14-1            60.0b15-1
   firefox-developer-edition-i18n-it            60.0b14-1            60.0b15-1
   firefox-developer-edition-i18n-ja            60.0b14-1            60.0b15-1
   firefox-developer-edition-i18n-ka            60.0b14-1            60.0b15-1
  firefox-developer-edition-i18n-kab            60.0b14-1            60.0b15-1
   firefox-developer-edition-i18n-kk            60.0b14-1            60.0b15-1
   firefox-developer-edition-i18n-km            60.0b14-1            60.0b15-1
   firefox-developer-edition-i18n-kn            60.0b14-1            60.0b15-1
   firefox-developer-edition-i18n-ko            60.0b14-1            60.0b15-1
  firefox-developer-edition-i18n-lij            60.0b14-1            60.0b15-1
   firefox-developer-edition-i18n-lt            60.0b14-1            60.0b15-1
   firefox-developer-edition-i18n-lv            60.0b14-1            60.0b15-1
  firefox-developer-edition-i18n-mai            60.0b14-1            60.0b15-1
   firefox-developer-edition-i18n-mk            60.0b14-1            60.0b15-1
   firefox-developer-edition-i18n-ml            60.0b14-1            60.0b15-1
   firefox-developer-edition-i18n-mr            60.0b14-1            60.0b15-1
   firefox-developer-edition-i18n-ms            60.0b14-1            60.0b15-1
   firefox-developer-edition-i18n-my            60.0b14-1            60.0b15-1
firefox-developer-edition-i18n-nb-no            60.0b14-1            60.0b15-1
firefox-developer-edition-i18n-ne-np            60.0b14-1            60.0b15-1
   firefox-developer-edition-i18n-nl            60.0b14-1            60.0b15-1
firefox-developer-edition-i18n-nn-no            60.0b14-1            60.0b15-1
   firefox-developer-edition-i18n-or            60.0b14-1            60.0b15-1
firefox-developer-edition-i18n-pa-in            60.0b14-1            60.0b15-1
   firefox-developer-edition-i18n-pl            60.0b14-1            60.0b15-1
firefox-developer-edition-i18n-pt-br            60.0b14-1            60.0b15-1
firefox-developer-edition-i18n-pt-pt            60.0b14-1            60.0b15-1
   firefox-developer-edition-i18n-rm            60.0b14-1            60.0b15-1
   firefox-developer-edition-i18n-ro            60.0b14-1            60.0b15-1
   firefox-developer-edition-i18n-ru            60.0b14-1            60.0b15-1
   firefox-developer-edition-i18n-si            60.0b14-1            60.0b15-1
   firefox-developer-edition-i18n-sk            60.0b14-1            60.0b15-1
   firefox-developer-edition-i18n-sl            60.0b14-1            60.0b15-1
  firefox-developer-edition-i18n-son            60.0b14-1            60.0b15-1
   firefox-developer-edition-i18n-sq            60.0b14-1            60.0b15-1
   firefox-developer-edition-i18n-sr            60.0b14-1            60.0b15-1
firefox-developer-edition-i18n-sv-se            60.0b14-1            60.0b15-1
   firefox-developer-edition-i18n-ta            60.0b14-1            60.0b15-1
   firefox-developer-edition-i18n-te            60.0b14-1            60.0b15-1
   firefox-developer-edition-i18n-th            60.0b14-1            60.0b15-1
   firefox-developer-edition-i18n-tr            60.0b14-1            60.0b15-1
   firefox-developer-edition-i18n-uk            60.0b14-1            60.0b15-1
   firefox-developer-edition-i18n-ur            60.0b14-1            60.0b15-1
   firefox-developer-edition-i18n-uz            60.0b14-1            60.0b15-1
   firefox-developer-edition-i18n-vi            60.0b14-1            60.0b15-1
   firefox-developer-edition-i18n-xh            60.0b14-1            60.0b15-1
firefox-developer-edition-i18n-zh-cn            60.0b14-1            60.0b15-1
firefox-developer-edition-i18n-zh-tw            60.0b14-1            60.0b15-1
                              gnokii            0.6.31-15            0.6.31-16
                             gnu-apl                1.7-4                1.7-5
                            hercules            3.13.00-1            3.13.00-3
                             jenkins              2.117-1              2.118-1
                              kstars            1:2.9.4-4            1:2.9.5-1
                               libfm              1.2.5-2              1.3.0-1
                         libfm-extra              1.2.5-2              1.3.0-1
                          libfm-gtk2              1.2.5-2              1.3.0-1
                          libfm-gtk3              1.2.5-2              1.3.0-1
                             libnids               1.24-3               1.24-4
                             libspf2             1.2.10-3             1.2.10-4
                             libwrap             7.6.24-3             7.6.24-4
                             lockdev          1.0.3_1.6-4          1.0.3_1.6-5
                             log4cpp              1.1.1-2              1.1.3-1
                          metasploit            4.16.50-1            4.16.51-1
                               minio         2018.04.19-2         2018.04.19-3
                           miniupnpd       2.0.20180412-1       2.0.20180422-1
                       mod_passenger              5.2.2-1              5.2.3-3
                               navit              0.5.0-2              0.5.1-1
                            neofetch              3.4.0-1              3.4.0-2
                  nginx-mod-auth-pam              1.5.1-3              1.5.1-4
                    nginx-mod-brotli             1.12.2-3            1:0.1.1-1
                      nginx-mod-echo               0.61-2               0.61-3
                    nginx-mod-geoip2                2.0-3                2.0-4
              nginx-mod-headers-more               0.33-1               0.33-2
                      nginx-mod-memc               0.18-3               0.18-4
               nginx-mod-modsecurity            1:1.0.0-1            1:1.0.0-2
                     nginx-mod-naxsi             0.55.3-3             0.55.3-4
                       nginx-mod-ndk         0.31+0.3.0-3         0.32+0.3.0-1
                       nginx-mod-njs             0.1.12-2              0.2.0-1
                 nginx-mod-pagespeed          1.13.35.2-1          1.13.35.2-2
                 nginx-mod-passenger              5.2.2-1              5.2.3-3
                     nginx-mod-redis              0.3.8-3              0.3.8-4
                    nginx-mod-redis2               0.14-3               0.14-4
                  nginx-mod-set-misc         0.31+0.3.0-3         0.32+0.3.0-1
                   nginx-mod-srcache               0.31-3               0.31-4
                           notepadqq              1.2.0-2              1.3.6-1
                   npm-check-updates             2.14.1-1             2.14.2-1
                           passenger              5.2.2-1              5.2.3-3
                             pcmanfm              1.2.5-2              1.3.0-1
                        pcmanfm-gtk3              1.2.5-2              1.3.0-1
              python-async_generator                1.8-1                1.9-1
                  python-oslo-config              6.1.0-1              6.2.0-1
                      python-oslo-db             4.36.0-1             4.37.0-1
                   python-oslo-utils             3.36.0-1             3.36.1-1
                        python-pypdf               1.13-4                    -
                       python-pytest              3.5.0-1              3.5.1-1
                python2-faulthandler                3.0-1                3.1-1
                 python2-oslo-config              6.1.0-1              6.2.0-1
                     python2-oslo-db             4.36.0-1             4.37.0-1
                  python2-oslo-utils             3.36.0-1             3.36.1-1
                    python2-pyassert              0.4.2-3                    -
                   python2-pybuilder            0.11.10-1                    -
                       python2-pyfix              0.2.3-3                    -
                       python2-pypdf               1.13-4               1.13-5
                      python2-pytest              3.5.0-1              3.5.1-1
                            radicale              2.1.9-1              2.1.9-2
                           ruby-rack              2.0.4-1              2.0.5-1
                            smplayer             18.3.0-1             18.4.0-1
                               squid             3.5.27-2             3.5.27-3
                             stunnel               5.44-2               5.44-3
                         sweethome3d                5.7-1                5.7-2
                            sylpheed              3.7.0-1              3.7.0-2
                        tcp-wrappers             7.6.24-3             7.6.24-4
                          unrealircd             4.0.17-2             4.0.17-3
                               v2ray               3.20-1               3.21-1
                       vim-gitgutter        491.3724e1c-1        493.ad25925-1
                              vsftpd              3.0.3-3              3.0.3-4
                       wireshark-cli              2.5.1-1              2.6.0-1
                    wireshark-common              2.5.1-1              2.6.0-1
                       wireshark-gtk              2.5.1-1              2.6.0-1
                        wireshark-qt              2.5.1-1              2.6.0-1
                                 yrd              0.5.2-1              0.5.3-1
             yubikey-personalization             1.18.1-2             1.19.0-1
                             gpodder                    -             3.10.1-1
                               kitty                    -              0.9.0-1
               kvantum-theme-materia                    -           20180424-1
                         materia-kde                    -           20180424-1
                  python-mygpoclient                    -                1.8-1
                python-podcastparser                    -              0.6.3-1
                    python2-gtkglext                    -              1.1.0-8
                 python2-mygpoclient                    -                1.8-1
               python2-podcastparser                    -              0.6.3-1


:: Different overlay package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-04-24           2018-04-25
-------------------------------------------------------------------------------
                          filesystem          2017.06-4.5             2018.1-2
                         mhwd-nvidia           1:390.48-1           1:396.18-1


:: Different sync package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-04-24           2018-04-25
-------------------------------------------------------------------------------
                            binutils             2.29.1-3               2.30-3
                                 gcc     7.3.1+20180312-2     7.3.1+20180406-1
                             gcc-ada     7.3.1+20180312-2     7.3.1+20180406-1
                         gcc-fortran     7.3.1+20180312-2     7.3.1+20180406-1
                              gcc-go     7.3.1+20180312-2     7.3.1+20180406-1
                            gcc-libs     7.3.1+20180312-2     7.3.1+20180406-1
                            gcc-objc     7.3.1+20180312-2     7.3.1+20180406-1
                               glibc              2.26-11               2.27-2
                      lib32-gcc-libs     7.3.1+20180312-2     7.3.1+20180406-1
                         lib32-glibc              2.26-11               2.27-2
                   linux-api-headers             4.14.8-1             4.16.1-1
                                 pam              1.3.0-1              1.3.0-2
                            pinentry              1.1.0-1              1.1.0-2
             thin-provisioning-tools              0.7.5-1              0.7.6-1
                              libnsl                    -              1.2.0-1


:: Different overlay package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-04-24           2018-04-25
-------------------------------------------------------------------------------
                     linux316-nvidia           1:390.48-1           1:396.18-1
                     linux318-nvidia           1:390.48-3           1:396.18-2
                      linux41-nvidia           1:390.48-2           1:396.18-1
                     linux414-nvidia           1:390.48-6           1:396.18-4
                     linux415-nvidia           1:390.48-5           1:396.18-3
                     linux416-nvidia           1:390.48-3           1:396.18-3
                     linux417-nvidia         1:390.48-0.8         1:396.18-0.8
                      linux44-nvidia           1:390.48-3           1:396.18-2
                      linux49-nvidia           1:390.48-5           1:396.18-4
                        nvidia-utils           1:390.48-1           1:396.18-2
                       opencl-nvidia           1:390.48-1           1:396.18-1


:: Different sync package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-04-24           2018-04-25
-------------------------------------------------------------------------------
                     accountsservice             0.6.46-1             0.6.47-1
            archlinux-appstream-data           20180318-1           20180424-1
                              bigloo               4.3a-1               4.3a-3
                              falkon              3.0.0-1              3.0.0-2
                                fcgi             2.4.0-13             2.4.0-14
                               finch             2.13.0-1             2.13.0-2
                                gnet              2.0.8-4              2.0.8-5
                            graphviz            2.40.1-10            2.40.1-11
                                kwin             5.12.4-1             5.12.4-2
                          libetonyek              0.1.7-1              0.1.8-1
                           libpurple             2.13.0-1             2.13.0-2
                              libraw             0.18.8-2             0.18.9-1
                               libuv             1.20.0-1             1.20.1-1
                        libvncserver             0.9.11-2             0.9.11-3
                         libwbclient              4.7.6-1              4.8.0-2
                            net-snmp              5.7.3-7              5.7.3-8
                               nginx             1.12.2-2             1.14.0-1
                                nmap               7.70-1               7.70-2
                            perl-uri               1.73-1               1.74-1
                                 php              7.2.4-1              7.2.5-1
                          php-apache              7.2.4-1              7.2.5-1
                             php-cgi              7.2.4-1              7.2.5-1
                           php-dblib              7.2.4-1              7.2.5-1
                           php-embed              7.2.4-1              7.2.5-1
                         php-enchant              7.2.4-1              7.2.5-1
                             php-fpm              7.2.4-1              7.2.5-1
                              php-gd              7.2.4-1              7.2.5-1
                            php-imap              7.2.4-1              7.2.5-1
                            php-intl              7.2.4-1              7.2.5-1
                            php-odbc              7.2.4-1              7.2.5-1
                           php-pgsql              7.2.4-1              7.2.5-1
                          php-phpdbg              7.2.4-1              7.2.5-1
                          php-pspell              7.2.4-1              7.2.5-1
                            php-snmp              7.2.4-1              7.2.5-1
                          php-sodium              7.2.4-1              7.2.5-1
                          php-sqlite              7.2.4-1              7.2.5-1
                            php-tidy              7.2.4-1              7.2.5-1
                             php-xsl              7.2.4-1              7.2.5-1
                              pidgin             2.13.0-1             2.13.0-2
                             postfix              3.3.0-2              3.3.0-3
                              python              3.6.5-1              3.6.5-2
                             python2             2.7.14-2             2.7.14-3
                               samba              4.7.6-1              4.8.0-2
                           smbclient              4.7.6-1              4.8.0-2
                         suitesparse              5.1.0-1              5.2.0-1
                           syslog-ng             3.14.1-1             3.14.1-2
                            valgrind             3.13.0-6             3.13.0-7
                             varnish              5.2.1-2              5.2.1-3
                  xdg-desktop-portal               0.10-1               0.11-1
              xdg-desktop-portal-gtk               0.10-1               0.11-1
                            xerces-c              3.2.1-1              3.2.1-2
                            xine-lib              1.2.9-3              1.2.9-5
                    xkeyboard-config             2.23.1-2             2.23.1-3
                          libnss_nis                    -                3.0-1
                        rpcsvc-proto                    -              1.3.1-1


:: Different overlay package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-04-24           2018-04-25
-------------------------------------------------------------------------------
                  lib32-nvidia-utils           1:390.48-1           1:396.18-1
                 lib32-opencl-nvidia           1:390.48-1           1:396.18-1


:: Different sync package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2018-04-24           2018-04-25
-------------------------------------------------------------------------------
                       lib32-libldap             2.4.45-1             2.4.46-1
                       lib32-libwrap             7.6.24-2             7.6.24-3
                           lib32-nss               3.36-1             3.36.1-1
                           lib32-pam              1.3.0-1              1.3.0-2
                        lib32-libnsl                    -              1.2.0-1


  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:


#2

This is a wiki post; please edit as necessary.


Nautilus - Middle click on any location in other-locations:/// closes tab



#3

Just noticed this, but i will look at them in a few hours to see the difference.

warning: /etc/locale.conf saved as /etc/locale.conf.pacsave
warning: /etc/hostname saved as /etc/hostname.pacsave
(2/37) upgrading filesystem
warning: /etc/passwd installed as /etc/passwd.pacnew
warning: /etc/gshadow installed as /etc/gshadow.pacnew
warning: /etc/fstab installed as /etc/fstab.pacnew
warning: /etc/resolv.conf installed as /etc/resolv.conf.pacnew
warning: /etc/shells installed as /etc/shells.pacnew
warning: /etc/shadow installed as /etc/shadow.pacnew
warning: /etc/crypttab installed as /etc/crypttab.pacnew
warning: /etc/hosts installed as /etc/hosts.pacnew
warning: /etc/group installed as /etc/group.pacnew
(3/37) upgrading glibc
warning: /etc/locale.gen installed as /etc/locale.gen.pacnew

This was the case on KDE install, not in the Gnome install.
On Gnome i only had to install manjaro-gnome-extension-settings-v17 and manjaro-gnome-assets as mentioned here:

After reboot all seems to be ok.


#4

Had to add:

export LANG="en_US.UTF-8"

To the top of my zsh config.

Cinnamon desklets are broken as usual by a version change to 3.8, even the ones that launch cannot launch their configuration dialogs.

Cinnamon itself seems a little flaky - had it go into safe mode twice.

But other than that no problems.

:edit:

All of my locale settings in manjaro-settings-manager had cleared, have reset.


#5

error: failed to prepare transaction (could not satisfy dependencies)
:: manjaro-gnome-settings: removing manjaro-gnome-extension-settings breaks dependency ‘manjaro-gnome-extension-settings’


#6

Wondering about something…
does the pacsave files should not be replaced by a new config file? why to save config files and finish with no config files at all :thinking: (vconsole, locale and hostname)


#7

I had the same Problem.

Specially the “remove” of locale.conf and hostname is a problem.


#8

Went fine:

cd /etc
sudo mv locale.conf.pacsave locale.conf
sudo mv locale.gen.pacnew locale.gen
sudo mv vconsole.conf.pacsave vconsole.conf
cd /etc/modules-load.d
sudo mv modules.conf.pacsave modules.conf

Launch MSM and re-add English and Polish language (for example) :wink:

One question, should I just delete all lines from files in /etc/pam.d with pam_unix.so:

[fademind@manjaro ~]$ cat /etc/pam.d/*   
#%PAM-1.0
auth            sufficient      pam_rootok.so
auth            required        pam_unix.so
account         required        pam_unix.so
session         required        pam_unix.so
password        required        pam_permit.so
#%PAM-1.0
auth            sufficient      pam_rootok.so
auth            required        pam_unix.so
account         required        pam_unix.so
session         required        pam_unix.so
password        required        pam_permit.so
#%PAM-1.0
auth            sufficient      pam_rootok.so
account         required        pam_permit.so
password        include         system-auth
#%PAM-1.0
auth            sufficient      pam_rootok.so
auth            required        pam_unix.so
account         required        pam_unix.so
session         required        pam_unix.so
password        required        pam_unix.so sha512 shadow
#%PAM-1.0
auth            sufficient      pam_rootok.so
auth            required        pam_unix.so
account         required        pam_unix.so
session         required        pam_unix.so
password        required        pam_permit.so
auth      required    pam_unix.so
auth      required    pam_env.so

account   required    pam_access.so
account   required    pam_unix.so
account   required    pam_time.so

session    required   pam_loginuid.so
session   required    pam_limits.so
session   required    pam_unix.so
auth            required        pam_unix.so
account         required        pam_unix.so
session         required        pam_unix.so
#%PAM-1.0
auth            sufficient      pam_rootok.so
auth            required        pam_unix.so
account         required        pam_unix.so
session         required        pam_unix.so
password        required        pam_permit.so
#%PAM-1.0
auth            sufficient      pam_rootok.so
auth            required        pam_unix.so
account         required        pam_unix.so
session         required        pam_unix.so
password        required        pam_permit.so
#%PAM-1.0
auth            sufficient      pam_rootok.so
account         required        pam_permit.so
password        include         system-auth
#%PAM-1.0
auth            sufficient      pam_rootok.so
auth            required        pam_unix.so
account         required        pam_unix.so
session         required        pam_unix.so
password        required        pam_permit.so
#%PAM-1.0

auth            include         system-login

account         include         system-login

password        include         system-login

session         include         system-login

session         optional        pam_gnome_keyring.so auto_start
#%PAM-1.0

auth       required     pam_securetty.so
auth       requisite    pam_nologin.so
auth       include      system-local-login
account    include      system-local-login
session    include      system-local-login
session    optional     pam_gnome_keyring.so        auto_start
#%PAM-1.0
auth            sufficient      pam_rootok.so
auth            required        pam_unix.so
account         required        pam_unix.so
session         required        pam_unix.so
password        required        pam_unix.so sha512 shadow
#%PAM-1.0
auth            required        pam_unix.so
account         required        pam_unix.so
password        required        pam_unix.so
session         required        pam_unix.so
#%PAM-1.0
#password       required        pam_cracklib.so difok=2 minlen=8 dcredit=2 ocredit=2 retry=3
#password       required        pam_unix.so sha512 shadow use_authtok
password        required        pam_unix.so sha512 shadow nullok
password    optional    pam_gnome_keyring.so
#%PAM-1.0

auth       include      system-auth
account    include      system-auth
password   include      system-auth
session    include      system-auth
#%PAM-1.0
# For root login to succeed here with pam_securetty, "rlogin" must be
# listed in /etc/securetty.
auth       required     pam_nologin.so
auth       required     pam_securetty.so
auth       required     pam_env.so
auth       sufficient   pam_rhosts.so
auth       include      system-auth
account    include      system-auth
password   include      system-auth
session    optional     pam_keyinit.so    force revoke
session    required     pam_loginuid.so
session    include      system-auth
#%PAM-1.0
# For root login to succeed here with pam_securetty, "rsh" must be
# listed in /etc/securetty.
auth       required     pam_nologin.so
auth       required     pam_securetty.so
auth       required     pam_env.so
auth       required     pam_rhosts.so
account    include      system-auth
session    optional     pam_keyinit.so    force revoke
session    required     pam_loginuid.so
session    include      system-auth
auth            required        pam_unix.so
account         required        pam_unix.so
session         required        pam_unix.so
#%PAM-1.0

auth            include         system-login
auth            optional        pam_kwallet5.so
account         include         system-login
password        include         system-login
session         include         system-login
session         optional        pam_kwallet5.so auto_start
#%PAM-1.0
auth        required    pam_env.so
auth        required    pam_tally.so file=/var/log/faillog onerr=succeed
auth        required    pam_shells.so
auth        required    pam_nologin.so
auth        required    pam_permit.so
-auth       optional    pam_gnome_keyring.so
-auth       optional    pam_kwallet5.so
account     include     system-local-login
password    include     system-local-login
session     include     system-local-login
-session    optional    pam_gnome_keyring.so auto_start
-session    optional    pam_kwallet5.so auto_start
#%PAM-1.0

# Load environment from /etc/environment and ~/.pam_environment
auth            required pam_env.so

# Always let the greeter start without authentication
auth            required pam_permit.so

# No action required for account management
account         required pam_permit.so

# Can't change password
password        required pam_deny.so

# Setup session
session         required pam_unix.so
-session                optional pam_systemd.so
-session                optional pam_elogind.so
#%PAM-1.0
auth            sufficient      pam_rootok.so
auth            required        pam_unix.so
account         required        pam_unix.so
session         required        pam_unix.so
password        required        pam_permit.so
#%PAM-1.0
#auth     required  pam_securetty.so     #disable remote root
auth      include   system-remote-login
account   include   system-remote-login
password  include   system-remote-login
session   include   system-remote-login
#%PAM-1.0
auth            sufficient      pam_rootok.so
# Uncomment the following line to implicitly trust users in the "wheel" group.
#auth           sufficient      pam_wheel.so trust use_uid
# Uncomment the following line to require a user to be in the "wheel" group.
#auth           required        pam_wheel.so use_uid
auth            required        pam_unix.so
account         required        pam_unix.so
session         required        pam_unix.so
#%PAM-1.0
auth            include         system-auth
account         include         system-auth
session         include         system-auth
#%PAM-1.0
auth            sufficient      pam_rootok.so
# Uncomment the following line to implicitly trust users in the "wheel" group.
#auth           sufficient      pam_wheel.so trust use_uid
# Uncomment the following line to require a user to be in the "wheel" group.
#auth           required        pam_wheel.so use_uid
auth            required        pam_unix.so
account         required        pam_unix.so
session         required        pam_unix.so
#%PAM-1.0

auth      required  pam_unix.so     try_first_pass nullok
auth      optional  pam_permit.so
auth      required  pam_env.so

account   required  pam_unix.so
account   optional  pam_permit.so
account   required  pam_time.so

password  required  pam_unix.so     try_first_pass nullok sha512 shadow
password  optional  pam_permit.so

session   required  pam_limits.so
session   required  pam_unix.so
session   optional  pam_permit.so
# Used by systemd --user instances.

account  include system-login
session  required pam_loginuid.so
session  include system-login
#%PAM-1.0

auth      include   system-login
account   include   system-login
password  include   system-login
session   include   system-login
#%PAM-1.0

auth       required   pam_tally.so         onerr=succeed file=/var/log/faillog
auth       required   pam_shells.so
auth       requisite  pam_nologin.so
auth       include    system-auth

account    required   pam_access.so
account    required   pam_nologin.so
account    include    system-auth

password   include    system-auth

session    optional   pam_loginuid.so
session    optional   pam_keyinit.so       force revoke
session    include    system-auth
session    optional   pam_motd.so          motd=/etc/motd
session    optional   pam_mail.so          dir=/var/spool/mail standard quiet
-session   optional   pam_systemd.so
session    required   pam_env.so
#%PAM-1.0

auth      include   system-login
account   include   system-login
password  include   system-login
session   include   system-login
#%PAM-1.0

auth      sufficient  pam_permit.so

account   include     system-auth

session   optional    pam_loginuid.so
session   required    pam_limits.so
session   required    pam_unix.so
session   optional    pam_permit.so
session   required    pam_env.so
#%PAM-1.0
auth            sufficient      pam_rootok.so
auth            required        pam_unix.so
account         required        pam_unix.so
session         required        pam_unix.so
password        required        pam_permit.so
#%PAM-1.0
auth            sufficient      pam_rootok.so
auth            required        pam_unix.so
account         required        pam_unix.so
session         required        pam_unix.so
password        required        pam_permit.so
#%PAM-1.0
auth            sufficient      pam_rootok.so
auth            required        pam_unix.so
account         required        pam_unix.so
session         required        pam_unix.so
password        required        pam_permit.so

and

$ locate pam_unix
/usr/lib/security/pam_unix.so
/usr/lib32/security/pam_unix.so
/usr/share/doc/Linux-PAM/sag-pam_unix.html
/usr/share/man/man8/pam_unix.8.gz

OR just do nothing with it.

@philm ??


#9

For pam_unix.so, it’s pam_unix2 and pam_unix_*.so are not supported.
Check grep -rn 'pam_unix[2_]' /etc/pam.d, if no output, you need do nothing.


#10

install manjaro-gnome-assets
all is good thanks


#11

Are those pacsave files needed anymore?
For me it was vconsole locale.conf and hostname


#12

Yes they are needed. You should copy them back. Especially when you have different language settings than en_US or set a Hostname different than manjaro.


#13

For me gnome-terminal stopped working. I had to recreate locales and reboot to make it work again.


#14

For me system on my laptop is starting 15 seconds slower, no warnings and errors on start, just blinking console mark


#15

Which kernel?


#16

4.16 and 4.14, tried both


#17

hm. so looks more like Plasma-related then, if that’s still what you’re running? :wink:
The blinking cursor before the desktop starts? Or even before systemd inits (meaning ‘starting version…’ is being displayed)?


#18

Also had issues with kde, had to revert to testing because didn’t have time this morning.
A lot of things didn’t work, couldn’t even start konsole and systemsettings5…
Will try to reproduce and troubleshoot further this evening.

edit: seems to be something with sddm in tty1, when I restart the sddm.service in tty2, my desktop becomes normal again

edit2: The pacsaving of locale.conf , hostname and vconsole.conf made my system quirky, renamed them to normal. Problems solved.

ref: [Unstable Update] 2014-04-25 - Kernels, PAM, GLIBC, GCC, PHP, Firefox, Gnome-Settings


#19

It is happening after “starting kernel xxx” then blinking. I dont have systemd version printed problably because i did something to hide it, but i dont remember what :grinning:
Now it is starting faster it seems, looks like random thing, will try something later.
EDIT:
It is happening after systemd starts. Also sometimes it prints bluetooth errors, not sure if related


#20

@xabbu and @xircon I just enter Preferences >Local settings> I had 2 pre added languages:EN_US and ES_cl. So I removed EN_Us and left the ES_cl and then in there licked on Advanced settings Tab> Once there I set all the options for my native language Espanol-Chile es_CL UTF-8. Then I clicked Apply button and reboot…all my system got back into Spanish again.