[Unstable Update] 2017-07-29 - Kernels, Virtualbox, spl/zfs, Cinnamon, Pamac

unstable
update

#21

That looks like it’s coming from dunst… You need to uninstall it, otherwise dunst will be your notification daemon…

sudo pacman -Rns dunst

See also :


#22

@thefallenrat thank you for pointing me in the right direction.
The new update-notifier v0.6.4-1 with the updatefunction has pulled down some dependencies I didn’t notice.

dunst
dunstify
libxdg-basedir

I downgraded back to v0.6.2-3 that doesn’t need those dependencies.
@Chrysostomus
Will dunst be mandatory to keep the update-notifier working, maybe a version without the feature and dependencies?


#23

The new version adds update buttons to the notifications. For this dunstify is required. Dunst is unnecessary. Maybe we should package dunstify without dunst being dependency? That would be the simplest solution. Other option is to check for availability of dunstify, use notify-send if it is not present, and make dunstify optdepend.

Is there a way in kde to prioritize notification daemons? Update-notifier is coded with bspwm and gnome editions in mind. Bspwm edition actually uses dunst, and gnome just happily uses its own notifications regardless of what else is installed.


#24

Yes this will do it for me, I’ve just tested after I -Rdd dunst (not sure if libxdg-basedir is still needed), the notification with update option was normal again within kde. But, do I get some feedback when I press the update button, looks like it isn’t doing anything?


#25

What should happen is that terminal should open with running update command. Can you run the script

   update-notifier

from terminal and post its output?

Also, post contents of ~/.profile


#26

Okay, I now uploaded dunst 1.2 to unstable repos. It should not depend on dunst anymore.


#27

Running update-notifier from konsole worked, after pressing the update icon it opened a new terminal using pacaur and asked for my password to continue upgrading.

cat ~/.profile

export TERMINAL="konsole"

edit: makes me wonder if the

systemctl --user start update-notifier.service

[Unit]
Description=Update notifier service
After=network.target

[Service]
Type=oneshot
ExecStart=/usr/bin/update-notifier

is part of my issue not having enough privileges to open the update terminal


#28

Or maybe too much privledges? As what user does that service run the script? Ideally it should be your own user, because it uses your ~/.profile, and it cannot be found if it is some other user.

You could also just use the update-checker command provided by the package.


#29

As my own user.
The update works normal when I have removed the pacaur package.


#30

Aa. Then it is an issue of too much privledges. Pacaur won’t update as root.


#31

The user post-factum says that "You need blk-mq fixes as well for suspend-to-ram issue to be fixed."
What these “blk-mq fixes” are? It is possible to integrate them into the kernel for a real solution?
4.13 series also has the same issue.


#32

I don’t know if the blk-mq patch is ready … @philm is the master of kernel ( i have more to study :wink: )
my workaround simply switch to off blk-mq this is the reason because suspend work :slight_smile:


#33

I have installed the 4.12.4-2 kernel, and for the moment I did not have problems with the suspension, it works very well.


#34

i encountered some problems with the language support for the DE - mixed languages in GUI.
Managed to fix it by reinstalling some of the affected programs f.e. manjaro-settings-manager

Have to say I love the integration of the update section in pacmac-manager!


#35

Works also to me because blk-mq one of the most important features of kernel 4.12 s disabled. But this is not a real solution, just a workaround.


#36

I do not have it disabled, restore the grub as it was before.

RUB_DISTRIBUTOR='Manjaro'
GRUB_CMDLINE_LINUX_DEFAULT="quiet resume=UUID=99960f52-c381-44ba-a322-6ef742ca3aaf"
GRUB_CMDLINE_LINUX=""

#37

4.12.4-2 disables bfq-mq by default to work around the issue. There’s an upstream BFQ patch for 4.13 that should fix the issue but (IIRC) it needs to be backported for kernel 4.12.


#38

Do you know when will be integrated into the manjaro’s 4.13 kernel?
I tried 4.13-rc3 but there is the same issue.


#39

Today’s (Aug. 3) Deepin update on Unstable solverd the issue with small font size in Deepin UI elements. @oberon

Kernels 4.9, 4.12, 4.13 work fine. No issues found on different DEs and machines.


#41

Another Awesome update thank you Phil and the rest of the Manjaro team. No issues found on 4.13.rc3, 4.12, 4.10, or the 4.4 kernels.