[Unstable Update] 2017-05-26 - Samba, Openssl, Kernels

unstable
update

#1

Hi community,

with this update we fixed some security issue with samba, updated most of our kernels plus released the latest openssl versions.

Please test and give us feedback as usual


Current supported Kernels

  • linux310 3.10.105
  • linux312 3.12.74 [EOL]
  • linux316 3.16.42
  • linux318 3.18.55 [EOL]
  • linux41 4.1.39
  • linux44 4.4.70
  • linux48 4.8.17 [EOL]
  • linux49 4.9.30
  • linux410 4.10.17 [EOL]
  • linux411 4.11.3
  • linux412 4.12-rc2 (x86_64)
  • linux-RT-LTS 4.4.66_rt79 (x86_64)
  • linux-RT 4.9.27_rt18 (x86_64)

Package Updates (Fri May 26 01:58:38 CEST 2017)

:: Different overlay package(s) in repository community i686

-------------------------------------------------------------------------------
                             PACKAGE           2017-05-25           2017-05-26
-------------------------------------------------------------------------------
                      compiz-manjaro           0.9.13.1-3           0.9.13.1-4
               lightdm-slick-greeter              1.0.1-3              1.0.5-1
                  qt5-base-nosystemd              5.8.0-3              5.8.0-4


:: Different sync package(s) in repository community i686

-------------------------------------------------------------------------------
                             PACKAGE           2017-05-25           2017-05-26
-------------------------------------------------------------------------------
                             aws-cli            1.11.90-1            1.11.92-1
                                bmon                4.0-1                4.0-2
                       cabal-install           1.24.0.0-9          1.24.0.0-10
                             confuse                3.0-1                3.1-1
                               darcs            2.12.5-29            2.12.5-30
                           git-annex         6.20170519-4         6.20170519-5
                              gitlab              9.2.0-2              9.2.1-1
                      haskell-hakyll           4.9.5.1-59           4.9.5.1-61
                       haskell-hpack            0.17.0-13            0.17.0-14
                        haskell-http           4000.3.6-2           4000.3.7-1
                      haskell-pandoc          1.19.2.1-54          1.19.2.1-56
             haskell-pandoc-citeproc          0.10.4.1-49          0.10.4.1-51
             haskell-pandoc-crossref           0.2.5.0-40           0.2.5.0-42
                       haskell-stack             1.4.0-52             1.4.0-53
                        haskell-yaml           0.8.22.1-2             0.8.23-1
                       haskell-yesod             1.4.5-43             1.4.5-44
                             hindent              5.2.3-3              5.2.3-4
                      hopenpgp-tools            0.19.4-91            0.19.4-92
                            i3status               2.11-1               2.11-2
                              kcptun           20170329-1           20170525-1
                             libftdi                1.3-3                1.3-4
                    libretro-shaders                587-1                    -
                 libretro-shaders-cg                661-2                694-1
               libretro-shaders-glsl                661-2                145-1
              libretro-shaders-slang                661-2                370-1
                             libvirt              3.2.0-2              3.3.0-1
                            lollypop            0.9.231-2            0.9.238-1
         nextcloud-app-richdocuments            1.12.28-1            1.12.31-1
                   npm-check-updates             2.11.1-1             2.11.2-1
                              pandoc          1.19.2.1-54          1.19.2.1-56
                     pandoc-citeproc          0.10.4.1-49          0.10.4.1-51
                     pandoc-crossref           0.2.5.0-40           0.2.5.0-42
                         python-boto             2.46.1-1             2.47.0-1
                     python-botocore             1.5.53-1             1.5.55-1
               python-configargparse             0.11.0-2             0.12.0-1
                 python-phonenumbers              8.4.3-1              8.5.0-1
                      python-pytools           2016.2.6-2           2017.1.1-1
                        python2-boto             2.46.1-1             2.47.0-1
              python2-configargparse             0.11.0-2             0.12.0-1
                       python2-eyed3             0.7.11-2                0.8-1
                python2-phonenumbers              8.4.3-1              8.5.0-1
                     python2-pytools           2016.2.6-2           2017.1.1-1
                              scrapy              1.3.3-1              1.4.0-1
                               stack             1.4.0-52             1.4.0-53
                     stylish-haskell           0.7.1.0-24           0.7.1.0-25
                               tilda              1.3.3-2              1.3.3-3
                                 tlp                0.9-2                1.0-1
                             tlp-rdw                0.9-2                1.0-1
                              xmobar             0.24.4-2             0.24.4-3
                             kashmir                    -           20150805-2
                        python-eyed3                    -                0.8-1
                             restbed                    -                4.5-2
                                yate                    -              5.5.0-1


:: Different overlay package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2017-05-25           2017-05-26
-------------------------------------------------------------------------------
                      compiz-manjaro           0.9.13.1-3           0.9.13.1-4
               lightdm-slick-greeter              1.0.1-3              1.0.5-1
                  qt5-base-nosystemd              5.8.0-3              5.8.0-4


:: Different sync package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2017-05-25           2017-05-26
-------------------------------------------------------------------------------
                             aws-cli            1.11.90-1            1.11.92-1
                                bmon                4.0-1                4.0-2
                       cabal-install           1.24.0.0-9          1.24.0.0-10
                             confuse                3.0-1                3.1-1
                               darcs            2.12.5-29            2.12.5-30
                           git-annex         6.20170519-4         6.20170519-5
                              gitlab              9.2.0-2              9.2.1-1
                      haskell-hakyll           4.9.5.1-59           4.9.5.1-61
                       haskell-hpack            0.17.0-13            0.17.0-14
                        haskell-http           4000.3.6-2           4000.3.7-1
                      haskell-pandoc          1.19.2.1-54          1.19.2.1-56
             haskell-pandoc-citeproc          0.10.4.1-49          0.10.4.1-51
             haskell-pandoc-crossref           0.2.5.0-40           0.2.5.0-42
                       haskell-stack             1.4.0-52             1.4.0-53
                        haskell-yaml           0.8.22.1-2             0.8.23-1
                       haskell-yesod             1.4.5-43             1.4.5-44
                             hindent              5.2.3-3              5.2.3-4
                      hopenpgp-tools            0.19.4-91            0.19.4-92
                            i3status               2.11-1               2.11-2
                              kcptun           20170329-1           20170525-1
                             libftdi                1.3-3                1.3-4
                    libretro-shaders                587-1                    -
                 libretro-shaders-cg                661-2                694-1
               libretro-shaders-glsl                661-2                145-1
              libretro-shaders-slang                661-2                370-1
                             libvirt              3.2.0-2              3.3.0-1
                            lollypop            0.9.231-2            0.9.238-1
         nextcloud-app-richdocuments            1.12.28-1            1.12.31-1
                   npm-check-updates             2.11.1-1             2.11.2-1
                              pandoc          1.19.2.1-54          1.19.2.1-56
                     pandoc-citeproc          0.10.4.1-49          0.10.4.1-51
                     pandoc-crossref           0.2.5.0-40           0.2.5.0-42
                      pycuda-headers           2016.1.2-6             2017.1-1
                         python-boto             2.46.1-1             2.47.0-1
                     python-botocore             1.5.53-1             1.5.55-1
               python-configargparse             0.11.0-2             0.12.0-1
                 python-phonenumbers              8.4.3-1              8.5.0-1
                       python-pycuda           2016.1.2-6             2017.1-1
                      python-pytools           2016.2.6-2           2017.1.1-1
                        python2-boto             2.46.1-1             2.47.0-1
              python2-configargparse             0.11.0-2             0.12.0-1
                       python2-eyed3             0.7.11-2                0.8-1
                python2-phonenumbers              8.4.3-1              8.5.0-1
                      python2-pycuda           2016.1.2-6             2017.1-1
                     python2-pytools           2016.2.6-2           2017.1.1-1
                              scrapy              1.3.3-1              1.4.0-1
                               stack             1.4.0-52             1.4.0-53
                     stylish-haskell           0.7.1.0-24           0.7.1.0-25
                               tilda              1.3.3-2              1.3.3-3
                                 tlp                0.9-2                1.0-1
                             tlp-rdw                0.9-2                1.0-1
                              xmobar             0.24.4-2             0.24.4-3
                             kashmir                    -           20150805-2
                        python-eyed3                    -                0.8-1
                             restbed                    -                4.5-2
                                yate                    -              5.5.0-1


:: Different overlay package(s) in repository core i686

-------------------------------------------------------------------------------
                             PACKAGE           2017-05-25           2017-05-26
-------------------------------------------------------------------------------
                            linux318            3.18.54-1            3.18.55-1
                    linux318-headers            3.18.54-1            3.18.55-1
                            linux411             4.11.2-1             4.11.3-1
                    linux411-headers             4.11.2-1             4.11.3-1
                             linux44             4.4.69-1             4.4.70-1
                     linux44-headers             4.4.69-1             4.4.70-1
                             linux49             4.9.29-1             4.9.30-1
                     linux49-headers             4.9.29-1             4.9.30-1
                             openssl                    -            1.1.0.f-1


:: Different overlay package(s) in repository core x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2017-05-25           2017-05-26
-------------------------------------------------------------------------------
                            linux318            3.18.54-1            3.18.55-1
                    linux318-headers            3.18.54-1            3.18.55-1
                            linux411             4.11.2-1             4.11.3-1
                    linux411-headers             4.11.2-1             4.11.3-1
                             linux44             4.4.69-1             4.4.70-1
                     linux44-headers             4.4.69-1             4.4.70-1
                             linux49             4.9.29-1             4.9.30-1
                     linux49-headers             4.9.29-1             4.9.30-1
                             openssl                    -            1.1.0.f-1


:: Different overlay package(s) in repository extra i686

-------------------------------------------------------------------------------
                             PACKAGE           2017-05-25           2017-05-26
-------------------------------------------------------------------------------
                    broadcom-wl-dkms       6.30.223.271-1       6.30.223.271-2
                  linux411-acpi_call              1.1.0-2              1.1.0-3
                   linux411-bbswitch                0.8-2                0.8-3
                linux411-broadcom-wl       6.30.223.271-2       6.30.223.271-3
                   linux411-catalyst      1:15.201.1151-2      1:15.201.1151-3
                linux411-ndiswrapper               1.61-2               1.61-3
                     linux411-nvidia           1:375.66-2           1:375.66-3
               linux411-nvidia-304xx          1:304.134-2          1:304.134-3
               linux411-nvidia-340xx            340.101-2            340.101-3
                   linux411-nvidiabl               0.88-2               0.88-3
                      linux411-r8168           8.044.02-2           8.044.02-3
                  linux411-rt3562sta         2.4.1.1_r4-2         2.4.1.1_r4-3
                        linux411-spl            0.6.5.9-2            0.6.5.9-3
                   linux411-tp_smapi               0.41-2               0.41-3
                linux411-vhba-module           20161009-2           20161009-3
   linux411-virtualbox-guest-modules             5.1.22-2             5.1.22-3
    linux411-virtualbox-host-modules             5.1.22-2             5.1.22-3
                        linux411-zfs            0.6.5.9-2            0.6.5.9-3
                   linux44-acpi_call             1.1.0-49             1.1.0-50
                    linux44-bbswitch               0.8-49               0.8-50
                 linux44-broadcom-wl      6.30.223.271-19      6.30.223.271-20
                    linux44-catalyst     1:15.201.1151-49     1:15.201.1151-50
                 linux44-ndiswrapper              1.61-17              1.61-18
                      linux44-nvidia           1:375.66-2           1:375.66-3
                linux44-nvidia-304xx         1:304.134-19         1:304.134-20
                linux44-nvidia-340xx           340.101-19           340.101-20
                    linux44-nvidiabl              0.88-49              0.88-50
       linux44-open-vm-tools-modules      2:2013.09.16-49      2:2013.09.16-50
                       linux44-r8168           8.044.02-3           8.044.02-4
                   linux44-rt3562sta        2.4.1.1_r4-17        2.4.1.1_r4-18
                         linux44-spl           0.6.5.9-12           0.6.5.9-13
                    linux44-tp_smapi              0.41-49              0.41-50
                 linux44-vhba-module          20161009-17          20161009-18
    linux44-virtualbox-guest-modules             5.1.22-3             5.1.22-4
     linux44-virtualbox-host-modules             5.1.22-3             5.1.22-4
                         linux44-zfs           0.6.5.9-12           0.6.5.9-13
                   linux49-acpi_call             1.1.0-24             1.1.0-25
                    linux49-bbswitch               0.8-24               0.8-25
                 linux49-broadcom-wl      6.30.223.271-24      6.30.223.271-25
                    linux49-catalyst     1:15.201.1151-24     1:15.201.1151-25
                 linux49-ndiswrapper              1.61-22              1.61-23
                      linux49-nvidia           1:375.66-3           1:375.66-4
                linux49-nvidia-304xx         1:304.134-24         1:304.134-25
                linux49-nvidia-340xx           340.101-24           340.101-25
                    linux49-nvidiabl              0.88-24              0.88-25
                       linux49-r8168           8.044.02-4           8.044.02-5
                   linux49-rt3562sta        2.4.1.1_r4-22        2.4.1.1_r4-23
                         linux49-spl           0.6.5.9-15           0.6.5.9-16
                    linux49-tp_smapi              0.41-24              0.41-25
                 linux49-vhba-module          20161009-22          20161009-23
    linux49-virtualbox-guest-modules             5.1.22-4             5.1.22-5
     linux49-virtualbox-host-modules             5.1.22-4             5.1.22-5
                         linux49-zfs           0.6.5.9-15           0.6.5.9-16
                         libwbclient                    -             4.5.10-0
                               samba                    -             4.5.10-0
                           smbclient                    -             4.5.10-0


:: Different sync package(s) in repository extra i686

-------------------------------------------------------------------------------
                             PACKAGE           2017-05-25           2017-05-26
-------------------------------------------------------------------------------
                                  go            2:1.8.2-1            2:1.8.3-1
                  libhttpseverywhere              0.4.3-1              0.4.4-1
                         openssl-1.0            1.0.2.k-4            1.0.2.l-1
                                opus              1.1.4-1              1.1.5-1
                               pango 1.40.6+6+g6f59d0f3-2 1.40.6+9+g92cc73c8-1
                        python-attrs             17.1.0-1             17.2.0-1
             python-service-identity             16.0.0-2             17.0.0-1
                       python2-attrs             17.1.0-1             17.2.0-1
            python2-service-identity             16.0.0-2             17.0.0-1
                                 qbs              1.8.0-1              1.8.0-2
                            qt5-base             5.8.0-12           5.8.0-12.1
             qt5-xcb-private-headers             5.8.0-12           5.8.0-12.1
                           qtcreator              4.3.0-1              4.3.0-2
                              strace               4.16-1               4.17-1
                          webkit2gtk             2.16.2-1             2.16.3-1


:: Different overlay package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2017-05-25           2017-05-26
-------------------------------------------------------------------------------
                    broadcom-wl-dkms       6.30.223.271-1       6.30.223.271-2
                  linux411-acpi_call              1.1.0-2              1.1.0-3
                   linux411-bbswitch                0.8-2                0.8-3
                linux411-broadcom-wl       6.30.223.271-2       6.30.223.271-3
                   linux411-catalyst      1:15.201.1151-2      1:15.201.1151-3
                linux411-ndiswrapper               1.61-2               1.61-3
                     linux411-nvidia           1:375.66-2           1:375.66-3
               linux411-nvidia-304xx          1:304.134-2          1:304.134-3
               linux411-nvidia-340xx            340.101-2            340.101-3
                   linux411-nvidiabl               0.88-2               0.88-3
                      linux411-r8168           8.044.02-2           8.044.02-3
                  linux411-rt3562sta         2.4.1.1_r4-2         2.4.1.1_r4-3
                        linux411-spl            0.6.5.9-2            0.6.5.9-3
                   linux411-tp_smapi               0.41-2               0.41-3
                linux411-vhba-module           20161009-2           20161009-3
   linux411-virtualbox-guest-modules             5.1.22-2             5.1.22-3
    linux411-virtualbox-host-modules             5.1.22-2             5.1.22-3
                        linux411-zfs            0.6.5.9-2            0.6.5.9-3
                   linux44-acpi_call             1.1.0-49             1.1.0-50
                    linux44-bbswitch               0.8-49               0.8-50
                 linux44-broadcom-wl      6.30.223.271-19      6.30.223.271-20
                    linux44-catalyst     1:15.201.1151-49     1:15.201.1151-50
                 linux44-ndiswrapper              1.61-17              1.61-18
                      linux44-nvidia           1:375.66-2           1:375.66-3
                linux44-nvidia-304xx         1:304.134-19         1:304.134-20
                linux44-nvidia-340xx           340.101-19           340.101-20
                    linux44-nvidiabl              0.88-49              0.88-50
       linux44-open-vm-tools-modules      2:2013.09.16-49      2:2013.09.16-50
                       linux44-r8168           8.044.02-3           8.044.02-4
                   linux44-rt3562sta        2.4.1.1_r4-17        2.4.1.1_r4-18
                         linux44-spl           0.6.5.9-12           0.6.5.9-13
                    linux44-tp_smapi              0.41-49              0.41-50
                 linux44-vhba-module          20161009-17          20161009-18
    linux44-virtualbox-guest-modules             5.1.22-3             5.1.22-4
     linux44-virtualbox-host-modules             5.1.22-3             5.1.22-4
                         linux44-zfs           0.6.5.9-12           0.6.5.9-13
                   linux49-acpi_call             1.1.0-24             1.1.0-25
                    linux49-bbswitch               0.8-24               0.8-25
                 linux49-broadcom-wl      6.30.223.271-24      6.30.223.271-25
                    linux49-catalyst     1:15.201.1151-24     1:15.201.1151-25
                 linux49-ndiswrapper              1.61-22              1.61-23
                      linux49-nvidia           1:375.66-3           1:375.66-4
                linux49-nvidia-304xx         1:304.134-24         1:304.134-25
                linux49-nvidia-340xx           340.101-24           340.101-25
                    linux49-nvidiabl              0.88-24              0.88-25
                       linux49-r8168           8.044.02-4           8.044.02-5
                   linux49-rt3562sta        2.4.1.1_r4-22        2.4.1.1_r4-23
                         linux49-spl           0.6.5.9-15           0.6.5.9-16
                    linux49-tp_smapi              0.41-24              0.41-25
                 linux49-vhba-module          20161009-22          20161009-23
    linux49-virtualbox-guest-modules             5.1.22-4             5.1.22-5
     linux49-virtualbox-host-modules             5.1.22-4             5.1.22-5
                         linux49-zfs           0.6.5.9-15           0.6.5.9-16
                         libwbclient                    -             4.5.10-0
                               samba                    -             4.5.10-0
                           smbclient                    -             4.5.10-0


:: Different sync package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2017-05-25           2017-05-26
-------------------------------------------------------------------------------
                                  go            2:1.8.2-1            2:1.8.3-1
                  libhttpseverywhere              0.4.3-1              0.4.4-1
                         openssl-1.0            1.0.2.k-4            1.0.2.l-1
                                opus              1.1.4-1              1.1.5-1
                               pango 1.40.6+6+g6f59d0f3-2 1.40.6+9+g92cc73c8-1
                        python-attrs             17.1.0-1             17.2.0-1
             python-service-identity             16.0.0-2             17.0.0-1
                       python2-attrs             17.1.0-1             17.2.0-1
            python2-service-identity             16.0.0-2             17.0.0-1
                                 qbs              1.8.0-1              1.8.0-2
                           qtcreator              4.3.0-1              4.3.0-2
                              strace               4.16-1               4.17-1
                          webkit2gtk             2.16.2-1             2.16.3-1


:: Different sync package(s) in repository multilib x86_64

-------------------------------------------------------------------------------
                             PACKAGE           2017-05-25           2017-05-26
-------------------------------------------------------------------------------
                       lib32-openssl          1:1.1.0.e-1          1:1.1.0.f-1

  • No issues, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself. (Please post your solution)
  • Yes I am currently experiencing an issue due to the update. (Please post about it)

0 voters


Check if your mirror has already synced:


#2
error: libwbclient: signature from "Philip Müller (Called Little) <philm@manjaro.org>" is marginal trust
:: File /var/cache/pacman/pkg/libwbclient-4.5.10-0-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: linux411: signature from "Philip Müller (Called Little) <philm@manjaro.org>" is marginal trust
:: File /var/cache/pacman/pkg/linux411-4.11.3-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: linux49: signature from "Philip Müller (Called Little) <philm@manjaro.org>" is marginal trust
:: File /var/cache/pacman/pkg/linux49-4.9.30-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: smbclient: signature from "Philip Müller (Called Little) <philm@manjaro.org>" is marginal trust
:: File /var/cache/pacman/pkg/smbclient-4.5.10-0-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: samba: signature from "Philip Müller (Called Little) <philm@manjaro.org>" is marginal trust
:: File /var/cache/pacman/pkg/samba-4.5.10-0-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: failed to commit transaction (invalid or corrupted package (PGP signature))
Errors occurred, no packages were upgraded.

#3

Already tried the suggested solutions I found in other manjaro and arch forums, none worked.

EDIT: Also, how do I put code/output in that box? Haven’t really used the new forums, so I don’t know how it works.


#4

Successfully upgraded and briefly tested in separate KDE and LXQt VMs:

linux49 from 4.9.29-1 to 4.9.30-1
linux49-virtualbox-guest-modules from 5.1.22-4 to 5.1.22-5


#5

Did you tried the fix option of pacli?

phil@manjaro ~ $ pacli

                      ::Pacli - Package manager::
 ┌────────────────────────────────────────────────────────────────────┐
 │    1   Update System                2   Clean System               │
 │    3   Install Package              4   Remove Package + Deps      │
 │    5   Package Information          6   List Local Package Files   │
 │    7   Dependency Tree              8   Reverse Dependency Tree    │
 └────────────────────────────────────────────────────────────────────┘
 ┌────────────────────────────────────────────────────────────────────┐
 │    9   Defragment Database         10   Help                       │
 │   11   Downgrade Packages          12   Pacman Log                 │
 │   13   Fix Errors                  14   Configure Pacman           │
 │   15   Force Install Package       16   Force Update System        │
 │   17   Force Remove Package        18   Empty Package Cache        │
 └────────────────────────────────────────────────────────────────────┘

 ┌────────────────────────────────────────────────────────────────────┐
 │   19   Update AUR                  20   Force Update AUR           │
 │   21   Search+Install from AUR     22   Install from AUR           │
 │   23   List Installed from AUR     24   Configure Yaourt           │
 └────────────────────────────────────────────────────────────────────┘


     Enter a number between 0..24 and press [Enter] - 0 Exit Pacli

#6

Don’t have pacli, can’t install it, because I can’t install any package at all.

EDIT: Managed to build it from the AUR, trying the fix now.


#7

Else we have some tips in our wiki. As last straw you may disable signatures in your /etc/pacman.conf

Default

# By default, pacman accepts packages signed by keys that its local keyring
# trusts (see pacman-key and its man page), as well as unsigned packages.
SigLevel    = Required DatabaseOptional
LocalFileSigLevel = Optional
#RemoteFileSigLevel = Required

Manual

PACKAGE AND DATABASE SIGNATURE CHECKING
       The SigLevel directive is valid in both the [options] and repository
       sections. If used in [options], it sets a default value for any
       repository that does not provide the setting.

   ·   If set to Never, no signature checking will take place.

   ·   If set to Optional , signatures will be checked when present, but
       unsigned databases and packages will also be accepted.

   ·   If set to Required, signatures will be required on all packages and
       databases.

   Alternatively, you can get more fine-grained control by combining some
   of the options and prefixes described below. All options in a config
   file are processed in top-to-bottom, left-to-right fashion, where later
   options override and/or supplement earlier ones. If SigLevel is
   specified in a repository section, the starting value is that from the
   [options] section, or the built-in system default as shown below if not
   specified.

   The options are split into two main groups, described below. Terms used
   such as “marginally trusted” are terms used by GnuPG, for more
   information please consult gpg(1).

   When to Check
       These options control if and when signature checks should take
       place.

       Never
           All signature checking is suppressed, even if signatures are
           present.

       Optional (default)
           Signatures are checked if present; absence of a signature is
           not an error. An invalid signature is a fatal error, as is a
           signature from a key not in the keyring.

       Required
           Signatures are required; absence of a signature or an invalid
           signature is a fatal error, as is a signature from a key not in
           the keyring.

   What is Allowed
       These options control what signatures are viewed as permissible.
       Note that neither of these options allows acceptance of invalid or
       expired signatures, or those from revoked keys.

       TrustedOnly (default)
           If a signature is checked, it must be in the keyring and fully
           trusted; marginal trust does not meet this criteria.

       TrustAll
           If a signature is checked, it must be in the keyring, but is
           not required to be assigned a trust level (e.g., unknown or
           marginal trust).

   Options in both groups can additionally be prefixed with either Package
   or Database, which will cause it to only take effect on the specified
   object type. For example, PackageTrustAll would allow marginal and
   unknown trust level signatures for packages.

   The built-in default is the following:

       SigLevel = Optional TrustedOnly

#8

Seems to be fixed now. Thanks @philm


#9

That is great to know.


#10

Something is going wrong today in my VM:

$ sudo pacman-mirrors -g && sudo pacman -Syyu
.: Info Downloading mirrors from repo.manjaro.org
.: Info Nutze benutzerspezifische Mirrordatei
.: Info Frage Mirrors ab - Dies kann einige Zeit in Anspruch nehmen
   0.200 Germany        : https://mirror.netzspielplatz.de/manjaro/packages/
.: Info Schreibe Mirrorliste
   Germany         : https://mirror.netzspielplatz.de/manjaro/packages/unstable
.: Info Mirrordatei generiert und gesichert in: /etc/pacman.d/mirrorlist
:: Synchronisiere Paketdatenbanken...
 core                                                                                     140,5 KiB  1633K/s 00:00 [####################################################################] 100%
 extra                                                                                   1809,7 KiB  5,65M/s 00:00 [####################################################################] 100%
 community                                                                                  4,2 MiB  5,61M/s 00:01 [####################################################################] 100%
 multilib                                                                                 180,7 KiB  5,88M/s 00:00 [####################################################################] 100%
:: Starte vollständige Systemaktualisierung...
Löse Abhängigkeiten auf...
Suche nach in Konflikt stehenden Paketen...
Warnung: Entferne 'gcc-libs' aus der Ziel-Liste, da es mit 'gcc-libs-multilib' in Konflikt steht
Warnung: Entferne 'gcc' aus der Ziel-Liste, da es mit 'gcc-multilib' in Konflikt steht
Fehler: Konnte den Vorgang nicht vorbereiten (Kann Abhängigkeiten nicht erfüllen)
:: gcc-fortran: benötigt gcc=7.1.1-2

Edit:
Cause of the sortation of the threads i was not able to find the right one… sorry for that.


#11

You need to first update gcc-libs-multilib and gcc-multilib, then it should be fine.

(The reason is that although gcc-libs-multilib does provide gcc, latest gcc-fortran 7.1.1-2 explicitly Depends On : gcc=7.1.1-2, which will only be provided by gcc-libs-multilib 7.1.1-3:stuck_out_tongue: )


#12
$ sudo pacman-mirrors -g && sudo pacman -S gcc-libs-multilib gcc-multilib
[sudo] Passwort für laza: 
.: Info Downloading mirrors from repo.manjaro.org
.: Info Nutze benutzerspezifische Mirrordatei
.: Info Frage Mirrors ab - Dies kann einige Zeit in Anspruch nehmen
   0.217 Germany        : https://mirror.netzspielplatz.de/manjaro/packages/
.: Info Schreibe Mirrorliste
   Germany         : https://mirror.netzspielplatz.de/manjaro/packages/unstable
.: Info Mirrordatei generiert und gesichert in: /etc/pacman.d/mirrorlist
Löse Abhängigkeiten auf...
Suche nach in Konflikt stehenden Paketen...
Fehler: Konnte den Vorgang nicht vorbereiten (Kann Abhängigkeiten nicht erfüllen)
:: gcc-fortran: das Installieren von gcc-multilib (7.1.1-3) löscht ein benötigtes Packet von 'gcc=6.3.1-2'

So i tried to deleted two packages but PAMAC says:
You cannot delted these packages cause they’re part of Manjaro and blocked


#13

How about adding gcc-fortran and also binutils just in case to your manual update:

sudo pacman -S gcc-libs-multilib gcc-multilib gcc-fortran binutils

#14
$ sudo pacman -S gcc-libs-multilib gcc-multilib gcc-fortran binutils
[sudo] Passwort für laza: 
Löse Abhängigkeiten auf...
Suche nach in Konflikt stehenden Paketen...
Warnung: Entferne 'gcc-libs' aus der Ziel-Liste, da es mit 'gcc-libs-multilib' in Konflikt steht
Warnung: Entferne 'gcc' aus der Ziel-Liste, da es mit 'gcc-multilib' in Konflikt steht
Fehler: Konnte den Vorgang nicht vorbereiten (Kann Abhängigkeiten nicht erfüllen)
:: gcc-fortran: benötigt gcc=7.1.1-2

Reminds me of “Die Unendliche Geschichte” :slight_smile:


#15

Chrchr…
Can you remove gcc-fortran temporarily? Or is someone else complaining then …?


#16

Aaaaaah!!
gcc-fortran-multilib - :smiley: seems to be a new package
no. not new apparently, but it will be happy with gcc-multilib :wink:


#17

That did the trick!

$ sudo pacman -R gcc-fortran 
[sudo] Passwort für laza: 
Prüfe Abhängigkeiten...

Pakete (1) gcc-fortran-6.3.1-2

Gesamtgröße der entfernten Pakete:  24,55 MiB

:: Möchten Sie diese Pakete entfernen? [J/n] 
:: Starte pre-transaction hooks...
(1/1) Removing old entries from the info directory file...
:: Verarbeite Paketänderungen...
(1/1) Entferne gcc-fortran                                                                                                     [#############################################################################] 100%
:: Starte post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...
$ sudo pacman -S gcc-libs-multilib gcc-multilib gcc-fortran binutils
Löse Abhängigkeiten auf...
Suche nach in Konflikt stehenden Paketen...
Warnung: Entferne 'gcc-libs' aus der Ziel-Liste, da es mit 'gcc-libs-multilib' in Konflikt steht
Warnung: Entferne 'gcc' aus der Ziel-Liste, da es mit 'gcc-multilib' in Konflikt steht
Fehler: Konnte den Vorgang nicht vorbereiten (Kann Abhängigkeiten nicht erfüllen)
:: gcc-fortran: benötigt gcc=7.1.1-2
$ sudo pacman-mirrors -g && sudo pacman -Syyu
.: Info Downloading mirrors from repo.manjaro.org
.: Info Nutze benutzerspezifische Mirrordatei
.: Info Frage Mirrors ab - Dies kann einige Zeit in Anspruch nehmen
   0.324 Germany        : https://mirror.netzspielplatz.de/manjaro/packages/
.: Info Schreibe Mirrorliste
   Germany         : https://mirror.netzspielplatz.de/manjaro/packages/unstable
.: Info Mirrordatei generiert und gesichert in: /etc/pacman.d/mirrorlist
:: Synchronisiere Paketdatenbanken...
 core                                                                                                 140,5 KiB  1561K/s 00:00 [#############################################################################] 100%
 extra                                                                                               1809,7 KiB  5,59M/s 00:00 [#############################################################################] 100%
 community                                                                                              4,2 MiB  5,65M/s 00:01 [#############################################################################] 100%
 multilib                                                                                             180,7 KiB  5,35M/s 00:00 [#############################################################################] 100%
:: Starte vollständige Systemaktualisierung...
Löse Abhängigkeiten auf...
Suche nach in Konflikt stehenden Paketen...

Pakete (15) binutils-2.28.0-3  blas-3.7.0-2  boost-1.64.0-1  boost-libs-1.64.0-1  gcc-libs-multilib-7.1.1-3  gcc-multilib-7.1.1-3  glibc-2.25-2  lapack-3.7.0-2  lib32-gcc-libs-7.1.1-3  lib32-glibc-2.25-3
            libcmis-0.5.1-6  libixion-0.12.2-2  liborcus-0.12.1-2  libtool-2.4.6-8  linux412-4.12rc3-1

Gesamtgröße des Downloads:           157,02 MiB
Gesamtgröße der installierten Pakete:  611,17 MiB
Größendifferenz der Aktualisierung:   31,65 MiB

:: Installation fortsetzen? [J/n] 
:: Empfange Pakete...
 glibc-2.25-2-x86_64                                                                                    8,2 MiB  4,42M/s 00:02 [#############################################################################] 100%
 binutils-2.28.0-3-x86_64                                                                               4,7 MiB  5,64M/s 00:01 [#############################################################################] 100%
 libtool-2.4.6-8-x86_64                                                                               396,1 KiB  5,53M/s 00:00 [#############################################################################] 100%
 linux412-4.12rc3-1-x86_64                                                                             61,9 MiB  5,61M/s 00:11 [#############################################################################] 100%
 blas-3.7.0-2-x86_64                                                                                  112,7 KiB  6,47M/s 00:00 [#############################################################################] 100%
 boost-libs-1.64.0-1-x86_64                                                                             2,2 MiB  5,72M/s 00:00 [#############################################################################] 100%
 boost-1.64.0-1-x86_64                                                                                 10,5 MiB  5,62M/s 00:02 [#############################################################################] 100%
 lapack-3.7.0-2-x86_64                                                                               2015,6 KiB  5,74M/s 00:00 [#############################################################################] 100%
 libcmis-0.5.1-6-x86_64                                                                               506,2 KiB  6,18M/s 00:00 [#############################################################################] 100%
 libixion-0.12.2-2-x86_64                                                                             205,3 KiB  5,90M/s 00:00 [#############################################################################] 100%
 liborcus-0.12.1-2-x86_64                                                                             494,5 KiB  6,04M/s 00:00 [#############################################################################] 100%
 lib32-glibc-2.25-3-x86_64                                                                              2,9 MiB  5,67M/s 00:01 [#############################################################################] 100%
 lib32-gcc-libs-7.1.1-3-x86_64                                                                         14,6 MiB  5,63M/s 00:03 [#############################################################################] 100%
 gcc-libs-multilib-7.1.1-3-x86_64                                                                      17,4 MiB  5,62M/s 00:03 [#############################################################################] 100%
 gcc-multilib-7.1.1-3-x86_64                                                                           30,9 MiB  5,61M/s 00:06 [#############################################################################] 100%
(15/15) Prüfe Schlüssel im Schlüsselring                                                                                       [#############################################################################] 100%
(15/15) Überprüfe Paket-Integrität                                                                                             [#############################################################################] 100%
(15/15) Lade Paket-Dateien                                                                                                     [#############################################################################] 100%
(15/15) Prüfe auf Dateikonflikte                                                                                               [#############################################################################] 100%
(15/15) Überprüfe verfügbaren Festplattenspeicher                                                                              [#############################################################################] 100%
:: Verarbeite Paketänderungen...
( 1/15) Aktualisiere glibc                                                                                                     [#############################################################################] 100%
Generating locales...
  en_US.UTF-8... done
  de_DE.UTF-8... done
  en_US.UTF-8... done
Generation complete.
( 2/15) Aktualisiere binutils                                                                                                  [#############################################################################] 100%
( 3/15) Aktualisiere lib32-glibc                                                                                               [#############################################################################] 100%
( 4/15) Aktualisiere lib32-gcc-libs                                                                                            [#############################################################################] 100%
( 5/15) Aktualisiere gcc-libs-multilib                                                                                         [#############################################################################] 100%
( 6/15) Aktualisiere blas                                                                                                      [#############################################################################] 100%
( 7/15) Aktualisiere boost-libs                                                                                                [#############################################################################] 100%
( 8/15) Aktualisiere boost                                                                                                     [#############################################################################] 100%
( 9/15) Aktualisiere gcc-multilib                                                                                              [#############################################################################] 100%
(10/15) Aktualisiere lapack                                                                                                    [#############################################################################] 100%
(11/15) Aktualisiere libcmis                                                                                                   [#############################################################################] 100%
(12/15) Aktualisiere libixion                                                                                                  [#############################################################################] 100%
(13/15) Aktualisiere liborcus                                                                                                  [#############################################################################] 100%
(14/15) Aktualisiere libtool                                                                                                   [#############################################################################] 100%
(15/15) Aktualisiere linux412                                                                                                  [#############################################################################] 100%
>>> Updating module dependencies. Please wait ...
:: Starte post-transaction hooks...
(1/5) Updating linux412 initcpios
==> Building image from preset: /etc/mkinitcpio.d/linux412.preset: 'default'
  -> -k /boot/vmlinuz-4.12-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.12-x86_64.img
==> Starting build: 4.12.0-1-MANJARO
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [filesystems]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-4.12-x86_64.img
==> Image generation successful
==> Building image from preset: /etc/mkinitcpio.d/linux412.preset: 'fallback'
  -> -k /boot/vmlinuz-4.12-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-4.12-x86_64-fallback.img -S autodetect
==> Starting build: 4.12.0-1-MANJARO
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [keyboard]
  -> Running build hook: [keymap]
  -> Running build hook: [filesystems]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-4.12-x86_64-fallback.img
==> Image generation successful
(2/5) Updating Grub-Bootmenu
GRUB-Konfigurationsdatei wird erstellt …
Hintergrund gefunden: /usr/share/grub/background.png
Found Intel Microcode image
Linux-Abbild gefunden: /boot/vmlinuz-4.12-x86_64
initrd-Abbild gefunden: /boot/initramfs-4.12-x86_64.img
Found initrd fallback image: /boot/initramfs-4.12-x86_64-fallback.img
Linux-Abbild gefunden: /boot/vmlinuz-4.11-x86_64
initrd-Abbild gefunden: /boot/initramfs-4.11-x86_64.img
Found initrd fallback image: /boot/initramfs-4.11-x86_64-fallback.img
Linux-Abbild gefunden: /boot/vmlinuz-4.9-x86_64
initrd-Abbild gefunden: /boot/initramfs-4.9-x86_64.img
Found initrd fallback image: /boot/initramfs-4.9-x86_64-fallback.img
Found memtest86+ image: /boot/memtest86+/memtest.bin
erledigt
(3/5) Creating temporary files...
(4/5) Arming ConditionNeedsUpdate...
(5/5) Updating the info directory file...

I have here all the output fyi.

Thanks!


[Testing Update] 2017-05-31 - Boost, GCC, Kodi, MHWD, OpenRC
#18

Is this strict needed?


#19

I don’t have it on my system… I guess it will be installed as soon as you might need it in the future :wink:


#20

I took another route. I first updated gcc and pacman removed gcc-multilib. :slight_smile: