[Unstable Update] 2017-05-02 - Plasma5, Gnome, VirtualBox, OpenSSL

unstable
update

#41

Not just you. I rolled back to 375.39 for now, will try your fix when I get a chance. Thanks for the helpful post!


#42

[quote=“philm, post:17, topic:22921”]
extra/linux411-catalyst 1:15.201.1151-0.4 (linux411-extramodules)
AMD/ATI Catalyst drivers for linux. fglrx kernel module only.
[/quote]It crashes on my laptop
https://pastebin.com/K2GyGtFp


#43

You mean this crash?

fglrx: loading out-of-tree module taints kernel.
<6>[fglrx] Maximum main memory to use for locked dma buffers: 2491 MBytes.
<6>[fglrx]   vendor: 1002 device: 9802 revision: 0 count: 1
<6>[fglrx] ioport: bar 1, base 0xf000, size: 0x100
<6>[fglrx] Kernel PAT support is enabled
<6>[fglrx] module loaded - fglrx 15.20.3 [Sep  8 2015] with 1 minors
...
<6>[fglrx] Firegl kernel thread PID: 776
<6>[fglrx] Firegl kernel thread PID: 777
<6>[fglrx] Firegl kernel thread PID: 778
<6>[fglrx] IRQ 25 Enabled
<6>[fglrx] Reserved FB block: Shared offset:0, size:1000000 
<6>[fglrx] Reserved FB block: Unshared offset:fc7f000, size:3000 
<6>[fglrx] Reserved FB block: Unshared offset:fc82000, size:37e000 
<6>[fglrx] Reserved FB block: Unshared offset:17ff3000, size:d000 
<6>[fglrx] ATIF platform detected with notification ID: 0x81
BUG: unable to handle kernel paging request at 00003ffffffff018
IP: ip_vm_shm_fault+0x24/0x150 [fglrx]
PGD 0 

Oops: 0000 [#1] PREEMPT SMP
Modules linked in: nls_iso8859_1 nls_cp437 vfat fat joydev mousedev arc4 asus_nb_wmi asus_wmi sparse_keymap ath9k ath9k_common ath9k_hw ath mac80211 kvm_amd kvm irqbypass cfg80211 psmouse input_leds rfkill k10temp led_class uvcvideo snd_hda_codec_realtek snd_hda_codec_hdmi snd_hda_codec_generic videobuf2_vmalloc snd_hda_intel videobuf2_memops videobuf2_v4l2 videobuf2_core snd_hda_codec videodev media sp5100_tco snd_hda_core i2c_piix4 snd_hwdep snd_pcm shpchp snd_timer snd soundcore thermal wmi acpi_cpufreq tpm_tis tpm_tis_core video ac battery tpm sch_fq_codel uinput fglrx(O) evdev mac_hid button amd_iommu_v2 ip_tables x_tables ext4 crc16 jbd2 fscrypto mbcache hid_generic usbhid hid sr_mod cdrom sd_mod ata_generic pata_acpi ohci_pci serio_raw atkbd libps2 ahci libahci pata_atiixp ohci_hcd
 ehci_pci ehci_hcd libata usbcore usb_common scsi_mod i8042 serio
CPU: 1 PID: 621 Comm: Xorg Tainted: G           O    4.11.3-1-MANJARO #1
Hardware name: ASUSTeK Computer Inc. K53U /K53U , BIOS 211 05/26/2011
task: ffff880098cb5940 task.stack: ffffc90001c10000
RIP: 0010:ip_vm_shm_fault+0x24/0x150 [fglrx]
RSP: 0000:ffffc90001c13d80 EFLAGS: 00013246
RAX: 0000000000000000 RBX: ffffc90001c13df8 RCX: 0000000000001052
RDX: ffffffffa048b470 RSI: 00003ffffffff000 RDI: ffffc90001c13df8
RBP: ffffc90001c13da0 R08: 00003fffffe00000 R09: 0000000000000000
R10: 000000000158c730 R11: 0000000000003246 R12: 00003ffffffff000
R13: ffffc90001c13df8 R14: ffff8800a299de00 R15: 0000000000000002
FS:  00007f384a5f3940(0000) GS:ffff8800a7700000(0000) knlGS:0000000000000000
CS:  0010 DS: 0000 ES: 0000 CR0: 0000000080050033
CR2: 00003ffffffff018 CR3: 000000009a720000 CR4: 00000000000006e0
Call Trace:
 __do_fault+0x20/0xd0
 __handle_mm_fault+0x99a/0x1320
 handle_mm_fault+0x101/0x240
 __do_page_fault+0x2b4/0x510
 do_page_fault+0x22/0x30
 page_fault+0x28/0x30
RIP: 0033:0x7f3848609a68
RSP: 002b:00007fffe6bb9168 EFLAGS: 00013206
RAX: 00007f384a6e2000 RBX: 0000000000000000 RCX: 00007f384a6e2040
RDX: 0000000000002000 RSI: 0000000000000000 RDI: 00007f384a6e2000
RBP: 0000000001633170 R08: 000000000000000d R09: 0000000000002000
R10: 000000000158c730 R11: 0000000000003246 R12: 0000000000000000
R13: 000000000158c730 R14: 0000000001632950 R15: 0000000000000002
Code: 1f 84 00 00 00 00 00 0f 1f 44 00 00 55 45 31 c9 31 c0 b9 52 10 00 00 48 c7 c2 70 b4 48 a0 48 89 e5 41 56 41 55 41 54 53 49 89 f4 <4c> 8b 46 18 48 89 fb be 07 00 00 00 bf 09 00 00 00 e8 26 a1 03 
RIP: ip_vm_shm_fault+0x24/0x150 [fglrx] RSP: ffffc90001c13d80
CR2: 00003ffffffff018
---[ end trace 9b005377437a062f ]---
BUG: unable to handle kernel paging request at 00003ffffffff018
IP: ip_vm_shm_fault+0x24/0x150 [fglrx]
PGD 0 

Does it also happen with linux412?


#44

I’m not on unstable (I mean, I just reported about this now since 4.11 actually landed in stable too).
I did test removing linux411 and linux411-catalyst, then installing linux410 and linux410-catalyst though. And that worked.


#45

Very Easy upgrade for me thank you.


#46

[quote=“philm, post:43, topic:22921, full:true”]Does it also happen with linux412?
[/quote]Just tested too, yes.
Faulty function is the same.

EDIT: patch was sent a couple of days ago https://aur.archlinux.org/packages/catalyst-test/#comment-597649


#47

@mirh: I’ve updated the package with the needed patch. Can you check once more if it works now?


#48

It’s good!


#49

After kernel update 4.12 every Virtualbox VM freezes whole systemc after start.


#50