[Unstable Update] 2017-05-02 - Plasma5, Gnome, VirtualBox, OpenSSL



Did you follow the part, where he said to install and AUR package for it?

That needs to be done first, then launch games with the command. :slight_smile:


Try also the following launch options:

LD_PRELOAD=/usr/lib/libcrypto-compat.so.1.0.0 %command%


LD_PRELOAD='/usr/lib/openssl-1.0-compat/libssl.so.1.0.0:/usr/lib/openssl-1.0-compat/libcrypto.so.1.0.0' %command%


Yep, did that as a necessity to get Spotify, Skype and some other games working in Steam.

No luck. :frowning:

EDIT: Doh, of course it doesn’t work. I’ve got libopenssl-1.0-compat installed, but not lib32-libopenssl-1.0-compat.

I picked the wrong week to quit bath salts. :innocent:


Plasma+openrc+btrfs nvidia 304 driver rtl8192eu wifi dongle.
Apparently all work correctly, the only problem to dkms the rtl8192eu.
This is the error:

Building module:
cleaning build area...
'make' all...(bad exit status: 2)
Error! Bad return status for module build on kernel: 4.11.0-1-MANJARO (x86_64)
Consult /var/lib/dkms/rtl8192eu/1.0/build/make.log for more information.

This is the log text:

DKMS make.log for rtl8192eu-1.0 for kernel 4.11.0-1-MANJARO (x86_64)
Wed May  3 11:15:53 CEST 2017
make ARCH=x86_64 CROSS_COMPILE= -C /lib/modules/4.11.0-1-MANJARO/build M=/var/lib/dkms/rtl8192eu/1.0/build  modules
make[1]: Entering directory '/usr/lib/modules/4.11.0-1-MANJARO/build'
  CC [M]  /var/lib/dkms/rtl8192eu/1.0/build/core/rtw_cmd.o
In file included from /var/lib/dkms/rtl8192eu/1.0/build/include/drv_types.h:32:0,
                 from /var/lib/dkms/rtl8192eu/1.0/build/core/rtw_cmd.c:22:
/var/lib/dkms/rtl8192eu/1.0/build/include/osdep_service.h: In function ‘thread_enter’:
/var/lib/dkms/rtl8192eu/1.0/build/include/osdep_service.h:342:2: error: implicit declaration of function ‘allow_signal’ [-Werror=implicit-function-declaration]
/var/lib/dkms/rtl8192eu/1.0/build/include/osdep_service.h: In function ‘flush_signals_thread’:
/var/lib/dkms/rtl8192eu/1.0/build/include/osdep_service.h:352:6: error: implicit declaration of function ‘signal_pending’ [-Werror=implicit-function-declaration]
  if (signal_pending (current))
/var/lib/dkms/rtl8192eu/1.0/build/include/osdep_service.h:354:3: error: implicit declaration of function ‘flush_signals’ [-Werror=implicit-function-declaration]
cc1: some warnings being treated as errors
make[2]: *** [scripts/Makefile.build:295: /var/lib/dkms/rtl8192eu/1.0/build/core/rtw_cmd.o] Error 1
make[1]: *** [Makefile:1492: _module_/var/lib/dkms/rtl8192eu/1.0/build] Error 2
make[1]: Leaving directory '/usr/lib/modules/4.11.0-1-MANJARO/build'
make: *** [Makefile:1335: modules] Error 2

No problem with 4.10 upgrade.


rtl8192eu you have to patch. Something similar like this.


I try


Most Steam apps which need OPENSSL_1.0.0 can by tricked by installing openssl-1.0-compat and/or lib32-openssl-1.0-compat from our unstable repos.

Then either do:

LD_PRELOAD='/usr/$LIB/openssl-1.0-compat/' %command%

Or create symlinks to: /usr/lib{32}/openssl-1.0-compat/libssl.so.1.0.0’ and ‘/usr/lib{32}/openssl-1.0-compat/libcrypto.so.1.0.0’ within for example ~/.steam/steam/steamapps/common/Tomb Raider/lib/i686/

ln -sfv /usr/lib/openssl-1.0-compat/libssl.so.1.0.0 ~/.steam/steam/steamapps/common/Tomb Raider/lib/i686/libssl.so.1.0.0
ln -sfv /usr/lib/openssl-1.0-compat/libcrypto.so.1.0.0 ~/.steam/steam/steamapps/common/Tomb Raider/lib/i686/libcrypto.so.1.0.0

ln -sfv /usr/lib32/openssl-1.0-compat/libssl.so.1.0.0 ~/.steam/steam/steamapps/common/Tomb Raider/lib/i686/libssl.so.1.0.0
ln -sfv /usr/lib32/openssl-1.0-compat/libcrypto.so.1.0.0 ~/.steam/steam/steamapps/common/Tomb Raider/lib/i686/libcrypto.so.1.0.0


Thanks a lot @philm for the “official fix”. :slight_smile:

I confirm that packages and command (as launch option) works for me (for “Life is strange”) but is enough (and better) the command:

LD_LIBRARY_PATH=/usr/lib/openssl-1.0-compat/ %command% 

instead of:

LD_PRELOAD='/usr/lib/openssl-1.0-compat/libssl.so.1.0.0:/usr/lib/openssl-1.0-compat/libcrypto.so.1.0.0':'/usr/lib32/openssl-1.0-compat/libssl.so.1.0.0':'/usr/lib32/openssl-1.0-compat/libcrypto.so.1.0.0' %command%

The second one also works but for some reason the fps of game disappears.
I don’t know if the first command is enough for other games though.


After this update I noticed the following in Xfce.
When Thunar was open (regardless of any other applications being open or not), the .xsession-errors file kept filling up with this message (I didn’t experience crashes or loss of fuctionality, though)

(Thunar:586): GLib-CRITICAL **: g_file_test: assertion ‘filename != NULL’ failed

Downgrading Thunar didn’t help, so I downgraded everything to stable and then this stopped, so it must have to do with some package(s) in this upgrade, just not sure which.


dont forget to install 32bit libs

sudo pacman -Syyu lib32-openssl-1.0{,-compat}


BTW, better use $LIB instead of lib, so it will use the right architecture by itself, without trying 64bit first.
LD_PRELOAD='/usr/$LIB/openssl-1.0-compat/libssl.so.1.0.0 /usr/$LIB/openssl-1.0-compat/libcrypto.so.1.0.0' %command%

Thanks for providing these things via official repo :slight_smile:
& lets hope feral will come up with a fix for this…


Sorry if there was a notice somewhere else: Will there still be a testing version of this update or will this more or less become stable? I usually used the testing branch but if it isn’t as such less risky happy to switch to unstable


I’ve used sudo pacman -Syyu --force to update openssh and openssl forcibly.
It needs to update over files that already exist in the file system. :slight_smile:
Problems with ICU will not occur if you update all the packages at once. So I did not get into trouble with this package. :wink:


Just one question…Unstable KDE is not working for me. SDDM does not start Networkmanager needs icu 5.8…is there any ETA ? :wink:


What do you mean with that? How come? Don’t get the connection here …


I installed 17.0.1 KDE a time ago…I want to test unstable and changed the pacman-mirrors.conf after pacman-mirrors -g and pacman -Suuyy NetworkManager Service hangs on boot and SDDM does not start due to openssl error…I unpacked the old icu58 package and copied libicuuc.so.58 to /usr/lib/ after that I could start NetworkManager again but SDDM still does not start…I downgraded to stable again and it working fine again.

Have to add that I installed my system with manjaro-architect due to snapper and pac-snap with btrfs.


@mac: which exact version of package network-manager got installed? It is strange, since KDE is widely used and you’re one of the few complaining about it. Can you check with the mirror Netzspielplatz in Germany to see if the current updates fixes your issue?


the patch must be applied to the file osdep_service.h and it is:

 * Copyright(c) 2007 - 2013 Realtek Corporation. All rights reserved.
 * This program is free software; you can redistribute it and/or modify it
 * under the terms of version 2 of the GNU General Public License as
 * published by the Free Software Foundation.
 * This program is distributed in the hope that it will be useful, but WITHOUT
 * ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
 * FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License for
 * more details.
 * You should have received a copy of the GNU General Public License along with
 * this program; if not, write to the Free Software Foundation, Inc.,
 * 51 Franklin Street, Fifth Floor, Boston, MA 02110, USA
#ifndef __OSDEP_SERVICE_H_
#define __OSDEP_SERVICE_H_

// PATCH Kernel 411 --> START
#include <linux/version.h>
#include <linux/sched/signal.h>
// PATCH Kernel 411 --< END

#define _FAIL		0
#define _SUCCESS	1
#define RTW_RX_HANDLED 2

The same patch must be applied to the 8192cu driver. Anyway: its still present in the 8192eu git but NOT in 8192cu git. Just for info :slight_smile:


I’m glad to see new nvidia lts driver is in the repo, but it will need a rebuild of the kernels. See attached output:

[anon@loonix ~]$ sudo pacman -Syu [sudo] password for anon: :: Synchronizing package databases... core is up to date extra is up to date community is up to date :: Starting full system upgrade... resolving dependencies... looking for conflicting packages... error: failed to prepare transaction (could not satisfy dependencies) :: linux-rt-manjaro-nvidia: installing nvidia-utils (1:375.66-1) breaks dependency 'nvidia-utils=1:375.39'


Am I the only one always having the same issue when Nvidia drivers are updated?

When rebooting, X won’t start and the journal is full of this error repeated over and over:

NVRM: API mismatch: the client has the version 375.66, but NVRM: this kernel module has the version 375.39. Please NVRM: make sure that this kernel module and all NVIDIA driver NVRM: components have the same version.

The fix, for me, is to boot into recovery using a different kernel version than I normally use, and then remove and reinstall the kernel using mhwd-kernel -r and mhwd-kernel -i. That way, the new Nvidia drivers and its modules are properly installed.

Just reinstalling the kernel without removing it first won’t do it as the older Nvidia modules remain “sticky” for whatever reason. Neither does it work to remove and reinstall the Nvidia drivers using mhwd -r pci video-nvidia followed by mhwd -i pci video-nvidia.

[Testing Update] 2018-01-06 - Browsers, Nvidia, PHP, Compiz, Repo-Cleanup
[Testing Update] 2017-06-28 - Kernels, Cinnamon, Deepin, Calamares, Plasma 5
[Testing Update] 2017-09-24 - Nvidia, Gambas, JADE, Haskell, JDK9, Python

It looks like I just got linux49 4.9.26-1
Easy update on LXQt via Octopi, rebooted the VirtualBox, and all is well, thanks.