[Unstable Update] 2017-05-02 - Plasma5, Gnome, VirtualBox, OpenSSL

unstable
update

#1

Hi community,

seems somebody is really angry about Manjaro lately. Therefore I spent most of my time to restore our Main-Webserver. It took a while to complete all tasks. This forum however and our repositories weren’t affected by all this.

I found some time to compare our current stable branch with what is going on within unstable. We had several updates:

Please test and give us feedback as usual


Current supported Kernels

  • linux310 3.10.105
  • linux312 3.12.73
  • linux316 3.16.42
  • linux318 3.18.51
  • linux41 4.1.39
  • linux44 4.4.65
  • linux48 4.8.17 [EOL]
  • linux49 4.9.25
  • linux410 4.10.13
  • linux411 4.11.0
  • linux-RT-LTS 4.4.60_rt73
  • linux-RT 4.9.20_rt16

Package Updates (Tue May 2 10:49:36 CEST 2017)

A detailed list of package changes can be found here.


  • No issues, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself. (Please post your solution)
  • Yes I am currently experiencing an issue due to the update. (Please post about it)

0 voters


Check if your mirror has already synced:


Install VirtualBox 5.1.22 please
#2

Networking is broken for me on linux411, because of missing linux411-r8168 maybe? Back on 410 everythings fine.

mhwd -l 
> 0000:04:00.0 (0200:10ec:8168) Network controller Realtek Semiconductor Co., Ltd.:
--------------------------------------------------------------------------------
                  NAME               VERSION          FREEDRIVER           TYPE
--------------------------------------------------------------------------------
         network-r8168            2016.04.20                true            PCI

other than that everything works perfectly for me :thumbsup:


#3

Easy upgrade, thanks!

My 64-bit LXQt guest is running fine with virtualbox-guest-utils and linux49-virtualbox-guest-modules both upgraded to 5.1.22-1, even though their host (KDE Stable) is still at 5.1.20.


#4

“We still don’t recommend to use linux411 series” xD


#5

Working fine in VBox - no problems happened to me


#6

no problems with 4.11 here - using it since rc6 on my main system.


#7

Everything fine except one issue:

I still don’t know what causes this behaviour since it occurs randomly.


#8

This is not related on the update … is a Gnome issue : have you try to login not in wayland but in Xorg ?
At last you can switch form gdm to lightdm …


#9

As i mentioned in the morning when there where some troubles with the mirrors, i switched to pacman-mirrors-dev and from testing to unstable and i can say that everything went smooth and clean. 229 packages and i could say that tis update seems to be rock solid stable for an unstable update.
Really awesome!!!
Cheers!


#10

but I wanted to try :stuck_out_tongue: it’s unstable, so I dont expect it to work


#11

Woo! Finally! Going to get that 4.11 from the unstable branch.


#12

Tried with my Manjaro Mate in virtual box and surprisingly everything worked, including the linux411 kernel.
For being unstable updates these one’s were pretty stable.


#13

I was able to fix this. Just needed to write the r8169 driver to a modules-load file and rebuild mkinitcpio and it was able to successfully use this driver. No need for the r8168 anymore. :grinning:

I still don’t get why it don’t wants to load r8169 (and use) just by itself, without a modules-load entry, tho


#14

I added some more extramodules for linux411 series. Please test.

extra/linux411-acpi_call 1.1.0-0.4 (linux411-extramodules)
    A linux kernel module that enables calls to ACPI methods through
    /proc/acpi/call
extra/linux411-bbswitch 0.8-0.4 (linux411-extramodules)
    kernel module allowing to switch dedicated graphics card on Optimus laptops
extra/linux411-broadcom-wl 6.30.223.271-0.4 (linux411-extramodules)
    Broadcom 802.11 Linux STA wireless driver BCM43142.
extra/linux411-nvidia-304xx 1:304.134-0.4 (linux411-extramodules)
    NVIDIA drivers for linux.
extra/linux411-nvidia-340xx 340.101-0.4 (linux411-extramodules)
    NVIDIA drivers for linux.
extra/linux411-nvidiabl 0.88-0.4 (linux411-extramodules)
    Driver to adjust display backlight on modern mobile NVidia graphics
    adapters.
extra/linux411-r8168 8.044.02-0.4 (linux411-extramodules)
    A kernel module for Realtek 8168 network cards
extra/linux411-rt3562sta 2.4.1.1_r4-0.4 (linux411-extramodules)
    Ralink RT3562 PCI WLAN adaptors kernel module
extra/linux411-tp_smapi 0.41-0.4 (linux411-extramodules)
    Modules for ThinkPads SMAPI functionality
extra/linux411-vhba-module 20161009-0.4 (linux411-extramodules)
    Kernel module that emulates SCSI devices
extra/linux411-virtualbox-guest-modules 5.1.22-0.4 (linux411-extramodules)
    Guest kernel modules for VirtualBox
extra/linux411-virtualbox-host-modules 5.1.22-0.4 (linux411-extramodules)
    Host kernel modules for VirtualBox

#15

The only issue with latest updates is that openssl-1.0 breaks some games on steam (the “Life is strange” to me).

Workaround is to install libopenssl-1.0-compat from AUR and use
LD_LIBRARY_PATH=/usr/lib/openssl-1.0-compat/ %command%
as launch option in game properties on steam.

https://bugs.archlinux.org/task/53618?project=1&cat[0]=2&string=openssl-1.0
https://bbs.archlinux.org/viewtopic.php?id=225539


#16

Awww, no regular linux411-nvidia module yet? :stuck_out_tongue:


#17

Some more to the bunch :wink:

extra/linux411-catalyst 1:15.201.1151-0.4 (linux411-extramodules)
    AMD/ATI Catalyst drivers for linux. fglrx kernel module only.
extra/linux411-nvidia 1:375.39-0.4 (linux411-extramodules) 
    NVIDIA drivers for linux.

Still struggling with ndiswrapper and spl_zfs


#18

… and here we go :smile:


#19

Any idea if there’s a way to get Age of Wonders III working again? The workaround above doesn’t work with it. When starting it from a terminal, it says:

./AoW3: /usr/lib32/libssl.so.1.0.0: version `OPENSSL_1.0.0' not found (required by ./AoW3) ./AoW3: /usr/lib32/libcrypto.so.1.0.0: version `OPENSSL_1.0.0' not found (required by ./AoW3)


#20

Everything is working ok with linux411 and the nvidia drivers :grinning: