[Unstable Update] 2017-02-25 - PKGfile, Calamares, QT5-Webengine

unstable
update

#1

Hi community,

Guillaume and I worked hard to get file db support into our repositories. Seems we have succeeded now.

phil@manjaro ~/dev/boxit-work/unstable/community/x86_64 $ sudo pkgfile --update
:: Updating 4 repos…
download complete: multilib [ 338.7 KiB 1391K/s 3 remaining]
download complete: core [ 1386.9 KiB 2.80M/s 2 remaining]
download complete: extra [ 7.3 MiB 4.09M/s 1 remaining]
download complete: community [ 18.3 MiB 7.51M/s 0 remaining]
:: download complete in 2.44s < 27.3 MiB 11.2M/s 4 files >
:: waiting for 1 process to finish repacking repos…

With Calamares v3.1 we ship the last release maintained by Teo. All the best to you my friend. It was great working with you on that project. A backport fix for popup menus focus issue got also added to qt5-webengine.

Please test and give us feedback as usual


Current supported Kernels

  • linux310 3.10.105
  • linux312 3.12.70
  • linux316 3.16.40
  • linux318 3.18.48 [EOL]
  • linux41 4.1.38
  • linux44 4.4.51
  • linux48 4.8.17 [EOL]
  • linux49 4.9.12
  • linux410 4.10.0
  • linux-RT-LTS 4.4.47_rt59
  • linux-RT 4.9.9_rt9

Package Updates (Sat Feb 25 16:07:22 CET 2017)

:: Different overlay package(s) in repository community i686

-------------------------------------------------------------------------------
                             PACKAGE              testing             unstable
-------------------------------------------------------------------------------
       manjaro-xfce-minimal-settings           20170224-1           20170225-1
               manjaro-xfce-settings           20170224-1           20170225-1
                   manjaro-architect                    -0.7.4.r144.gce843e2-1
               manjaro-architect-dev                    -0.7.4.r144.gce843e2-1
      manjaro-architect-dev-launcher                    -0.7.4.r144.gce843e2-1
          manjaro-architect-launcher                    -0.7.4.r144.gce843e2-1


:: Different sync package(s) in repository community i686

-------------------------------------------------------------------------------
                             PACKAGE              testing             unstable
-------------------------------------------------------------------------------
                                maim             3.4.47-2             4.4.50-1
                                 pcb           20140316-3            1:4.0.0-1
                    python-traitlets              4.3.1-3              4.3.2-1
                   python2-traitlets              4.3.1-3              4.3.2-1
                            rsibreak             0.12.5-1             0.12.6-1
                                slop             4.3.21-2             5.3.28-1


:: Different overlay package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE              testing             unstable
-------------------------------------------------------------------------------
       manjaro-xfce-minimal-settings           20170224-1           20170225-1
               manjaro-xfce-settings           20170224-1           20170225-1
                   manjaro-architect                    -0.7.4.r144.gce843e2-1
               manjaro-architect-dev                    -0.7.4.r144.gce843e2-1
      manjaro-architect-dev-launcher                    -0.7.4.r144.gce843e2-1
          manjaro-architect-launcher                    -0.7.4.r144.gce843e2-1


:: Different sync package(s) in repository community x86_64

-------------------------------------------------------------------------------
                             PACKAGE              testing             unstable
-------------------------------------------------------------------------------
                                maim             3.4.47-2             4.4.50-1
                                 pcb           20140316-3            1:4.0.0-1
                    python-traitlets              4.3.1-3              4.3.2-1
                   python2-traitlets              4.3.1-3              4.3.2-1
                            rsibreak             0.12.5-1             0.12.6-1
                                slop             4.3.21-2             5.3.28-1


:: Different overlay package(s) in repository extra i686

-------------------------------------------------------------------------------
                             PACKAGE              testing             unstable
-------------------------------------------------------------------------------
                           calamares              3.0.1-8              3.1.0-1
                    calamares-dev3.0.91.r3087.e9e8b47c-13.1.0.r3093.6bb046fa-1


:: Different sync package(s) in repository extra i686

-------------------------------------------------------------------------------
                             PACKAGE              testing             unstable
-------------------------------------------------------------------------------
                             mutagen             1.36.2-1               1.37-1
                              octave              4.2.0-1              4.2.1-1
                      python-mutagen             1.36.2-1               1.37-1
                       qt5-webengine              5.8.0-2              5.8.0-3
               xfce4-diskperf-plugin              2.6.0-1              2.6.1-1
                 xfce4-genmon-plugin              3.4.0-3              4.0.0-1
                             pkgfile                    -                 15-1


:: Different overlay package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE              testing             unstable
-------------------------------------------------------------------------------
                           calamares              3.0.1-8              3.1.0-1
                    calamares-dev3.0.91.r3087.e9e8b47c-13.1.0.r3093.6bb046fa-1


:: Different sync package(s) in repository extra x86_64

-------------------------------------------------------------------------------
                             PACKAGE              testing             unstable
-------------------------------------------------------------------------------
                             mutagen             1.36.2-1               1.37-1
                              octave              4.2.0-1              4.2.1-1
                      python-mutagen             1.36.2-1               1.37-1
                       qt5-webengine              5.8.0-2              5.8.0-3
               xfce4-diskperf-plugin              2.6.0-1              2.6.1-1
                 xfce4-genmon-plugin              3.4.0-3              4.0.0-1
                             pkgfile                    -                 15-1

  • No issues, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself. (Please post your solution)
  • Yes I am currently experiencing an issue due to the update. (Please post about it)

0 voters


Check if your mirror has already synced:


How to get the files included in a package?
I dont get it...one file vs a lot of files
#2

Thanks a lot @philm for file db support!
Now manjaro has a functioning pkgfile. :slight_smile:
It works without issues for me:

giorgos@manjaro ~ sudo pkgfile --update
[sudo] password for giorgos: 
:: Updating 4 repos...
  multilib is up to date
  extra is up to date
  community is up to date
  core is up to date

#3

pkgfile ? no but

pacman -Fy
#and pacman -Fh ...

#4

Outstanding!

Me too…

$ sudo pkgfile --update
:: Updating 4 repos...
  download complete: multilib             [   338.7 KiB   398K/s  3 remaining]
  download complete: core                 [  1387.9 KiB   518K/s  2 remaining]
  download complete: extra                [     7.3 MiB   786K/s  1 remaining]
  download complete: community            [    18.3 MiB  1298K/s  0 remaining]
:: download complete in 14.47s            <    27.3 MiB  1933K/s  4 files    >
:: waiting for 1 process to finish repacking repos...
$ pkgfile -l manjaro-architect
community/manjaro-architect     /etc/
community/manjaro-architect     /etc/skel/
community/manjaro-architect     /etc/skel/.config/
community/manjaro-architect     /etc/skel/.config/autostart/
community/manjaro-architect     /etc/skel/.config/autostart/ma-launcher.desktop
community/manjaro-architect     /usr/
community/manjaro-architect     /usr/bin/
community/manjaro-architect     /usr/bin/btrfs-subvol-functions
community/manjaro-architect     /usr/bin/ma-launcher
community/manjaro-architect     /usr/bin/manjaro-architect
community/manjaro-architect     /usr/lib/
community/manjaro-architect     /usr/lib/manjaro-architect/
community/manjaro-architect     /usr/lib/manjaro-architect/util-base.sh
community/manjaro-architect     /usr/lib/manjaro-architect/util-desktop.sh
community/manjaro-architect     /usr/lib/manjaro-architect/util-disk.sh
community/manjaro-architect     /usr/lib/manjaro-architect/util-menu.sh
community/manjaro-architect     /usr/lib/manjaro-architect/util.sh
community/manjaro-architect     /usr/share/
community/manjaro-architect     /usr/share/applications/
community/manjaro-architect     /usr/share/applications/manjaro-architect.desktop
community/manjaro-architect     /usr/share/icons/
community/manjaro-architect     /usr/share/icons/hicolor/
community/manjaro-architect     /usr/share/icons/hicolor/48x48/
community/manjaro-architect     /usr/share/icons/hicolor/48x48/apps/
community/manjaro-architect     /usr/share/icons/hicolor/48x48/apps/manjaro-architect.png
community/manjaro-architect     /usr/share/manjaro-architect/
community/manjaro-architect     /usr/share/manjaro-architect/package-lists/
community/manjaro-architect     /usr/share/manjaro-architect/package-lists/base-openrc-manjaro
community/manjaro-architect     /usr/share/manjaro-architect/package-lists/base-systemd-manjaro
community/manjaro-architect     /usr/share/manjaro-architect/package-lists/input-drivers
community/manjaro-architect     /usr/share/manjaro-architect/translations/
community/manjaro-architect     /usr/share/manjaro-architect/translations/danish.trans
community/manjaro-architect     /usr/share/manjaro-architect/translations/dutch.trans
community/manjaro-architect     /usr/share/manjaro-architect/translations/english.trans
community/manjaro-architect     /usr/share/manjaro-architect/translations/french.trans
community/manjaro-architect     /usr/share/manjaro-architect/translations/german.trans
community/manjaro-architect     /usr/share/manjaro-architect/translations/hungarian.trans
community/manjaro-architect     /usr/share/manjaro-architect/translations/italian.trans
community/manjaro-architect     /usr/share/manjaro-architect/translations/portuguese.trans
community/manjaro-architect     /usr/share/manjaro-architect/translations/portuguese_brasil.trans
community/manjaro-architect     /usr/share/manjaro-architect/translations/russian.trans
community/manjaro-architect     /usr/share/manjaro-architect/translations/spanish.trans

Tis a thing of beauty

$ pkgfile -s /usr/share/manjaro-architect/translations/spanish.trans
community/manjaro-architect
community/manjaro-architect-dev

#5

This morning, I got this:
https://www.kde.org/announcements/announce-applications-16.12.3.php

All is good, thank you.


#6

Hello guys, when nvidia-378 will be available? There are many bug fixes in this driver release.
Thanks in advance!


#7

as soon as it is stable - with the nvidia driver quality of the last year, it will take 2-3 months after release to be stable enough for all users.


#8

Thanks!
This just was a misunderstanding of unstable branch. I thought it is possible to have unstable nvidia-378 on unstable Manjaro branch and keep 375 on stable and testing


#9

I’m not on unstable, but I’m happy about that incoming update. It will be great to be able to do: pacman -Fs package


#10