[Unstable Update] 2017-01-29 - QT 5.8, LibreOffice, NetworkManager, FF, TB, Manjaro Tools



Well to know that.
I know only Deep House Music :stuck_out_tongue_winking_eye:


out of sudden while playing games KDE environment goes all black screen, all monitors goes black and whatever I have in screen open windows , widgets etc goes black then after a few secs it recovers but sometimes it doesnt so I have to log out.

I haven’t noticed that behaviour while not playing games… need more investigation…
I dont know what I have changed but I think maybe is because of steam ???
as far as I remember I have changed today Steam to use Runtime than Native … is that causing this issue? Oo?


Didn’t know this had to be explicitly installed. Thanks.


qt5.8 breaks Plasma5 on wayland, there are lots of issues currently.

How can I downgrade the entire qt5.8 based packages with dependencies?
downgrade qt5-base was not OK.


for me as a Plasma user is a bit annoying crashing the desktop while using opengl games/software so I thing I am gonna visit the Testing or Stable repo for a while…


Can anyone comment on this?


like as they got removed from repos. if no other packages depends on them in your installation you can remove then safely.


Just making sure as this is unstable and their removal from the unstable repos may not have been intentional. Thanks.


as you can see here. it’s on purpose. after if you have any problem because they are missing. report a bug.



According to the above sources the following environment value is a workaroung to the QT5.8 issues: QML_DISABLE_DISK_CACHE=1


After testing again today the unstable repo with the new QT5.8 I have noticed that the whole KDE environment was very slow and I could notice that on start up.
Also the random KDE environment crashes occurred more often ><
I have moved to testing but somehow I had some problems with the network manager.
I was getting at boot an error about network manager failed to run a script or something like that.

Anyway I have moved to stable now and is it feels so amazing as it should be . Fast and no problems at all. :slight_smile:
I may test again the unstable when the new KDE Plasma version 5.9 lands on unstable repo.

At the moment I will enjoy the stability of Manjaro stable :stuck_out_tongue:


I’m having no issues with KDE and QT 5.8 on unstable branch. Plasma 5.9 should be on unstable branch within the next 2 days or less.





Is that an honest Yay or a Marvin the Depressed robot “Oh Joy!” ?

What is all the lather about 5.9?
This is KDE remember. Its as likely to come with as many infuriating bugs and forced marches as it is to come with actual fixes.

What does it bring that we lack?



Bah, still no wallpaper per desktop.
Bunch of flash that doesn’t fix what people have been demanding for 4 years.


Not excitement exactly, more enthusiastic curiosity to have a play with it in unstable.

Of course, as you point out, this is KDE and my initial enthusiasm may turn to brown sticky stuff after a couple of potentially bug filled hours. Time will tell.


I’d like them to bring back all the fancy desktop layouts that were in KDE4 too, instead of just Desktop and Folder View.


No problems updating Manjaro KDE 17.0 (Beta1). Thanks to @FadeMind for his advice to ignore the directory permissions warning.


on both testing and unstable repos I am getting

Failed to start Network Manager Script Dispatcher Service.

on stable is working fine…

Anyone know why??

[root@w wolfyrion]# systemctl status NetworkManager-dispatcher.service
● NetworkManager-dispatcher.service - Network Manager Script Dispatcher Service
   Loaded: loaded (/usr/lib/systemd/system/NetworkManager-dispatcher.service; enabled; vendor preset: disabled)
   Active: failed (Result: exit-code) since Fri 2017-02-03 20:14:56 EET; 2min 26s ago
  Process: 8341 ExecStart=/usr/lib/NetworkManager/nm-dispatcher (code=exited, status=127)
 Main PID: 8341 (code=exited, status=127)

Φεβ 03 20:14:56 w systemd[1]: Starting Network Manager Script Dispatcher Service...
Φεβ 03 20:14:56 w nm-dispatcher[8341]: /usr/lib/NetworkManager/nm-dispatcher: error while loading shared libraries: libnm.so.0: cannot open shared object file
Φεβ 03 20:14:56 w systemd[1]: NetworkManager-dispatcher.service: Main process exited, code=exited, status=127/n/a
Φεβ 03 20:14:56 w systemd[1]: Failed to start Network Manager Script Dispatcher Service.
Φεβ 03 20:14:56 w systemd[1]: NetworkManager-dispatcher.service: Unit entered failed state.
Φεβ 03 20:14:56 w systemd[1]: NetworkManager-dispatcher.service: Failed with result 'exit-code'.


Solved it!

just needed to install lib32-libnm