[unstable] Qt5-styleplugins has been dropped on AUR.

This morning, after searching and doing upgrades on my manjaro testing powered laptop, I noticed an error message related to qt5-styleplugins being an orphan AUR package.

Archlinux dropped it on AUR on march 25th.

https://lists.archlinux.org/pipermail/arch-commits/2019-March/589384.html

https://aur.archlinux.org/cgit/aur.git/commit/?h=qt5-styleplugins&id=571147ce160e6378efa087ddee4aaa7a64faa45c

https://aur.archlinux.org/qt5-styleplugins.git

I adopted it on AUR. Maybe a new package for Manjaro’s community repository?

4 Likes

What is it needed for? The dropped package version looked quite “old”.

I think it if needed for gtk+ style with qt…
It was removed from qt5-base long time ago and put inside qt5-styleplugins.

2 Likes

Yes, it allows you to make qt apps use your gtk theme. Nice for those who just use a few qt apps. It hasn’t been updated for gtk3, but it seems to still work.

Manjaro used to have qt5-styleplugins in the repos until a little over a year ago, I think, when arch picked it up.

1 Like

By the way, I also adopted and updated mate-menu : https://aur.archlinux.org/packages/mate-menu/

…still running xfce 4.12, it is dependency of manjaro-xfce-minimal-settings.

Yeah, actually it is a dependency of ALL xfce-settings packages! :stuck_out_tongue_winking_eye:
@philm

Kinda the most notable use, the “gtk2” style.

Which is something I use actually (for some theme, the kvantum equivalent looks way too off). Aww. :frowning:

…that’s why I use still 4.12. Kvantum is like an alien, just not belogs to xfce.

$ yay -Sii qt5-styleplugins
[...]
Required By     : manjaro-budgie-settings
                  manjaro-gnome-assets
                  manjaro-gnome-assets-dev
                  manjaro-mate-settings
                  manjaro-webdad-settings
                  manjaro-xfce-gtk3-minimal-settings
                  manjaro-xfce-gtk3-settings
                  manjaro-xfce-minimal-settings
                  manjaro-xfce-settings
                  sonar-gnome-settings
                  sonar-mate-settings
                  xfce-sx-settings
[...]

We should adopt qt5-styleplugins again in our repo. @oberon: if you’re faster, then build it. Else I’ll do it later.

2 Likes

Yes, please adopt qt5-styleplugins again. Without it, all the QT apps on Gnome look like :poop: .

I don’t know what you guys are talking. It got removed in unstable for now. testing still has it.

Looks like you won’t need to adopt it. It is back in Archlinux community repository.

https://lists.archlinux.org/pipermail/arch-commits/2019-March/591268.html

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by