[Unstable] Mate 1.18 in repo and on ISO



Don’t worry , tonight i have up to date the profile :wink:
@philm all is ok now but i’m curios to know what packages are the guilty :smirk: i have checked also the arch pkgbuild but mate-desktop is equal at the my overlay :pensive:


Last thing I did was updating mate-menu. Since the old pkgs were still present it might had pulled some other package which created the conflict. What was the full list mt pulled?


@philm Steam icon sub menu (context menu) is not available at all and after launch menu options on icon (plasma widget icon only) steam hang up whole gui.


You can try Mate 1.18 ISO if you like. Download it from here.


Downloading now, will test it on bare bones.
(running MATE right now which I installed via Manjaro Architect)

Thank you Philip.

Installed it. Runs very smooth, no problems found.
Installed wingo as tiling window manager.

Typing this as a happy clam :smile:

Manjaro rocks!


@Ste74 Mate 1.18 seems pretty stable. Just a few things:

  1. You should change the /etc/skel/.config/qt5ct/qt5ct.conf the line:




since you are using arc-maia-icon-theme or else the msm notifier isn’t shown.
2. I cannot launch qt5ct:

If I do export QT_QPA_PLATFORMTHEME=qt5ct then I can launch it from terminal. I thought that this issue was fixed on previous releases but I’m not sure so I don’t know if it’s related to the latest updates or if it was always there.


Hi , thank you to report :slight_smile:
1 was fixed now by @philm
2 we now use this approach :

this not work in mate ?


Apparently not. Command echo $QT_QPA_PLATFORMTHEME returns nothing.

EDIT: I was wrong. Command echo $QT_QPA_PLATFORMTHEME returns qt5ct and if I run qt5ct from terminal then it works fine. But when I run it from the mate control center then it throws the error.

EDIT2: Running qt5ct.desktop from caja works fine. Also, running qt5ct form the main MATE menu works fine (brisk menu doesn’t show control center’s items yet). So the problem only exists when I run it from the control-mate-center or from the advanced MATE menu, so maybe there is a bug at those making them to ignore the environmental variables and it needs to be reported on MATE devs?


Yes this make sense : seem only a problem with the mate control center …


If I put QT_QPA_PLATFORMTHEME=qt5ct at /etc/environment and reboot (logout and login is not enough) then it works with mate-control-center too. So, maybe some problem when this is set locally from ~/.profile

I cannot think of anything else, but I hope that this helps you a bit. I hope you get it fixed, if not I don’t consider it a serious problem to stall the final 17.0 MATE release.


Mate packages can now be found also in our testing branch.


Will this one have mate-indicator-applet? Found out about Mailnag, and I think it needs the indicator applet to work properly.


Testing these now. Live environment with the unstable ISOs

Lenovo Thinkpad T460s
00:00.0 Host bridge: Intel Corporation Skylake Host Bridge/DRAM Registers (rev 08)
00:02.0 VGA compatible controller: Intel Corporation HD Graphics 520 (rev 07)
00:08.0 System peripheral: Intel Corporation Skylake Gaussian Mixture Model
00:14.0 USB controller: Intel Corporation Sunrise Point-LP USB 3.0 xHCI Controller (rev 21)
00:14.2 Signal processing controller: Intel Corporation Sunrise Point-LP Thermal subsystem (rev 21)
00:16.0 Communication controller: Intel Corporation Sunrise Point-LP CSME HECI #1 (rev 21)
00:17.0 SATA controller: Intel Corporation Sunrise Point-LP SATA Controller [AHCI mode] (rev 21)
00:1c.0 PCI bridge: Intel Corporation Device 9d10 (rev f1)
00:1c.2 PCI bridge: Intel Corporation Device 9d12 (rev f1)
00:1f.0 ISA bridge: Intel Corporation Sunrise Point-LP LPC Controller (rev 21)
00:1f.2 Memory controller: Intel Corporation Sunrise Point-LP PMC (rev 21)
00:1f.3 Audio device: Intel Corporation Sunrise Point-LP HD Audio (rev 21)
00:1f.4 SMBus: Intel Corporation Sunrise Point-LP SMBus (rev 21)
00:1f.6 Ethernet controller: Intel Corporation Ethernet Connection I219-LM (rev 21)
02:00.0 Unassigned class [ff00]: Realtek Semiconductor Co., Ltd. RTS522A PCI Express Card Reader (rev 01)
04:00.0 Network controller: Intel Corporation Wireless 8260 (rev 3a)

  • right touchpad click doesn’t work
  • no function keys working
  • still similar issues affecting certain Dell and Lenovo machines in older Mate versions: screenbrightness and keyboard light settings no preserved, maximum brightness and keyboard light coming on randomly