[Unstable] Mate 1.18 in repo and on ISO

mate

#1

Hi community ,
MATE 1.18 is in our unstable repo . Check it :wink:

to perform the update before do this :

sudo pacman -Rdd mate-panel-gtk3
sudo rm /usr/share/glib-2.0/schemas/org.mate.xml*

@philm i don’t know why this broken the update :innocent:

Stefano


#2

So new MATE iso release is when this goes into stable?


#3

Yep , today also arch adopt in testing this new point release for mate . Yes is logic do the iso in 1.18 release … i hope all work My first DE is GNOME , i don’t know fine Mate . I have build the mate group for manjaro but not tried to build an iso at now … i think tonight or tomorrow try build a unsable iso for test …


#4

Tried to build but fail

error: failed to prepare transaction (conflicting dependencies)
:: mate-desktop-gtk3 and mate-desktop are in conflict
==> ERROR: Failed to install packages to new root

Mate team have completed transition to Gtk3 so Arch devs renamed all Gtk3 packages to “normal” version
for example https://www.archlinux.org/packages/?sort=&q=mate-desktop&maintainer=&flagged=

It’s time to update mate-gtk3-manjaro or even remove it


#5

Strange … mate-gtk3-manjaro now not have dependence :


and all pkgs are renamed …

Are you sure to have mate-gtk3-manjaro at ver2 ?

Temporary
https://github.com/manjaro/packages-community/blob/master/mate-gtk3-manjaro/PKGBUILD


#6

No have ver 1 in /var/cache/pacman/pkg


#7

Working great for me, but is there a gtk3 version of Mate tweak?


#8

Ok the ver 2 is ok and present on unstable repo . After a bit time i can remove it ( at now is only present to not break the update ) … Check again your mirror …


#9

Seems that there is https://aur.archlinux.org/packages/?O=0&K=mate-tweak


#10

At the moment i not considering this pkgs because also the previous version is affected by a little bug ( not all feature working how expected )


#11

Yep is the pkgs in our repo :wink:

Let me rebuild it :wink: but not sure how works now


#12

I’m using buildiso -p mate -b unstable . I’ll wait


#13

Ah … i not updtae the profiles for iso on github at the moment :grin:


#14

Just pushed now in unstable new mate tweak version : check it :wink:


#15

Re-tried and failed again some more times, this time the cause is mate-menu which has not been updated upstream

It still depend on mate-panel-gtk3 https://www.archlinux.org/packages/community/any/mate-menu/

Cryptically it was failing with the same error seen before

:: mate-desktop-gtk3 and mate-desktop are in conflict


#16

Thanks Mate tweak worked great.


#17

I assume you missed the provides=("${pkgbase}-gtk3") lines.


#18

I pulled Arch Mate 1.18 into our sync-folder. @Ste74: you may remove our overlay pkgs as needed. For mate-menu I recommend to create one with version v17.04.2 and flag the Arch one out of date.

overwritten packages:

   [OVERWRITTEN SYNC PACKAGE]  ->  [LOCAL PACKAGE]

   atril-1.18.0-1-i686.pkg.tar.xz  ->  atril-1.18.0-0.1-i686.pkg.tar.xz
   bumblebee-3.2.1-15-i686.pkg.tar.xz  ->  bumblebee-3.2.1-18-i686.pkg.tar.xz
   caja-1.18.0-1-i686.pkg.tar.xz  ->  caja-1.18.0-0.1-i686.pkg.tar.xz
   caja-extensions-common-1.18.0-1-i686.pkg.tar.xz  ->  caja-extensions-common-1.18.0-0.1-i686.pkg.tar.xz
   caja-gksu-1.18.0-1-i686.pkg.tar.xz  ->  caja-gksu-1.18.0-0.1-i686.pkg.tar.xz
   caja-image-converter-1.18.0-1-i686.pkg.tar.xz  ->  caja-image-converter-1.18.0-0.1-i686.pkg.tar.xz
   caja-open-terminal-1.18.0-1-i686.pkg.tar.xz  ->  caja-open-terminal-1.18.0-0.1-i686.pkg.tar.xz
   caja-sendto-1.18.0-1-i686.pkg.tar.xz  ->  caja-sendto-1.18.0-0.1-i686.pkg.tar.xz
   caja-share-1.18.0-1-i686.pkg.tar.xz  ->  caja-share-1.18.0-0.1-i686.pkg.tar.xz
   caja-wallpaper-1.18.0-1-i686.pkg.tar.xz  ->  caja-wallpaper-1.18.0-0.1-i686.pkg.tar.xz
   cinnamon-3.2.8-1-i686.pkg.tar.xz  ->  cinnamon-3.2.8-1.1-i686.pkg.tar.xz
   deepin-account-faces-1.0.10-1-any.pkg.tar.xz  ->  deepin-account-faces-1.0.10-3-any.pkg.tar.xz
   deepin-desktop-base-2016.11.30-1-any.pkg.tar.xz  ->  deepin-desktop-base-2016.11.30-1.1-any.pkg.tar.xz
   deepin-wallpapers-1.4-1-any.pkg.tar.xz  ->  deepin-wallpapers-20170316-1-any.pkg.tar.xz
   engrampa-1.18.0-1-i686.pkg.tar.xz  ->  engrampa-1.18.0-0.1-i686.pkg.tar.xz
   eom-1.18.0-1-i686.pkg.tar.xz  ->  eom-1.18.0-0.1-i686.pkg.tar.xz
   espeak-1:1.48.04-1-i686.pkg.tar.xz  ->  espeak-1.49.0.r58.g8320581-1-i686.pkg.tar.xz
   faenza-icon-theme-1.3.1-4-any.pkg.tar.xz  ->  faenza-icon-theme-1.3.1-5-any.pkg.tar.xz
   gtk-engine-murrine-0.98.2-2-i686.pkg.tar.xz  ->  gtk-engine-murrine-0.98.2-2.2-i686.pkg.tar.xz
   libmatekbd-1.18.0-1-i686.pkg.tar.xz  ->  libmatekbd-1.18.0-0.1-i686.pkg.tar.xz
   libmatemixer-1.18.0-1-i686.pkg.tar.xz  ->  libmatemixer-1.18.0-0.1-i686.pkg.tar.xz
   libmateweather-1.18.0-1-i686.pkg.tar.xz  ->  libmateweather-1.18.0-0.1-i686.pkg.tar.xz
   marco-1.18.0-1-i686.pkg.tar.xz  ->  marco-1.18.0-1.1-i686.pkg.tar.xz
   mate-applets-1.18.0-1-i686.pkg.tar.xz  ->  mate-applets-1.18.0-0.1-i686.pkg.tar.xz
   mate-backgrounds-1.18.0-1-any.pkg.tar.xz  ->  mate-backgrounds-1.18.0-0.1-any.pkg.tar.xz
   mate-common-1.18.0-1-any.pkg.tar.xz  ->  mate-common-1.18.0-0.1-any.pkg.tar.xz
   mate-control-center-1.18.0-1-i686.pkg.tar.xz  ->  mate-control-center-1.18.0-0.1-i686.pkg.tar.xz
   mate-desktop-1.18.0-1-i686.pkg.tar.xz  ->  mate-desktop-1.18.0-0.2-i686.pkg.tar.xz
   mate-icon-theme-1.18.0-1-any.pkg.tar.xz  ->  mate-icon-theme-1.18.0-0.1-any.pkg.tar.xz
   mate-icon-theme-faenza-1.18.0-1-any.pkg.tar.xz  ->  mate-icon-theme-faenza-1.18.0-0.1-any.pkg.tar.xz
   mate-media-1.18.0-1-i686.pkg.tar.xz  ->  mate-media-1.18.0-0.1-i686.pkg.tar.xz
   mate-menus-1.18.0-1-i686.pkg.tar.xz  ->  mate-menus-1.18.0-0.1-i686.pkg.tar.xz
   mate-netbook-1.18.0-1-i686.pkg.tar.xz  ->  mate-netbook-1.18.0-0.1-i686.pkg.tar.xz
   mate-notification-daemon-1.18.0-1-i686.pkg.tar.xz  ->  mate-notification-daemon-1.18.0-0.1-i686.pkg.tar.xz
   mate-panel-1.18.0-1-i686.pkg.tar.xz  ->  mate-panel-1.18.0-0.1-i686.pkg.tar.xz
   mate-polkit-1.18.0-1-i686.pkg.tar.xz  ->  mate-polkit-1.18.0-0.1-i686.pkg.tar.xz
   mate-power-manager-1.18.0-1-i686.pkg.tar.xz  ->  mate-power-manager-1.18.0-0.1-i686.pkg.tar.xz
   mate-screensaver-1.18.0-1-i686.pkg.tar.xz  ->  mate-screensaver-1.18.0-0.1-i686.pkg.tar.xz
   mate-sensors-applet-1.18.0-1-i686.pkg.tar.xz  ->  mate-sensors-applet-1.18.0-0.1-i686.pkg.tar.xz
   mate-session-manager-1.18.0-1-i686.pkg.tar.xz  ->  mate-session-manager-1.18.0-0.1-i686.pkg.tar.xz
   mate-settings-daemon-1.18.0-1-i686.pkg.tar.xz  ->  mate-settings-daemon-1.18.0-0.1-i686.pkg.tar.xz
   mate-system-monitor-1.18.0-1-i686.pkg.tar.xz  ->  mate-system-monitor-1.18.0-0.1-i686.pkg.tar.xz
   mate-terminal-1.18.0-1-i686.pkg.tar.xz  ->  mate-terminal-1.18.0-0.1-i686.pkg.tar.xz
   mate-user-guide-1.18.0-1-any.pkg.tar.xz  ->  mate-user-guide-1.18.0-0.1-any.pkg.tar.xz
   mate-user-share-1.18.0-1-i686.pkg.tar.xz  ->  mate-user-share-1.18.0-0.1-i686.pkg.tar.xz
   mate-utils-1.18.0-1-i686.pkg.tar.xz  ->  mate-utils-1.18.0-0.1-i686.pkg.tar.xz
   mozo-1.18.0-1-any.pkg.tar.xz  ->  mozo-1.18.0-0.1-any.pkg.tar.xz
   packagekit-1.1.5-1-i686.pkg.tar.xz  ->  packagekit-1.1.5-1.1-i686.pkg.tar.xz
   pluma-1.18.0-1-i686.pkg.tar.xz  ->  pluma-1.18.0-0.1-i686.pkg.tar.xz
   purple-facebook-0.9.0-1-i686.pkg.tar.xz  ->  purple-facebook-1:0.9.0-1-i686.pkg.tar.xz
   python2-caja-1.18.0-1-i686.pkg.tar.xz  ->  python2-caja-1.18.0-0.1-i686.pkg.tar.xz
   screenfetch-3.8.0-2-any.pkg.tar.xz  ->  screenfetch-3.7.0.r252.g5f15e57-1-any.pkg.tar.xz
   terminus-font-4.40-3-any.pkg.tar.xz  ->  terminus-font-4.40-3.1-any.pkg.tar.xz

:: 53 package(s) overwrite sync packages in repository community i686!
   Continue? [Y/n/d] (d=details)

#19

I removed our overlay pkgs and updated mate-menu. Please check once more.


#20

It is good to keep profiles up to date, because manjaro-architect uses them directly to installing system