[unstable] Manjaro-architect beta testing



I think this was caused by a problem with unmounting partitions upon exit. Should be fixed now.


So Budgie just shouldn’t be on the list for Openrc then, I guess :wink:
We need to exclude it aswell as Gnome…


Not really. Just added some error catching there. The message is weird, since we certainly have

if [[ -f $PROFILES ]]; then
        git -C $PROFILES pull 2>$ERR
        check_for_error "pull profiles repo" $? install_graphics_menu
        git clone ...

So, the installer shouldn’t even attempt cloning when the directory exists…


Progress seems to be really good on your end @Chrysostomus and @oberon. Still had no time to test this. What I read it seems it is getting somewhere. When ready, I recommend to bump the version somehow.

Then there should be a stable branch which only gets fixes on freezed features. And yes, fixing is easier than disabling some stuff. However, that might take longer to accomplish. Since you guys used a full featured installer and adopt it, new issues might happen. However, you all do a great job and with the given testers you get the needed feedback aswell. @sueridgepipe: thx for pushing them so hard :wink:


KDE minimal + OpenRC
DOS Partition Table + /boot 512M + swap + LUKS all right
cups-openrc NOT INSTALLED and service not activated
The installer closing is “cumbersome”, it ask me 2 times to verify installation steps I did previously (Network installation, etc…)
cfdisk don’t delete the previous flag when I want to redefine the single partitions of the harddisk (luks, swap, file system) so, in my opinion, its unusable at this level or I don’t know the cfdisk command to rewrite the info on the disk partition :). I used fdisk and all is right

I retry now using GPT Partition Table

(manjaro-architect installed and used the new version 1 hour ago, before to do the test)


Possibility of simpler layout:

We are in the process of restructuring the code to be non-recursive (read: fix the issue that causes the installer to jump to a random submenu when you try to exit). Since great majority of the recursive code is in the untouched aif parts (the options to install unconfigured desktops, networkmanager, cups and related options), I’m considering disabling those submenus until we can get them working properly. Or possibly permanently, if that is the direction that the installer should go.

What do you guys think?


Is there a [gui]-Distro that does not use GUI-networkmanager, well yes there is, mostly openrc based…
which is fine, but you’re still gonna battle with a lot of the other “untouched aif” parts that you already summarily mentioned.
I know this has been repeated, ad nauseum, but imho, the whole point of majjaro-architect has been to provide the abilty for the User to install Official/Ciommunity Manjaro Desktop iso profiles, be it from a manjaro-architect script, and/or, a manjaro-architect iso.

lol, I relaize this probably doesn’t help you much, but since dev’s, maintainer’s,…, do re-focus on the start-of-things, now and then, then it never hurts to re-visit the possibilities that make things better for the end-user, 'cause in the end, that’s what it’s all about.


I wasn’t able to make OpenRC work with Budgie. Everything seems according to the wiki, xdm, consolekit and stuff. I even tried lxdm-consolekit to no avail.

But I’ve just installed a systemd Budgie with manjaro-arcitect-dev 0.7.4.r215.gc4101a8-1, dev profile, unstable. Will see how it works.

The installer doesn’t have the loop at the end and closes correctly.

Update: Budgie works very well.


We’ve been busy all day with the new non-recursive code structure - ~800 lines of bash still to go… :stuck_out_tongue: it’s great, bigly :wink: !
Then lets pray that we didn’t break anything - and we should hopefully end up with a clean new version of the program without any of those looplooploop holes but some proper loops instead :wink:
@Chrysostomus and @papajoke are just awesome and admireable patient and I am learning tons by the hour :smiley:
Thank you all for all the testing, feedback and contributions!


It’s hard to believe how fast things are happening. It took @papajoke to spot the problem and point the proper procedure, @huluti to explain the matter and @oberon to get started with the matter. But it is happening now.


So we should hold off further testing until these changes are complete?

Sounds like a very major code refactoring, which is a good thing I suppose given the weird side effects recursion had on error handling, but a lot of testing will have to be re-done.

Keep us posted.


25 changed files
1,695 additions and 1,477 deletions


Tested the last version after updating the repos manjaro-architect-0.7.4.r215.gc4101a8-1. Almost perfect!

KDE minimal + openrc

The final loop is yet present, but less… loop: only 2 times :slight_smile:
cupsd is not activated for openrc (cupsd-openrc is not installed)

A request: you are using light blue color for the character used for the text to select (keyboard, locale, etc…), please, use a more readable color, light blue on a white background is really very difficult to read. Ok, I’m old and you are young… but be comprehensive :wink:

Great WORK!

Calamares crash on install

Late (very late) last night I uploaded a package manjaro-architect-exp. I didn’t even make a full install with it, yet, I barely checked that it is running at all… :wink:
I am almost sure that there are still some bugs in it, but anyone who would like to just run this to help us spot the possibly broken places, you can try it !! IN A SAFE ENVIRONMENT !!.
Please don’t even launch this thing on a system you will need afterwards, promise!? :wink:
:bomb: :bomb: :bug: :bomb:


Just a quck test of manjaro-archtitect-exp: KDE-minimum

  • within Unstable branch, ran pacman -Sy manjaro-architect-exp, then sudo manjaro-architect

gpt/uefi/unstable/systemd/grub/Kern 4.10

manjaro-architect 0.7.4.r226.gd11f87d-1
system: UEFI, init: systemd
set LANG=en_US.UTF-8
loadkeys us

Selected [Regular], KDE[min]

Only error that popped up was:

and after selecting [OK] it continued installing, …

relevant /.m-a.log of above error:

ERROR [disable pacman-init][1]   --install_manjaro_de_wm()<-install_manjaro_de_wm_pkg()

anyway, it did complete successfuly, and came up fine afterwards, afaik? :wink:


KDE minimal + systemd

I got the same error of scjet [disable pacman-init][1] but all work correctly


Sounds good, :slight_smile: Thanks for testing! The pacman-init error seems was just a little typo. Should be fixed now.


A pleasure :wink: I retry but, please, change that light blue color used for the selection, you are making me blind :smiley:


a GREEN against black is always a good terminal one, and easy to read too. :wink:


Interesting topic @fdc1b :wink:
Your suggestions for a config are welcome: