[unstable] Manjaro-architect beta testing

netinstall
manjaro-architect

#524

U don’t think I even understand your set up entirely. How many installation there are on that setup and what are the mountpoints?

LVM on LUKS should be supported, but I don’t really know anything about this because I have never tried LVM.


#525
  1. Encrypt two partitions, sdb1 and sdc1.

  2. Create a volume group containing both these encrypted partitions, mvg1.

  3. From the volume group create a single logical volume containing both encrypted partitions, mlv1.

  4. Mount the logical volume mvg1-mlv1, and install.

This is an edge test and probably not supported in manjaro-architect, I just want to try and get it working post install.


#526

The information specific to the architect-ISO was in the other dedicated thread. :slight_smile:

The ISO doesn’t even have manjaro-architect pre-installed but only the package manjaro-architect-launcher.
When you launch setup (sudo is not needed in the live environment) the script will open nmtui in case no internet connection is detected. This should work with lan and wifi. It’s just a CLI-wrapper for networkmanager.
Then it will install the latest available version of manjaro-architect automatically and launch it for you.
Like that you can basically use the same ISO for a very long time. Both the installer and of course all the packages installed to target will be downloaded on the spot.


#527

Okay, tonight I managed to make a rudimentary checklist for the exit dialog.
It should warn you if you have not

It is not yet translated though, and many checks get very confused if you unmount partitions before exiting installer.

I’m done for tonight.


#528

Testing some installation and find two small problem, simply:

  1. define 2 partition, one 512Mb, one all the disk (without a swap file)

and

a) I mount the bigger as root, no problem, but if I mount the smaller and I try to format it as ext2 I got an error (it seems like if ext2 is not supported

and

b) if I repeat the mount step, mounting the root partition and after the boot partition, I’ve a 255 Error telling me that is impossible to mount the partition. The only way to continue is to stop everything, clean the disk and restart.


#529

Is this uefi or legacy install? On uefi the other one needs to be fat32 to be able to boot.

Why would you want to use ext2 btw? The kernel doesn’t even have driver for it anymore, afaik it is mounted with ext4 driver. Why not use ext4 without journaling (data=writeback) instead? Anyway, I think we should just drop ext2 from options…


#530

If you have succesfully installed a manjaro edtion with manjaro-architect, go here to tick the box of your edition if it is not yet ticked:


#531

Installation is in Legacy. I tried ext2 cause it was in the list and i tested it :slight_smile: Ext4 with data=writeback is what I use for the boot partition.
I agree, better to remove the option.
I continue the test. I’m having some problems installing boot + luks partiton + swap file. Ok, Il redo and I’ll send you more info; better.
I completed an installation of Manjaro OpenRC+KDE and its working perfectly: great work: I like!


#532

Do i have to have a GitHub account to check a box? I have done an LXQT systemd install successfully but box iz greyed for me.


#533

I think you might need one. I’ll check the box.


#534

I tested Cinnamon systemd unstable with manjaro-architect-dev.
The problem is I get a Grub created which doesn’t boot correctly. I chose to install no bootloader, because I wanted to install into a btrfs subvolume, but got Grub entries. Also intel-ucode.img seems to be in a transition… Will try to fix.

It was my mistake, I defined the path to the wrong (non-existent subvolume). But for some reason one of the mkinitcpio loops in the installer updates an existing Grub from the chrooted install target. Is it necessary/intentional?

The installed Cinnamon minimal profile works fine so far.


#535

At the end of the base install fsck is removed from mkinitcpio.conf if root is on btrfs partition.

The updating of grub is triggered by 1) grub install item 2) pacman hooks in installed system. It might also be triggered by driver installation, because that item adds kernel parameters?


#536

At the end the user gets asked β€œUpdate mkinitcpio?” The last time must be the event when the β€œwrong” Grub gets created. I think in my case it was after Review config files -> editing /etc/fstab. Will see how it works next times.


#537

O-ou! Second install from the current system, I chose development profiles, getting this error:

 Manjaro Architect Installer v0.7.4 - BIOS (x86_64)
 ─────────────────────────────────────────────────────────────────────────────────────────────────────────







                     β”Œβ”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€ Install Graphical Interface ─────────────────┐
                     β”‚ Choose a full Manjaro edition or vanilla desktop            β”‚  
                     β”‚ environments                                                β”‚  
                     β”‚ β”Œβ”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β” β”‚  
                     β”‚ β”‚   1  Install Manjaro Desktop (stable profiles)          β”‚ β”‚  
                     β”‚ β”‚   2  Install Manjaro Desktop (development profiles)     β”‚ β”‚  
                     β”‚ β”‚   3  Install unconfigured desktop environments      >   β”‚ β”‚  
                     β”‚ β”‚   4  Back                                               β”‚ β”‚  
                     β”‚ β””β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”˜ β”‚  
                     β”‚                                                             β”‚  
                     β”‚                                                             β”‚  
                     β”œβ”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€  
                     β”‚                 <  OK  >         <Cancel>                   β”‚  
                     β””β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”˜  
                       




































 Manjaro Architect Installer v0.7.4 - BIOS (x86_64)
 ─────────────────────────────────────────────────────────────────────────────────────────────────────────










                           β”Œβ”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€ Error ──────────────────────┐
                           β”‚                                                 β”‚  
                           β”‚ [clone profiles repo][128] fatal: destination   β”‚  
                           β”‚ path '/usr/share/manjaro-architect/profiles'    β”‚  
                           β”‚ already exists and is not an empty directory.   β”‚  
                           β”œβ”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€  
                           β”‚                   <  OK  >                      β”‚  
                           β””β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”˜  
                             














#538

Okay, it seems someone has edited git installation part without testing modifications. This is with git or repo version of manjaro-architect?

I’ll take a look at it later today


#539

manjaro-architect-dev 0.7.4.r204.g257fe52-1

After installing Budgie OpenRC (for test) I cannot close the installer properly:

 Manjaro Architect Installer v0.7.4 - BIOS (x86_64)
 ─────────────────────────────────────────────────────────────────────────────────────────────────────────





















                              β”Œβ”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”
                              β”‚                                           β”‚  
                              β”‚ Would you like to keep the install-log?   β”‚  
                              β”‚ It will be copied to /.m-a.log of the     β”‚  
                              β”‚ target install.                           β”‚  
                              β”œβ”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€  
                              β”‚           < Yes >      < No  >            β”‚  
                              β””β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”˜  
                                
















































































 Manjaro Architect Installer v0.7.4 - BIOS (x86_64)
 ─────────────────────────────────────────────────────────────────────────────────────────────────────────












              β”Œβ”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€ Install Desktop Environments ───────────────────────┐
              β”‚                                                                          β”‚  
              β”‚ Please choose a Manjaro Environment.                                     β”‚  
              β”‚                                                                          β”‚  
              β”‚ Note that the following are currently available for systemd base only:   β”‚  
              β”‚ bspwm cinnamon deepin                                                    β”‚  
              β”‚                                                                          β”‚  
              β”‚ Use [Spacebar] to de/select options listed.                              β”‚  
              β”‚ β”Œβ”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β” β”‚  
              β”‚ β”‚                           ( ) gnome     -                            β”‚ β”‚  
              β”‚ β”‚                           ( ) kde       -                            β”‚ β”‚  
              β”‚ β”‚                           ( ) lxqt      -                            β”‚ β”‚  
              β”‚ β”‚                           ( ) xfce      -                            β”‚ β”‚  
              β”‚ β”‚                           ( ) bspwm     -                            β”‚ β”‚  
              β”‚ β”‚                           ( ) budgie    -                            β”‚ β”‚  
              β”‚ β”‚                           ( ) cinnamon  -                            β”‚ β”‚  
              β”‚ β”‚                           ( ) deepin    -                            β”‚ β”‚  
              β”‚ β”‚                           ( ) i3        -                            β”‚ β”‚  
              β”‚ β”‚                           ( ) mate      -                            β”‚ β”‚  
              β”‚ β”‚                                                                      β”‚ β”‚  
              β”‚ β”‚                                                                      β”‚ β”‚  
              β”‚ β””β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”˜ β”‚  
              β”‚                                                                          β”‚  
              β”‚                                                                          β”‚  
              β”œβ”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€  
              β”‚                       <  OK  >            <Cancel>                       β”‚  
              β””β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”€β”˜  
                














It keeps asking to install a Manjaro desktop.


#540

Should we disable the alternative gui installation parts for stable version? Just go straight into repo based (stable) manjaro edition installation?


#541

I will have think about it, before I recommend.


#542

This is a known problem with recursive structure of the installer. It shall be fixed, but it is going to take some. Since it requires temporary feature freeze for the installer, we try to get other bugs fixed first, so that the installer would remain usable in the meantime


#543

Budgie OpenRC doesn’t work. After Login I get sent back to Lightdm.
startx gives β€œwiting for .Xautority timeout” and doesn’t start X either.