[unstable] elogind update 228.1-1 breaking suspend, hibernate

The recent unstable elogind/libelogind update to 228.1-1 breaks suspend and hibernate for me (using kernel 3.16, XFCE). Or rather it breaks resuming from suspend/hibernate. When attempting to resume, the desktop appears briefly, then it goes back into suspend/hibernate. Only a hard reset can get me out of this cycle.

This occurs after using the loginctl commands for suspend and hibernate. Using the xfce4-session-logout commands produces the same results.

My issue seems similar to this old one:

I tried the logind.conf changes recommended, but no effect on the suspend/hibernate loop. Downgrading to version 227.2-1 solves the issue for now.

1 Like

I have the same kind of issues on one of my laptops.
Hybernate works, but not suspend.
I can live with it. but it is annoying.

BoxIt memo

User artoo committed following changes:

  • unstable community i686: 2 new and 2 removed package(s)
  • unstable community x86_64: 2 new and 2 removed package(s)


[New Packages]

[Removed Packages]


[New Packages]

[Removed Packages]

Please test, should be fixed.


Thanks for the quick response. Yes, that does enable resuming from suspend (I haven’t tested hibernate yet).

But on resume, the nm-applet indicates that networking is disabled (and cannot enable it), even though there is a working ethernet connection. Wifi won’t work. Restarting nm-applet has no effect. Restarting the NetworkManager service restores connected indication on nm-applet, but wifi still seems not to work (says “device not managed”). Rebooting restores complete network functionality.

EDIT: After suspend with elogind 228.3-1 these two commands restore Network Manager (and nm-applet) proper operation:

sudo rc-service NetworkManager restart
sudo nmcli dev set wlp3s0 managed yes

(with wlp3s0 replaced by your wireless interface)

1 Like

With the recent update of Cinnamon to 3.4 the shutdown, logout and restart all work now but
suspend and hibernate work but on resume have the no network connection, restarting the service works for me.
I guess this needs to be added somewhere


Thanks kindly. I hit the CLI hard and got as far as restarting NetworkManager, but I didn’t have the nmcli piece before reading this. Much obliged. Works fine now, as a workaround.


Same issue with NetworkManager on Stable branch after update elogind from 227.2-1 to 229.3-1 and libelogind from 228.3-1 to 229.3-1. Downgrade solves issue.

DE is KDE 5, Network Manager plasmoid. Kernel 4.10, 4.11

@artoo thinks this may be an issue with the network manager applet. It seemed to only affect systems using the GTK applet, but maybe your KDE system doesn’t use that?

I was able to get networking to work properly after suspend (with elogind 229.3) by installing pm-utils and configuring that to handle suspend. But to install that I had to first edit /var/lib/pacman/local/elogind-229.3-1/desc to remove the conflict with pm-utils. So this also is just a workaround.

I experienced a similar issue with NetWorkManager, here

@cimarronline, no, KDE NetworkManager plasmoid is used (update my post).

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by