[unstable branch] Steam-Manjaro/native "next gen"

unstable
steam

#41

Im sure than this is not my fault. This is a know issue. Games are developed targeting the steam runtime, so sometimes some of them doesnt work with the system libraries. But if I run the game on the terminal they usually say what is missing.

For example, for alien isolation I had to do a symlink, and for Overgrowth I had to install a sdl2 library from the repos to make it work.


#42

like already said, steam-native installs the libraries and for me, the old symlinks even interfered with steam-native.
Removed the old symlinks and now the libraries are installed and the games still run great (symlinking also uses the system-libraries, they don’t magically become steam libraries by that)

Tell us the games that won’t start and also the terminal output when you try to start them.


#43

it’s still lacking some libraries for what I see.

On Alien isolation the relevant output was

error while loading shared libraries: libpcre.so.3: cannot open shared object file: No such file or directory

and the fix was

sudo ln -s /usr/lib/libpcre.so.1 /usr/lib/libpcre.so.3

On Overgrowth it said than it was lacking sdl2_net. So I just installed it from the repos and that fixed it.

Now Devil Daggers is not working either

/media/DocumentosEXT4/SteamLibrary/steamapps/common/devildaggers/devildaggers: /usr/lib/libcurl.so.4: version `CURL_OPENSSL_3’ not found (required by /media/DocumentosEXT4/SteamLibrary/steamapps/common/devildaggers/devildaggers)

It also fixed a problem than I had on Borderlands 2.


#44

i think you understand something wrong here.

The steam-runtime is active by default in steam-manjaro

when you also install steam-native, it will be disabled and the system runtime will be used. (thats what “native”-runtime means. This will be triggered at runtime

However, even when steam-native is installed, you can set STEAM_RUNTIME yourself and that will be used.

Usually all games should run nur with steam AND native runtime. There is a known issue now with optirun/primusrun (call it whatever you want) and mesas dri prime. Because of a change in how steam handles graphicsdrivers its (for many) not possible anymore to just call steam on the dedicated graphicscard. Thats why everyone should let only the game itself start with the stronger graphicscard.

I will not blame anyone here, but with both changes (our new client AND how steam itself acts now) you should not use any strange “hack” anymore. Like @BS86 said here, they cause some trouble you will not have on a “fresh” manjaro installation.

If a game still not runs please start steam on the terminal, start the game then and post your output here. We’ll try to fix it.


#45

@eduardo do a
sudo pacman -S steam-native and check if it shows any errors


#46

see above.
But my manjaro install is like a year old, to take in mind

everything seems to be ok there.


#47

Is this with or without steam-native, with or without a STEAM_RUNTIME variable?


#48

the default launcher with steam native installed (steam runtime disabled)


#49

for devildaggers it could be this:

https://bugs.archlinux.org/task/28252

So nothing we can do on the steam-native pack. Devs have to solve this. add it to the list*

for alien isolation, can you remove that symlink and

ldd <alienisolationbinary>

?


#50

Devil Daggers seems to be broken with the steam runtime enabled too.

And the output of Alien isolation is:

]$ ldd AlienI> solation
./AlienIsolation: /usr/lib/libldap_r-2.4.so.2: no version information available (required by /media/DocumentosEXT4/SteamLibrary/steamapps/common/Alien Isolation/bin/…/lib/x86_64/libcurl.so.4)
./AlienIsolation: /usr/lib/liblber-2.4.so.2: no version information available (required by /media/DocumentosEXT4/SteamLibrary/steamapps/common/Alien Isolation/bin/…/lib/x86_64/libcurl.so.4)
./AlienIsolation: /usr/lib/libssl.so.1.0.0: no version information available (required by /media/DocumentosEXT4/SteamLibrary/steamapps/common/Alien Isolation/bin/…/lib/x86_64/libcurl.so.4)
./AlienIsolation: /usr/lib/libssl.so.1.0.0: no version information available (required by /media/DocumentosEXT4/SteamLibrary/steamapps/common/Alien Isolation/bin/…/lib/x86_64/libcurl.so.4)
./AlienIsolation: /usr/lib/libcrypto.so.1.0.0: no version information available (required by /media/DocumentosEXT4/SteamLibrary/steamapps/common/Alien Isolation/bin/…/lib/x86_64/libcurl.so.4)
linux-vdso.so.1 (0x00007ffed75b9000)
libpcre.so.3 => not found
libjpeg.so.8 => /usr/lib/libjpeg.so.8 (0x00007ff12aafc000)
libCoreFoundation.so.476 => /media/DocumentosEXT4/SteamLibrary/steamapps/common/Alien Isolation/bin/…/lib/x86_64/libCoreFoundation.so.476 (0x00007ff12a759000)
libcurl.so.4 => /media/DocumentosEXT4/SteamLibrary/steamapps/common/Alien Isolation/bin/…/lib/x86_64/libcurl.so.4 (0x00007ff12a4e2000)
libvorbis.so.0 => /usr/lib/libvorbis.so.0 (0x00007ff12a2b5000)
libpthread.so.0 => /usr/lib/libpthread.so.0 (0x00007ff12a098000)
librt.so.1 => /usr/lib/librt.so.1 (0x00007ff129e90000)
libdl.so.2 => /usr/lib/libdl.so.2 (0x00007ff129c8c000)
libSDL2-2.0.so.0 => /usr/lib/libSDL2-2.0.so.0 (0x00007ff129972000)
libSDL2_image-2.0.so.0 => /usr/lib/libSDL2_image-2.0.so.0 (0x00007ff12974f000)
libz.so.1 => /usr/lib/libz.so.1 (0x00007ff129538000)
libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x00007ff129277000)
libfontconfig.so.1 => /usr/lib/libfontconfig.so.1 (0x00007ff129033000)
libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x00007ff128cab000)
libm.so.6 => /usr/lib/libm.so.6 (0x00007ff1289a7000)
libgcc_s.so.1 => /usr/lib/libgcc_s.so.1 (0x00007ff128790000)
libc.so.6 => /usr/lib/libc.so.6 (0x00007ff1283f2000)
/lib64/ld-linux-x86-64.so.2 (0x00007ff12ad66000)
libuuid.so.1 => /usr/lib/libuuid.so.1 (0x00007ff1281ed000)
libicui18n.so.51 => /media/DocumentosEXT4/SteamLibrary/steamapps/common/Alien Isolation/bin/…/lib/x86_64/libicui18n.so.51 (0x00007ff127dd6000)
libicuuc.so.51 => /media/DocumentosEXT4/SteamLibrary/steamapps/common/Alien Isolation/bin/…/lib/x86_64/libicuuc.so.51 (0x00007ff127a45000)
libidn.so.11 => /usr/lib/libidn.so.11 (0x00007ff127811000)
librtmp.so.0 => /usr/lib/librtmp.so.0 (0x00007ff1275f6000)
libssl.so.1.0.0 => /usr/lib/libssl.so.1.0.0 (0x00007ff127385000)
libcrypto.so.1.0.0 => /usr/lib/libcrypto.so.1.0.0 (0x00007ff126f0d000)
libgssapi_krb5.so.2 => /usr/lib/libgssapi_krb5.so.2 (0x00007ff126cbf000)
liblber-2.4.so.2 => /usr/lib/liblber-2.4.so.2 (0x00007ff126ab0000)
libldap_r-2.4.so.2 => /usr/lib/libldap_r-2.4.so.2 (0x00007ff12685a000)
libogg.so.0 => /usr/lib/libogg.so.0 (0x00007ff126653000)
libbz2.so.1.0 => /usr/lib/libbz2.so.1.0 (0x00007ff126443000)
libpng16.so.16 => /usr/lib/libpng16.so.16 (0x00007ff12620d000)
libharfbuzz.so.0 => /usr/lib/libharfbuzz.so.0 (0x00007ff125f7d000)
libexpat.so.1 => /usr/lib/libexpat.so.1 (0x00007ff125d53000)
libicudata.so.51 => /media/DocumentosEXT4/SteamLibrary/steamapps/common/Alien Isolation/bin/…/lib/x86_64/libicudata.so.51 (0x00007ff124609000)
libkrb5.so.3 => /usr/lib/libkrb5.so.3 (0x00007ff124324000)
libk5crypto.so.3 => /usr/lib/libk5crypto.so.3 (0x00007ff1240f3000)
libcom_err.so.2 => /usr/lib/libcom_err.so.2 (0x00007ff123eef000)
libkrb5support.so.0 => /usr/lib/libkrb5support.so.0 (0x00007ff123ce2000)
libkeyutils.so.1 => /usr/lib/libkeyutils.so.1 (0x00007ff123ade000)
libresolv.so.2 => /usr/lib/libresolv.so.2 (0x00007ff1238c7000)
libsasl2.so.3 => /usr/lib/libsasl2.so.3 (0x00007ff1236aa000)
libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0x00007ff123397000)
libgraphite2.so.3 => /usr/lib/libgraphite2.so.3 (0x00007ff12316b000)
libpcre.so.1 => /usr/lib/libpcre.so.1 (0x00007ff122ef8000)


#51

I have the same problem with Alien Isolation. It works with STEAM_RUNTIME=1 but not when it’s set to 0. It’s always been like that since I first bought the game, regardless of Steam version or package.

Just like @eduardo, the only missing dependency I have is libpcre.so.3. I tried installing pcre, pcre2 and lib32-pcre but it made no difference.


#52

Just nice to see that it requires libpcre.so.3 and libpcre.so.1 instead of just libpcre.so … ohh people :smiley: looks like we have to write a “game library fix”-thing for the native-runtime I think we should not do that. Include libs is OK, workaround library naming not… :sweat_smile:

Arch libpcre pkg maintainer would just say: 2not my job, upstream has to fix that." I also see no reason why it is version .3. Seems that is (again) some stupid debian naming. :confused:

So lets mark this also as dont runs on native runtime


#53

…and here i was hoping some poor soul is willing to take on the gargantuan task of fixing all the Linux games on Steam which the developers themselves are unable/don’t care to fix. :smiley: :smiley: :smiley:

One game that bothers me, is Painkiller Hell & Damnation. I paid full price for it, only to discover it’s not working no matter what I do. Reading the forums, I found out the issue is known since the Linux port was released in 2014… and no one reporting it has ever received any reply or any kind of feedback from the game devs.

When I start the game, I hear the intro sound but the screen is black. After a while I can see the Steam overlay in the lower right corner and some more intro sounds before the game crashes to desktop. The logs report only error, albeit over and over again: OpenGL error 0x502


#54

Here are my results after testing STEAM

  1. Steam runtime can run alone but is very slow , on KDE the system tray menu is not working and it freezes a bit my computer, however some games that were not running from steam menu like Deadfall Adventures is running now.

  2. Steam Native Alone is not working at all not Steam Executable etc

  3. if I install both Steam-Native and Manjaro, Steam is working much better and faster but some games like Deadfall Adventures are not running from steam menu and I have to launch them manually.

At the end I think steam is a bit of a mess, some game are working some other games not , but since all the games I play are working fine is not an issue.


#55

So for me to have everything working I had to Install both:

steam native and steam manjaro and launch steam with

env STEAM_RUNTIME=1 /usr/bin/steam %U

I have tested these games:

Painkiller Hell & Damnation
Alien Isolation
Deadfall Adventures

All are working fine!


#56

May I ask what gfx card and drivers you’re using? I can’t get that game to work on my Nvidia card.


#57

I have an NVIDIA GTX980 and I am using the latest nvidia drivers 375.26
(it took around 1-2 mins for the first time to launch but it was showing on steam that the game was running so I waited)


#58

I have tried to run devil daggers as well but I got this error

[wolfyrion@w devildaggers]$ /media/STEAM/SteamLibrary/steamapps/common/devildaggers/devildaggers
/media/STEAM/SteamLibrary/steamapps/common/devildaggers/devildaggers: /usr/lib/libcurl.so.4: version `CURL_OPENSSL_3’ not found (required by /media/STEAM/SteamLibrary/steamapps/common/devildaggers/devildaggers)

Well I think this is not a steam problem
The game actually is looking for libcur.so.3 but since Manjaro/arch updated this lib the game is not working anymore.


#59

Thats not possible. We can workaround some stuff for some time but the hard truth is that app developers need to fix stuff up… Thats why i just dont buy anything from Aspyr, because i know that they dont care about linux.

In this case you can use that workaround and create a symlink and if you want to: create a “steam-native-workarounds” package for manjaro (I’d totally help you with this).

Just give it back. Thats something you can do for all games that you havent played for 2h (or longer) or that you own for less than 14days.


^ THIS. And thats because of debian<->steamOS<->Ubuntu.


#60

that’s why they brought Civ V, Civ Beyond Earth and soon Civ VI to Linux and they work since day 1?