[unstable branch] Steam-Manjaro/native "next gen"

unstable
steam

#21

Nope thats how it should be :slight_smile:


#22

you did see that that I “fixed” the problem by renaming the files, and the part you quoted is from after the fix, meaning when steam-native successfully installed?
The part where .bckup is added are the files with which the faults happened.

the other part you quoted is a try in solving why the “already exists” happened in the first place.


#23

and you have created them by symlinking. Thats why pacman sais they where already there. after moving them to a new name everything was fine, because pacman could create the new files from inside the package.


#24

nice - yes, your work is appreciated!
Makes the symlinking stuff unnecessary :slight_smile:


#25

Errr… because it’s easier to update 100-200 game configs via UI than one .desktop file?

You must be kidding.


#26

I am getting a lot of updates from AUR about gstreamer plugins.
Dont remember using aur for gstreamer plugins.
I cannot even install them anyway.

If I remove all the gstreamer plugins some other software will be removed as well.
So anything happened with gstreamer plugins? Did manjaro removed them from their repo?
we dont need them any more?


#27

You’re up to write a bugreport to steam to support hybrid-GPU systems. Its just that for some users, with the latest steam update (client, not this package) it will not work anymore.

BTW you can also edit:
~/.local/share/Steam//userdata/*/config/localconfig.vdf and add the every game

"LaunchOptions"		"DRI_PRIME=1 %command%"

(or optirun, primusrun, whatever nvidia supports). But other than this we can not do much about it.


#28

the old gstreamer0.10 was removed (moved to AUR), you can remove them. Please also read [Testing Update] 2017-01-26 - Kernels, Virtualbox, Lumina-Desktop, GStreamer v0.10 removed
:slight_smile:


#29

I removed all my installed gstreamer0.10 packages after this update, just to see if something would break without them. It also uninstalled some stuff that was dependent on them, of which none I could recognize ever using. So far so good…


#30

Yeah primusrun/optirun broke on steam-manjaro, so I switched to steam-native which seems to work fine with primusrun so far - I’ll have to see if any games misbehave. Is this related to the client update?
http://www.phoronix.com/scan.php?page=news_item&px=Steam-Client-Beta-20170105


#31

Thanks for the instructions. I plan to test this soon as I am affected.


#32

I’m on stable repo, and I have both steam-manjaro and steam-native installed.
I have $STEAM_RUNTIME set to 0. Is this still the correct way of doing things (on stable)?


#33

If you have steam-native installed, then yes. If it’s not installed and steam-manjaro is, STEAM_RUNTIME will default to 1.

If you’re asking which setting you should be using, you’ll have to try them out. On some systems game work best if it’s 0, on others 1. Certain games may require either or.


#34

is Steam-Manjaro 1.0.0.54-5 already in stable? Otherwise don’t change anything yet :slight_smile:


#35
multilib/steam-manjaro 1.0.0.54-2 [Installiert]
multilib/steam-native 1.0.0.52-2 [Installiert]

I’m using STEAM_RUNTIME=0 for the moment, 1 crashes steam.


#36

Thats still the old steam implementation. i can’t tell anything about this one. With the new one

steam-manjaro 1.0.0.54-5
steam-native 1.0.0.54-4

you dont need STEAM_RUNTIME=0 anymore


#37

does it do any harm if one still uses it?
how does it now work to trigger the native option?

Edit: Found it myself, stupid me.
The steam startup script now checks if steam-native is installed, and if it is, it switches to STEAM_RUNTIME=0 on its own.

My KDE Menu short cut however still has the old env STEAM_RUNTIME=0 /usr/bin/steam %U command and I did not change that on my own.


#38

No :slight_smile: set everything yourself is still a thing. so it was important to let the users do this.

# Steam runtime settings
# if STEAM_RUNTIME=1, ignore this entirely
if ! [ "${STEAM_RUNTIME}" == "1" ]
    then
        # if steam-native package is installed, enable native runtime
        if [ -f "/usr/lib/steam/native_runtime.txt" ]
            then
                export STEAM_RUNTIME=0
                echo "Manjaro steam native configuration found!"
        fi
fi

Yep. It just checks if the file/usr/lib/steam/native_runtime.txt exists (that file is shipped with steam-native) and if yet, it sets STEAM_RUNTIME=0 itself.


#39

this disablement of the steam runtime explain why several games doesn’t work. Anyway, I will just enable it, or find workarounds to fix those, usually a symlink or the instalation of some package fix them. But having 2 launchers was nice.


#40

remove steam-native or set STEAM_RUNTIME=1 : Steam uses the runtime like before

install steam-native and start steam without any further launch options: all necessary libraries are installed, no need to symlink anymore and no need for 2 different launchers.

You are doing something wrong if games don’t start. Here all are starting, including those that required the steam runtime before.