Unrecoverable user name and root passwords


As a new user of Manjaro, I cannot recover my user name and root passwords, which I unfortunately lost, from the pre-installed version of Manjaro KDE on my Pinebook Pro laptop. In sudo mode, the current user name password is required, but I can’t recover it.

I tried to reinstall a flashed version of the OS’s .iso file on a USB stick but couln’t boot from it. As Pinebook Pro doesn’t have a BIOS access, its boot order cannot be changed.

I would therefore very much appreciate any hint or assistance from anyone who might have some familiarity with this issue.

At the Grub prompt, enter edit mode (E)
and append
to the command line

You’ll (you should) have a very limited system on TTY which allows you to alter the password
using the

ls /home
will give you the username(s)

You should at least do
after that
because the only way to reboot will be a power cycle/forced power off.

If this is a completely new Pinebook Pro, then there is no user until you boot it up and complete the setup process.
If it’s a system you bought used, you can either ask the seller for the credentials or reflash a Pinebook Pro specific image to the system, by booting an SD card with an image on it, like this one.

We don’t use .iso files on ARM, you need the device specific .img.xz image.

We don’t use Grub on ARM (yet).

Thank you for your replies, ‘Nachlese’ and ‘Strit’.


Indeed, there is no GRUB. Moreover, the passwd command asks for my current password before changing it, but I still can’t recover it.


Yes, it is a brand new Pinebook Pro. I did complete the setup process after my first boot up and it worked perfectly well on a few initial reboots but then, lest I made some mistake, it couldn’t recognize the password I entered during the initial setup process.

I confess that I am a bit at a loss here, as I am otherwise quite familiar with other Linux flavors, mainly with Ubuntu which I would also like to install. I did flash the Ubuntu 22.04 Mate desktop version on a USB stick and Manjaro can see it but I can’t boot directly from the USB key.

Any suggestions in this regard?

I didn’t realize that we are talking about an ARM device.
which thus does not use Grub as the bootloader.

Your mention of the name Pinebook Pro should have told me, but I missed it.

As I have zero experience with whatever way this device uses to boot
I cannot tell how to pass similar arguments to the boot loader as I suggested for Grub, or whether that is even possible.

With Grub and x86_64 architecture - this would have worked.

With ARM architecture and being unfamiliar with it’s boot process - I just don’t know.

but there still is another way -
IF you can access the filesystem of the device
for example by booting some kind of live media (from USB …)
… can you access it? - needs to be rw (read/write)

Since its a new device, have you tried contacting support for the device?

Maybe it’s a keyboard layout issue, if you tend to use special characters in your password.

1 Like


I don’t think it is a keyboard issue. I tend to avoid special characters and limit myself to alpha-numeric signs.

Jim B.

Thank you for the suggestion. I surely will contact support.


As I cannot recover my user password, I cannot switch to sudo mode, which is required to access the filesystem, as It is only accessible in read mode (I need to be super user in order to add the write permission). Therefore I cannot boot from a USB key or from any other live media.

Would changing the SSD and the SD card (at the right of the laptop) make it possible to re-install Manjaro and possibly another Linux flavor as a dual boot system, or can only one OS be bootable?

I don’t know - I don’t know anything about the Pinebook.

But if the filesystem is on an SD card then it would be accessible when put into another device.
…IF it is a normal filesystem - no squashfs or overlays

Then it would be way too sketchy for me to provide any advice on how to (re)set a password.

I’d guess (cave: a guess!) that the actual filesystem is on the SSD.
You’d need to access that.