Unknown device name in System Settings



System:    Kernel: 5.14.0-0-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 Console: tty pts/1 wm: kwin_x11 DM: SDDM 
           Distro: Manjaro Linux base: Arch Linux 
Machine:   Type: Laptop System: MEDION product: P6645 MD61379 v: 5.13_VEB_1AUOK026 serial: <filter> 
           Mobo: MEDION model: M15WKN v: 0.2 serial: <filter> UEFI: American Megatrends v: 206 date: 10/30/2018 
Battery:   ID-1: BAT0 charge: 39.4 Wh (100.0%) condition: 39.4/41.6 Wh (94.6%) volts: 12.8 min: 11.4 model: M153137 
           type: Unknown serial: <filter> status: Full cycles: 81 
CPU:       Info: Quad Core model: Intel Core i5-8265U bits: 64 type: MT MCP arch: Kaby Lake note: check rev: B cache: 
           L1: 256 KiB L2: 6 MiB L3: 6 MiB 
           flags: avx avx2 lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 28808 
           Speed: 900 MHz min/max: 400/3900 MHz volts: 0.7 V ext-clock: 100 MHz Core speeds (MHz): 1: 900 2: 900 3: 900 4: 900 
           5: 900 6: 900 7: 900 8: 900 
Graphics:  Device-1: Intel WhiskeyLake-U GT2 [UHD Graphics 620] driver: i915 v: kernel bus-ID: 00:02.0 chip-ID: 8086:3ea0 
           class-ID: 0300 
           Device-2: NVIDIA GP108M [GeForce MX150] vendor: Pegatron driver: nvidia v: 470.63.01 bus-ID: 02:00.0 
           chip-ID: 10de:1d10 class-ID: 0302 
           Display: server: X.Org 1.20.13 compositor: kwin_x11 driver: loaded: modesetting resolution: 1920x1080~60Hz 
           s-dpi: 96 
           OpenGL: renderer: Mesa Intel UHD Graphics 620 (WHL GT2) v: 4.6 Mesa 21.2.1 direct render: Yes 
Audio:     Device-1: Intel Cannon Point-LP High Definition Audio vendor: Pegatron driver: snd_hda_intel v: kernel 
           bus-ID: 00:1f.3 chip-ID: 8086:9dc8 class-ID: 0403 
           Sound Server-1: ALSA v: k5.14.0-0-MANJARO running: yes 
           Sound Server-2: JACK v: 1.9.19 running: no 
           Sound Server-3: PulseAudio v: 15.0 running: yes 
           Sound Server-4: PipeWire v: 0.3.34 running: yes 
Network:   Device-1: Intel Cannon Point-LP CNVi [Wireless-AC] driver: iwlwifi v: kernel port: 4000 bus-ID: 00:14.3 
           chip-ID: 8086:9df0 class-ID: 0280 
           IF: wlo1 state: up mac: <filter> 
           IF-ID-1: tun0 state: unknown speed: 10 Mbps duplex: full mac: N/A 
Bluetooth: Device-1: Intel Bluetooth 9460/9560 Jefferson Peak (JfP) type: USB driver: btusb v: 0.8 bus-ID: 1-10:4 
           chip-ID: 8087:0aaa class-ID: e001 
           Report: This feature requires one of these tools: hciconfig/bt-adapter 
Drives:    Local Storage: total: 357.72 GiB used: 180.83 GiB (50.6%) 
           ID-1: /dev/nvme0n1 vendor: Phison model: E12-256G-SSD-B3-BB1 size: 238.47 GiB speed: 31.6 Gb/s lanes: 4 
           rotation: SSD serial: <filter> rev: ECFM12.1 temp: 30 (303 Kelvin) C scheme: GPT 
           ID-2: /dev/sda vendor: Samsung model: SSD 840 PRO Series size: 119.24 GiB speed: 6.0 Gb/s rotation: SSD 
           serial: <filter> rev: 6B0Q scheme: MBR 
Partition: ID-1: / size: 233.43 GiB used: 114.04 GiB (48.9%) fs: ext4 dev: /dev/nvme0n1p2 
           ID-2: /boot/efi size: 299.4 MiB used: 300 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 
Swap:      ID-1: swap-1 type: file size: 4 GiB used: 4 MiB (0.1%) priority: -2 file: /swapfile 
Sensors:   System Temperatures: cpu: 42.0 C mobo: N/A 
           Fan Speeds (RPM): N/A 
Info:      Processes: 243 Uptime: 5h 29m wakeups: 1 Memory: 7.66 GiB used: 2.91 GiB (38.0%) Init: systemd v: 248 Compilers: 
           gcc: 11.1.0 clang: 12.0.1 Packages: pacman: 1461 Shell: Bash (sudo) v: 5.1.8 running-in: yakuake pinxi: 3.3.03-2

Just noticed, in System Settings > Hardware Configuration,
under Serial bus controller:
SPI contr.
Unknown device name
Serial IO I2C contr.
USB 3.1 xHCI contr.
SMBus contr.

I looked at dmesg but noticed nothing.
Any idea how to find out which device this is?


You’re probably looking for this:



Thanks, in lsusb I noticed nothing but lspci showed:

00:00.0 Host bridge: Intel Corporation Coffee Lake HOST and DRAM Controller (rev 0b)
00:02.0 VGA compatible controller: Intel Corporation WhiskeyLake-U GT2 [UHD Graphics 620]
00:04.0 Signal processing controller: Intel Corporation Xeon E3-1200 v5/E3-1500 v5/6th Gen Core Processor Thermal Subsystem (rev 0b)
00:08.0 System peripheral: Intel Corporation Xeon E3-1200 v5/v6 / E3-1500 v5 / 6th/7th/8th Gen Core Processor Gaussian Mixture Model
00:12.0 Signal processing controller: Intel Corporation Cannon Point-LP Thermal Controller (rev 30)
00:14.0 USB controller: Intel Corporation Cannon Point-LP USB 3.1 xHCI Controller (rev 30)
00:14.2 RAM memory: Intel Corporation Cannon Point-LP Shared SRAM (rev 30)
00:14.3 Network controller: Intel Corporation Cannon Point-LP CNVi [Wireless-AC] (rev 30)
00:15.0 Serial bus controller [0c80]: Intel Corporation Cannon Point-LP Serial IO I2C Controller #0 (rev 30)
00:15.2 Serial bus controller [0c80]: Intel Corporation Device 9dea (rev 30)
00:16.0 Communication controller: Intel Corporation Cannon Point-LP MEI Controller #1 (rev 30)
00:17.0 SATA controller: Intel Corporation Cannon Point-LP SATA Controller [AHCI Mode] (rev 30)
00:1c.0 PCI bridge: Intel Corporation Cannon Point-LP PCI Express Root Port #1 (rev f0)
00:1c.4 PCI bridge: Intel Corporation Cannon Point-LP PCI Express Root Port #5 (rev f0)
00:1d.0 PCI bridge: Intel Corporation Cannon Point-LP PCI Express Root Port #9 (rev f0)
00:1f.0 ISA bridge: Intel Corporation Cannon Point-LP LPC Controller (rev 30)
00:1f.3 Audio device: Intel Corporation Cannon Point-LP High Definition Audio Controller (rev 30)
00:1f.4 SMBus: Intel Corporation Cannon Point-LP SMBus Controller (rev 30)
00:1f.5 Serial bus controller [0c80]: Intel Corporation Cannon Point-LP SPI Controller (rev 30)
02:00.0 3D controller: NVIDIA Corporation GP108M [GeForce MX150] (rev a1)
03:00.0 Non-Volatile memory controller: Phison Electronics Corporation E12 NVMe Controller (rev 01)

I think line 00:15.2 is the one, still searching…

is an unknown device so it won’t show up in the next kernel neither but I found this in the metadata of an Intel page:

Intel® Serial IO I2C Host Controller

But that’s used in Intel NUCs only, so I’d contact your manufacturer with the above question. (I think Medion is :de: )


1 Like

The unknown device seems to be a PCI device, see my previous post, lspci.
Tried enabling/disabling webcam/TPM in BIOS.
Looked in /usr/share/hwdata/*.ids
I have also tried older kernels but it’s the same.

So I just didn’t notice it ever before and has probably always been the case.
Maybe I’ll try another live distro to find out.

Thanks so far.

If they would find something that Manjaro didn’t find, you’d be the first because IMH experience, it’s always the other way around: people move to Manjaro to get to use their shiny gadgets because other distro’s don’t support these.