Undo `sudo update-grub` (grub wasn't there before)

Hi! Everything was working perfectly but I had fsck messages such as Clearing orphaned inode, etc.

I had no grub, it was going straight to these messages and then on the splash screen and on my login screen.

But I wanted to hide those messages, so I tried with my first finding, which seemed legit: https://askubuntu.com/a/289/708806

Now it still works perfectly fine, but I now have the grub, which is a step I don’t want to have. I obviously tried to undo my change in the grub config file: I replaced back GRUB_CMDLINE_LINUX_DEFAULT="splash" with GRUB_CMDLINE_LINUX_DEFAULT="quiet udev.log_priority=3" and ran update-grub.

But grub is still here. How can I bypass it as before? (and let’s forget about the fsck messages, I’ll keep them)

PS: I precise I have a dual boot with Windows (and I don’t want to have the choice with grub but with my laptop BIOS, just as before)

Here is the output of my update-grub command, if it can help:

Generating grub configuration file ...
Found theme: /usr/share/grub/themes/manjaro/theme.txt
Found linux image: /boot/vmlinuz-5.12-x86_64
Found initrd image: /boot/intel-ucode.img /boot/initramfs-5.12-x86_64.img
Found initrd fallback image: /boot/initramfs-5.12-x86_64-fallback.img
Warning: os-prober will be executed to detect other bootable partitions.
It's output will be used to detect bootable binaries on them and create new boot entries.
Found Windows Boot Manager on /dev/sda1@/EFI/Microsoft/Boot/bootmgfw.efi
Adding boot menu entry for UEFI Firmware Settings ...
Found memtest86+ image: /boot/memtest86+/memtest.bin

Thanks!

in /etc/default/grub view keys

  • GRUB_TIMEOUT_STYLE
  • (GRUB_TIMEOUT)

I’ve got this:

GRUB_TIMEOUT=5
GRUB_TIMEOUT_STYLE=hidden

What should I set instead?

You have Windows so it will show Grub, unless you disable OS Prober to not detect Windows and then show Grub. You can’t hide Grub with the Windows boot entry added by OS Prober. Modify your Grub config here

GRUB_DISABLE_OS_PROBER=true

then do sudo update-grub

You can set it to 0 but it will be set back to 10 then because of the Windows menu entry set by OS Prober.

1 Like

Thank you! :smiley:

So I disabled OS Prober with GRUB_DISABLE_OS_PROBER=true and set the GRUB_TIMEOUT to 0.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.