Undo "No border" for Konsole in KDE Plasma

I opened my Konsole window, then from Settings > Configure Console I UNCHECKED the Show window title on the titlebar and clicked the Apply button. The titlebar has been properly removed.

Right after that I CHECKED again the Show window title on the titlebar and clicked the Apply button again. From that moment I couldn’t get back the titlebar for my Konsole window no matter what I try.

  1. Alt+F3 ⇒ “more actions” ⇒ uncheck “no border”
    no border setting remains unchaged (checked)

  2. There are no special entries for Konsole in ~/.config/kwinrulesrc

  3. BorderlessMaximizedWindows=false has been set in ~/.config/kwinrc

  4. Not sure if it’s relevant for this issue, but I use the following kwin script as a tiling manager:

How could I get back a titlebar for my Konsole window?

That is just about the text that shows in the titlebar… not whether the the borders or titlebar appear.

Maybe you mean the option just below that - “Remove window titlebar and frame” ?

In any case … everything you did can be viewed, changed, or obliterated in ~/.config/konsolerc

1 Like

Try to make the menu bar appear with Alt + F3 and again go to Settings and disable it :wink:

I made the change and the file changed was $HOME/.config/konsolerc. When I unchecked that option the file did not contain ShowWindowTitleOnTitleBar keyword. I don’t have the option “Remove Window Titlebar and frame” checked, which is right under “Show window title on titlebar”.

If you don’t have it, you might want to add:


If you have it, you might want to remove it:


TIP: I have an alias, alias f1='find -newermt "1 minute ago"'
When I make a change I run this alias, so I know what gets touched. It’s educational, plus can be a lifesaver too :slight_smile:


This seems quite universally helpful for much more than just this issue, so I’ll mark it as a solution. Thanks!

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.