Unacceptable TLS certificate from many suggested mirrors

Using the package manager to update my system, some messages concern me

hxxps://mirrors.ft.uam.es/manjaro/stable/extra/x86_64/firefox-122.0.1-1-x86_64.pkg.tar.zst: Unacceptable TLS certificate
hxxps://repo.skni.umcs.pl/manjaro/stable/extra/x86_64/firefox-122.0.1-1-x86_64.pkg.tar.zst: Unacceptable TLS certificate

Note : ive changed http to hxxp to allow me to post the mirror link

Are these mirrors attempting to provide potentially unsafe packages?
I didn’t select these mirrors, they are default.

What mirrors are considered the safest for future updates?

Thanks

You should actually select (a couple of) mirrors yourself. Default is all mirrors.

Also do a search of whatever error you’re having before posting.

firefox 123.0-1 has been released to stable branch
but some mirrors have not been updated yet
https://repo.manjaro.org/