Unable to use a USB Stick with ext4

Hello!
I tried to format a USB Stick in ext4 with Gparted, Mintstick and the terminal, but nothing worked. If I copy files to the stick (in this case .mkv), they will be corrupted as soon as I insert the stick again.

This problem occurs on two different computers and with two different USB Sticks. I have already tried to change the kernel (4.14.141-1, 4.19.69-1, 5.2.11-1) without a positive result. The two USB Sticks work perfectly under Windows 7 with NTFS.

Is there a solution for this?
I use Manjaro 18.1.0 with KDE.

If files becomes corrupted it is because you pull the stick before the data transfer is complete. It is only complete when the cache buffers has been written to disk.

Use the eject function of the filemanager - in KDE Nautilus.

If you have any doubt if data has been flushed to the device - use a terminal (Konsole) to execute the sync command and wait for it to return.

sync
5 Likes

That helped a lot, now it works fine. Thanks a lot!

1 Like

Forum kindly sponsored by Bytemark