Unable to upgrade packages on first install

HI all,
finally managed to dual boot manjaro with pre-installed win10 on my dell…
the issue now is that i’m not able to upgrade the packages.
The gui hangs…
on terminal,
sudo pacman -Syu returns
unable to synchronize packages

Help please!!! I need to install a few more packages and start with my photo/video edits soon…

System: Dell latitude 5400, Windows 10 OEM, and manjaro gnome lysia

Hi,
use a speed mirror for you with pacman-mirrors

sudo pacman-mirrors --continent

Welcome to the forum! :slight_smile:

sudo pacman-mirrors -f 5 && sudo pacman -Syyu

That’s a -Syyu instead of -Syu, because you’ll be using a different mirror list for the first time now.

First update always require - to force download of database

sudo pacman -Syyu

There is no database after install.

2 Likes

Thanks a lot ppl…
the gui worked after a reoot…
now, that the packages have been upgraded, and i rebooted the laptop, i am not able to boot manjaro at all!! ’
grub shows up, gives me the option of windows boot manager, manjaro linux and advance options for manjaro linux, but on selecting any of the linux options, the screen freezes at the dell logo, and doesn’t move further…
Had the same experience earlier, and had to remove and rebuild the boot manager so that the manjaro efi was removed, and the laptop went back to it’s original state…
Is there a command line fix from grub i can use to fix this?

Your system might be low on entropy. It might help to install haveged. :arrow_down:

sudo pacman -S haveged
sudo systemctl enable haveged --now

If you cannot get your system to boot up from the installed Manjaro, boot up from the install medium, open up a terminal, and issue the following command… :arrow_down:

su -

Then issue the following command… :arrow_down:

manjaro-chroot -a

Select your Manjaro root partition if it’s not automatically detected, and then issue… :arrow_down:

pacman -S haveged
systemctl enable haveged --now
exit

The above does assume that you’ve successfully update your system earlier.

@Aragorn
thanks for the update… Might sound silly, but I’ll still ask a newbie kinda doubt… this I do with my live usb, right?
the system has been updated, that’s for sure… While I do this, is there any way from grub shell/command line…

  0.266 Greece         : https://ftp.cc.uoc.gr/mirrors/linux/manjaro/
  0.179 Greece         : http://ftp.cc.uoc.gr/mirrors/linux/manjaro/

Who is faster ? i thing the 2nd .

Tried the haveged, but couldn’t execute the chroot…
here’s the screenshot

~ >>> manjaro-chroot -a
grub-probe: error: cannot find a GRUB drive for /dev/sda1. Check your device.map.
grub-probe: error: cannot find a GRUB drive for /dev/sda1. Check your device.map.
==> Detected systems:
–> 0) ManjaroLinux
==> Select system to mount [0-0] :
0
==> ERROR: You can’t mount 0!

Now what??

Testing … Press 1 not 0 ?!

Yes, that is correct.


Then we’re going to have to chroot manually, but given that you haven’t given us much information, we have no idea on how to proceed.

  • Is this system booting in UEFI mode or in legacy BIOS (CSM) mode?
  • If it boots in UEFI mode, do you have an EFI system partition?

Hi all!!
Sorry couldn’t write back earlier, since couldn’t sit on the laptop for a few days. But here goes anyway…

@Lila-Kuh
Thanks!! the [1] did work…

But then this is what happened next

~ >>> manjaro-chroot -a                                                   [127]
grub-probe: error: cannot find a GRUB drive for /dev/sda1.  Check your device.map.
grub-probe: error: cannot find a GRUB drive for /dev/sda1.  Check your device.map.
==> Detected systems:
 --> 0) ManjaroLinux
==> Select system to mount [0-0] : 
1
==> Mounting (ManjaroLinux) [/dev/nvme0n1p5]
 --> mount: [/mnt]
 --> mount: [/mnt/boot/efi]
[manjaro-gnome /]# pacman -S haveged
warning: haveged-1.9.13-1 is up to date -- reinstalling
resolving dependencies...
looking for conflicting packages...

Packages (1) haveged-1.9.13-1

Total Installed Size:  0.15 MiB
Net Upgrade Size:      0.00 MiB

:: Proceed with installation? [Y/n] y
(1/1) checking keys in keyring                     [######################] 100%
(1/1) checking package integrity                   [######################] 100%
(1/1) loading package files                        [######################] 100%
(1/1) checking for file conflicts                  [######################] 100%
(1/1) checking available disk space                [######################] 100%
:: Processing package changes...
(1/1) reinstalling haveged                         [######################] 100%
:: Running post-transaction hooks...
(1/2) Reloading system manager configuration...
  Skipped: Current root is not booted.
(2/2) Arming ConditionNeedsUpdate...

[manjaro-gnome /]# systemctl enable haveged --now
System has not been booted with systemd as init system (PID 1). Can't operate.
Failed to connect to bus: Host is down

@Aragorn
The system is a UEFI boot, and both the bootmgr are on EFI system partition only… The MBR was modified during the manjaro install.

Try this (in the chroot)… :arrow_down:

grub-install --recheck --no-rs-codes --efi-directory="/boot/efi" --target="x86_64-efi" --modules="part_gpt part_msdos zstd"
update-grub

Note: I have edited your post in order to reformat your terminal output. When pasting terminal output into a post, please use the </> button in the toolbar of the post editor.

nope…
doesn’t work
in-fact, after rebooting the machine, i don’t even enter grub menu!!
All i get is the Dell logo flashing for a couple of times, before freezing… Had to reboot again and use f12 for boot menu
Either I try to do a fresh install/dual boot - if anyone could pls help me through it… or is there a way out?