Unable to upgrade manjaro



I’m unable to upgrade manjaro system which I last updated/upgraded am year ago.

When I run “sudo pacman-Syyuu”, I get the following results.

[rahul@e18hteen ~]$ sudo pacman-Syyuu
[sudo] password for rahul:
:: Synchronizing package databases...
:: Some packages should be upgraded first...
resolving dependencies...
looking for conflicting packages...

Packages (2) archlinux-keyring-20180108-1.0 manjaro-system-20180107-2.0

Total Installed Size: 0.90 MiB
Net Upgrade Size:    0.03 MiB

:: Proceed with installation? [Y/n] Y
(2/2) checking keys in keyring 
downloading required keys...
error: key “77BEA194A234FF8F” could not be looked up remotely 
error: required key missing from keyring 
error: failed to commit transaction (unexpected error)
Errors occurred, no packages were upgraded. 

:: Starting full system upgrade...
:: Replace fuse with extra/fuse2? [Y/n] Y

    —- some packages asking for replace —-

I searched for similar posts in the manjaro & archlinux forums. I did try most of the suggestions mentioned but still I’m unable to resolve the issue.

System:    Host: e18hteen  Kernel:  4.4.30-1-MANJARO i686 (32 bit gcc: 6.2.1). Desktop: Xfce 4.12.3 (Gtk 2.24.31)  Distro: Manjaro Linux

Kindly help me. Thanks.


did you try what it says on the forum main page before you log in?

If you’re getting an error similar to “Can’t update: signature from *** is marginal trust” or “invalid or corrupted package” you probably just need to update your package signing keys:

sudo pacman -Sy archlinux-keyring manjaro-keyring
sudo pacman-key --populate archlinux manjaro
sudo pacman-key --refresh-keys

If one fails, try the next then retry, and once all succeed retry the update.

If these still don’t work, check this thread: Issues with “signature is marginal trust” or “invalid or corrupted package”


I followed “nuclear option” mentioned in the link too. But no success.


Seems you are using 32bit version of Manjaro. The support for this has been dropped. However, there is the manjaro32 project. Have a look here: https://manjaro32.org/


Do NOT use “uu” unless you intend to downgrade your entire installation!

WTF told you to do so? WTF did you read it? Those idiots deserve to be spanked! :smiley:


As @c00ter said, don’t use “uu”, maybe this enough:

sudo pacman-mirrors -f 3
sudo pacman -Syyu


@ragavendrarahul, here. Pacman Rosetta is your trusty source for Pacman commands.

Too damn much bad information otherwise abounds. :wink:


@yerri @c00ter Enough now with your spanking, he’s running an i686 system so needs to transition to manjaro32…

@ragavendrarahul Try:

sudo sed -i '/# Branch = /c\Branch = x32-stable' /etc/pacman-mirrors.conf
sudo pacman-mirrors -c all
sudo pacman -Sy archlinux32-keyring-transition
sudo pacman -S archlinux32-keyring
sudo pacman -Syu


Consider @c00ter spanked. :smiley:


Did not know this existed… bookmarked now!


I didn’t pull it out of thin air–someone pointed it out to me–possibly for reasons similar to why I posted it above. :wink:

closed #13

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.