Unable to update vulkan-amdgpu-pro

Console log:

Synchronizing Package Databases...
Checking vulkan-amdgpu-pro dependencies...
Warning: ckbcomp: local (1.221-1) is newer than extra (1.215-1)
Warning: v86d: local (0.1.10-12) is newer than extra (0.1.10-6)
Resolving dependencies...
Checking inter-conflicts...

Building amdgpu-pro-installer...
==> ERROR: PKGBUILD does not exist.

Hi @inverser,

I noticed multiple Warnings in your post:

And considering the Warning is that you local package is newer than the repository one, it would seem that, either:

  1. You are switching from the Testing/Unstable branch to the Stable; or
  2. you haven’t updated in some time, which I doubt is the case or there would have been many more Warnings…

And while the vulkan-amdgpu-pro package is AUR, not being up to date might cause the databases to be out-of-sync. Or something like that. So lets try and sync them first:

pamac checkupdates --force-refresh

Give that a go, and if there were no errors, try updating again:

pamac upgrade

Hope this helps!

Thank you. I just removed this library. I installed it in the hope that the video card would be able to decode video normally. However, this, as I understand it, is not realistic. Although the drivers are open… I don’t understand this question. It is when recording video (SimpleScreenRecorder) or rendering video in KDenlive or when rendering in Blender that the video card does not work…

I noticed it’s for AMD. Something I know nothing about, perhaps someone else does - @linux-aarhus comes to mind - but AFAIK there has been some issues with the AMD cards…or maybe not because, as I said, I’m completely unsure.

Perhaps, I don’t know - I’m shooting in the dark here, but perhaps this helps:


1 Like

Thank you, bro

I installed

# locally trust the ci key
sudo pacman-key --recv-keys B728DB23B92CB01B && \
  sudo pacman-key --lsign-key B728DB23B92CB01B

## add the repo configuration:
sudo sh -c "curl -s https://nonfree.eu/$(pacman-mirrors -G)/ > /etc/pacman.d/mesa-nonfree.pre.repo.conf"

## include the repo configuration:
sudo sed -i '/^\[core\]/i \Include = /etc/pacman.d/mesa-nonfree.pre.repo.conf\n' /etc/pacman.conf

When you try to fix the error in SSR, the same error pops up as in the first message of the topic.

Then I tried to record video in SSR, choosing the h264_AMF codec, and this is what happened (The same error occurred before installing nonfree):

[h264_amf @ 0x5556bf14c080] DLL libamfrt64.so.1 failed to open
[BaseEncoder::Init] Error: Can't open codec!
[PageRecord::StartOutput] Error: Something went wrong during initialization.

Through KDEnlive and the VAAPI AMD 264 profile the rendering is running, but it seems that the video card is still not used.

I’ll try to roll back the changes in TimeShift and try rendering the video in KDEnlive. I’ll look at the time difference. With nonfree installed, my video took 1 hour to render

After I reverted all the changes (without nonfree), the encoding time was almost 2 times longer.
Also, the fan speed remained the same, while when using nonfree, it increased by 2 times.
Therefore, most likely, with nonfree the video card actually works during video encoding. However, the question remains regarding SSR; I don’t know which codec to choose.
I was also interested in the question of broadcasting videos on YouTube. I’ll also try this with nonfree. Because I have to switch to Windows for broadcasting…

Also KDEnlive without nonfree gives this error (with VAAPI renderer)

0x7f60ec010580] deprecated pixel format used, make sure you did set range correctly
[swscaler @ 0x7f60f8014f80] deprecated pixel format used, make sure you did set range correctly