Unable to update or install anything

#1

I am not being able to update my system or install anything.

sudo pacman -Syu
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
:: Starting full system upgrade...
:: Replace geoclue2 with extra/geoclue? [Y/n] n
:: Replace libsystemd with core/systemd-libs? [Y/n] n
resolving dependencies...
looking for conflicting packages...
:: systemd-libs and libsystemd are in conflict. Remove libsystemd? [y/N] y

Packages (456) akonadi-18.12.2-1  akonadi-calendar-18.12.2-1  akonadi-calendar-tools-18.12.2-1  akonadi-contacts-18.12.2-1  akonadi-import-wizard-18.12.2-1
               akonadi-mime-18.12.2-1  akonadi-notes-18.12.2-1  akonadi-search-18.12.2-1  akonadiconsole-18.12.2-1  akregator-18.12.2-1  analitza-18.12.2-1
               ark-18.12.2-1  attica-5.55.0-1  audiocd-kio-18.12.2-1  audit-2.8.4-3  baloo-5.55.0-1  baloo-widgets-18.12.2-1  bluedevil-1:5.15.0-1  bluez-qt-5.55.0-1
               brave-0.59.35-1  breeze-5.15.0-1  breeze-gtk-5.15.0-1  breeze-icons-5.55.0-1  btrfs-progs-4.20.1-2  ca-certificates-mozilla-3.42.1-1  cairo-1.16.0-2
               calendarsupport-18.12.2-1  cantor-18.12.2-1  cervisia-18.12.2-1  crda-4.14-2  cryptsetup-2.1.0-1  cups-filters-1.22.1-1  curl-7.64.0-7.1
               deluge-1.3.15+18+ge050905b2-1  discover-5.15.0-2  dnsmasq-2.80-3  dolphin-18.12.2-1  dolphin-plugins-18.12.2-1  drkonqi-5.15.0-1  espeak-ng-1.49.2-5
               eventviews-18.12.2-1  festival-2.4-4  ffmpeg-1:4.1.1-1  ffmpegthumbs-18.12.2-1  filelight-18.12.2-1  firefox-65.0.1-1  flatpak-1.2.3-1
               fluidsynth-2.0.3-1  frameworkintegration-5.55.0-1  gnome-desktop-1:3.30.2.1-1  gnome-online-accounts-3.30.2-1  gnupg-2.2.13-1  gnutls-3.6.6-3
               grantlee-editor-18.12.2-1  grantleetheme-18.12.2-1  graphene-1.8.4-1  grub-2.03.3-1  gst-plugins-bad-1.14.4-8  gtk-update-icon-cache-3.24.5-1
               gtk3-3.24.5-1  gwenview-18.12.2-1  harfbuzz-2.3.1-2  harfbuzz-icu-2.3.1-2  hplip-1:3.19.1-1  hwinfo-21.59-1  iana-etc-20190125-1  imagemagick-7.0.8.28-1
               incidenceeditor-18.12.2-1  iputils-20180629.f6aac8d-4  iw-5.0.1-1  k3b-1:18.12.2-1  kaccounts-integration-18.12.2-1  kaccounts-providers-18.12.2-1
               kactivities-5.55.0-1  kactivities-stats-5.55.0-1  kactivitymanagerd-5.15.0-1  kaddressbook-18.12.2-1  kalarm-18.12.2-1  kalarmcal-18.12.2-1
               kalgebra-18.12.2-1  kalzium-18.12.2-1  kamera-18.12.2-1  kamoso-18.12.2-1  kapptemplate-18.12.2-1  karchive-5.55.0-1  kate-18.12.2-1  kauth-5.55.0-1
               kbackup-18.12.2-1  kbookmarks-5.55.0-1  kbruch-18.12.2-1  kcachegrind-18.12.2-2  kcachegrind-common-18.12.2-2  kcalc-18.12.2-1  kcalcore-18.12.2-1
               kcalutils-18.12.2-1  kcharselect-18.12.2-1  kcmutils-5.55.0-1  kcodecs-5.55.0-1  kcolorchooser-18.12.2-1  kcompletion-5.55.0-1  kconfig-5.55.0-1
               kconfigwidgets-5.55.0-1  kcontacts-18.12.2-1  kcoreaddons-5.55.0-1  kcrash-5.55.0-1  kcron-18.12.2-1  kdav-18.12.2-1  kdbusaddons-5.55.0-1
               kde-cli-tools-5.15.0-1  kde-dev-scripts-18.12.2-1  kde-dev-utils-18.12.2-1  kde-gtk-config-5.15.0-1  kdebugsettings-18.12.2-1  kdeclarative-5.55.0-1
               kdecoration-5.15.0-1  kded-5.55.0-1  kdeedu-data-18.12.2-1  kdegraphics-mobipocket-18.12.2-1  kdegraphics-thumbnailers-18.12.2-1
               kdelibs4support-5.55.0-1  kdenetwork-filesharing-18.12.2-1  kdenlive-18.12.2-1  kdepim-addons-18.12.2-1  kdepim-apps-libs-18.12.2-1
               kdepim-runtime-18.12.2-1  kdeplasma-addons-5.15.0-1  kdesdk-kioslaves-18.12.2-1  kdesdk-thumbnailers-18.12.2-1  kdesu-5.55.0-1  kdf-18.12.2-1
               kdialog-18.12.2-1  kdnssd-5.55.0-1  kdoctools-5.55.0-1  keditbookmarks-18.12.2-1  kemoticons-5.55.0-1  kfilemetadata-5.55.0-1  kfind-18.12.2-1
               kfloppy-18.12.2-1  kgamma5-5.15.0-1  kgeography-18.12.2-1  kget-18.12.2-1  kglobalaccel-5.55.0-1  kgpg-18.12.2-1  kguiaddons-5.55.0-1
               khelpcenter-18.12.2-1  kholidays-1:5.55.0-1  khotkeys-5.15.0-1  khtml-5.55.0-1  ki18n-5.55.0-1  kiconthemes-5.55.0-1  kidentitymanagement-18.12.2-1
               kidletime-5.55.0-1  kig-18.12.2-1  kimageformats-5.55.0-1  kimagemapeditor-18.12.2-1  kimap-18.12.2-1  kinfocenter-5.15.0-1  kinit-5.55.0-1
               kio-5.55.0-1  kio-extras-18.12.2-1  kirigami2-5.55.0-1  kitemmodels-5.55.0-1  kitemviews-5.55.0-1  kitinerary-18.12.2-2  kjobwidgets-5.55.0-1
               kjs-5.55.0-1  kjsembed-5.55.0-1  kldap-18.12.2-1  kleopatra-18.12.2-1  klettres-18.12.2-1  kmag-18.12.2-1  kmail-18.12.2-1
               kmail-account-wizard-18.12.2-1  kmailtransport-18.12.2-1  kmbox-18.12.2-1  kmenuedit-5.15.0-1  kmime-18.12.2-1  kmod-26-2  kmousetool-18.12.2-1
               kmouth-18.12.2-1  kmplot-18.12.2-1  knetattach-5.15.0-1  knewstuff-5.55.0-1  knotes-18.12.2-1  knotifications-5.55.0-1  knotifyconfig-5.55.0-1
               kolourpaint-18.12.2-1  kompare-18.12.2-1  konqueror-18.12.2-1  konsole-18.12.2-1  kontact-18.12.2-1  kontactinterface-18.12.2-1  kopete-18.12.2-1
               korganizer-18.12.2-1  kpackage-5.55.0-1  kparts-5.55.0-1  kpeople-5.55.0-1  kpimtextedit-18.12.2-1  kpkpass-18.12.2-1  kplotting-5.55.0-1  kpty-5.55.0-1
               kqtquickcharts-18.12.2-1  krdc-18.12.2-1  krfb-18.12.2-1  kross-5.55.0-1  kross-interpreters-18.12.2-1  kruler-18.12.2-1  krunner-5.55.0-1
               kscreen-5.15.0-1  kscreenlocker-5.15.0-1  kservice-5.55.0-1  ksmtp-18.12.2-1  ksshaskpass-5.15.0-1  ksysguard-5.15.0-1  ksystemlog-18.12.2-1
               ktexteditor-5.55.0-1  ktextwidgets-5.55.0-1  ktimer-18.12.2-1  ktnef-18.12.2-1  ktouch-18.12.2-1  kturtle-18.12.2-1  kunitconversion-5.55.0-1
               kwallet-5.55.0-1  kwallet-pam-5.15.0-1  kwalletmanager-18.12.2-1  kwave-18.12.2-1  kwayland-5.55.0-1  kwayland-integration-5.15.0-1
               kwidgetsaddons-5.55.0-1  kwin-5.15.0-1  kwindowsystem-5.55.0-1  kwordquiz-18.12.2-1  kwrited-5.15.0-1  kxmlgui-5.55.0-1  kxmlrpcclient-5.55.0-1
               ladspa-1.15-1  lib32-alsa-lib-1.1.8-2  lib32-expat-2.2.6-2  lib32-harfbuzz-2.3.1-2  lib32-libjpeg-turbo-2.0.2-1  lib32-libltdl-2.4.6+42+gb88cebd5-1
               lib32-libogg-1.3.3-3  lib32-libva-mesa-driver-18.3.3-1  lib32-mesa-18.3.3-1  lib32-mesa-vdpau-18.3.3-1  lib32-systemd-241.159-1
               lib32-vulkan-intel-18.3.3-1  lib32-vulkan-radeon-18.3.3-1  lib32-zstd-1.3.8-1  libassuan-2.5.3-1  libbluray-1.1.0-1  libcdio-paranoia-10.2+2.0.0-1
               libfbclient-3.0.4.33054-1  libgit2-1:0.27.8-1  libgnomekbd-3.26.1-1  libgpg-error-1.35-1  libgravatar-18.12.2-1  libidn2-2.1.1-2  libjpeg-turbo-2.0.2-1
               libkcddb-18.12.2-1  libkcompactdisc-18.12.2-1  libkdcraw-18.12.2-1  libkdegames-18.12.2-1  libkdepim-18.12.2-1  libkeduvocdocument-18.12.2-1
               libkexiv2-18.12.2-1  libkgapi-18.12.2-1  libkipi-18.12.2-1  libkleo-18.12.2-1  libkmahjongg-18.12.2-1  libkomparediff2-18.12.2-1  libksane-18.12.2-1
               libkscreen-5.15.0-1  libksieve-18.12.2-1  libksysguard-5.15.0-1  libmagick-7.0.8.28-1  libnghttp2-1.36.0-1  libpipeline-1.5.1-1  libpsl-0.20.2-5
               libpwquality-1.4.0-2  libqalculate-2.9.0-1  libqmi-1.22.0-2  libreoffice-fresh-6.2.0-3  librsvg-2:2.44.13-1  libsasl-2.1.27-1  libspeechd-0.9.0-1
               libsystemd-239.303+really+239.6-1 [removal]  libtommath-1.1.0-1  libuv-1.26.0-1  libva-mesa-driver-18.3.3-2  libxau-1.0.9-1  libxkbcommon-0.8.3-1
               libxkbcommon-x11-0.8.3-1  linux-firmware-20190212.28f5f7d-1  linux419-4.19.23-1  linux419-r8168-8.045.08-18  linux419-virtualbox-host-modules-6.0.4-5
               linux420-4.20.10-1  lokalize-18.12.2-1  mailcommon-18.12.2-1  mailimporter-18.12.2-1  manjaro-release-18.0.3-1  marble-18.12.2-1
               marble-common-18.12.2-1  mbox-importer-18.12.2-1  mesa-18.3.3-2  mesa-vdpau-18.3.3-2  messagelib-18.12.2-1  milou-5.15.0-1  minuet-18.12.2-2
               modemmanager-qt-5.55.0-1  mpfr-4.0.2-1  ndctl-64.1-1  networkmanager-openconnect-1.2.5dev+110+g524a2e0-2  networkmanager-openvpn-1.8.10-1
               networkmanager-pptp-1.2.9dev+10+gb41b0d0-1  networkmanager-qt-5.55.0-1  networkmanager-vpnc-1.2.7dev+20+gdca3aea-1  nodejs-11.10.0-1  npm-6.8.0-1
               nss-3.42.1-1  okular-18.12.2-1  openal-1.19.1-2  openconnect-1:8.02-1  oxygen-5.15.0-1  pambase-20190105.1-1  parley-18.12.2-1  perl-xml-libxml-2.0134-1
               pim-data-exporter-18.12.2-1  pim-sieve-editor-18.12.2-1  pimcommon-18.12.2-1  pixman-0.38.0-2  plasma-browser-integration-5.15.0-1
               plasma-desktop-5.15.0-1  plasma-framework-5.55.0-1  plasma-integration-5.15.0-1  plasma-nm-5.15.0-1  plasma-pa-5.15.0-1  plasma-sdk-5.15.0-1
               plasma-vault-5.15.0-1  plasma-workspace-5.15.0-1  plasma-workspace-wallpapers-5.15.0-1  polkit-kde-agent-5.15.0-1  poppler-0.74.0-1
               poppler-qt5-0.74.0-1  powerdevil-5.15.0-1  poxml-18.12.2-1  print-manager-18.12.2-1  prison-5.55.0-1  purpose-5.55.0-1
               pycharm-community-edition-2018.3.4-1  pyqt5-common-5.12-2  python-beaker-1.10.0-3  python-distro-1.4.0-1  python-markdown-3.0.1-1
               python-msgpack-0.6.1-1  python-parso-0.3.3-1  python-prompt_toolkit-2.0.8-1  python-pyqt5-5.12-2  python-setuptools-1:40.8.0-1
               python-sip-pyqt5-4.19.14-1  python-soupsieve-1.8.0-1  python-urllib3-1.24.1-2  python2-beaker-1.10.0-3  python2-cryptography-2.5-1
               python2-distro-1.4.0-1  python2-msgpack-0.6.1-1  python2-pygame-1.9.4-2  python2-setuptools-1:40.8.0-1  python2-urllib3-1.24.1-2  qpdf-8.4.0-1
               qqc2-desktop-style-5.55.0-1  qt5-base-5.12.1-2.1  qt5-declarative-5.12.1-1  qt5-graphicaleffects-5.12.1-1  qt5-imageformats-5.12.1-1
               qt5-location-5.12.1-1  qt5-multimedia-5.12.1-1  qt5-quickcontrols-5.12.1-1  qt5-quickcontrols2-5.12.1-1  qt5-script-5.12.1-1  qt5-sensors-5.12.1-1
               qt5-speech-5.12.1-1  qt5-svg-5.12.1-1  qt5-tools-5.12.1-1  qt5-virtualkeyboard-5.12.1-1  qt5-webchannel-5.12.1-1  qt5-webengine-5.12.1-1
               qt5-webkit-5.212.0alpha2-23  qt5-x11extras-5.12.1-1  qt5-xmlpatterns-5.12.1-1  qtermwidget-0.14.0-1  rocs-18.12.2-1  ruby-2.6.1-1  run-parts-4.8.6.1-1
               s-nail-14.9.11-3  sddm-kcm-5.15.0-1  sdl_mixer-1.2.12-7  shared-mime-info-1.12-1  signon-kwallet-extension-18.12.2-1  sn0int-0.9.1-1  solid-5.55.0-1
               sonnet-5.55.0-1  spectacle-18.12.2-1  speech-dispatcher-0.9.0-1  speexdsp-1.2rc3-4  spglib-1.12.2-1  sqlite-3.27.1-1  step-18.12.2-1  sweeper-18.12.2-1
               syndication-5.55.0-1  syntax-highlighting-5.55.0-1  systemd-241.159-1  systemd-libs-241.159-1  systemd-sysvcompat-241.159-1  systemsettings-5.15.0-1
               taglib-1.11.1-3  telepathy-kde-accounts-kcm-18.12.2-1  telepathy-kde-approver-18.12.2-1  telepathy-kde-auth-handler-18.12.2-1
               telepathy-kde-call-ui-18.12.2-1  telepathy-kde-common-internals-18.12.2-1  telepathy-kde-contact-list-18.12.2-1  telepathy-kde-contact-runner-18.12.2-1
               telepathy-kde-desktop-applets-18.12.2-1  telepathy-kde-filetransfer-handler-18.12.2-1  telepathy-kde-integration-module-18.12.2-1
               telepathy-kde-send-file-18.12.2-1  telepathy-kde-text-ui-18.12.2-1  threadweaver-5.55.0-1  tracker-2.1.7-1  umbrello-18.12.2-1  user-manager-5.15.0-1
               vamp-plugin-sdk-2.8.0-1  virtualbox-6.0.4-1  virtualbox-guest-iso-6.0.4-1  vlc-3.0.6-3  vpnc-1:0.5.3.r454.r67-1
               vulkan-icd-loader-1.1.99+3022+e1eafa18e-1  vulkan-intel-18.3.3-2  vulkan-radeon-18.3.3-2  webkit2gtk-2.22.6-1  wget-1.20.1-3  wine-4.2-1  x265-3.0-1
               xapian-core-1:1.4.10-1  xdg-desktop-portal-1.2.0-2  xdg-desktop-portal-gtk-1.2.0-1  xdg-desktop-portal-kde-5.15.0-1  xdg-user-dirs-0.17-2
               xf86-input-libinput-0.28.2-1  xf86-video-nouveau-1.0.16-1  xkeyboard-config-2.26-2  xterm-344-1  zeroconf-ioslave-18.12.2-1  zsh-5.7.1-1

Total Installed Size:  5069.96 MiB
Net Upgrade Size:        36.95 MiB

:: Proceed with installation? [Y/n] 
(455/455) checking keys in keyring                                                                   [############################################################] 100%
(455/455) checking package integrity                                                                 [############################################################] 100%
error: failed to commit transaction (invalid or corrupted package)
Errors occurred, no packages were upgraded
#2

You need to say Yes when updates ask for replacement

#3

Even I say yes the problem still persist.

sudo pacman -Syu
[sudo] password for techie: 
:: Synchronizing package databases...
 core is up to date
 extra is up to date
 community is up to date
 multilib is up to date
:: Starting full system upgrade...
:: Replace geoclue2 with extra/geoclue? [Y/n] Y
:: Replace libsystemd with core/systemd-libs? [Y/n] Y
resolving dependencies...
looking for conflicting packages...

Packages (458) akonadi-18.12.2-1  akonadi-calendar-18.12.2-1  akonadi-calendar-tools-18.12.2-1  akonadi-contacts-18.12.2-1  akonadi-import-wizard-18.12.2-1
               akonadi-mime-18.12.2-1  akonadi-notes-18.12.2-1  akonadi-search-18.12.2-1  akonadiconsole-18.12.2-1  akregator-18.12.2-1  analitza-18.12.2-1
               ark-18.12.2-1  attica-5.55.0-1  audiocd-kio-18.12.2-1  audit-2.8.4-3  baloo-5.55.0-1  baloo-widgets-18.12.2-1  bluedevil-1:5.15.0-1  bluez-qt-5.55.0-1
               brave-0.59.35-1  breeze-5.15.0-1  breeze-gtk-5.15.0-1  breeze-icons-5.55.0-1  btrfs-progs-4.20.1-2  ca-certificates-mozilla-3.42.1-1  cairo-1.16.0-2
               calendarsupport-18.12.2-1  cantor-18.12.2-1  cervisia-18.12.2-1  crda-4.14-2  cryptsetup-2.1.0-1  cups-filters-1.22.1-1  curl-7.64.0-7.1
               deluge-1.3.15+18+ge050905b2-1  discover-5.15.0-2  dnsmasq-2.80-3  dolphin-18.12.2-1  dolphin-plugins-18.12.2-1  drkonqi-5.15.0-1  espeak-ng-1.49.2-5
               eventviews-18.12.2-1  festival-2.4-4  ffmpeg-1:4.1.1-1  ffmpegthumbs-18.12.2-1  filelight-18.12.2-1  firefox-65.0.1-1  flatpak-1.2.3-1
               fluidsynth-2.0.3-1  frameworkintegration-5.55.0-1  geoclue-2.5.2-3  geoclue2-2.5.2-2 [removal]  gnome-desktop-1:3.30.2.1-1
               gnome-online-accounts-3.30.2-1  gnupg-2.2.13-1  gnutls-3.6.6-3  grantlee-editor-18.12.2-1  grantleetheme-18.12.2-1  graphene-1.8.4-1  grub-2.03.3-1
               gst-plugins-bad-1.14.4-8  gtk-update-icon-cache-3.24.5-1  gtk3-3.24.5-1  gwenview-18.12.2-1  harfbuzz-2.3.1-2  harfbuzz-icu-2.3.1-2  hplip-1:3.19.1-1
               hwinfo-21.59-1  iana-etc-20190125-1  imagemagick-7.0.8.28-1  incidenceeditor-18.12.2-1  iputils-20180629.f6aac8d-4  iw-5.0.1-1  k3b-1:18.12.2-1
               kaccounts-integration-18.12.2-1  kaccounts-providers-18.12.2-1  kactivities-5.55.0-1  kactivities-stats-5.55.0-1  kactivitymanagerd-5.15.0-1
               kaddressbook-18.12.2-1  kalarm-18.12.2-1  kalarmcal-18.12.2-1  kalgebra-18.12.2-1  kalzium-18.12.2-1  kamera-18.12.2-1  kamoso-18.12.2-1
               kapptemplate-18.12.2-1  karchive-5.55.0-1  kate-18.12.2-1  kauth-5.55.0-1  kbackup-18.12.2-1  kbookmarks-5.55.0-1  kbruch-18.12.2-1
               kcachegrind-18.12.2-2  kcachegrind-common-18.12.2-2  kcalc-18.12.2-1  kcalcore-18.12.2-1  kcalutils-18.12.2-1  kcharselect-18.12.2-1  kcmutils-5.55.0-1
               kcodecs-5.55.0-1  kcolorchooser-18.12.2-1  kcompletion-5.55.0-1  kconfig-5.55.0-1  kconfigwidgets-5.55.0-1  kcontacts-18.12.2-1  kcoreaddons-5.55.0-1
               kcrash-5.55.0-1  kcron-18.12.2-1  kdav-18.12.2-1  kdbusaddons-5.55.0-1  kde-cli-tools-5.15.0-1  kde-dev-scripts-18.12.2-1  kde-dev-utils-18.12.2-1
               kde-gtk-config-5.15.0-1  kdebugsettings-18.12.2-1  kdeclarative-5.55.0-1  kdecoration-5.15.0-1  kded-5.55.0-1  kdeedu-data-18.12.2-1
               kdegraphics-mobipocket-18.12.2-1  kdegraphics-thumbnailers-18.12.2-1  kdelibs4support-5.55.0-1  kdenetwork-filesharing-18.12.2-1  kdenlive-18.12.2-1
               kdepim-addons-18.12.2-1  kdepim-apps-libs-18.12.2-1  kdepim-runtime-18.12.2-1  kdeplasma-addons-5.15.0-1  kdesdk-kioslaves-18.12.2-1
               kdesdk-thumbnailers-18.12.2-1  kdesu-5.55.0-1  kdf-18.12.2-1  kdialog-18.12.2-1  kdnssd-5.55.0-1  kdoctools-5.55.0-1  keditbookmarks-18.12.2-1
               kemoticons-5.55.0-1  kfilemetadata-5.55.0-1  kfind-18.12.2-1  kfloppy-18.12.2-1  kgamma5-5.15.0-1  kgeography-18.12.2-1  kget-18.12.2-1
               kglobalaccel-5.55.0-1  kgpg-18.12.2-1  kguiaddons-5.55.0-1  khelpcenter-18.12.2-1  kholidays-1:5.55.0-1  khotkeys-5.15.0-1  khtml-5.55.0-1
               ki18n-5.55.0-1  kiconthemes-5.55.0-1  kidentitymanagement-18.12.2-1  kidletime-5.55.0-1  kig-18.12.2-1  kimageformats-5.55.0-1
               kimagemapeditor-18.12.2-1  kimap-18.12.2-1  kinfocenter-5.15.0-1  kinit-5.55.0-1  kio-5.55.0-1  kio-extras-18.12.2-1  kirigami2-5.55.0-1
               kitemmodels-5.55.0-1  kitemviews-5.55.0-1  kitinerary-18.12.2-2  kjobwidgets-5.55.0-1  kjs-5.55.0-1  kjsembed-5.55.0-1  kldap-18.12.2-1
               kleopatra-18.12.2-1  klettres-18.12.2-1  kmag-18.12.2-1  kmail-18.12.2-1  kmail-account-wizard-18.12.2-1  kmailtransport-18.12.2-1  kmbox-18.12.2-1
               kmenuedit-5.15.0-1  kmime-18.12.2-1  kmod-26-2  kmousetool-18.12.2-1  kmouth-18.12.2-1  kmplot-18.12.2-1  knetattach-5.15.0-1  knewstuff-5.55.0-1
               knotes-18.12.2-1  knotifications-5.55.0-1  knotifyconfig-5.55.0-1  kolourpaint-18.12.2-1  kompare-18.12.2-1  konqueror-18.12.2-1  konsole-18.12.2-1
               kontact-18.12.2-1  kontactinterface-18.12.2-1  kopete-18.12.2-1  korganizer-18.12.2-1  kpackage-5.55.0-1  kparts-5.55.0-1  kpeople-5.55.0-1
               kpimtextedit-18.12.2-1  kpkpass-18.12.2-1  kplotting-5.55.0-1  kpty-5.55.0-1  kqtquickcharts-18.12.2-1  krdc-18.12.2-1  krfb-18.12.2-1  kross-5.55.0-1
               kross-interpreters-18.12.2-1  kruler-18.12.2-1  krunner-5.55.0-1  kscreen-5.15.0-1  kscreenlocker-5.15.0-1  kservice-5.55.0-1  ksmtp-18.12.2-1
               ksshaskpass-5.15.0-1  ksysguard-5.15.0-1  ksystemlog-18.12.2-1  ktexteditor-5.55.0-1  ktextwidgets-5.55.0-1  ktimer-18.12.2-1  ktnef-18.12.2-1
               ktouch-18.12.2-1  kturtle-18.12.2-1  kunitconversion-5.55.0-1  kwallet-5.55.0-1  kwallet-pam-5.15.0-1  kwalletmanager-18.12.2-1  kwave-18.12.2-1
               kwayland-5.55.0-1  kwayland-integration-5.15.0-1  kwidgetsaddons-5.55.0-1  kwin-5.15.0-1  kwindowsystem-5.55.0-1  kwordquiz-18.12.2-1  kwrited-5.15.0-1
               kxmlgui-5.55.0-1  kxmlrpcclient-5.55.0-1  ladspa-1.15-1  lib32-alsa-lib-1.1.8-2  lib32-expat-2.2.6-2  lib32-harfbuzz-2.3.1-2
               lib32-libjpeg-turbo-2.0.2-1  lib32-libltdl-2.4.6+42+gb88cebd5-1  lib32-libogg-1.3.3-3  lib32-libva-mesa-driver-18.3.3-1  lib32-mesa-18.3.3-1
               lib32-mesa-vdpau-18.3.3-1  lib32-systemd-241.159-1  lib32-vulkan-intel-18.3.3-1  lib32-vulkan-radeon-18.3.3-1  lib32-zstd-1.3.8-1  libassuan-2.5.3-1
               libbluray-1.1.0-1  libcdio-paranoia-10.2+2.0.0-1  libfbclient-3.0.4.33054-1  libgit2-1:0.27.8-1  libgnomekbd-3.26.1-1  libgpg-error-1.35-1
               libgravatar-18.12.2-1  libidn2-2.1.1-2  libjpeg-turbo-2.0.2-1  libkcddb-18.12.2-1  libkcompactdisc-18.12.2-1  libkdcraw-18.12.2-1  libkdegames-18.12.2-1
               libkdepim-18.12.2-1  libkeduvocdocument-18.12.2-1  libkexiv2-18.12.2-1  libkgapi-18.12.2-1  libkipi-18.12.2-1  libkleo-18.12.2-1  libkmahjongg-18.12.2-1
               libkomparediff2-18.12.2-1  libksane-18.12.2-1  libkscreen-5.15.0-1  libksieve-18.12.2-1  libksysguard-5.15.0-1  libmagick-7.0.8.28-1
               libnghttp2-1.36.0-1  libpipeline-1.5.1-1  libpsl-0.20.2-5  libpwquality-1.4.0-2  libqalculate-2.9.0-1  libqmi-1.22.0-2  libreoffice-fresh-6.2.0-3
               librsvg-2:2.44.13-1  libsasl-2.1.27-1  libspeechd-0.9.0-1  libsystemd-239.303+really+239.6-1 [removal]  libtommath-1.1.0-1  libuv-1.26.0-1
               libva-mesa-driver-18.3.3-2  libxau-1.0.9-1  libxkbcommon-0.8.3-1  libxkbcommon-x11-0.8.3-1  linux-firmware-20190212.28f5f7d-1  linux419-4.19.23-1
               linux419-r8168-8.045.08-18  linux419-virtualbox-host-modules-6.0.4-5  linux420-4.20.10-1  lokalize-18.12.2-1  mailcommon-18.12.2-1
               mailimporter-18.12.2-1  manjaro-release-18.0.3-1  marble-18.12.2-1  marble-common-18.12.2-1  mbox-importer-18.12.2-1  mesa-18.3.3-2  mesa-vdpau-18.3.3-2
               messagelib-18.12.2-1  milou-5.15.0-1  minuet-18.12.2-2  modemmanager-qt-5.55.0-1  mpfr-4.0.2-1  ndctl-64.1-1
               networkmanager-openconnect-1.2.5dev+110+g524a2e0-2  networkmanager-openvpn-1.8.10-1  networkmanager-pptp-1.2.9dev+10+gb41b0d0-1
               networkmanager-qt-5.55.0-1  networkmanager-vpnc-1.2.7dev+20+gdca3aea-1  nodejs-11.10.0-1  npm-6.8.0-1  nss-3.42.1-1  okular-18.12.2-1  openal-1.19.1-2
               openconnect-1:8.02-1  oxygen-5.15.0-1  pambase-20190105.1-1  parley-18.12.2-1  perl-xml-libxml-2.0134-1  pim-data-exporter-18.12.2-1
               pim-sieve-editor-18.12.2-1  pimcommon-18.12.2-1  pixman-0.38.0-2  plasma-browser-integration-5.15.0-1  plasma-desktop-5.15.0-1
               plasma-framework-5.55.0-1  plasma-integration-5.15.0-1  plasma-nm-5.15.0-1  plasma-pa-5.15.0-1  plasma-sdk-5.15.0-1  plasma-vault-5.15.0-1
               plasma-workspace-5.15.0-1  plasma-workspace-wallpapers-5.15.0-1  polkit-kde-agent-5.15.0-1  poppler-0.74.0-1  poppler-qt5-0.74.0-1  powerdevil-5.15.0-1
               poxml-18.12.2-1  print-manager-18.12.2-1  prison-5.55.0-1  purpose-5.55.0-1  pycharm-community-edition-2018.3.4-1  pyqt5-common-5.12-2
               python-beaker-1.10.0-3  python-distro-1.4.0-1  python-markdown-3.0.1-1  python-msgpack-0.6.1-1  python-parso-0.3.3-1  python-prompt_toolkit-2.0.8-1
               python-pyqt5-5.12-2  python-setuptools-1:40.8.0-1  python-sip-pyqt5-4.19.14-1  python-soupsieve-1.8.0-1  python-urllib3-1.24.1-2
               python2-beaker-1.10.0-3  python2-cryptography-2.5-1  python2-distro-1.4.0-1  python2-msgpack-0.6.1-1  python2-pygame-1.9.4-2
               python2-setuptools-1:40.8.0-1  python2-urllib3-1.24.1-2  qpdf-8.4.0-1  qqc2-desktop-style-5.55.0-1  qt5-base-5.12.1-2.1  qt5-declarative-5.12.1-1
               qt5-graphicaleffects-5.12.1-1  qt5-imageformats-5.12.1-1  qt5-location-5.12.1-1  qt5-multimedia-5.12.1-1  qt5-quickcontrols-5.12.1-1
               qt5-quickcontrols2-5.12.1-1  qt5-script-5.12.1-1  qt5-sensors-5.12.1-1  qt5-speech-5.12.1-1  qt5-svg-5.12.1-1  qt5-tools-5.12.1-1
               qt5-virtualkeyboard-5.12.1-1  qt5-webchannel-5.12.1-1  qt5-webengine-5.12.1-1  qt5-webkit-5.212.0alpha2-23  qt5-x11extras-5.12.1-1
               qt5-xmlpatterns-5.12.1-1  qtermwidget-0.14.0-1  rocs-18.12.2-1  ruby-2.6.1-1  run-parts-4.8.6.1-1  s-nail-14.9.11-3  sddm-kcm-5.15.0-1
               sdl_mixer-1.2.12-7  shared-mime-info-1.12-1  signon-kwallet-extension-18.12.2-1  sn0int-0.9.1-1  solid-5.55.0-1  sonnet-5.55.0-1  spectacle-18.12.2-1
               speech-dispatcher-0.9.0-1  speexdsp-1.2rc3-4  spglib-1.12.2-1  sqlite-3.27.1-1  step-18.12.2-1  sweeper-18.12.2-1  syndication-5.55.0-1
               syntax-highlighting-5.55.0-1  systemd-241.159-1  systemd-libs-241.159-1  systemd-sysvcompat-241.159-1  systemsettings-5.15.0-1  taglib-1.11.1-3
               telepathy-kde-accounts-kcm-18.12.2-1  telepathy-kde-approver-18.12.2-1  telepathy-kde-auth-handler-18.12.2-1  telepathy-kde-call-ui-18.12.2-1
               telepathy-kde-common-internals-18.12.2-1  telepathy-kde-contact-list-18.12.2-1  telepathy-kde-contact-runner-18.12.2-1
               telepathy-kde-desktop-applets-18.12.2-1  telepathy-kde-filetransfer-handler-18.12.2-1  telepathy-kde-integration-module-18.12.2-1
               telepathy-kde-send-file-18.12.2-1  telepathy-kde-text-ui-18.12.2-1  threadweaver-5.55.0-1  tracker-2.1.7-1  umbrello-18.12.2-1  user-manager-5.15.0-1
               vamp-plugin-sdk-2.8.0-1  virtualbox-6.0.4-1  virtualbox-guest-iso-6.0.4-1  vlc-3.0.6-3  vpnc-1:0.5.3.r454.r67-1
               vulkan-icd-loader-1.1.99+3022+e1eafa18e-1  vulkan-intel-18.3.3-2  vulkan-radeon-18.3.3-2  webkit2gtk-2.22.6-1  wget-1.20.1-3  wine-4.2-1  x265-3.0-1
               xapian-core-1:1.4.10-1  xdg-desktop-portal-1.2.0-2  xdg-desktop-portal-gtk-1.2.0-1  xdg-desktop-portal-kde-5.15.0-1  xdg-user-dirs-0.17-2
               xf86-input-libinput-0.28.2-1  xf86-video-nouveau-1.0.16-1  xkeyboard-config-2.26-2  xterm-344-1  zeroconf-ioslave-18.12.2-1  zsh-5.7.1-1

Total Installed Size:  5071.15 MiB
Net Upgrade Size:        36.95 MiB

:: Proceed with installation? [Y/n] Y
(456/456) checking keys in keyring                                                                   [############################################################] 100%
(456/456) checking package integrity                                                                 [############################################################] 100%
error: failed to commit transaction (invalid or corrupted package)
Errors occurred, no packages were upgraded.

#4

Try this:

  1. sudo pacman-mirrors -f
  2. sudo pacman -Syyu
#5

Still facing same problem.

#6

This could be a solution

#7

tried those three commands but when i am updating, facing same errors.

#8

Try general cleanup of pacman and related problems, this helps in most cases:

  1. delete pacman db:

sudo rm -r /var/lib/pacman/sync/core.db

  1. restore pacman db:
sudo pacman -Syy
  1. If the issue is with the keys, do this:
sudo rm -r /etc/pacman.d/gnupg
sudo pacman -Sy gnupg archlinux-keyring manjaro-keyring
sudo pacman-key --init
sudo pacman-key --populate archlinux manjaro
sudo pacman-key --refresh-keys
sudo pacman -Sc
sudo pacman -Syu
  1. If mirros are a problem, at this moment it’s good to try:

sudo pacman-mirrors --fasttrack

All of those should clean and restore correct files as databases, mirrors, keys.

And finally:

sudo pacman -Syyu

#9

rm: cannot remove ‘/etc/pacman.d/gnupg/S.gpg-agent.extra’: No such file or directory
rm: cannot remove ‘/etc/pacman.d/gnupg/S.gpg-agent.ssh’: No such file or directory

#10

It looks like system changed and those commands don’t work anymore. Anyone care to update them? Thanks

@techiehere in meantime you can still try other commands and see if it worked for you. You may not have key issue so not all commands must be done.

#11

I am not being able to install anything , I tried using pamac and terminal nothing is working. Pamac says some transaction issue.

#12

Looks like with the previous similar issues, the key was to remove the package that is causing the issue. The problem is, it was pointed in the output but it’s not happening for you.

So it looked like that:

(97/97) checking package integrity                                                                                                             
error: firefox: signature from "Philip Müller (Called Little) <philm@manjaro.org>" is invalid
:: File /var/cache/pacman/pkg/firefox-58.0.2-1-x86_64.pkg.tar.xz is corrupted (invalid or corrupted package (PGP signature)).
Do you want to delete it? [Y/n] y
error: failed to commit transaction (invalid or corrupted package)

Are you sure you don’t get any specific packaged mentioned?

1 Like
#13

You could try this… after doing this and creating the directory that was missing update was smoothly…
Read the all the post.

#14

This.

Run sudo pacman -Syu and it should tell you.

If Pamac isn’t reporting the “problem package” then that’s a stupid bug which needs to be reported.

2 Likes
#15

My system is totally broken. Failed to start network manager and lots of error. Can’t even go to hui interface.

#16

You may try updating/fixing from a Live ISO (or another Manjaro installation on same PC, if exists)
Mount the root partition (i.e at /mnt) and

  • If your broken installation (at /mnt) is not the same branch as your rescue installation (Live Manjaro, or other Manjaro installation), verify (if you are not sure about thew branch)
grep -E "^Branch" /mnt /etc/pacman-mirrors.conf
   or
pacman-mirrors -ap /mnt -G

Check local (rescue) Branch

pacman-mirrors -G

If not the same, change your local Branch and change mirrors

  # if broken install is in testing, etc 
sudo pacman-mirrors -aRB testing
  • Finally, do the update on your broken installation
sudo pacman -Syyu --sysroot /mnt

If it gives errors, you may try updating first archlinux-keyring and manjaro-keyring

pacman -S  --sysroot /mnt archlinux-keyring  manjaro-keyring

If there is still problem, depending the errors, you may use the --overwrite flag.

But… one at a time… :wink:

3 Likes
Manjaro goes black screen on boot up
#17

That is some nice use of the pacman-mirrors api :+1:

2 Likes
#18

I guess that’s what you were thinking about when you made these flags available. :wink:
Let’s see if it will be useful on this OT… :no_mouth:

That workaround could become one of the proposed solution in such problems. :bulb:

1 Like
closed #19

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.