Unable to update due to plasma package conflict

After executing pacman -Syyu the update to latest stable kde version fails with this error message:

error: failed to commit transaction (conflicting files)
plasma-desktop: /usr/bin/knetattach exists in filesystem (owned by knetattach)
plasma-desktop: /usr/share/applications/org.kde.knetattach.desktop exists in filesystem (owned by knetattach)
Errors occurred, no packages were upgraded.

I suppose I could try deleting both the offending files above, but I’m reluctant to do so without advice from someone more knowledgeable than me.
Any help would be appreciated.

My system and current config.
Computer: Dell Vostro 5460
Operating System: Manjaro Linux
KDE Plasma Version: 5.20.4
KDE Frameworks Version: 5.77.0
Qt Version: 5.15.2
Kernel Version: 5.10.2-2-MANJARO
OS Type: 64-bit
Processors: 4 × Intel® Core™ i5-3230M CPU @ 2.60GHz
Memory: 3.7 GiB of RAM
Graphics Processor: Mesa DRI Intel® HD Graphics 4000


You can run:
sudo pacman-mirrors -f5 && sudo pacman -Syyu --overwrite '*'
No need to remove the file manually …

1 Like

Thank you very much - it worked and I managed to update so problem seems to have been solved.