Unable to switch kernel version because of nvidia-utils


I’m trying to update my Manjaro but when I run “pacman -Suuyy” I have the following error :

“installing nvidia-utils (495.46-3) breaks the “nvidia-utils=495.44” dependency required by linux513-nvidia”.

After some researches , I found that I’m currently running a Linux kernel which is EOF.

I’m using the 5.13.19-2 version of the Linux kernel.

When I try to downgrade/upgrade my kernel, I still face the same issue with the same error message.

What can I do to upgrade my kernel please ?

I’m kind of new to the Linux world, sorry if I’m not clear.

Thanks you in advance.

sudo mhwd-kernel -i linux515

Then reboot into 5.15 (Press Esc during boot to get into grub menu and boot with 5.15)
Double check your running kernel is not 5.13 then remove it:

uname -r #to check kernel version
sudo mhwd-kernel -r linux513
sudo pacman-mirrors --fasttrack 5 && sudo pacman -Syyu 

The issue is I still face this error message when running the “mhwd-kernel -i” command.

The package “nvidia-utils” is blocking my kernel update.

Hi @0xKera,

I think that’s normal. Kind of. I suspect you’ll have to do it from a chroot environment.

I haven’t had this problem in several years, but these steps should work:

  1. Uninstall the nvidia driver, (it should uninstall nvidia-utils along with it)
  2. Install new kernel
  3. Uninstall unsupported 5.13 kernel
  4. Install nvidia driver.
  5. Reboot to start using the new kernel & nvidia driver.

Remember don’t do any rebooting until every step here has been completed successfully.

I suggest using Manjaro Settings Manager/hardware configuration tool to do it.

1 Like

Hi @Mirdarthos,

That what I was suspecting.

I’ve never done that before, do I need to know certains things beforehand ? Can I break my distro or can I loose any data ?

If I understand correctly, I need to boot from a LiveUSB Manjaro then chroot my env and finally update my kernel with the “mhwd-kernel” command ?

Thank you.

Hi @ydar,

I already tried to uninstall the nvidia driver but when I run “pacman -R nvidia-utils”, I still face the same issue.

Here is the error message (it’s in French, sorry in advance, but it’s saying that uninstalling “nvidia-utils” will breaks the dependency “nvdia-utils” used by lib32-nvidia-utils) :

vérification des dépendances…
erreur : la préparation de la transaction a échoué (la satisfaction des dépendances a échoué)
:: la suppression de nvidia-utils casse la dépendance « nvidia-utils » requise par lib32-nvidia-utils
:: la suppression de nvidia-utils casse la dépendance « nvidia-utils=495.44 » requise par linux513-nvidia

Always a danger, as you’ll be root. So yes, but if you’re careful, you’ll be fine.

You understand correctly. I suggest you use an ISO with a different kernel than 5.13.

Use pamac and go to update tab, after that unselect the nvidia driver from the update list and update other depecndecies … after that is done reboot and run update again. This time it will update without showing that error…

i had the same issue yesterday and i did this and it worked…

Problem here is it won’t work if the kernel isn’t there…which is the case with 5.13.

The problem is nvidia requires newer linuxfirmware update which is in the update as well… so if you just unselect the nvidia form the update and update other dependency first, then next time you will run the update it will be statisfying those dependecies as well and hence it wont show that error anymore…

@Mirdarthos Sorry you are correct here haven’t read any of the later replies in the thread

1 Like

Except it won’t install if kernel 5.13 is present, because it tries to download packages for kernel 5.13, because it’s EOL and has been removed. And he can’t install a different one…because of exactly that.


Alternatively you can first uninstall the 5.13 kernel even if it’s being used (the system will still work - just don’t reboot until you’ve got another kernel installed), then remove the nvidia driver (including dependencies like lib32-nvidia-utils, nvidia-utils, opencl-nvidia), then install a supported kernel and then the nvidia driver, then reboot.

@Mirdarthos I am not sure but can he remove the nvidia-utils first with the -Rdd flag and then install the kernel?

sudo pacman -Rdd nvidia-utils
sudo mhwd-kernel -i linux515


I don’t like forcing things, or taking shortcuts or something like that. And removing things recursively. It has potential to be disastrous.

Thanks for all the answers.

I will try to upgrade the kernel via a chroot env.

One last thing I wanted to ask, which kernel version should I choose ? I’m guessing if I want to dodge this issue in the future, I need to choose a LTS kernel version. Is 5.15 considered as a LTS version ? I can see it’s EOF is expected on October 2023.

Many thanks, I will update this post after updating the kernel.

I’d suggest the LTS for that very reason yes. And 5.15 is set to be the next LTS, so it’s a good idea, yes.

1 Like

Ok so everything is working fine now, I managed to update my kernel and now I can update my manjaro without any problems.

For anyone wondering how, here are the steps I followed :

  • Create a LiveUSB Manjaro (use the latest ISO from the official download page, be sure to check the kernel version of it, personally I needed the 5.15 version).
  • Boot on it.
  • Open a Konsole as root and run manjaro-chroot -a (The -a flag will automatically detect any Linux filesystem on your devices and mount them on /mnt)
  • From the chroot env, install the new kernel with pacmanpacman -S linux515 for my case (mhwd-kernel -i linux515 won’t work in a chroot env).
  • Reboot on your Manjaro and press Esc. in order to choose which kernel you’ll use.
  • Uninstall the old kernel → sudo mhwd-kernel -r linux513.
  • Uninstall the video driver → sudo mhwd -r pci video-nvidia in my case.
  • Reboot and run sudo pacman-mirrors --fasttrack 5 && sudo pacman -Syyu.
  • Reinstall the video-driver via the GUI and reboot.

With theses steps it should work.

Many thanks to @Mirdathos and you guys for your help & speed.

I’m happy you got it fixed, however for you or anyone else reading, if you do not have the ability/hardware available to do chroot, this particular situation can be fixed within the running system by following some of the other suggestions here, such as following one of the suggestions I made.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.