Unable to suspend when closing lid on Dell Inspiron 1545

I am unable to suspend by closing the lid on my Dell Inspiron 1545. In the Xfce Power Manager, I have ‘When laptop lid is closed:’ set to Suspend. I did a little searching on these forums and with Google. One post I saw said this was a known issue with the 4.4 kernel so I used the Manjaro Settings Manager to switch to 4.6. I am having the same issue with 4.6. However, I am able to suspend using the Log out menu. I would appreciate any advice or assistance.

System: Host: mhanna49-1545 Kernel: 4.6.2-1-MANJARO i686 (32 bit gcc: 6.1.1) Desktop: Xfce 4.12.3 (Gtk 2.24.30) Distro: Manjaro Linux Machine: System: Dell (portable) product: Inspiron 1545 Mobo: Dell model: 0G848F Bios: Dell v: A14 date: 12/07/2009 Battery BAT0: charge: 44.0 Wh 102.9% condition: 42.8/44.0 Wh (97%) model: Sanyo DELL 00 status: Full CPU: Dual core Pentium T4200 (-MCP-) cache: 1024 KB flags: (lm nx pae sse sse2 sse3 ssse3) bmips: 7982 clock speeds: max: 2000 MHz 1: 1600 MHz 2: 1200 MHz Graphics: Card: Intel Mobile 4 Series Integrated Graphics Controller bus-ID: 00:02.0 Display Server: X.Org 1.17.4 driver: intel Resolution: 1366x768@60.00hz GLX Renderer: Mesa DRI Mobile Intel GM45 Express x86/MMX/SSE2 GLX Version: 2.1 Mesa 11.2.2 Direct Rendering: Yes Audio: Card Intel 82801I (ICH9 Family) HD Audio Controller driver: snd_hda_intel bus-ID: 00:1b.0 Sound: Advanced Linux Sound Architecture v: k4.6.2-1-MANJARO Network: Card-1: Marvell 88E8040 PCI-E Fast Ethernet Controller driver: sky2 v: 1.30 port: de00 bus-ID: 09:00.0 IF: enp9s0 state: down mac: 00:23:ae:3d:eb:f7 Card-2: Broadcom BCM4312 802.11b/g LP-PHY driver: wl bus-ID: 0c:00.0 IF: wlp12s0 state: up mac: 00:25:56:21:02:6f Drives: HDD Total Size: 160.0GB (5.8% used) ID-1: /dev/sda model: TOSHIBA_MK1655GS size: 160.0GB Partition: ID-1: / size: 143G used: 4.6G (4%) fs: ext4 dev: /dev/sda1 ID-2: swap-1 size: 4.57GB used: 0.00GB (0%) fs: swap dev: /dev/sda2 Sensors: System Temperatures: cpu: 46.0C mobo: N/A Fan Speeds (in rpm): cpu: N/A Info: Processes: 138 Uptime: 10 min Memory: 291.4/1979.7MB Init: systemd Gcc sys: 6.1.1 Client: Shell (bash 4.3.421) inxi: 2.3.0

I would try 4.1 kernel also.

check your /etc/systemd/logind.conf
Here’s mine

[Login]
#NAutoVTs=6
#ReserveVT=6
#KillUserProcesses=no
#KillOnlyUsers=
#KillExcludeUsers=root
#InhibitDelayMaxSec=5
HandlePowerKey=poweroff
HandleSuspendKey=suspend
HandleHibernateKey=hibernate
HandleLidSwitch=suspend
HandleLidSwitchDocked=ignore
#PowerKeyIgnoreInhibited=no
#SuspendKeyIgnoreInhibited=no
#HibernateKeyIgnoreInhibited=no
#LidSwitchIgnoreInhibited=yes
#HoldoffTimeoutSec=30s
#IdleAction=ignore
#IdleActionSec=30min
#RuntimeDirectorySize=10%
#RemoveIPC=yes
#UserTasksMax=12288

reboot for effect.

1 Like

I have Manjaro XFCE running on an Inspiron 1150, kernel 4.1. It also doesn’t suspend when the lid is closed (despite being set to do so). Once suspended, though, it does wake up when the lid is opened.

You could set a keyboard shortcut to suspend…

it might be the bug with light-locker that hasn’t been fixed yet.
here’s the fix that works for my xps 13

try:

under settings > session and startup > application autostart

  • disable “Screen Locker” (uncheck the box)
  • add a new Screen locker, the command should be: light-locker --lock-on-suspend

under settings > power manager > security:

  • disable “Lock screen when system is going for sleep”

logout and log back in (or restart if you like) try closing the lid.

1 Like

Thanks for the replies everyone. I changed two lines in the /etc/systemd/logind.conf

HandleSuspendKey=suspend
HandleLidSwitch=suspend

Both were set to ignore on my computer and I changed it to suspend. I rebooted and now it suspends when closing the lid.

2 Likes

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by Bytemark