Unable to start VMplayer15 properly after GCC update.

Hi Guys,

I'm experiencing some issues after a full Manjaro update yesterday with VMplayer. VMplayer 15 needs GCC 8.3 to compile and apparently to work properly.

If I downgrade the GCC package from the new 9.1 to 8.3 VMplayer works. It literally says it needs 8.3 to work and want me to find it in case 9.1 has been installed

Downgrading to GCC 8.3 makes VMplayer work but breaks several applications like firefox, as an example.

]⚡️sudo pacman -U /var/cache/pacman/pkg/gcc-8.3.0-1-x86_64.pkg.tar.xz /var/cache/pacman/pkg/gcc-libs-8.3.0-1-x86_64.pkg.tar.xz 
]⚡️firefox /usr/lib/firefox/firefox: /usr/lib/libstdc++.so.6: version `GLIBCXX_3.4.26' not found (required by /usr/lib/firefox/firefox)

So I upgraded back to GCC 9.1 after the VMPlayer compilation

]⚡️sudo pacman -Suy

... which makes the applications work again but not VMplayer 15, this time it complains about

Could not open /dev/vmmon: No such file or directory.
Please make sure that the kernel module `vmmon' is loaded.

I'm not a package manager master so I would like some guidance what to do in this case. Should I revert all the packages back to a previous state ( i'm not sure if this is possible ) or do some hacks or something?

Please advice, thanks in advance.

Have you checked the Manjaro Wiki on VMware?
https://wiki.manjaro.org/index.php?title=VMware#Installing_VMWare_Workstation_on_Manjaro

There is not much to see there.

I tried to install via pamac and I got this:

Checking file conflicts...                                                                                                                                                                               [2/2]
Error: Failed to commit transaction:
conflicting files:
ncurses5-compat-libs: /usr/lib/libncursesw.so.5 already exists in filesystem

See the Pinned Comments in the AUR page of vmware-workstation.

This thread explains the error you're getting in more detail:

Sorry there, I was a bit quick to reply

I did:

]⚡️sudo mv /usr/lib/libncursesw.so.5 /usr/lib/libncursesw.so.5.bak

and retried building.

but I can't seem to get things working.

]⚡️sudo vmware
Segmentation fault

VMware is an unsupported software. While it may initially work - at first - you will sooner rather than later face many issues.

Hi @linux-aarhus @bill_t

Thanks for the responses

Is there a way to revert the updates I issued yesterday. I'm in a production environment so I need to get my installations back on track. I understand the continous VMware battle but I would like some safe installation points from my OS. That's exact the reason I fled the Ubuntu scene. : to many unstable updates

What branch are you using?

pacman-mirrors -G

If you are on stable - no luck - unless you take the totally unsupported and reckless route. If you have not cleared your pacman cache there is a theoretical chance that you can downgrade using CLI and pacman -U

Check pacman log and note every package installed at the moment in time then use the cache at /var/cache/pacman/pkg

But it is reckless and may make things worse for you.

Proceed at own risk.


Virtual disk from VMware can be used in VirtualBox

VirtualBox can use the vmdk file from a VMware virtual machine - it should be possible to make a copy of that and assign it to a VirtualBox VM

Yes it's stable

OMG. :neutral_face:

I'll go ahead with Virtual box first, then I'll try the revert of the system. ( We're obliged to use VMware.)

Is this something which can be build into Manjaro perhaps? I know it's related to Arch's Pacman but it would be a very productive feature.

Alternative, I should look for some aid tools like timeshift or something. Should have done it before..

Thanks for your help on this. Please let me now if anything else comes up.

:+1:

pamac search downgrade

The package downgrade works with your cache.

man downgrade

The rest is AUR and unsupported as they are primarily Archlinux tools - so be careful :dragon:

We'll do

Timeshift, Clonezilla... then the crazy command, I learned this much already with computer systems :wink:

While GCC got updated to 9.1, the old GCC 8.3 got a new package called gcc8 in the repo.
Try installing that and see if that makes VMPlayer work again.

Downgrading is not a solution, but a workaround.

4 Likes

Please do think of the time you are going to spend working out a solution.

While I made and still make money supporting clients with their computer related problems - I have always been straight with them in relation to time spent fixing and adviced accordingly.

Calculate your time and make a decision - don't spend time on issues which may be unsolvable.

@Strit
Good catch on the gcc8

1 Like

YES it worked.

Such a simple solution. I looked for it in AUR and at the same time I thought it was impossible to have multiple versions of an application installed alongside each other, at least on an Arch system.

@linux-aarhus @Strit @bill_t
Thanks guys, you rock!!

2 Likes

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.

Forum kindly sponsored by