Unable to run Majaro Linux with kernel greater than 4.14

I’ m trying to run Majaro Linux with new kernel, greater than 4.14, but i show only black screen and the mouse pointer. When I try to change to other tty, I show other one black screen and cursor.

Operating System: Manjaro Linux
KDE Plasma Version: 5.23.4
KDE Frameworks Version: 5.88.0
Qt Version: 5.15.2
Kernel Version: 4.14.257-1-MANJARO (64-bit)
Graphics Platform: X11
Processors: 2 × Intel® Core™2 Duo CPU E8400 @ 3.00GHz
Memory: 7.8 GiB of RAM
Graphics Processor: GeForce GTX 460/PCIe/SSE2

When I run live-cd (manjaro-kde -19.0.2-minimal-200311-linux54 ) with free or non-free drivers, everything works perfectly. Trying to do a new fresh installation, with free drivers and non-free ones, had no effect. The problem remains when I install the manjaro on the disk.

I quote information that can help solve the problem.
I have the following outputs that resulted during the operation of the 4.14 kernel system. I can’t have any output with newer kernels because system freezes.

Here is the output of: journalctl --catalog --priority=3 --boot=-1

-- Journal begins at Mon 2021-12-13 02:28:56 EET, ends at Sat 2022-01-01 14:52:02 EET. --
Ιαν 01 14:31:28 stelios-linuxHomePC kernel: firewire_ohci 0000:05:02.1: Pinnacle MovieBoard is not yet supported
Ιαν 01 14:31:30 stelios-linuxHomePC NetworkManager[489]: <error> [1641040290.5899] session-monitor: failed to create systemd-logind monitor: -2

and the output of: sudo inxi -SGMayz

Kernel: 4.14.262-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
parameters: BOOT_IMAGE=/boot/vmlinuz-4.14-x86_64
root=UUID=b0b4f042-73ab-4d04-9ec6-11ff0c5251b4 rw quiet apparmor=1
security=apparmor udev.log_priority=3
Console: pty pts/1 wm: kwin_x11 DM: SDDM Distro: Manjaro Linux
base: Arch Linux
Type: Desktop Mobo: ASUSTeK model: P5K3 Deluxe v: Rev 1.xx serial: <filter>
BIOS: American Megatrends v: 1206 date: 04/16/2009
Device-1: NVIDIA GF104 [GeForce GTX 460] vendor: ASUSTeK driver: nvidia
v: 390.147 alternate: nouveau,nvidia_drm bus-ID: 01:00.0 chip-ID: 10de:0e22
class-ID: 0300
Display: server: X.Org compositor: kwin_x11 driver:
loaded: nvidia display-ID: :0 screens: 1
Screen-1: 0 s-res: 1680x1050 s-dpi: 90 s-size: 474x303mm (18.7x11.9")
s-diag: 563mm (22.1")
Monitor-1: DVI-I-2 res: 1680x1050 hz: 60 dpi: 98
size: 434x270mm (17.1x10.6") diag: 511mm (20.1")
OpenGL: renderer: GeForce GTX 460/PCIe/SSE2 v: 4.6.0 NVIDIA 390.147
direct render: Yes

That one is really old, did you also try (live boot and installing) from a current one?

1 Like

Yes. I’ ve tried all these cores. They runs only with liveCD.

Your graphics is unsupported and so is kernels < 5.4.

Due to upstream implementing compressed kernel modules everything before 5.4 has been deprecated.

With the above in mind - you should be able to get to a usable state using the opensource Nouveau driver.

1 Like

Theoretically the 390 driver should work for him for a year out of the box with kernels >=5.4 :thinking:

The Linux 390.* legacy driver series is the last to support GF1xx (“Fermi”) GPUs. Support for new Linux kernels and X servers, as well as fixes for critical bugs, will be included in 390.* legacy releases through the end of 2022.
Support timeframes for Unix legacy GPU releases | NVIDIA

1 Like

Unfortunately, installing the nouneau driver has no effect. System freezes either with nvidia driver or with nouveau driver.
As i wrote in my firs post, when I run live-cd (manjaro-kde -19.0.2-minimal-200311-linux54), with non-free drivers, everything works perfectly. Trying to update my system or to do a new fresh installation, with free drivers or non-free ones, had no effect. The problem remains when I install manjaro on the disk.

Please take a look in this link:

In ‘grub’, like said in the link, you can edit the grub-command by pressing E in grub. First delete the “quiet” in the command line to get more informatione while booting.

If these dont bring you more meaningful errormessages/information you should ‘chroot’ your installation and search the cause of the problem from there.