Unable to run any OS through KVM on Manjaro

Hi Team,

I recently switched from Windows and installed Manjaro OS on my system. While installing the basic applications, I got stuck with applications like - Adobe Photoshop, Microsoft Office Suite, and many others.

After searching on Google, I figured out that I can run these Windows apps, by installing “KVM” on Manjaro.

I followed this guide here -


to successfully install KVM.

However, when I select any Windows image (.iso) file and try running the virtual machine, I get stuck with the following error:

Unable to complete install: 'Cannot access storage file '/run/media/mathur/Jaipur Home/Technical/Operating Systems/Windows OS/Windows 8.1 Pro Update 3 [x86 & x64] JAN-2021.iso': No such file or directory'

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/asyncjob.py", line 72, in cb_wrapper
    callback(asyncjob, *args, **kwargs)
  File "/usr/share/virt-manager/virtManager/createvm.py", line 2008, in _do_async_install
    installer.start_install(guest, meter=meter)
  File "/usr/share/virt-manager/virtinst/install/installer.py", line 695, in start_install
    domain = self._create_guest(
  File "/usr/share/virt-manager/virtinst/install/installer.py", line 637, in _create_guest
    domain = self.conn.createXML(initial_xml or final_xml, 0)
  File "/usr/lib/python3.10/site-packages/libvirt.py", line 4400, in createXML
    raise libvirtError('virDomainCreateXML() failed')
libvirt.libvirtError: Cannot access storage file '/run/media/mathur/Jaipur Home/Technical/Operating Systems/Windows OS/Windows 8.1 Pro Update 3 [x86 & x64] JAN-2021 Pre-Activated.iso': No such file or directory

I have tried editing the “qemu.conf” file using the steps listed here:


but even after changing the ‘user’ and ‘group’ directives to ‘my username’ and ‘libvirt’, I still get the same error.

Can someone please guide me as to where am I getting wrong?

NOTE: I have tried this with Windows 8.1, Win-10, and even Windows 11 .ISO files.

Look forward to some quick assistance from the experts.

Manu Mathur


First of all, i edited your post so we do not fall into braking this forum rule.

Second, folders and files with spaces in their names require the \ (aka escape caracter) when passed trough a command like containing the path. See more about here:

Most things about KVM installs are covered in a very good KVM - ArchWiki

Thanks, @bogdancovaciu for editing the post.

Most of us are no experts but users like yourself.

Some of us for a longer time than others - but we are all volunteering - so now you know - this is no big shot Linux but a community driven operating system.

As already pointed to by @bogdancovaciu rename you iso to a short distinguishable name - use dashes or lodash if you need a space - then move it or them to a short location - outside your home - e.g. /data/isos - as this would prevent a lot of permission issues.

sudo mkdir -p /data/iso

Set permisssions to readwrite for everyone

sudo chmod ugo+rw /data/iso

Then copy your ISO to the /data/iso folder.

Thanks a lot, @linux-aarhus

Your steps worked like a charm. I was finally able to run the OS within KVM.
Now, all I need to see is - if Photoshop runs smoothly or not.

But, thanks again.
Appreciate your help.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.