Unable to remove old kernel 5.4

I tried removing kernel 5.4 after updating to 5.15. The kernel is removed but still appears on the Software centre prompting me to update. What am I missing?

Here’s some info:

[andreas@andreas-pc ~]$ sudo ls /etc/mkinitcpio.d/*.preset
[sudo] password for andreas: 
[andreas@andreas-pc ~]$ sudo ls /boot/*
/boot/initramfs-5.15-x86_64-fallback.img  /boot/linux515-x86_64.kver
/boot/initramfs-5.15-x86_64.img		  /boot/vmlinuz-5.15-x86_64

fonts  grub.cfg  grubenv  i386-pc  themes



[andreas@andreas-pc ~]$ sudo mhwd-kernel -r linux-lts54
[sudo] password for andreas: 
Error: Please enter a valid kernel name.
Currently running: 5.15.32-1-MANJARO (linux515)
The following kernels are installed in your system:
   * linux515
[andreas@andreas-pc ~]$

Before that, there were some dependencies with the linux-lts-headers. So I ran: sudo pacman -Rcsnu linux-lts-headers and then sudo mhwd-kernel -r linux54.

Have you tried to use Manjaro setting to remove it.

This is not an official kernel from Manjaro, but one from the AUR. Therefore remove it with pamac.

1 Like

I missed that aur part.

sudo pacman -Rcsnu linux-lts54 did the trick.

I knew I was missing something obvious…


This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.