Unable to paste files to Windows partition

Hello folks!

I’m using KDE Plasma. My laptop has dual boot, Window$ 10 and Manjaro. When in Manjaro, using kernel 5.15.114-2 or kernel 6.1.31-2, I have no problem with copying files to Windows partition. Copy and paste work fine! But when I use kernel 6.2.16-2 (which is the latest kernel installed), I can only copy files in Manjaro, but when I browse to the Windows partition to paste the file into a directory, the paste option is not available. The problem appears to be the kernel 6.2.16-2 because I don’t have this problem with the previous kernels as stated above. How can I fix this issue with kernel 6.2.16-2? Any suggestions or ideas?

Thank you.

  1. Make sure that Windows Fast Boot (Hybrid Sleep) is disabled. If enabled, it will not properly shut down your Windows partitions, leaving them in an open state. The Linux kernel detects this as being potential filesystem damage and will then mount said Windows filesystems in read-only mode to prevent further damage.

  2. If you’re sure that this is a problem with the Linux kernel and not with your Windows settings, then use the 6.1 LTS kernel instead. It’s the recommended kernel anyway.

1 Like

please use the forum search function for “windows file copy” first, there are several reasons, check them first. by using the forum search you’ll find threads like this one:

and others.


Kernel 6.2 is marked EOL. It will no longer receive updates. You should stick with 6.1 or 5.15 as they are LTS or try with 6.3


Thank you all for responding to my post. I previously searched the internet and the forum for solutions and saw the same post, but the solution suggested in the previous post didn’t solve my problem and could not find the solution to the problem I have. Thus, I decided to ask for help, but I get your point and I do understand it is best to avoid cluttering the forum with another post if the solution to a particular problem has been provided previously.

As previously stated in my initial post, the problem is not related to Windows, being on fast boot or hybrid sleep, because copy & paste function works fine with kernel 5.15.114-2 and kernel 6.1.31-2. It just doesn’t work with kernel 6.2.16-2. If it were a Windows related issue, then I would have had the very same issue with the other kernels I have. I was just wondering and possibly try to fix the issue with kernel kernel 6.2.16-2 because it is the latest kernel I have, installed. By no means, I’m hellbent on only using and sticking to kernel 6.2.16-2. As a matter of fact, I didn’t know kernel 6.2 was marked EOL. As suggested, I installed kernel 6.3 and tried it too and had the same problem with the copy and paste function. Once again, I was not able to paste a file to Windows partition even with kernel 6.3.5-2. So, I deleted kernel 6.3.5-2 and 6.2.16-2 so that I don’t have to manually select kernel 6.1.31-2 each time I boot up Manjaro. Copy & Paste function (to Windows partition) works fine with kernel 6.1.31-2. I have no problem with it whatsoever!

Here is another question. Just wondering!?! Why are there so many different kernels and why some of them is marked EOL and don’t get supported? For the lack of a better term, what is the “logic” or maybe I should say, “motivation” behind it? Is it because different group of people (team) come up with that particular kernel and come to dead-end and decide not to go with it? And another question! What is your suggestion or opinion on installing and using a newer kernel? Let me rephrase it! When do you think it is a good idea or valid reason to install a newer kernel? The common sense tells me that you don’t really need to install a newer kernel just because it happens to be the latest one unless and until you have a problem with the current kernel that you’re using. Maybe I answered my own question, but there may be other reasons to switch to a newer kernel from a perspective of a Linux savvy person.

Once again, thank you for all your help and cheers!

because the amount of different hardware is growing from day to day and the kernel needs to get updated for their support and it’s obvious that there’s time for older kernels to stop maintaining them. to the other hand installing a new kernel needs a reboot and there are a lot of environments that have to run 24/7 and a reboot isn’t simple because it would break the infrastructure temporarily. there are reasons to keep the old kernel running as long as possible.

1 Like

Sorry for the bump - I didn’t see it was a week old.

You cannot - EOL

The kernel is is a joint operation in constant change → kernel.org

Newer kernels may remove support for older hardware - which makes the availablity of earlier LTS kernels a necessary evil - so to speak.

If Windows is using fast startup or hybrid sleep - it is a problem - if your Windows is not - it is not a problem.

Can it be assumed you are familiar with NTFS-3G - ArchWiki?

1 Like

I figured out, myself, what the issue (the problem, the cause) was… that prevented me from pasting into a folder in Windows partition when it was copied from a directory in Manjaro partition.

To be honest with you, I’m surprised that none of the experienced users could figure out the problem.

The file manager had to have the admin rights! That’s all!

Some of the file managers (if you have bunch of them installed in your system) would give you the option in its GUI interface to open a folder as admin by right-clicking on the folder and selecting “Open as Admin”. Some of the file manager would not even have that option whereas you would have to launch the file manager in terminal by typing “sudo [name of the file manager]”.

Unfortunately, (as much as I know and understand, correct me if I’m wrong!), you cannot launch a file manager in GUI with administrative rights by clicking on its icon on your desktop. But it can be done in terminal with “sudo” followed by the name of the file manager.

What you are saying here is: “I need to have root privileges to write to the drive”.

Why you are running as root on one kernel and not the other is to me a mystery, should not happen!

What I suspect is happening is the “windows drive” is being mounted differently on the different kernels, also something that should not happen (if it’s done automatically).
How do you mount the partition?

If it is a ntfs partition, and you set the credentials to YOUR_USER in the mounting process, you do not need to be root to write to it.

IMHO, always try to minimize the use of root if not absolutely necessary.

Read this earlier post and click the link again to learn how to mount correctly: Unable to paste files to Windows partition - #7 by linux-aarhus
(specifically point 4.3 in the wiki)

That is not correct.

The correct approach is to ensure permissions is set on the mountpoint.

What approach will be correct is an individual decision.

If you decide to launch your filemanager as root - that is your decision.

However - please do realize that you make life hard on yourself if you - due the the filemanager launched as root - inadvertently change permissions on other files due to opening files from the filemanager.


I don’t know how many other ways to mount a Windows partition. There may be millions of ways in Linux, but I just launch the Dolphin file manger, and when I see the Windows under “Devices”, I simply click on it. The Dolphin file manager mounts it automatically. Is there a separate and special Linux “ritual” for this that I don’t know of, please let me know??!?!?

Ritual, no. Configuring how mounting is done, yes.

The links provided should be more than enough.

But using root works, if you want to do it that way, go ahead.
But most experienced linux users would advice against that and configure the mounts instead.

Ooooookay! So, the permission must be set at the mounting point! That makes sense!?!? I’ll look at the links you threw at me and I will get back to you if i ever understand or makes sense of them. Maybe after reading the links, I’ll turn into Linux wizard. Why didn’t I figured that out, myself, before I post this!?!

While you are at reading those links, before coming back aggrovated or upset, please read this too:

We are here to help, but we ask basic linux knowledge of you.
Your manner also has a BIG impact on how much time people will spend on explaining things rather than posting wiki pages. hint hint.

1 Like

It may be a bit of frustration on my part, but it is not entitlement. I have more than enough patience and manner not to feel “entitled”.

I’ve tried many other Linux distros before I ran into Manjaro. This is not the first time I’m using Linux. To be honest with you, I don’t know where I stand in Linux, but that is not the point.

Experience is gained by time, using the system as one thing leads to another and you learn more and more by time, and you gain experience. Things don’t happen overnight, over a week or a month! Things take time.

You’re always and always going to run into and come across frustrated new comers and unexperienced people, coming into Manjaro. Again, you just can’t put a link to generalize that Manjaro is not for beginners. If that is the case, if that is the true approach of the Manjaro team, then Manjaro will never ever grow with new people! You just need to spend more time (a bit more explanation and a bit more patience) with new people to gain them. That’s all. Anything that you say (any link you throw) that goes over their head won’t help, but frustrate them. Breaking things down a bit is where the touch of “finesse” is… to gain people. Just my two cents!

I’m sorry but I didn’t know I had an “attitude” in my previous post! I just stated in my previous post, “I figured out, myself, what the issue was... To be honest with you, I’m surprised that none of the experienced users could figure out the problem.

If that truly sounded to you as I had “attitude”, I’m very surprised with your interpretation. I’m not here for “drama” or for inflammatory back-and-forth postings. I respect the forum and everybody here. You can read some of my previous postings here in the forum to get to know a bit about my “manner” if you care to do so. I just don’t appreciate to be misinterpreted or for getting “pinned” for making a simple statement.

Thank you for your time and effort, much appreciated. You have a great day!

1 Like

That depends on the filesystem. If it’s a POSIX-compatible filesystem, then yes, although the permissions of files on the filesystem in question may then differ.

If it’s a Microsoft-style filesystem, then no, because they do not store or even understand POSIX permissions, and so the kernel has to emulate them in the virtual filesystem layer at mount time. As such, this means that the permissions will be set for the whole filesystem at once, not for individual files, and that you cannot alter the permissions while the filesystem is mounted.

More information can be found in the two tutorials below… :point_down:

1 Like

maybe new ntfs module is related? thats why sudo ‘works’ ?


There may indeed be some correlation, but if so, it’ll be only sideways.

Userspace has thus far always allowed unprivileged users to mount external filesystems, but the ntfs3 driver lives in the kernel itself, and as such, userspace won’t be looking unto the usual fusermount with ntfs-3g for mounting it. The use of sudo on the other hand gives the mount process root privileges, which would thus allow the mount.